Forum Linux.débutant SSH

Posté par .
Tags : aucun
0
5
jan.
2009
Bonjour !

Je tente de me connecter en session SSH sur un poste distant, en vain
Il s'agit de 2 os ubuntu, avec client et serveur SSH installés sur chacun


ssh bureau-U@XX.XX.XX.XX
bureau-U@XX.XX.XX.XX's password:
Permission denied, please try again.
bureau-U@XX.XX.XX.XX's password:
Permission denied, please try again.
bureau-U@XX.XX.XX.XX's password:
Permission denied (publickey,password).


XX.XX.XX.XX est une ip publique (LIVEBOX)

Pourquoi le serveur me renvoie-t-il Permission denied (publickey,password).?

Merci
  • # Vert bose

    Posté par (page perso) . Évalué à 3.

    Lance la commande avec le niveau de verbosité max:

    ssh -vvv bureau-U@XX.XX.XX.XX

    Tu en sauras déjà plus et, si ça ne t'aide pas, les infos retournée aideront peut-être quelqu'un ici à trouver le problème.

    NB: man ssh t'aurais fait gagner un peu de temps...

    La gelée de coings est une chose à ne pas avaler de travers.

  • # Clé d'authentification et mot de passe

    Posté par (page perso) . Évalué à 4.

    Salut,

    Le message que tu vois corresponds au fait que tu n'as pas réussi à te connecter avec 2 méthodes différentes d'authentification :
    - une méthode via les clés privé/publique (apparemment, tu n'en as pas).
    - une autre via la saisie d'un mot de passe.

    Quand il n'arrive pas à faire la première méthode (clés certificats), il passe à la seconde (mot de passe)

    Sans faire d'autopromotion, j'ai fait un petit article sur linuxfr.org que tu peux retrouver à cette adresse : http://linuxfr.org/2008/03/07/23807.html . Tu y verras quelques tuyaux pour l'authentification.

    Sinon, il faut bien vérifier que ton user existe bien de l'autre côté et pour avoir plus d'information sur ce qui ne va pas, va faire un tour dans le fichier /var/log/auth.log du serveur distant. Tu y verras les messages d'authentification et une meilleure compréhension de ce qui ne va pas.

    Dernière astuce, tu peux également utiliser l'option '-v' avec ssh pour avoir de plus ample information sur ce qui se passe durant la connexion au serveur distant.

    Bonne chance !

    Yannig
    • [^] # Re: Clé d'authentification et mot de passe

      Posté par . Évalué à 2.

      Merci pour toute ces infos, Du coup j'ai essayé avec l'option -v que je ne connaissais pas. Voici ce qui m'est retourné :
      anselme@machine-desktop:~$ ssh -v bureau-U@XX.XX.XX.XX
      OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
      debug1: Reading configuration data /etc/ssh/ssh_config
      debug1: Applying options for *
      debug1: Connecting to XX.XX.XX.XX [XX.XX.XX.XX] port 22.
      debug1: Connection established.
      debug1: identity file /home/anselme/.ssh/identity type -1
      debug1: identity file /home/anselme/.ssh/id_rsa type -1
      debug1: identity file /home/anselme/.ssh/id_dsa type -1
      debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-3ubuntu1
      debug1: match: OpenSSH_5.1p1 Debian-3ubuntu1 pat OpenSSH*
      debug1: Enabling compatibility mode for protocol 2.0
      debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
      debug1: SSH2_MSG_KEXINIT sent
      debug1: SSH2_MSG_KEXINIT received
      debug1: kex: server->client aes128-cbc hmac-md5 none
      debug1: kex: client->server aes128-cbc hmac-md5 none
      debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
      debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
      debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
      debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
      debug1: Host 'XX.XX.XX.XX' is known and matches the RSA host key.
      debug1: Found key in /home/anselme/.ssh/known_hosts:11
      debug1: ssh_rsa_verify: signature correct
      debug1: SSH2_MSG_NEWKEYS sent
      debug1: expecting SSH2_MSG_NEWKEYS
      debug1: SSH2_MSG_NEWKEYS received
      debug1: SSH2_MSG_SERVICE_REQUEST sent
      debug1: SSH2_MSG_SERVICE_ACCEPT received
      debug1: Authentications that can continue: publickey,password
      debug1: Next authentication method: publickey
      debug1: Trying private key: /home/anselme/.ssh/identity
      debug1: Trying private key: /home/anselme/.ssh/id_rsa
      debug1: Trying private key: /home/anselme/.ssh/id_dsa
      debug1: Next authentication method: password
      bureau-U@XX.XX.XX.XX's password: 
      debug1: Authentications that can continue: publickey,password
      Permission denied, please try again.
      .......
      
      J'ai l'impression que dans mon cas, l'authentification par password ne suffise pas....... alors que sur le serveur le fichier /etc/ssh/sshd_config est bien configuré de la manière suivante :
      # Change to yes to enable tunnelled clear text passwords
      PasswordAuthentication yes
      
      Je continue à chercher en me basant sur vos réponses et vos précieux conseils, merci
  • # Es-tu sur la bonne machine ?

    Posté par (page perso) . Évalué à 3.

    Vérifie dans les log de ta machine cible (/var/log/auth.log) si tu trouves les traces de tes connexions. Si tu ne trouves pas de trace, c'est que c'est que tu te connectes sur ta LiveBox :-)
  • # Questions bêtes

    Posté par . Évalué à 3.

    As-tu bien redirigé le port 22 de la livebox vers un PC du réseau local ?
    Et ce PC du réseau local (derrière la box) est-il bien en IP fixe ?

    Je sais la question est bête mais tu n'as rien précisé là dessus dans ton post.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.