Forum Linux.général Connexion impossible pour un certain site

Posté par  .
Étiquettes : aucune
0
4
avr.
2010
Bonjour
Je poste ci-dessous la description du problème rencontré par ma fille. Elle travaille avec Ubuntu mais le problème est le même sur le Mac de son ami.
Elle a paramétré sa mtu à 1492.
Elle ne peut pas se connecter au site http://www.scurion.ch/jm/
pour lequel elle doit travailler.
Merci pour toute aide

Sa description des faits:

"je veux me connecter au site http://www.scurion.ch/jm/
les premiers jours aucun problème.
un jour, paf je veux y accéder et rien, une page blanche et ça charge charge charge. même chose sur le Mac de B, et en me connectant directement par ethernet.

tcptraceroute scurion.ch
Selected device eth1, address 192.168.1.66, port 51245 for outgoing packets
Tracing the path to scurion.ch (80.74.151.73) on TCP port 80 (www), 30 hops max
1 192.168.1.254 98.249 ms 103.084 ms 96.446 ms
2 94-192-88-1.zone6.bethere.co.uk (94.192.88.1) 25.618 ms 44.772 ms 39.304 ms
3 * * 10.1.3.245 48.638 ms
4 * 10.1.2.169 31.090 ms 30.733 ms
5 xe-9-2-0.edge3.London1.Level3.net (212.113.15.69) 33.585 ms 30.141 ms 35.067 ms
6 ae-11-51.car1.London1.Level3.net (4.69.139.66) 39.847 ms 39.003 ms 29.351 ms
7 212.113.16.110 32.801 ms 39.138 ms 44.436 ms
8 ae0-0.lon-004-score-1-re1.interoute.net (84.233.218.158) 90.126 ms 65.645 ms 65.708 ms
9 ae1-0.par-gar-score-1-re1.interoute.net (212.23.42.21) 77.568 ms 63.504 ms 65.579 ms
10 Gi1-0.gva-004-access-1.interoute.net (84.233.208.41) 71.108 ms 107.739 ms 66.198 ms
11 PO0-0.gva-004-access-3.interoute.net (84.233.208.38) 74.489 ms 60.894 ms 64.949 ms
12 Gi1-0.zrh-jos-access-1001.interoute.net (212.23.43.221) 60.688 ms 62.018 ms 62.283 ms
13 interoute-gig02-cr3.ch-meta.net (80.74.134.10) 58.177 ms 60.742 ms 60.490 ms
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *
Destination not reached

Je le dis donc au gars (pour qui je traduis) qui me dit 1) les autres traducteurs n'ont aucun problème pour accéder au site 2) me demande mon adresse ip pour la transmettre au Web service provider, qui apparemment ne la voit pas du tout.
Le web service provider réinitialise le pare-feu du site et paf! je peux accéder au site sans problème. youpi!
Le lendemain, je ne peux plus y accéder.
ai pensé à un problème de DNS donc commence à utiliser OpenDNS. Pas de différence.
J'essaie d'utiliser un web proxy et miracle ! je peux accéder au site. Mais je veux accéder au "contenu" (c'est-dire joomla) pour pouvoir traduire, ce qui veut dire presser des boutons "copier", "sauvegarder" etc et le web proxy ne peut le faire (car c'est interactif)"
  • # chezmoicamarche.com

    Posté par  . Évalué à 2.


    ~$ tcptraceroute scurion.ch 80
    Selected device eth0, address 192.168.1.101, port 48303 for outgoing packets
    Tracing the path to scurion.ch (80.74.151.73) on TCP port 80 (www), 30 hops max
    1 192.168.1.254 0.766 ms 0.738 ms 0.516 ms
    2 82.228.10.254 20.591 ms 18.903 ms 18.941 ms
    3 * 213.228.8.254 21.143 ms *
    4 th2-crs16-1-be1011.intf.routers.proxad.net (212.27.50.21) 22.071 ms 21.826 ms 21.808 ms
    5 aub-6k-1-po21.intf.routers.proxad.net (212.27.50.138) 23.062 ms * *
    6 aub-4k-1-v900.intf.routers.proxad.net (212.27.58.74) 22.291 ms 20.592 ms 21.163 ms
    7 interoute.FreeIX.net (213.228.3.148) 21.049 ms 20.891 ms 21.653 ms
    8 ae0-0.par-gar-score-1-re1.interoute.net (212.23.42.25) 44.294 ms 45.026 ms 45.385 ms
    9 Gi1-0.gva-004-access-1.interoute.net (84.233.208.41) 44.217 ms 45.262 ms 44.077 ms
    10 PO0-0.gva-004-access-3.interoute.net (84.233.208.38) 45.786 ms 45.293 ms 44.073 ms
    11 Gi1-0.zrh-jos-access-1001.interoute.net (212.23.43.221) 44.398 ms 44.973 ms 44.102 ms
    12 interoute-gig02-cr3.ch-meta.net (80.74.134.10) 43.961 ms 44.270 ms 44.554 ms
    13 delta.gb-webserver.com (80.74.151.73) [open] 45.847 ms 45.022 ms 45.318 ms


    je suis chez free, et mon MTU par defaut est à 1500
    • [^] # Re: chezmoicamarche.com

      Posté par  . Évalué à 1.

      Bonjour
      Chez moi aussi cela marche. Le problème, c'est que cela ne marche pas chez elle....

      "L'art est fait pour troubler. La science rassure" (Braque)

      • [^] # Re: chezmoicamarche.com

        Posté par  . Évalué à 2.

        pkoi ou comment a-t-elle choisit son MTU de 1492 ?
        • [^] # Re: chezmoicamarche.com

          Posté par  . Évalué à 1.

          Je lui ai demandé de changer. Explication :
          Sur mon système (Squeeze), j'ai été obligé de paramétrer la mtu à 1492 et non 1500, sinon certains sites sont inaccessibles.

          "L'art est fait pour troubler. La science rassure" (Braque)

          • [^] # Re: chezmoicamarche.com

            Posté par  . Évalué à 2.

            apparemment elle a plusieurs machines (la sienne, celle de son copain...)

            c'est donc au routeur d'avoir 1492, pas aux machines derrieres le routeur
            • [^] # Re: chezmoicamarche.com

              Posté par  . Évalué à 1.

              'c'est donc au routeur d'avoir 1492, pas aux machines derrieres le routeur '

              Tout à fait d'accord. Problème, son routeur le 'O2 Wireless Box II, Thomson TG585v7' ne comporte aucune possibilité de régler la mtu.

              "L'art est fait pour troubler. La science rassure" (Braque)

              • [^] # Re: chezmoicamarche.com

                Posté par  . Évalué à 3.

                Tout à fait d'accord. Problème, son routeur le 'O2 Wireless Box II, Thomson TG585v7' ne comporte aucune possibilité de régler la mtu.

                Ce qui est normal vu que c'est un routeur ADSL et que donc la MTU sur le port sortant est forcément 1492 (1500 comme partout -8 pour l'encapsulation ADSL)
  • # Le provider se prend les pieds dans l'inter-connexion

    Posté par  . Évalué à 3.

    Apparament ton traceroute part en vrille au moment ou les paquets quittent le réseau interoute.net pour rentrer dans le réseau metanet.ch (d'après les IP)

    Il s'agit donc soit d'un problème de routage, soit d'un filtre mis en place par l'une ou l'autre des parties suite à un problème.

    Test : essayer d'aller sur le site http://taurinus.sui-inter.net/ (site de quelques octets, au cas ou tout linuxfr déciderait de cliquer sur le lien)
    cas 1 : ca marche -> le routage entre les sous réseaux est bon, il y a donc du filtrage soit en sortie de ton provider, soit à l'entrée sur metanet.ch

    cas 2: ca marche pas -> le routage est défectueux ou l'interconnexion a été coupée suite au non respect des conditions d'utilisation ou au non paiement des factures.

    Dans le cas 1 il faut demander à ton provider de s'assurer qu'il n'y a pas de filtre vers la machine de destination. Si ca n'est pas le cas, c'est que la machine de destination se protège contre ton provider. Il faut alors voir avec l'admin du serveur web pourquoi. Mais le routage est bon.

    Dans le cas 2 C'est le bordel, Le routeur de metanet.ch n'aime pas ton provider, il faut alors que les deux providers (le tien et metanet.ch) se mettent en contact pour voir ce qui se passe.

    Quoi qu'il arrive le problème ne peut pas être résolu en configurant ta machine.
    • [^] # Re: Le provider se prend les pieds dans l'inter-connexion

      Posté par  . Évalué à 1.

      Elle se connecte à http://taurinus.sui-inter.net/ et obtient ceci :
      'This is the placeholder for domain taurinus.sui-inter.net. If you see this page after uploading site content you probably have not replaced the index.html file.
      This page has been automatically generated by Plesk.'

      Elle est donc ds le cas N°1, je pense

      "L'art est fait pour troubler. La science rassure" (Braque)

      • [^] # Re: Le provider se prend les pieds dans l'inter-connexion

        Posté par  . Évalué à 2.

        Elle est donc ds le cas N°1, je pense

        Tout à fait, et c'est donc un filtre firewall en sortie de provider ou en entrée sur la machine qui l'empêche d'aller plus loin.
        • [^] # Re: Le provider se prend les pieds dans l'inter-connexion

          Posté par  . Évalué à 2.

          Comme elle le dit tout en haut dans le journal:
          'Le web service provider réinitialise le pare-feu du site et paf! je peux accéder au site sans problème. youpi!
          Le lendemain, je ne peux plus y accéder.'

          Je ne vois pas pourquoi son provider filtrerait scurion ....
          A mon avis, c'est scurion qui se protège de son provider avec son pare-feu.
          L'affaire ne va pas être facile à régler.
          En tous cas, merci.

          "L'art est fait pour troubler. La science rassure" (Braque)

        • [^] # Re: Le provider se prend les pieds dans l'inter-connexion_résolu

          Posté par  . Évalué à 1.

          Message reçu de l'administrateur du site:
          'maybe a mod_security rule of the Apache webserver (see below) caused the problem. Our provider disabled the rule – please check if it works now! Sorry for the trouble!'

          message joint:

          [Tue Apr 06 23:16:38 2010] [error] [client xxxxxxxxxxx] ModSecurity: Access denied with code 501 (phase 2). Match of "rx ^((?:(?:POS|GE)T|OPTIONS|HEAD))$" against "REQUEST_METHOD" required. [file "/usr/local/apache/conf/modsec2.user.conf"] [line "44"] [id "xxxxxx"] [msg "Method is not allowed by policy"] [severity "CRITICAL"] [tag "POLICY/METHOD_NOT_ALLOWED"] [hostname "www.scurion.ch"] [uri "/jm/images/scurion/bilder/simulator/transport.jpg"] [unique_id "xxxxxxxxx"]

          [Tue Apr 06 23:16:38 2010] [error] [client xxxxxxxxxx] File does not exist: /home/cpan0225/public_html/501.shtml

          Merci à tous
          M

          "L'art est fait pour troubler. La science rassure" (Braque)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.