Forum Linux.général Desactivation du clavier et passage en Bépo sur le second

Posté par .
Tags : aucun
0
24
avr.
2009
Bonjour,

alors le titre du sujet est surement pas très clair... j'ai (enfin) reçu mon typematrix vierge avec sa skin bépo. C'est là que ça de corse.

Je sais détecter le branchement du clavier et effectuer un script suite à cet enfichage. Mais je ne sais pas comment «dire» :
tu ne prend plus en compte le clavier du portable (pour pouvoir poser le typematrix dessus)
tu passes la map en bépo

Donc si quelqu'un sait vers où m'orienter, j'en serai ravi :)


P.S : Ça pose des problémes inattendu la vie en couple parfois.
  • # Ah ? Ils ont été envoyés ?

    Posté par (page perso) . Évalué à 2.

    Parce que je n'ai pas eu de nouvelles depuis fin mars. Et rien dans la boite aux lettres...
    • [^] # Re: Ah ? Ils ont été envoyés ?

      Posté par . Évalué à 1.

      Les dernieres nouvelles que j'avais eu disait qu'on aurait certainement les claviers vers le 20 avril il me semble, et effectivement, ils ont été envoyé, j'ai reçu le mien hier.
  • # Passer en bépo

    Posté par . Évalué à 2.

    Pour basculer en bépo j'utilise :
    setxkbmap -layout fr -variant bepo7

    Sous xorg les deux claviers sont liés, je ne sais pas s'il est possible d'en désactiver un et pas l'autre.

    Deux solutions : tu le poses à côté du portable, ou tu convainc ta chère et tendre de se mettre au bépo elle aussi.

    Après tout faut bien amortir l'investissement. Surtout que toi, tu devrais taper en aveugle.
    • [^] # Re: Passer en bépo

      Posté par (page perso) . Évalué à 2.

      Pour moi, tapper sans regarder le clavier, j'y arrive que sur mes claviers. Je galère à fond dès que l'espacement change un tout petit peu.

      Alors son investissement vaut le coup :-)

      Envoyé depuis mon lapin.

    • [^] # Re: Passer en bépo

      Posté par . Évalué à 1.

      Pour l'instant, je sui sur la phase d'apprentisage, donc lorsque je ne usis pas sur Xultypist je regarde le clavier un peu :).

      Je me dis qu'au niveau du noyau comme le clavier du portable n'est pas sur port usb (en fait, j'ai aucune idée du type de port d'un clavier de portable), je me dis qu'il suffit de desactiver le module de gestion de ce port et que sa pourrait peut etre le faire.

      Mais je vais certainement convaincre ma douce et tendre d'utiliser le typematrix :)
  • # fin ou pas

    Posté par (page perso) . Évalué à 2.

    Si tu n'es pas très fin tu peux configurer hal en bépo, démarrer avec un clavier branché, faire un setxkbmap fr puis brancher le typematrx. Tu auras un clavier en azerty et l'autre en bépo. J'ai testé en tapant vite sur les deux claviers en même temps et ça m'a tout fait planter (obligé de faire un hard reboot).

    http://www.gentoo.fr/forum/viewtopic.php?id=790 est intéressant. Si tu fais un lshal tu dois pouvoir avoir des lignes comme :
    system.hardware.product = 'MM061' (string)
    system.hardware.vendor = 'Dell Inc.' (string)

    mais avec typematrix 2030 ez.

    Puis :
    sudo cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy/
    sudo vi /etc/hal/fdi/policy/10-keymap.fdi

    tu dois y mettre un :

    <match key="system.haldware.product" contains="typematrix">
    <merge key="input.xkb.layout" type="string">fr</merge>
    <merge key="input.xkb.variant" type="string">bepo</merge>
    </match>

    C'est une piste, je n'ai pas de linux pour tester, ni de second clavier.
    • [^] # Re: fin ou pas

      Posté par . Évalué à 1.

      Apparement, il ne prend pas en compte mon fichier fdi. Je vais trouver ce qui cloche.

      En tout cas, c'est une très bonne piste ; comme j'ai identifié mes deux claviers, je dois pouvoir les configurer tous les deux séparément.
      • [^] # Re: fin ou pas

        Posté par (page perso) . Évalué à 1.

        Attention au commentaire au dessus, il y a "haldware" au lieu de "hardware".

        Ca marche mieux sur ma débian avec :

        <match key="info.product" contains="TypeMatrix.com USB Keyboard">
        <merge key="input.xkb.layout" type="string">fr</merge>
        <merge key="input.xkb.variant" type="string">bepo</merge>
        </match>


        Maintenant, hal détecte bien, j'ai "fr" et "bepo" quand je fait "hal-device". Mais le clavier est toujours en azerty...
        • [^] # Re: fin ou pas

          Posté par . Évalué à 2.

          mon fichier fdi est :
          <code>
          <?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
          <deviceinfo version="0.2">
          <device>
          <match key="info.product" contains="TypeMatrix.com USB Keyboard">
          <merge key="input.xkb.layout" type="string">fr</merge>
          <merge key="input.xkb.variant" type="string">bepo</merge>
          </match>
          </device>
          </deviceinfo>
          </code>

          et hal ne me le met même pas en bepo :/
          Je cherche, je cherche, vous serez les premiers avertis lorsque j'aurai trouvé.
  • # Pour mémoire

    Posté par . Évalué à 2.

    L'indication importante ce situe à cet endroit : https://linuxfr.org/comments/1029301.html#1029301
    Certaines distribution trouvent judicieux de repasser derriere HAL pour configurer les claviers, donc il faut desactiver une option pour que le systeme prenne réellement en compte les reglages.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.