Forum Linux.mandriva Pas de 3D

Posté par .
Tags : aucun
0
13
mai
2009
Bonsoir

voilà le hic et quelques données
J'utilise un Dell Latitude | D505 muni d'une carte grapique Intel 82852/855GM
Je viens d'installer la mandriva 2009.1 free sans CD/DVD d'installation, ce qui n'a été possible qu'en mode texte
Suite sans doute à quelque erreur, je n'avais aucun pilote de carte graphique
J'ai corrigé cette erreur, et voici donc ce que j'ai dans le fichier xorg.conf dans /etc/X11 :

Section "Device"
Identifier "device1"
VendorName "Intel Corporation"
BoardName "Intel 810 and later"
Driver "intel"
BusID "PCI:0:2:0"
Option "DPMS"
EndSection

Par ailleurs, après vérification

Le paquetage x11-driver-video-intel-2.7.0-1mdv2009.1.i586 est déjà installé

Or, en l'état actuel des choses, impossible d'obtenir les effets 3D. 1) dans Bureau>configuration du système, les effets de bureau sont activés, mais ça n'a aucun "effet" réel (par exemple pas de cube) ; 2) dans mcc>matériel>configurer les effets 3D, si j'opte pour Compiz Fusion (sachant que l'option Xgl n'est pas disponible) et que je reboote, à la fin du boot c'est un écran blanc dont je sors par le mode console et en paramétrant l'absence d'effets 3D. Sur la mandriva 2008.0, cela fonctionnait pourtant...
  • # Euh... et de la 3D "toute conne" ?

    Posté par (page perso) . Évalué à 2.

    Et la 3D toute conne, genre des jeux 3D ca marche ?
    • [^] # Re: Euh... et de la 3D "toute conne" ?

      Posté par . Évalué à 1.

      Désolé, je n'ai pas ça en magasin, donc je n'en sais rien. J'ai constaté entretemps que vlc qui offrait une excellente image avant que je ne touche à l'affichage est maintenant dégradé (image dominée par du bleu) - cela pour le télévisionnage par le freeplayer.
      • [^] # Re: Euh... et de la 3D "toute conne" ?

        Posté par (page perso) . Évalué à 2.

        Désolé, je n'ai pas ça en magasin

        euh efface : urpmi task-games pour en avoir 2 Go, ou urpmi openarena pour essayer déjà avec un (libre de surcroît)

        et sinon, tu as essayé ce qu'il y a sur :
        http://wiki.mandriva.com/fr/2009.1_Errata#Gel_.28freeze.29_p(...)
        • [^] # Re: Euh... et de la 3D "toute conne" ?

          Posté par (page perso) . Évalué à 2.

          Euh oui évidemment, j'ai pas tilté, mais c'est bien ce bogue dont il s'agit, mandriva a volontairement désactivé la 3D pour les drivers intel à la sortie. Il suffit néanmoins d'une mise à jour pour corriger ce problème.
          • [^] # C'est-à-dire ?

            Posté par . Évalué à 1.

            "Il suffit néanmoins d'une mise à jour pour corriger ce problème."

            D'accord, mais en clair, cette mise à jour se fait comment ?
            • [^] # Re: C'est-à-dire ?

              Posté par (page perso) . Évalué à 2.

              Euh... normalement tu cliques sur le gros bouton rouge avec un point d'exclamation en bas à droite, comme toutes les mises à jours ...
              Après faut pas avoir fait le con, faut que les sources soient bien configurées, m'enfin bon normalement c'est le cas par défaut. Sinon un tour sur easyurpmi, ca regle le probleme.
        • [^] # Re: Euh... et de la 3D "toute conne" ?

          Posté par . Évalué à 1.

          et sinon, tu as essayé ce qu'il y a sur :
          http://wiki.mandriva.com/fr/2009.1_Errata#Gel_.28freeze.29_p(...)

          Oui, j'ai trouvé ces errata, et même avant d'avoir touché à ma configuration lacunaire de la carte graphique. J'avais exactement ce problème de gel intempestif de l'écran, que je n'ai plus désormais. Et les problèmes que j'ai sont donc ceux que j'ai exposés plus haut, avec encore un autre élément trouvé depuis hier : vlc et la tv par le freeplayer donnait une image d'une qualité que je n'aurais jamais soupçonnée sur ce "vieux" portable (avec toutefois des problèmes de coupure du son). Mais depuis la reconfiguration de l'affichage, l'image est dégueulasse, dominée de bleu...
          • [^] # Re: Euh... et de la 3D "toute conne" ?

            Posté par . Évalué à 2.

            vec encore un autre élément trouvé depuis hier : vlc et la tv par le freeplayer donnait une image d'une qualité que je n'aurais jamais soupçonnée sur ce "vieux" portable (avec toutefois des problèmes de coupure du son). Mais depuis la reconfiguration de l'affichage, l'image est dégueulasse, dominée de bleu..

            ca va avec ton probleme 3D

            pour economiser de la puissance processeur, vlc peut utiliser opengl (donc la partie 3D de la carte graphique) pour gerer l'affichage

            si tu n'as plus la 3D, vlc ne peut plus utiliser l'opengl, et donc tout se calcule avec le processeur => moins bonne qualité
            • [^] # Je n'en doute pas

              Posté par . Évalué à 1.

              et c'est pourquoi j'en parlais. Mais cela ne m'indique guère comment résoudre le problème. Je trouve des trucs, par exemple :

              https://linuxfr.org/~rictus/

              http://artisan.karma-lab.net/node/1703

              qui indiquent qu'intel pose des problèmes, mais je ne suis pas bien sûr que ce soit exactement les miens...
              • [^] # Re: Je n'en doute pas

                Posté par . Évalué à 2.

                les deux proposants des solutions similaires (option accelmode XAA ou accelmode EXA + autres options)

                et n'etant pas des options "destructrices", tu peux essayer
                (sans recompiler ton module intel pour l'instant)

                si cela ne marche pas, tu pourras alors attendre la prochaine mise à jour,
                ou si vraiment tu ne peux pas te passer de la 3D, tu pouras alors envisager de recompiler ton module intel
                • [^] # Faire sauter xorg.conf

                  Posté par . Évalué à 2.

                  On m'a suggéré de supprimer xorg.conf, et, vrai, ça a réglé le problème de l'image vidéo en négatif. Par contre, perte du déroulement avec la souris intégrée...
                  • [^] # Re: Faire sauter xorg.conf

                    Posté par . Évalué à 2.

                    evidemment tu auras gardé un copie de ce fichier quelquepart,
                    afin de remettre les options qui gerent la souris integrée ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.