Forum Linux.mandriva Problème de police Gtk

Posté par (page perso) .
Tags : aucun
0
20
nov.
2004
Bonjour tout le monde

J'utilise une Mandrake 10.1 (à moitié cookerizé pour kde3.3.1) et j'ai un problème de différences de polices entre les applis QT et les applis GTK.

En effet, en GTK, la police est plus petite que les applis QT.

Lorsque je tente de modifier les polices via gnome-font-properties, sans que je ne touche à rien, le simple fait de le lancer repositionne convenablement la police à une taille normale mais les applis QT nouvellement lancées sont automatiquement dans une très grosse police sans que je leur ai rien demandé.

Le fait de redémarrer arrange les choses, mais les applis GTK retournent à leur petite taille de police.

En essayant de toucher dans la configuration de KDE pour les polices, il ne se passe rien de spécial, cela marche.

Bref, c'est vraiment bidon et étrange et à mon avis, il y a une sorte d'autosynchronisation des polices entre GTk et KDE, mais comme elles sont décalés, cela bogue complètement.

PS: Ce n'est pas du à Cooker, j'ai ce problème depuis la 10.0 (par contre je ne dirais pas que ce n'est pas la faute de la Mdk ;-)

Bref connaitriez vous directement le fichier à bidouiller pour remettre les applis Gtk à une taille de police convenable, qu'il s'en rappelle une fois pour toutes et qu'il ne touche pas ne même temps à mes polices KDE.


Merci d'avance et j'attends vos réponses avec impatience...
  • # Suggestion pas terrible...

    Posté par . Évalué à 1.

    J'ai eu le même problème (mdk10.0) ; en fait après avoir réglé les polices sous kde et sous gnome, à chaque redémarrage de kde les polices gnomes étaient celles par défaut jusqu'à ce que je relance gnome-font-properties.
    
    Ma solution (je pense qu'il doit y avoir un autre moyen car je trouve pas ça terrible...) :
    - Créer un fichier (ex : gnomefonts) dans ~/.kde/Autostart et le rendre exécutable
    - Y copier le texte suivant :
    
    #!/bin/bash
    #
    #
    nohup gnome-settings-daemon --oaf-activate-iid=OAFIID:GNOME_SettingsDaemon 
    
    Au démarrage de kde normalement les polices gnomes seront celles souhaitées (pas de pb avec les polices kde).
    • [^] # Re: Suggestion pas terrible...

      Posté par . Évalué à 1.

      J'ai eu ce problème (ou similaire) sur mon précédent laptop thinkpad et pas sur l'actuel X40. Voici les notes pour la solution de mon problème (incluant les liens) que j'avais prises à ce sujet:

      (http://www.mandrakeclub.com/modules.php?op=modload&name=Splatt_(...))
      Dans le fichier /etc/X11/fs/config,

      default-point-size = 120

      il faut mettre 100 au lieu de 120 (je ne sais pas si ca fait quelque chose en tout cas je l'ai mis à 100)

      Il faut mettre:
      default-resolutions = 100,100,75,75 au lieu de 75,75,100,100


      Et enfin, modifier le fichier /etc/X11/xdm/Xservers en mettant -dpi 96 comme paramètre:

      :0 local /usr/X11R6/bin/X -deferglyphs 16 -dpi 9

      Depuis j'ai lu dans le forum de Mandrake club que celà pouvait être dû à l'absence d'une fonte ou au mauvais ordre des fontes dans une liste, mais je n'ai pas approfondi car je n'avais plus le problème.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.