Forum Linux.redhat Fail lors du Dual Boot Windows 10/Centos 7

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
10
sept.
2019

Bonjour,

Premièrement je m'excuse si ce sujet a déjà été traité ou si je poste au mauvais endroit, je suis tout nouveau à la fois sur le forum et sur Linux.

J'ai voulu faire un DualBoot sur mon PC (Windows 10) et ai donc fait une partition de mon sotkcage de 2To : 1.8 To pour windows et 200 Go pour Centos 7. A la suite de ceci j'ai téléchargé l'image iso de centos directement sur leur site et ai effectué le boot sur une clé USB.

J'ai redémarré le PC , suis entré dans le BIOS et ai lancé l'installation de Centos sur (ce que je croyais être) la partition réservée à cet usage. Or petit soucis, je ne sais pas comment retourner sur mon windows lorsque j'eteins et rallume le PC, on ne me propose que Centos 7 et Centos 7 recovery (quelque chose dans le genre).

Lorsque je regarde via l'explorateur de fichier je vois dans "autres emplacement" la partition de 1.8 To et ne peux pas y acceder depuis Linux.

Si quelqu'un pouvait m'aiguiller sur la marche a suivre je lui en serait très reconnaissant.

Merci d'avance

Dylan

  • # Plus d'info

    Posté par  . Évalué à 2.

    Il nous faudrait une "photo" de la "scène du crime" !

    Dans une console, probablement en tant que root pour que ça fonctionne, il nous faudrait au moins ça :

    fdisk -l
    

    pour lister les disques et leurs partitions. Et ensuite :

    df -h /
    

    Pour savoir quelle est la partition '/', le root filesystem.
    Ça permettra de savoir où tu as installé ton Linux déjà.

    Autre possibilité : utiliser un outil graphique comme gparted.

    • [^] # Re: Plus d'info

      Posté par  (site Web personnel) . Évalué à 2.

      Dans une console, probablement en tant que root pour que ça fonctionne, il nous faudrait au moins ça :

      fdisk -l

      pour lister les disques et leurs partitions.

      Donc soit

      $ sudo fdisk -l
      si tu fait partie des sudoers

      sinon

      $ su
      Mot de passe : (<== tu tapes le mot de passe root)

      fdisk -l

      Ensuite nous montrer le contenu de /etc/fstab

      cat /etc/fstab

      ce qui nous dirait qu'elles sont les partitions montées au démarrage de la machine, et voir si la partition Windows est montée et où

      $ su
      Mot de passe :    (<== tu tapes le mot de passe root)
      # fdisk -l
      

      « Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes. »

      • [^] # Re: Plus d'info

        Posté par  (site Web personnel) . Évalué à 2.

        J'ai eu un problème d'édition de mon post (d'ailleurs si un modo peut l'effacer). Je reposte donc la correction. Désolé pour le bruit !


        Dans une console, probablement en tant que root pour que ça fonctionne, il nous faudrait au moins ça :

        fdisk -l

        pour lister les disques et leurs partitions.

        Donc soit

        $ sudo fdisk -l

        si tu fait partie des sudoers

        sinon

        $ su
        Mot de passe :    (<== tu tapes le mot de passe root)
        # fdisk -l
        

        Ensuite nous montrer le contenu de /etc/fstab

        cat /etc/fstab

        ce qui nous dirait qu'elles sont les partitions montées au démarrage de la machine, et voir si la partition Windows est montée et où.

        Et comme dit ailleurs il faut que tu redémarre Windows pour correctement l'éteindre. Puisque tu ne le vois pas dans grub, il faut qu'a l'allumage de la machine tu appuie sur Del, F2 … pour pouvoir choisir sur quelle partition tu va démarrer (si ton bios le permet).

        Edit: pour ceux qui auront lu ce post avant l'Edit, le coup est parti tout seul !

        « Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes. »

  • # bonne nouvelle

    Posté par  . Évalué à 4.

    le fait que tu vois la partition de 1.8To prouve que tu ne l'as pas effacée par "erreur" lors de l'installation de linux.

    le fait de ne pas pouvoir y acceder, c'est simplement que le windows n'a pas "liberé" la partition lorsque tu as redemarré (le windows s'est en fait mis en veille et non en arret complet)

    du coup la bonne nouvelle, c'est qu'il faut juste faire detecter les partitions windows par le gestionnaire de demarrage (GRUB).

    quand tu dis etre allé dans le bios pour faire l'installation,
    c'etait pour demarrer sur la clef USB ou pour changer UEFI/BIOS/CSM ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.