Forum Linux.redhat Samba - ADS

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
5
oct.
2018

Bonjour,

Je suis en train de configurer Samba pour communiquer sur l'AD.
Sur 2 serveurs de test, cela fonctionne parfaitement.
Mais maintenant que je souhaite le passer en recette avec la même configuration, cela ne fonctionne qu'à moitié, je m'explique :

Les partages sont sur les serveurs REDHAT et je les ai connectés à l'AD [net ads join …]
Les commandes wbinfo et getend fonctionne parfaitement, je vois bien les users et groupes de l'AD.

Quand j'utilise mon compte du domaine, j'arrive bien à accéder aux partages :

[root@ serveur v9.4 samba]# smbclient //serveur/partage -U myuser
WARNING: The "idmap uid" option is deprecated
WARNING: The "idmap gid" option is deprecated
Enter myuser's password:
Domain=[mydomain] OS=[Unix] Server=[Samba 3.6.23-24.el6_7]
smb: >

Mais quand j'utilise un autre compte applicatif, cela ne fonctionne pas :

[root@ serveur v9.4 samba]# smbclient //serveur/partage -U srvprod1
WARNING: The "idmap uid" option is deprecated
WARNING: The "idmap gid" option is deprecated
Enter srvprod1's password:
session setup failed: NT_STATUS_LOGON_FAILURE

Ce compte ne pose pas de problème sur les 2 autres serveurs, donc pourquoi sur celui-ci ?, sachant que ce n'est pas un compte local mais bien un compte du domaine.

  • # Problème de chiffrement ou de ntp

    Posté par  (site Web personnel) . Évalué à 4. Dernière modification le 08/10/18 à 09:16.

    Première chose, vérifie que ton serveur est à l'heure ;)

    Ensuite, il faut connaître le chiffrement en place sur ton AD et adapté la conf kerberos en fonction.

        $ cat /etc/krb5.conf 
        [libdefaults]
            default_realm = *****************
            dns_lookup_realm = false
            dns_lookup_kdc = true
            default_tkt_enctypes = rc4-hmac
            default_tgs_enctypes = rc4-hmac

    Les deux dernières lignes correspondent au chiffrement en place sur l'AD.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.