Forum Programmation.web www.messervices.etudiant.gouv.fr : bug ou pas bug ?

Posté par  . Licence CC By‑SA.
Étiquettes :
1
4
juil.
2019

La page https://www.messervices.etudiant.gouv.fr/envole/recuperation/email est censée afficher un captcha mais l'image est invisible si j'ouvre la page avec Firefox (version 67.0.4 64 bits pour Ubuntu 18.04) ou avec Fennec (67.0.3) pour Android
Si j'ouvre la page avec Firefox Klar ou avec Chrome sous Android ou avec Chromium sous Ubuntu, je vois l'emplacement du captcha mais pas l'image elle-même. Pourtant elle existe bien et on peut l'afficher. Pour Firefox j'y arrive en passant par le code source de la page, pour Chrome et Firefox Klar on peut faire afficher l'image dans un autre onglet en cliquant dessus.

Qu'est-ce qui peut expliquer que l'image ne soit pas visible ? Tous mes essais sur l'abaissement des protections de Firefox/Fennec n'ont rien changé, que ce soit en désactivant les extensions uBlock Origin et uMatrix ou en jouant avec les paramètres de Firefox.
Comme le problème existe avec plusieurs navigateurs, mon idée est que le code de la page est probablement fautif.

Avez-vous une idée de ce qui ne va pas dans cette page ?

  • # Ça va pas t'aider ou peut-être que oui

    Posté par  (site Web personnel) . Évalué à 3. Dernière modification le 04/07/19 à 21:02.

    Mais à un moment donné, le site de l'EDF quand tu voulais payer, posait le même problème avec Firefox. Il fallait accepter les cookies tiers.

    Maintenant est-ce que ce site est configuré avec les pieds pareillement ?

    OS préféré Mageia 7, CMS préféré SPIP, suite bureautique préférée LibreOffice, logiciel de dessin préféré Inkscape.

  • # Code source

    Posté par  . Évalué à 1.

    Regarde le code source de la page, l'image du capcha y est présente en base64 (class="captcha_image")

    • [^] # Re: Code source

      Posté par  . Évalué à 2.

      Je sais bien qu'elle est présente, je l'ai précisé dans ma question. Elle est là mais elle n'est pas affichée. Pourquoi ?

      • [^] # Re: Code source

        Posté par  . Évalué à 2. Dernière modification le 05/07/19 à 00:27.

        Dans la console de Firefox, j'ai ce message d'erreur:

        Content Security Policy: Les paramètres de la page ont empêché le chargement d’une ressource à data:image/jpeg;base64,/9j/4AAQSkZJRgABA… (« img-src »).

        • [^] # Re: Code source

          Posté par  . Évalué à 2.

          Ah, je vois aussi, merci.
          C'est quoi "les paramètres de la page" ? Est-ce quelque chose sur lequel moi utilisateur je peux agir, comme une configuration à modifier ?

          • [^] # Re: Code source

            Posté par  (site Web personnel) . Évalué à 3.

            Remonté et corrigé chez eux.

            Merci du signalement.

            « Je vois bien à quels excès peut conduire une démocratie d'opinion débridée, je le vis tous les jours. » (Nicolas Sarkozy)

            • [^] # Re: Code source

              Posté par  . Évalué à 2. Dernière modification le 05/07/19 à 11:03.

              Merci ! Comment avez-vous fait pour leur signaler le problème ? Je n'ai pas trouvé d'adresse de contact pour signaler ce genre de problème.

              • [^] # Re: Code source

                Posté par  (site Web personnel) . Évalué à 4.

                J'ai fait 3 mètres à pied et demandé à mon collègue ;)

                https://www.cadoles.com/projects/pve

                Sinon il y a le formulaire de contact du site, mais ça peut mettre un peu de temps avant de remonter jusqu'aux développeurs/admin sys. Tu peux aussi twitter en mentionnant l'adresse du site, j'ai une alerte dessus.

                « Je vois bien à quels excès peut conduire une démocratie d'opinion débridée, je le vis tous les jours. » (Nicolas Sarkozy)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.