KDE 3.0.1

Posté par . Modéré par Benoît Sibaud.
Tags :
0
23
mai
2002
KDE
La version 3.0.1 de KDE est disponible et se propage sur les miroirs (j'en ai trouvé 2 à jour, sans compter le site principal ftp.kde.org qu'il ne faut pas utiliser pour le réserver aux miroirs). Attendez quelques heures pour avoir un miroir dispo près de chez vous.
Il y a pour le moment, en plus des archives sources, des paquets pour Conectiva 8.0 et source, Gentoo, Mandrake 8.0 8.1 8.2 et source, SuSE 7.0 7.1 7.2 7.3 8.0 et source, et Tru64.

Note du modérateur : en plus des corrections de bogues, cette version apporte de nombreuses traductions qui manquaient à la 3.0.

Aller plus loin

  • # Late

    Posté par . Évalué à -10.

    Yes, premier post !

    Et GNOME 2 en beta 5, un peu à la bourre mais bon...
    J'me console, j'vais pouvoir tester kde 3.0.1 avec les packages Mandrake...

    [-1 parce que non constructif]
  • # Requiert ...

    Posté par (page perso) . Évalué à 10.

    Il est nécessaire d'avoir : o Qt 3.0.3 pour X11 [ http://www.trolltech.com/developer/download/qt-x11.html ] o gcc > 2.95 (versions antérieures et versions 3.0.x non patchées poseront problème) Autrement, KDE 3.0.1 est livré avec : o KDevelop (Environnement de développement graphique "intuitif") o KOffice (une suite de logiciels de bureautique) o Une série d'outils d'administration et de mise en réseau (dont kmail obtient le plus grand nombre de fixes/évolutions) Vous pouvez aussi consulter le changelog officiel [ http://www.kde.org/announcements/changelog3_0to3_0_1.html ] Tous à vos MAJ... Have Fun !
    • [^] # Re: Requiert ...

      Posté par . Évalué à -10.

      Je me demande si cette mise a jour est vraiment utile.

      Un peu comme les Windows User je me rend compte que les Linux users sont des adeptes de la versionite (Style j'ai ma mandrake 8.1 qui va bien , faut absolument passer a la 8.2 au risque de tout perdre)

      KDE 3.0 fonctionne tres bien (notamment sur ma distrib que je ne citerai pas pour eviter un troll) alors pourquoi mettre à jour ?
      • [^] # Re: Requiert ...

        Posté par . Évalué à 10.

        Effectivement - JE - suis affecté de versionnite...
        mais je m'en explique si besoin:
        comme pas mal de personnes qui trainent sur linuxfr je pense, l'informatique est mon métier, et ma passion.
        Je me dois de me maintenir au courant de ce qui se fait, pour pouvoir continuer a conseiller/travailler chez mes clients ...
        Bref j'installe et je desinstalle beaucoup, je compile, j'efface, je migre, je reformate... (mais pas sur mes machines critiques !!)
        Faire et defaire fait partie de mon métier, ca fait partie de la veille techno.
        Comment répondre à mes clients qui tournent en redhat 6.2 ou 7.2 ce qu'apporterai la 7.3 si je ne l'utilise pas ??

        Du coup, bien que je n'utilise que linux, j'ai un windows 2000 sous vmware "pour voir". Sinon je ne connaitrais pas windows update, la registry, les antivirus ... je serai malheureux quoi :-)

        remarque: non je ne testerai pas KDE cette fois ci, j'ai d'autres chats a fouetter, et les environnements utilisateurs sont un peu loin de mes préoccupations (serveur/cluster/reseau/securite).

        Donc bonne installation a tout ceux que cela chante !! C'est en installant / migrant que l'on apprends le plus. Il faut conserver les données, modifier les configurations, ... plein de motifs pour apprendre un nouveau truc.
        • [^] # Re: Requiert ...

          Posté par . Évalué à 10.

          Effectivement - JE - suis affecté de versionnite...

          Pareil :-)

          C'est en installant / migrant que l'on apprends le plus. Il faut conserver les données, modifier les configurations, ... plein de motifs pour apprendre un nouveau truc

          Pareil encore ...

          De toute facon, personne ne doit se sentir oblige de faire des MAJ sur sa machine standalone (je ne parle pas de serveurs, bien sur, qui n'en n'ont de toute facon rien a faire de KDE ;-) ) ...

          Si certains se sentent obligés de troller sur les frequences des MAJ, qu'importe, moi je suis tjs heureux de voir un petit bug qui me genait corrigé ...

          Celui qui n'aime pas les MAJ n'a qu'a s'installer une Potato a partir des CDs sans access a l'ADSL, il pourra se sentir "warlord comblé" ... ;-))))
      • [^] # Re: Requiert ...

        Posté par . Évalué à 10.

        Le changelog http://www.kde.org/announcements/changelog3_0to3_0_1.html(...) fait 135 lignes dont :


        • The faster malloc replacement for Linux/glibc systems has been made default.

        • lilo-config: fixed crash.

        • Konqueror: Don't crash in some cases when a kpart exits.

      • [^] # Re: Requiert ...

        Posté par (page perso) . Évalué à 10.

        KDE en tout cas, n'est pas adepte de la versionite. Cette nouvelle version a une raison d'etre. Elle permet d'avoir une traduction complete pour les equipes un peu a la bourre (ce n'est pas le cas de la version francaise) et corrige quelques bugs.

        Typiquement, je conseillerai a une distrib de ne pas distribuer une version KDE x.0 mais plutot d'attendre la x.0.1 si c'est possible. Le deploiement massif de la version initiale permet de trouver les quelques bugs qui ont echappe aux developpeurs, et surtout d'avoir des tradcutions bien a jour (je me repete la ?)

        > KDE 3.0 fonctionne tres bien
        Mais c'est encore KDE 3.0, bugfix release 1, donc il fonctionnera tout aussi bien, avec quelques bugs en moins.
    • [^] # Re: Requiert ...

      Posté par (page perso) . Évalué à 6.

      J'utilise gcc 3.1 et tout compile bien, sauf kdevelop et koffice. Tu parles d'un patch pour les versions 3.0.x, ou peut-on le trouver ?
      • [^] # Re: Requiert ...

        Posté par (page perso) . Évalué à 5.

        Tu trouveras là [ http://gcc.gnu.org/releases.html(...) ] la liste des releases de gcc... le tout sur le site officiel.

        Je dois t'avouer que je n'ai jamais essayé gcc-3.0.x car je suis passé de la 2.95.3 à la 3.1 sans transition !... Je dois avouer avoir piqué l'info des bugs de gcc-3.0 sur le site officiel (honte à moi). :cD

        Happy compils' !
        • [^] # J'ai toujours honte de me poser des questions cons....

          Posté par . Évalué à 2.

          dites M'sieur, siouplé...

          hep, pourriez me dire si ca vaux bien le coup de compiler kde avec la 3.1 de GCC? (alors ca arrache-t-y vraiment des moules)... ma slack tourne sur des i386... ca boost si je recompile sur mon p3?

          merci m'sieur
  • # J'en etais sur!

    Posté par . Évalué à 10.

    J'ai telecharge KDE 3.0 hier soir!

    Grrr.

    Et pour ce qui est de l'accusation de "versionnite", c'est surtout les corrections de bugs qui m'interressent..
    Contrairement aux logiciels commerciaux, les mise-a-jour mineures font en general bien leur boulot dans les logiciels libres: elles corrigent des bugs et c'est tout!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.