Nouveaux pilotes pour les cartes ATI

Posté par  . Modéré par Benoît Sibaud.
Étiquettes :
0
2
jan.
2004
Matériel
Le pilote propriétaire pour Linux passe en version 3.7.0

Cartes concernées :
- ATI Radeon 8500, 9100, 9200, 9500, 9600, 9700, 9800,
- ATI Mobility 9000, 9600
- ATI FireGL 8700, 8800, E1, E2, X1, X2, Z1, T2
- ATI Mobility FireGL T2 Le changelog pour cette version :

- Un bug provoquant un crash avec le jeu "Savage" de S2games a été corrigé (la nouvelle version de Savage est en cours de bêta-test... n'oubliez pas de vous inscrire ;-) )
- Support pour RHEL 3.0 (Red Hat Ships Enterprise Linux 3.0)
- FSAA amélioré (Full Screen Anti-Aliasing ou Full Scene Anti-Aliasing selon les articles et les auteurs)
- Ajout du support pour les cartes MOBILITY FireGL T2

Il n'y a pas encore beaucoup de commentaires sur le forum de Linuxgames.com, la source de l'information, mais il peut être intéressant de le consulter plus tard pour lire les retours des tests des utilisateurs du forum.

Aller plus loin

  • # Radeon 7500 ?

    Posté par  (site Web personnel) . Évalué à 2.

    Question bete mais j'ai entendu dire qu'on pouvait utiliser ces pilotes sur des cartes de type radeon 7500, quelqu'un peut confirmer ?

    Steph
    • [^] # Re: Radeon 7500 ?

      Posté par  (site Web personnel) . Évalué à 1.

      C'est la premiere fois que je tente l'installation de ces drivers sur mon LFS, donc je fais ca en roue libre, ceci est a prendre avec des pincettes. Voila ce que j'obtiens:
      # lspci
      01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
      # ./make_install.sh
      - creating symlink
      - recreating module dependency list
      - trying a sample load of the kernel module
      /lib/modules/2.4.23/kernel/drivers/char/drm/fglrx.o: init_module: No such device


      Je pense que la reponse est donc "non".

      khorben

    • [^] # Re: Radeon 7500 ?

      Posté par  (site Web personnel) . Évalué à 3.

      Je prefere les drivers du projet GATOS :
      http://sourceforge.net/project/showfiles.php?group_id=12629(...)

      A vous de voir
      Enjoy
  • # Re: Nouveaux pilotes pour les cartes ATI

    Posté par  (site Web personnel) . Évalué à 1.

    Ils ne parlent plus de RADEON 9000 ???
  • # Re: Nouveaux pilotes pour les cartes ATI

    Posté par  . Évalué à 2.

    Perso je les ai testes sur une debian avec xfree 4.3.99 (celui du package DRI) et ben ca plante... ca marche correctement puis je veux relancer une appli opengl et la ecran tout zarbi et plus moyen de faire quoi que ce soit...
    P.S. c'etait pareil avec les autres versions des drivers
    P.P.S. j'ai une radeon 9000 mobility
  • # Re: Nouveaux pilotes pour les cartes ATI

    Posté par  . Évalué à 2.

    quid des performances ?
    à quand un installeur (et outil de configuration) de la meme trampe que Nvidia ? parce que le rpm qui contient un tgz à décompresser/make/install, c'est franchement indigeste et rebutant
    • [^] # Re: Nouveaux pilotes pour les cartes ATI

      Posté par  . Évalué à 2.

      [root@athlon modules]# dpkg -i fglrx-glc22_4.2.0-4.7_i386.deb
      *(Lecture de la base de données... 117939 fichiers et répertoires déjà installés.)
      Dépaquetage de fglrx-glc22 (à partir de fglrx-glc22_4.2.0-4.7_i386.deb) ...
      dpkg : erreur de traitement de fglrx-glc22_4.2.0-4.7_i386.deb (--install) :
      tentative de remplacement de « /usr/X11R6/lib/libGL.so.1.2 », qui appartient aussi au paquet xlibmesa3-gl
      dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
      Des erreurs ont été rencontrées pendant l'exécution :
      fglrx-glc22_4.2.0-4.7_i386.deb



      :o
    • [^] # Re: Nouveaux pilotes pour les cartes ATI

      Posté par  (site Web personnel) . Évalué à 1.

      La manipulation a effectuer pour decompresser ressemble a ca:
      $ rpm2cpio fglx.rpm > fglx.cpio
      $ cpio -i --make-directories < fglx.cpio

      HTH

      khorben

  • # Re: Nouveaux pilotes pour les cartes ATI

    Posté par  . Évalué à 1.

    Une question qui me trotte dans la tête depuis longtemps : quand un constructeur sort une nouvelle carte graphique mais qu'il n'y a pas encore de pilote ni propriétaire ni dans XFree, qu'est-ce qui se passe concrètement : la carte est-elle totalement inutilisable dans Linux, ou marche-t-elle seulement en 2D-VGA-machintruc-60Hz ? J'imagine que les applications comme TVTime ou Xine doivent ramer, non ?

    Une autre question : quel intéret pourrais-je avoir à passer aux pilotes d'ATI sur ma 8500 ? La compression de textures dans les jeux ?
    • [^] # Re: Nouveaux pilotes pour les cartes ATI

      Posté par  . Évalué à 1.

      comment tu la fait marcher en 3D sans ?
      • [^] # Re: Nouveaux pilotes pour les cartes ATI

        Posté par  . Évalué à 1.

        Ben elle marche en 3D avec les pilotes XFree...
        Il faut juste qu'il y ait dans le fichier /etc/X11/XF86Config-4 :
        Load "dri"
        et
        Section "DRI"
        Mode 0666
        EndSection
        Je ne sais pas si c'était ta question...

        Je peux même jouer à Quake III et Serious Sam.
        • [^] # Re: Nouveaux pilotes pour les cartes ATI

          Posté par  . Évalué à 1.

          sans déconner ? et quelles performances ? quel score à glxgears ?
          t'es sur de pas avoir une distribution avec les pilotes intégrés ?
          • [^] # Re: Nouveaux pilotes pour les cartes ATI

            Posté par  (site Web personnel) . Évalué à 1.

            Avec une Radeon 9000 et les pilotes de Xfree (MDK 92)

            [zapoyok@zapoyok zapoyok]$ glxgears
            6968 frames in 5.0 seconds = 1393.600 FPS
            8239 frames in 5.0 seconds = 1647.800 FPS
            8187 frames in 5.0 seconds = 1637.400 FPS
            8166 frames in 5.0 seconds = 1633.200 FPS

            Aucune idée de ce à quoi çà correspond par rapport à d'autres cartes
            • [^] # Re: Nouveaux pilotes pour les cartes ATI

              Posté par  . Évalué à 1.

              sur une ati 8500 powered, driver XFree 4.3 DRI activé.
              en premier plan : 2200 FPS
              en arière plan : 4800 FPS
            • [^] # Re: Nouveaux pilotes pour les cartes ATI

              Posté par  . Évalué à 1.

              hum hum, il me semble justement que Mandrake intègre les pilotes ATI ... donc ça serait pas parceque tu les as pas installé manuellement qu'ils n'y sont pas
              • [^] # Re: Nouveaux pilotes pour les cartes ATI

                Posté par  (site Web personnel) . Évalué à 1.

                Merci mais je sais encore ce que j'installe ou pas.

                Mandrake n'inclus aucunement les drivers dans sa distribution. Mandrake les rend disponibles en RPM, soit à partir de la powerpack ou du club !

                Jérôme.
                • [^] # Re: Nouveaux pilotes pour les cartes ATI

                  Posté par  . Évalué à 1.

                  j'ai fait plein de conditionnel, calme toi. tu peux donner un lien vers ton config ou coller ta section device ?
                  • [^] # Re: Nouveaux pilotes pour les cartes ATI

                    Posté par  (site Web personnel) . Évalué à 1.

                    Bon je viens de l'installer

                    Mandrake 9.2 ,noyau 2.4.22-21mdk, xfree 4.3-24.1.92mdk, fglrx-glc22-4.3.0-3.7.0

                    [zapoyok@zapoyok zapoyok]$ glxgears
                    9313 frames in 5.0 seconds = 1862.600 FPS
                    10901 frames in 5.0 seconds = 2180.200 FPS
                    10868 frames in 5.0 seconds = 2173.600 FPS
                    10819 frames in 5.0 seconds = 2163.800 FPS
                    10905 frames in 5.0 seconds = 2181.000 FPS
                    10801 frames in 5.0 seconds = 2160.200 FPS
                    10862 frames in 5.0 seconds = 2172.400 FPS


                    Donc apparemment les performances sont un peu meilleures, mais vu que je ne joue pas !!


                    Sinon ma section device (Xfree de base) :

                    Section "Device"
                    Identifier "device1"
                    VendorName "ATI"
                    BoardName "ATI Radeon (fglrx)"
                    Driver "radeon"
                    Screen 0
                    BusID "PCI:1:0:0"
                    Option "DPMS"
                    EndSection

                    C'est celle générée par l'installeur de Mandrake

                    et celle générée par ATI

                    # === ATI device section ===

                    Section "Device"
                    Identifier "ATI Graphics Adapter"
                    Driver "fglrx"
                    # ### generic DRI settings ###
                    # === disable PnP Monitor ===
                    #Option "NoDDC"
                    # === disable/enable XAA/DRI ===
                    Option "no_accel" "no"
                    Option "no_dri" "no"
                    # === misc DRI settings ===
                    Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
                    # ### FireGL DDX driver module specific settings ###
                    # === Screen Management ===
                    Option "DesktopSetup" "0x00000000"
                    Option "MonitorLayout" "AUTO, AUTO"
                    Option "IgnoreEDID" "off"
                    Option "HSync2" "unspecified"
                    Option "VRefresh2" "unspecified"
                    Option "ScreenOverlap" "0"
                    # === TV-out Management ===
                    Option "NoTV" "yes"
                    Option "TVStandard" "NTSC-M"
                    Option "TVHSizeAdj" "0"
                    Option "TVVSizeAdj" "0"
                    Option "TVHPosAdj" "0"
                    Option "TVVPosAdj" "0"
                    Option "TVHStartAdj" "0"
                    Option "TVColorAdj" "0"
                    Option "GammaCorrectionI" "0x00000000"
                    Option "GammaCorrectionII" "0x00000000"
                    # === OpenGL specific profiles/settings ===
                    Option "Capabilities" "0x00000000"
                    # === Video Overlay for the Xv extension ===
                    Option "VideoOverlay" "on"
                    # === OpenGL Overlay ===
                    # Note: When OpenGL Overlay is enabled, Video Overlay
                    # will be disabled automatically
                    Option "OpenGLOverlay" "off"
                    # === Center Mode (Laptops only) ===
                    Option "CenterMode" "off"
                    # === Pseudo Color Visuals (8-bit visuals) ===
                    Option "PseudoColorVisuals" "off"
                    # === QBS Management ===
                    Option "Stereo" "off"
                    Option "StereoSyncEnable" "1"
                    # === FSAA Management ===
                    Option "FSAAEnable" "no"
                    Option "FSAAScale" "1"
                    Option "FSAADisableGamma" "no"
                    Option "FSAACustomizeMSPos" "no"
                    Option "FSAAMSPosX0" "0.000000"
                    Option "FSAAMSPosY0" "0.000000"
                    Option "FSAAMSPosX1" "0.000000"
                    Option "FSAAMSPosY1" "0.000000"
                    Option "FSAAMSPosX2" "0.000000"
                    Option "FSAAMSPosY2" "0.000000"
                    Option "FSAAMSPosX3" "0.000000"
                    Option "FSAAMSPosY3" "0.000000"
                    Option "FSAAMSPosX4" "0.000000"
                    Option "FSAAMSPosY4" "0.000000"
                    Option "FSAAMSPosX5" "0.000000"
                    Option "FSAAMSPosY5" "0.000000"
                    # === Misc Options ===
                    Option "UseFastTLS" "0"
                    Option "BlockSignalsOnLock" "on"
                    Option "UseInternalAGPGART" "yes"
                    Option "ForceGenericCPU" "no"
                    BusID "PCI:1:0:0" # vendor=1002, device=496e
                    Screen 0
                    EndSection
          • [^] # Re: Nouveaux pilotes pour les cartes ATI

            Posté par  . Évalué à 1.

            J'ai laissé les pilotes XFree de la Mandrake 9.2.
            Pour glxgears :
            7746 frames in 5.0 seconds = 1549.200 FPS
            7891 frames in 5.0 seconds = 1578.200 FPS
            Quake III marche très bien (AthlonXP1600+), moins que dans Windows bien sûr à cause des textures non compressées. Il est super stable. Serious Sam marche nettement plus lengtement que dans Windows, mais ça reste tout à fait honnète. Jusqu'ici je n'ai eu qu'un plantage, mais je n'y ai joué que quelques heures. Par contre j'avais essayé rapidement la démo d'UT2003, et là ça plantait lamentablement... Je n'ai pas esssayé grand-chose d'autre.
            • [^] # Re: Nouveaux pilotes pour les cartes ATI

              Posté par  (site Web personnel) . Évalué à 1.

              Il y a quelques options sympa a rajouter pour accelerer un peu:

              J'ai ca:

              Section "Device"
              Identifier "Radeon8500"
              Driver "ati"
              Option "UseFBDev" "true"
              Option "AGPMode" "4"
              Option "AGPFastWrite" "true"
              Option "AGPSize" "64" # default: 8
              Option "RingSize" "8"
              Option "BufferSize" "2"
              Option "EnablePageFlip" "true"
              EndSection


              Je suis passé d'a peu près les même chiffres que toi a ca:
              $ glxgears
              9735 frames in 5.0 seconds = 1947.000 FPS
              10591 frames in 5.0 seconds = 2118.200 FPS
              10596 frames in 5.0 seconds = 2119.200 FPS
              10598 frames in 5.0 seconds = 2119.600 FPS

              Ma machine est un peu chargé, je pense qu'a vide, ca doit monter un poil plus haut.

              PS: glxgears n'est carrement pas un bon outil de benchmark! Il est surtout utile pour comparer certaines perfs en bidouillant, mais pas pour comparer 2 drivers radicalement different.
          • [^] # Re: Nouveaux pilotes pour les cartes ATI

            Posté par  (site Web personnel) . Évalué à 1.

            Il n'y a pas que les solutions propretaires pour avoir de la 3D!

            Les drivers d'xfree86/DRI existent pour les radeons (et supporte aussi la 7500 contrairement a ceux d'ATI). Et non seulement ils existent, mais les radeon font partit des cartes les mieux supportés par DRI. Bien sur, les drivers fait par ATI sont plus performant, (et encore que, après les avoir testés il ya longtemps, ils etaient bourrés de bugs, et supportaient mal la 2D).
            Pour ce qui est des textures compressés (S3TC), des patchs trainent, ils ne sont pas inclus à cause de brevets logiciels, mais on peut peut être s'attendre à trouver une version non-US avec le support S3TC integré un jour...
    • [^] # Re: Nouveaux pilotes pour les cartes ATI

      Posté par  . Évalué à 1.

      ca marche generalement en vesa , neanmoins il y a eu quelques exceptions comme l i810 qui ne le supporte pas dans ce cas c etait vga16 couleurs
      • [^] # Re: Nouveaux pilotes pour les cartes ATI

        Posté par  . Évalué à 1.

        En VESA, la fréquence et la résolution d'affichage sont limitées, non ?
        Xv dans Xine, ça fonctionnerait ?

        Je suis désolé pour ces questions de débutant, mais je m'y perds un peu...
  • # Re: Nouveaux pilotes pour les cartes ATI

    Posté par  . Évalué à 0.

    Bon... personne se lance...

    -Un bug provocant un crash
    +Un bug provoquant un crash
  • # problème avec himem ?

    Posté par  . Évalué à 1.

    depuis que je suis passé à 1Go de RAM (donc himem 4G), mon système plante aléatoirement au bout d'environ 24H on va dire... ça me laisse perplexe ... le dernier plantage, l'affichage est parti en sucette, merci les touches magiques, j'ai pas tout foutu en l'air...

    bref je me demande s'il n'y a pas de problème entre le driver ATI proprio et himem (ma ram étant OK) ? la je suis repassé avec radeon XF4.2 pour essayer (toutes façons j'arrive po à reinstaller proprement ces derniers drivers :o)
  • # Re: Nouveaux pilotes pour les cartes ATI et kernel 2.6.0

    Posté par  (site Web personnel) . Évalué à 1.

    Salut,

    Moi j'ai un problème avec le kernel 2.6.0: la création du module ne passe pas.
    Pourtant, lors du lancement du script, il me dit "assuming new VMA API since we do have kernel 2.6.x..." donc il a l'air d'être prévu pour ca. Cependant, le Makefile généré ne crée pas le module. Il s'arrête en disant "Makefile:50: *** mixed implicit and normal rules. Stop." et ca s'arrête là... Quelqu'un a des infos sur ce problème ?
    Ma config: debian/sid, kernel 2.6.0, gcc 3.3.3, xfree 4.3

    Merci :-)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.