Sortie de Galeon 2.0

Posté par . Modéré par Nÿco.
Tags :
0
29
nov.
2005
Internet
Sortie ce dimanche 27 novembre de la version 2.0 de Galeon, navigateur écrit en GTK+, pour Gnome et basé sur Gecko.

Au menu de cette version "un dernier pour la route" :
  • Fonctionne avec Mozilla 1.7.5+, 1.8a3 et supérieurs, Firefox 1.0.x et 1.5
  • Incorporation des pages de messages d'erreur HTTP.
  • Bouton de gestion des éléments de sécurité dans les préférences de sécurité.
  • La touche Delete fonctionne maintenant dans le gestionnaire de données personnelles.
  • Support des touches des claviers multimédia comme Back et Forward.
  • Corrections de bugs

Cette version est la dernière de Galeon tel qu'on le connaît. Pour rappel, en octobre dernier les développeurs de Galeon ont adressé un courriel aux listes Galeon-user, Galeon-devel et Galeon-announce, dans lequel ils ont annoncé que Galeon va fusionner avec Epiphany.

Il est donc rappelé sur le site de Galeon que cette sortie n'est en rien une reprise du développement mais bien la dernière version prévue lors de cette décision et que le travail sera désormais, hormis d'éventuels correctifs, axé sur le passage à Epiphany, le navigateur officiel de Gnome basé sur Gecko.

Aller plus loin

  • # Adblock and co ?

    Posté par . Évalué à 5.

    Je me demandais si les extensions type adblock fonctionnent également sur Galeon. Vu qu'il est compatible avec Mozilla et Firefox, je me dis que ça doit être possible et je trouverai çà fort sympathique car je trouve Firefox _un peu_ lourd à mon goût.
    • [^] # Re: Adblock and co ?

      Posté par (page perso) . Évalué à 10.

      J'avais réussi à installer l'excellent Flashblock sur Galeon. En fait, l'installation des .xpi est désactivée par défaut. Pour la rétablir, il faut aller dans la page about:config, et mettre la clé xpiinstall.enabled sur true et pas false. Et après ça marche.
    • [^] # Re: Adblock and co ?

      Posté par . Évalué à 4.

      Est-ce "installable" en bidouillant ou pas, je sais pas trop, mais quoi qu'il en soit je vois mal comment se ferait l'intégration à la GUI (ajout dans le menu contextuel, lien "adblock" en bas de la fenêtre, etc.), faute d'avoir une interface en XUL. Donc amha faut de toute façon pas espérer un adblock pleinement fonctionnel.
      • [^] # Re: Adblock and co ?

        Posté par (page perso) . Évalué à 2.

        tout à fait. C'est d'ailleurs valable pour n'importe quelle extensions.
      • [^] # Re: Adblock and co ?

        Posté par . Évalué à 3.

        C'est un peu plus complique qu'en XUL mais ca se fait avec Epiphany.

        http://www.gnome.org/projects/epiphany/documentation/extensi(...)

        D'ailleurs il y a deja un adblock pour Epiphany. Quand Galeon sera base dessus, ca devrait marcher sans problemes.
        • [^] # Re: Adblock and co ?

          Posté par (page perso) . Évalué à 1.

          on peut tjr fusionner son /etc/hosts avec des blacklists de trackers, annonceurs etc

          J'utilise cette blacklist : http://www.accs-net.com/hosts/
          mais il doit en exister d'autres...

          gpg:0x467094BC

          • [^] # Re: Adblock and co ?

            Posté par (page perso) . Évalué à 3.

            L'intérêt d'adblock c'est de pouvoir utiliser des regexp sur tout l'url, pas seulement sur le nom de domaine. Et puis même en travaillant juste sur le nom de domaine, sans regexp c'est pas la joie. Un /etc/hosts de 17776 lignes c'est un peu gruik je trouve.

            pertinent adj. Approprié : qui se rapporte exactement à ce dont il est question.

          • [^] # Re: Adblock and co ?

            Posté par (page perso) . Évalué à 2.

            Je vois marqué que le dernier date de 2003... Ca marche bien ?
            • [^] # Re: se passer d ablock

              Posté par . Évalué à 1.

              La manipulation pour bloquer les pubs sans passer par adblock est indiquée sur le site officiel de galeon.
              Cette manipulation s applique pour tous les browers basés sur mozilla.

              Il faut créer un fichier userContent.css dans le dossier chrome de votre naviguateur favori.

              .mozilla/firefox/.../chrome pour mozilla-firefox

              .galeon/mozilla/galeon/chrome pour galeon

              Et tu mets tes régles de bloquages dans le fichier userContent.css.

              Ca permet d éviter d installer une autre extension .
  • # pages de messages d'erreur HTTP

    Posté par (page perso) . Évalué à 3.

    pas forcément une super idée ça...

    sympathique pour l'utilisateur lambda effectivement d'afficher une page locale "standard", mais il serait sympathique dans certains cas d'afficher tout de même le message d'erreur envoyé côté serveur (cas d'un problème de configuration...). Bon après je ne dis pas qu'il faut afficher les superbes erreurs java hein, mais un bouton pour afficher la page fournie par le serveur ça serait sympathique (genre : si vous souhaitez envoyer l'erreur au développeur...).
    J'ai eu ce souci avec IE qui affichait sa propre page, l'utilisation de Firefox a permis de voir l'erreur en clair (problème de conf' de weblogic mais bon... ça arrive et pas forcément évident à diagnostiquer avec l'erreur cachée).

    ça existe peut-être comme option ? j'avoue ne pas avoir encore essayé...
    • [^] # Re: pages de messages d'erreur HTTP

      Posté par . Évalué à 5.

      Si je me souviens bien les pages d'erreur local c'est juste pour le cas où il arrive pas a contacter le serveur. Ça a l'aventage de supprimer la petite boite de dialogue modale qui bloquait toute l'application a chaque fois qu'un tab foirait
      • [^] # Re: pages de messages d'erreur HTTP

        Posté par . Évalué à 2.

        En plus ça existe déjà sous Firefox (option à changer) et sous IE (c'est pas une réfrence ok)
        • [^] # Re: pages de messages d'erreur HTTP

          Posté par (page perso) . Évalué à 2.

          je me suis mal exprimé...

          "option" => disponible sur la page directement, pas dans un menu / onglet / bouton / liste d'options interminable hein....
        • [^] # Re: pages de messages d'erreur HTTP

          Posté par . Évalué à 2.

          En même temps, Galeon et Firefox utilisent le même moteur (Gecko)...
          C'est assez récent dans Gecko et je crois d'aillleurs que c'est apparu seulement dans la 1.5 de Firefox
          • [^] # Re: pages de messages d'erreur HTTP

            Posté par (page perso) . Évalué à 1.

            La fonctionalité existe deja depuis un bout de temps, mais c'etait moche (pages non stylées tres "brutes"), un rien buggé sur certains points, et donc pas activé par défaut.

            Du travail a été effectué pour améliorer tout ca, et c'est donc maintenant utilisable par tout le monde et activé par défaut dans firefox 1.5.
            • [^] # Re: pages de messages d'erreur HTTP

              Posté par (page perso) . Évalué à 2.

              une amélioration supplémentaire (je suppose, toujours pas essayé) serait donc d'avoir possibilité **sur la page de remplacement** d'avoir un bouton (ou un lien) pour afficher tout de même la page provenant du serveur (un 403 parfois renvoit un message d'erreur - de mémoire - indiquant la raison du "forbidden").

              bref ça permet de cacher, mais d'accéder rapidement, à un mode "debug" (que seuls les connaisseurs regarderont ou sur demande du support ;-) )
  • # libgtkembedmoz.so

    Posté par . Évalué à 3.

    Pour info, galeon a t il besoin de mozilla tout entier ou libgtkembedmoz.so lui suffit il ?
  • # Traduction ?

    Posté par . Évalué à 3.


    Il est donc rappelé sur le site de Galeon que cette sortie n'est en rien une reprise du développement mais bien la dernière version prévue lors de cette décision et que le travail sera désormais, hormis d'éventuels correctifs, axé sur le passage à Epiphany, le navigateur officiel de Gnome basé sur Gecko.

    Ha c'est marrant moi je lis sur le site qu'ils n'arrêtent pas le développement froidement mais qu'il y aura encore des releases pour les nouvelles versions de mozilla avec éventuellement des bug fix. :p


    I'll repeat my assurance that this doesn't mean we're just stopping galeon development cold; it's going to be quite a while before enough work has been completed to make epiphany my primary browser so, if nothing else, expect to see periodic releases that keep it compiling against newer mozilla releases. You might even see a bug fix or two. :)
    • [^] # Re: Traduction ?

      Posté par . Évalué à 2.

      Je pense que c'est ce que veux dire le « hormis d'éventuels correctifs ». Il n'y a pas de nouvelle version prévue au sens « on a plein de truc à mettre encore dans une 2.1 », mais il peut y avoir une 2.1 (ou 2.0.1 ?) pour des corrections de bugs ou problèmes de compil'.
    • [^] # Re: Traduction ?

      Posté par . Évalué à 2.

      Heu le but des développeurs c'est de porter toutes les fonctionnalités de Galeon comme extensionsd'Epiphany, plus du tout de développer Galeon.

      Cela a été moult fois répété et débattu sur les ML de Galeon en octobre dernier.
      • [^] # Re: Traduction ?

        Posté par . Évalué à 2.

        Mais ça je le sais très bien.
        Je critique juste l'effet "téléphone arabe" qu'il y a eu lors du passage à LinuxFR.
        Moi qui souhait simplement apporter une précision :(

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.