Coninox a écrit 22 commentaires

  • [^] # Re: Un drame en qq actes...

    Posté par  (site Web personnel) . En réponse au journal S'occuper pendant les vacances ! YunoHost et AutoHébergement. Évalué à 2.

    Je tiens à préciser que j'utilise Yunohost avec une IP dynamique, et c'est un problème qui se contourne facilement. Il existe des services de type dyndns qui se chargent de mettre à jour la configuration dns auprès du registrar automatiquement en cas de changement d'IP.
    J'ai un nom de domaine chez OVH, et ils ont leur propre service pour ça.
    Il y a juste un démon à installer et à configurer sur le serveur, mais ça se fait en deux minutes.

  • [^] # Re: le problème vient peut-être d’ailleurs

    Posté par  (site Web personnel) . En réponse au journal Campagne contre les thèmes du côté de chez GNOME. Évalué à 3.

    Je sais bien, mais par le même raisonnement, la part des gens qui utilisent une souris sur GNOME est probablement infiniment plus importante que ceux qui utilisent leurs gros doigts sales. Et du coup, ce choix leur prend à eux aussi une part non négligeable de la surface de leur écran.

  • [^] # Re: le problème vient peut-être d’ailleurs

    Posté par  (site Web personnel) . En réponse au journal Campagne contre les thèmes du côté de chez GNOME. Évalué à 0.

    Par exemple, j'utilise Gnome sur une tablette surfacepro 4 de Microsoft (Parceque rare sont les matériels qui disposent de vrai stylets sensibles à la pression quand on veut dessiner un peu), et l'écran est petit.
    Le style par défaut de gnome ne me convient pas du tout, beaucoup de choses sont inutilement très grosses (Je pense nottament aux barres de titres des fenêtres), réduisant drastiquement la surface utile de l'écran.

    Pourtant, Gnome shell semble avoir été pensé pour être aussi utilisé sur les interfaces tactiles, donc les tablettes de ce type. (Je n'ai pas trouvé mon bonheur chez la concurrence en tout cas)

  • [^] # Re: doque

    Posté par  (site Web personnel) . En réponse au message Script qui utilise Weboob cassé après une màj. Évalué à 2.

    C'est une bonne idée.

    Ceci dit, j'ai corrigé mon problème en mettant ma variable w en variable globale, et en faisant une fonction qui fait le load du backend uniquement si il n'a pas été chargé auparavant.

    Pour l'instant, ça re-marche !

  • [^] # Re: doque

    Posté par  (site Web personnel) . En réponse au message Script qui utilise Weboob cassé après une màj. Évalué à 1.

    C'est à dire que pour l'instant je ne sais pas vraiment si c'est un bug du module cragr, ou si c'est un mauvais usage de Weboob de ma part, donc c'est peut-être prématuré d'écrire un rapport de bug.

  • [^] # Re: doque

    Posté par  (site Web personnel) . En réponse au message Script qui utilise Weboob cassé après une màj. Évalué à 1.

    à vrai dire j'avais déjà lu cette documentation il y a des mois, quand j'avais fait la première version qui fonctionnait.

    Mais j'ai du mal à l'apréhender, déjà parcequ'il n'y a aucun exemple de code, et c'est souvent en contextualisant les choses qu'on en comprend le fonctionnement, et ensuite, parce que je ne comprends pas la structure du bouzin.

    Ici, les fonctions documentées le sont dans "weboob.capabilities.bank.CapBank"
    Or, quand je fais un appel à iter_accounts(), je fais w.iter_accounts(), et non pas w.capabilities.bank.Capbank.iter_accounts().

    Il doit me manquer une notion, mais du coup je n'arrive pas à comprendre le lien entre la doc et ce que je dois écrire pour que ça fonctionne.

    Je m'étais inspiré du seul exemple de code que j'avais trouvé, à savoir le Hello World sur dev.weboob.org

  • # Transformations dans l'outil de mesure

    Posté par  (site Web personnel) . En réponse à la dépêche GIMP 2.10.6 : rien ne nous arrête !. Évalué à 8.

    Merci, à la fois pour la dépèche, et pour cette implication à faire avancer Gimp. C'est un des logiciels libres que j'utilise le plus, et c'est toujours avec joie que je lis ce genre de dépèche.

    J'avais pas réalisé que l'outil de mesure permettait de redresser des photos.
    Je l'avais probablement lu dans la précédente dépèche, mais j'ai dû oublier.

    J'espère que je n'oublierai pas cette fois-ci, parceque ça a l'air très pratique, et j'ai l'impression que j'aurai pu m'en servir bien souvent car un des gros reproche que je pourrais faire aux outils de transformations tel que rotation ou perspective, c'est qu'on ne peut pas afficher de repère horizontal ou vertical.
    Enfin, il me semble que j'avais trouvé comment faire, mais que le repère se retrouvait déformé comme l'ensemble de l'image, le rendant complètement inutile.

    Ou alors je n'ai pas assez cherché.

    Donc si un outil me permet de faire ça simplement et en une seule opération, c'est parfait !

    Par contre je pense que si j'étais passé à côté de son existence, c'est que son emplacement ne me semble pas très évident.
    Le fait qu'une transformation de l'image passe par un outil nommé "Mesures" n'est pas très logique.
    Pour moi, justement, un outil nommé "Mesures" devrait permettre de faire tout un tas de trucs, mais dont aucun ne serait susceptible d'entrainer une modification !
    Il fait quoi, concrètement, pour redresser l'image ? une rotation ?
    ça n'aurait pas été plus logique d'inclure ça dans l'outil de rotation ?

    Enfin je voudrais pas avoir l'air de râler sur ces bonnes nouvelles, hein, je m'interroge juste :)

  • # ça me fait penser à Mycroft

    Posté par  (site Web personnel) . En réponse à la dépêche Snips ouvre sa technologie NLU. Évalué à 4.

    Je ne connais pas tous les détails de chaque solution, mais ça me rappelle ce que fait Mycroft, qui est une startup dont l'ambition est de faire un assistant intelligent libre.
    Ils ont déjà commercialisé un produit embarquant cette technologie, et un deuxième est en cours de lancement après quelques campagnes de financement participatives.

    Après, je ne sais pas si ça tient la route face à ceux développés par les géants du secteur.

    Je ne savais pas qu'il y avait une initiative similaire en France, c'est une bonne nouvelle !

  • [^] # Re: diverses questions

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    Visiblement, ça marche.
    Je suppose que mon problème est donc résolu.
    Merci beaucoup !

  • [^] # Re: diverses questions

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1. Dernière modification le 29/01/18 à 20:01.

    Alors, si j'y accède en ssh, que je fais cat /etc/network/interfaces, et que je copie-colle le résultat, ça donne :

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    source /etc/network/interfaces.d/*
    
    # The loopback network interface
    auto lo
    iface lo inet loopback eth0
    
    # primary network interface
    allow-hotplug eth0
    iface eth0 inet dhcp
    

    (et par la même occasion, j'ai fait un ls /etc/network/interfaces.d , et il est vide)

  • [^] # Re: diverses questions

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    Du coup, ça va être assez assez simple, il te suffit d'ajouter:
    allow-hotplug eth0
    iface eth0 inet dhcp

    J'obtiens /etc/network/interfaces:8: too many parameters for iface line lorsque je fais mon ifup -a

  • [^] # Re: diverses questions

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    debian 4.8.4? Debian n'a que 2 numéro dans leurs versions: majeur.patch. Et la stable actuelle est stretch, en 9.3.

    /proc/version me dit ça : Linux version 3.16.0-5-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08)

    Ce qui me parait pas trop cohérent, en fait, ou alors j'interprête mal ce truc.
    Je suis sur une debian Jessie, le projet Yunohost ne supporte pas encore Strech (ça devrait arriver avec la prochaine version majeure)

    Le plus simple, ça serait d'avoir la sortie d'un pstree

    systemd─┬─ModemManager─┬─{gdbus}
            │              └─{gmain}
            ├─accounts-daemon─┬─{gdbus}
            │                 └─{gmain}
            ├─atd
            ├─avahi-daemon───avahi-daemon
            ├─cron
            ├─cups-browsed
            ├─cupsd
            ├─dbus-daemon
            ├─dnsmasq
            ├─dockerd─┬─docker-containe───12*[{docker-containe}]
            │         └─12*[{dockerd}]
            ├─dovecot─┬─anvil
            │         ├─auth
            │         ├─config
            │         └─log
            ├─fail2ban-server───16*[{fail2ban-server}]
            ├─glances
            ├─haveged
            ├─irqbalance
            ├─login───bash
            ├─lua5.1
            ├─master─┬─bounce
            │        ├─cleanup
            │        ├─pickup
            │        ├─pipe
            │        ├─qmgr
            │        ├─tlsmgr
            │        └─trivial-rewrite
            ├─mysqld_safe───mysqld───22*[{mysqld}]
            ├─nginx───4*[nginx]
            ├─nscd───10*[{nscd}]
            ├─nslcd───5*[{nslcd}]
            ├─ntpd───ntpd
            ├─php5-fpm───11*[php5-fpm]
            ├─polkitd─┬─{gdbus}
            │         └─{gmain}
            ├─redis-server───2*[{redis-server}]
            ├─rmilter───5*[{rmilter}]
            ├─rpc.idmapd
            ├─rpc.statd
            ├─rpcbind
            ├─rspamd───5*[rspamd]
            ├─rsyslogd─┬─{in:imklog}
            │          ├─{in:imuxsock}
            │          └─{rs:main Q:Reg}
            ├─shellinaboxd───shellinaboxd
            ├─slapd───6*[{slapd}]
            ├─sshd───sshd───sshd───bash───pstree
            ├─systemd───(sd-pam)
            ├─systemd-journal
            ├─systemd-logind
            ├─systemd-udevd
            ├─uwsgi───4*[uwsgi]
            └─yunohost-api───{yunohost-api}
    

    Ça se lance en tant que root :)

    Ah ben je m'attendais à un message d'erreur qui dit que j'ai pas le droit, dans ce genre de cas !

    Table de routage IP du noyau
    Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
    172.17.0.0      *               255.255.0.0     U     0      0        0 docker0
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    

    Donc effectivement, y'a pas de passerelle de spécifiée.

    si je fais dhclient eth0 (ma carte eth0 est restée montée avec le ifconfig fait la veille) j'obtiens désormais :

    Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
    default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
    172.17.0.0      *               255.255.0.0     U     0      0        0 docker0
    192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
    

    Et je peux maintenant pinger meteofrance.com \o/

    Enfin, jusqu'au prochain reboot.

    Je suppose que maintenant, l'idée, c'est soit de réinstaller un gestionnaire réseau, soit de passer directement par /etc/network/interfaces, mais faut trouver pourquoi les modifications ne sont pas prises en compte.

    (ou alors de mettre un tâche cron qui fait dhclient eth0 à chaque reboot, mais je ne suis pas convaincu que ce n'est pas une solution dégueulasse)

  • [^] # Re: diverses questions

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    J'ai vu dans les commentaires que tu utilises apt-get, mais quelle distro?

    C'est une debian (4.8.4)

    As-tu fait une mise à jour récemment?

    Je commence à me demander si j'ai pas viré un truc nécessaire au fonctionnement du réseau avec un apt-get autoremove.
    Mais je ne pense pas que ça coïncide en terme de temporalité.

    Quel gestionnaire réseau utilises-tu?

    Aucune idée. Jusqu'à maintenant, je faisais rien, et ça marchait, c'était magique.

    Si tu n'utilises pas de gestionnaire, peut-on voir le contenu de ce fichier?

    Il n'y a que ça dedans :
    # The loopback network interface
    auto lo
    iface lo inet loopback eth0

    J'ai essayé de rajouter :
    #primary network interface
    auto eth0
    iface eth0 inet dhcp

    En espérant récupérer miraculeusement ma connection.
    J'ai pas constaté de changement.
    d'ailleurs, si je fais un /sbin/ifconfig, il n'y a toujours pas mention de eth0.

    Tu peux ping ta box, mais arrives-tu à ping une autre machine sur le LAN sur l'ethernet

    Après un /sbin/ifconfig eth0 192.168.1.92 up, eth0 aparait bien lors d'un /sbin/ifconfig.
    Je peux alors faire un ping vers ma box, mais aussi vers une autre machine de mon réseau.
    Je ne peux pas en faire vers une machine extérieure au réseau.

    Que donne la commande route?

    "Commande introuvable" :D

  • [^] # Re: Bonnes options de ifconfig

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    mais attention à ne pas déclarer « STATIC » l'adresse de ta carte sur ta machine

    Ah ben ça, ça risque pas, je savais pas qu'on pouvait.

    Vérifie la config de ta carte réseau dans ton gestionnaire. Si ça se trouve, tu as juste coché une mauvaise case et fait passer ta carte soit à l'état inactif, soit en configuration statique et avec des paramètres non renseignés.

    J'ai pas d'environnement graphique installé.

    J'ai tenté de suivre ce tuto pour configurer resolv.conf, sans succès.

    J'ai tenté d'écrire directement dans le fichier resolv.conf malgré la ligne d'avertissement qui signale que ça sera écrasé. Ca ne l'a pas été pendant mon test, mais ça n'a quand même pas marché.

    Puis, j'ai essayé de pinger une adresse IP extérieure à mon réseau.
    J'ai lancé un ping vers un nom de domaine (google en l'occurence) sur une machine sur laquelle tout fonctionne, j'ai noté l'adresse IP, puis j'ai fait un ping vers cette adresse IP depuis la machine problématique.
    ça me renvoie "Network unreachable"

    Donc je dois avoir un autre problème que la résolution DNS, non ?

  • [^] # Re: Bonnes options de ifconfig

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 2. Dernière modification le 20/01/18 à 21:17.

    Cette fois-ci, j'ai fait ifconfig eth0 192.168.0.2 up, avec l'adresse IP qui va bien
    (elle est paramétrée en adresse statique dans les paramètres DHCP de ma box, histoire de pas casser les redirections de ports à chaque reboot)

    Je l'avais fait avec une adresse quelconque la première fois, probablement l'égarement de la fin de semaine.

    Y'a du progrès.
    Maintenant, je peux pinger ma box.
    Par contre, j'arrive pas à pinger un nom de domaine, ni à faire les mises à jour par apt-get.
    Je suppute un problème de DNS.

    Mon serveur a l'air d'être accessible depuis l'extérieur par son nom de domaine.
    (je peux pas y accéder à cause d'un problème de certificat, mais le problème était apparu avant et n'a rien à voir)

    Donc ça a l'air de fonctionner, mais que dans un sens.

    Et la manip ne résiste pas à un reboot.

  • [^] # Re: dmesg

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 1.

    "pas de pb de cable ou de faux contact sur les pin du rj45 ? avec l'humidité et les années ca peut arriver, coté pc et coté routeur."
    J'ai essayé avec un autre RJ45 et un autre port sur ma box : même problèmes

    "ifconfig eth0 192.168.2.2 netmask 255.255.255.0 broadcast 192.168.2.255"
    La commande ne renvoie rien, je n'ai toujours pas d'accès au réseau après.

    "un modprobe modulekivabien te donne quelques choses ?"
    ça dépend, comment je fais pour connaitre le modulekivabien ?

  • [^] # Re: dmesg

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 2.

    J'ai bien un résultat avec cette commande. (je ne peux malheureusement pas faire de copier/coller ici pour des raisons évidentes)

    ça me donne deux ligne avec ce qui semble être la version du driver de la carte.
    Si je fais un
    /sbin/ifconfig eth0 up
    et que je refais
    dmesg | grep -i eth
    j'ai des lignes supplémentaires. Je ne sais pas quelle information est importante dedans, mais plusieurs lignes se terminent par "link is down".

  • [^] # Re: lister le materiel

    Posté par  (site Web personnel) . En réponse au message eth0 a disparu.. Évalué à 2.

    Oui, j'ai bien une carte Ethernet controler si je fais un lspci.

  • [^] # Re: Et surtout ...

    Posté par  (site Web personnel) . En réponse au journal Des retours d'expérience de « Linux (bash/ubuntu) sous Windows » ?. Évalué à 10.

    Personnellement, j'ai tenté l'inverse : installer wine sur ubuntu dans windows. Ça marche pas :)

  • # Précisions !

    Posté par  (site Web personnel) . En réponse au message réaliser un lien constant sur le "bureau" pour joindre un NAS reseau. Évalué à 2.

    Déjà, ça me semble assez confus.
    J'ai l'impression que tu as plein de questions à la fois, mais sans les poser explicitement.
    Ce qui semble être ton problème principal ne fait l'objet que d'une phrase tout à la fin, on doit lire tout un tas de trucs confus avant de pouvoir comprendre ou tu veux en venir.

    J'ai cherche et je suis tombé sur un message parlant du Bureau ou pas de bureau des liens ou pas utiles ou pas.

    Pas compris.

    existe t il un lexique repertoriant les applications linux et leur usage car entre gnome kde nautilus elementary etc… je n'ai pas envie de passer deux semaines à configurer >"mon open suse linux" selon mes besoins.

    Essaye de transposer la question à un autre système d'exploitation. Windows, par exemple, parce que statistiquement, il y a de fortes chances que tu en viennes. Existe-il un lexique répertoriant les applications sur windows et leur usage ?
    Il doit y avoir tout un tas de lexiques, listes, etc, toutes différentes, et pour la plupart pas à jour, tout simplement parcequ'il y a une plétore d'applications.
    Certes, certaines sont plus indispensables que d'autres, mais c'est subjectif, et on ne peut pas connaitre tes besoins.

    D'ailleurs, tu parles de gnome, kde, nautilus elementary… qui comportent eux-mêmes tout un tas de logiciels.
    Je ne connais pas Suse, mais si tu l'as déjà installé, je suppose que tu as déjà un de ces environnements de bureau. Et en général, dans une distribution, la plupart des logiciels nécessaires à une utilisation courante sont déjà
    inclus.

    Si il te manque quelque chose, je te conseille d'utiliser le site alternativeto.net pour trouver des logiciels dont les usages se rapprochent d'un logiciel que tu connais déjà.

    En deux j'ai un NAS reseau ou sont tous mes documents et je cherche à realiser un lien pratique immediat pour joindre celui-ci sans rentrer tous les liens et identifiants reseau. Est ce le lien symbolique qui repond à cela?

    Là, comme ça, je dirai que la réponse est non.
    On ne sait pas de quel modèle de NAS il s'agit, ni de quels protocoles il utilise pour le partage de fichiers : on va difficilement pouvoir t'aider.

  • # Merci pour vos réponses

    Posté par  (site Web personnel) . En réponse au message Netbook/Tablette graphique. Évalué à 1.

    Au final, je me demande si ce n'est pas la gamme des tablettes Microsoft PRO qui correspondent le mieux à ce que je recherche.
    Elles sont 2-en-1, elles ont un stylet sensible à la pression, et elles semblent plus facilement disponible sur le marché de l'occasion.

    Je devrais pouvoir m'en tirer pour 500€.

  • [^] # Re: mount bind

    Posté par  (site Web personnel) . En réponse au message Owncloud - Problème de droits. Évalué à 1.

    Effectivement, j'ai pu résoudre mon problème par cette méthode.
    Merci pour vos réponses :)