Journal Display port et hdmi sur nuc broadwell et ubuntu

Posté par  . Licence CC By‑SA.
Étiquettes :
-4
5
juin
2015

Bonjour.

J'ai terminé l'installation d'une ubuntu 15.04 sur mon NUC5i7RYH avec un écran 4K. Je ne peux pas utiliser 14.04 LTS comme iris 6100 pro n'est pas pris en charge. Je dois donc faire avec la 15.04
* Tout d'abord , il est assez complexe à installe car l'EFI ne regarde pas dans le dossier où ubuntu met l'image de démarrage, je dois copier les fichiers de démarrage au bon emplacement…
$ sudo mount /dev/sda1 /mnt
$ sudo mkdir /mnt/EFI/BOOT
$ sudo cp /mnt/EFI/ubuntu/* /mnt/EFI/BOOT
$ sudo mv /mnt/EFI/BOOT/grubx64.efi /mnt/EFI/BOOT/bootx64.efi

  • Tout fonctionne très bien excepté l'audio en DisplayPort/HDMI. Je ne parviens pas à avoir le son transféré aux enceintes de l'écran . Mon noyau est : Linux 3.19.0-18 générique # 18 - Ubuntu SMP mar 19 mai 2015 18:31:35 UTC x86_64 x86_64 x86_64 GNU / Linux Si je veux utiliser pleinement mon écran 4K Je ne pense pas que je puisse utiliser la sortie HDMI 1.4.

Est-ce que l'un d'entre vous a un tel joué et a eu des difficultés ?

P.S : post sur le site d'intel : https://communities.intel.com/message/310452#310452
P.P.S : requête sur le forum : http://linuxfr.org/forums/linux-debian-ubuntu/posts/sortie-audio-et-displayport-sur-une-ubuntu-15-04

  • # Pulseaudio vs Direct HDMI

    Posté par  . Évalué à 3.

    Je possède un NUC5i3RYK sur lequel je fais tourner Kodi (XBMC) sur Archlinux.
    Dans les settings audio de Kodi le son ne marchait pas avec Pulseaudio (sans doute mal configuré par mes soins), mais tout marche nickel en choisissant HDMI/Display port.

    Une piste à creuser pour toi ?

    • [^] # Re: Pulseaudio vs Direct HDMI

      Posté par  . Évalué à 0.

      Je pense qu'il est possible que mon écran ne supporte pas le son au travers du HDMI. J'ai remarqué par exemple que la carte audio analogique n’apparaît pas si le jack n'est pas branché. Il faudrait que j'achète un câble mini-HDMI HDMI pour vérifier !

      Merci pour le conseil sur Kodi, je testerais ça

  • # PulseAudio

    Posté par  (site Web personnel) . Évalué à 1.

    Bonjour.
    J'ai eu plusieurs fois des ordinateurs «muets» car le son sortais sur la mauvaise sortie.
    Ceci était généralement du a la configuration de PulseAudio. Ceci se réglais avec «pavucontrol» dans «périphérique de sortie»

    A essayer.

    • [^] # Re: PulseAudio

      Posté par  . Évalué à 1.

      Oui, j'ai également eu ce genre de problème mais là les sorties ne sont même pas accessible dans pavucontrol !

  • # Installation UEFI

    Posté par  (site Web personnel) . Évalué à 2.

    il est assez complexe à installe car l'EFI ne regarde pas dans le dossier où ubuntu met l'image de démarrage, je dois copier les fichiers de démarrage au bon emplacement

    Euh, oui, c'est le comportement UEFI normal que de lancer par défaut \EFI\boot\bootx64.efi.
    Pour le coup, c'est plutôt Ubuntu qui devrait installer l'image au bon endroit.

    Sinon, la plupart des UEFI que j'ai vus propose un "Boot Menu" où tu peux choisir quelle image lancer.

    • [^] # Re: Installation UEFI

      Posté par  . Évalué à 1.

      Je n'ai pas trop le niveau pour me prononcer sur ce qui doit être fait sur sur l'UEFI, je pense qu'il serait préférable qu'Ubuntu installe son image à un endroit où tout les PC puisse le trouver pour booter !

      En ce qui concerne le boot, c'est possible mais c'est tout de même un peu pénible de devoir faire cette manipulation à chaque démarrage.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.