Journal C'est la faute à Linux ! Toujours Linux !

Posté par  (site Web personnel) .
Étiquettes : aucune
0
9
déc.
2003
Et oui... C'est toujours la faute à Linux..

Ma maman m'appelle pour me dire que Evolution (elle dit Ximian) est vide et ne contient plus aucun mail. De même, il n'y a plus d'icones sur le desktop.

Elle me jure qu'elle n'a rien fait, juste sauvé une image depuis un site web. Je prends peur et je jure intérieurement que si le programme a effacé tous les mails suite à un bug, je réinstalle Windows (car c'est absolument inacceptable).

Je lui demande son ip ( elle tape ifconfig comme je lui ai appris) et me connecte à sa machine.

Effectivement le dossier evolution est vide. Je lui demande comment ça s'est passé exactement.

"ben j'ai rien fait.. j'ai juste fait un backup de certains dossiers dans mon home et puis j'étais sur internet..."

bingo ! Elle avait déplacer (au lieu de copier) le répertoire evolution ailleurs, ne sachant pas ce que c'était. De même avec le répertoire Desktop. Ouf... C'est réparé et elle est toute fière de me dire "au moins j'ai appris".

Notons que Evolution 1.5 corrige ce problème en stockant les mails dans .evolution
-------
C'est la faute de Linux !

Ma mère m'appelle catastrophée.. Hier, à 15h, elle était sur internet et la connection s'est coupée. Depuis, elle n'a toujours pas de connection malgré des reboots et tentatives de reconnections. Le modem, d'après les lampes, cherche à se connecter sans rien trouver.

Je lui donc que c'est de la faute du FAI. en effet, si le modem cherche bien à se connecter c'est que son système fonctionne parfaitement.

Elle appelle la hotline où on lui répond que on voit bien les tentatives de connection de sa part et que c'est son ordinateur qui est mal configuré et que on n'aide pas les gens sous Linux.

Elle me retéléphone en disant "Je veux Windows". Bon, je m'apprête à essayer de diagnostiquer le problème (en lui expliquant que non, je ne peux pas me connecter à sa machine si elle a pas internet.. Linux est quand même limité de ce coté là !)

Puis, avant de me lancer, je réfléchis :
Si le modem tente de se connecter sans y arriver et que le FAI "voit" la tentative de connection, il n'y a que deux solutions :
- le mot de passe envoyé est mauvais. Hors sans droit root, ma mère n'a PAS pu faire ça et un ordi ne fait pas ça tout seul.
- le FAI refuse la connection pour une raison ou une autre.

Linux est visiblement le coupable et je dis alors : "Tiens, essaye un peu avec le portable de papa (sous windows 98)". Personnellement, je commence à réfléchir au problème quand elle me dit : "ben le portable non plus ne veut pas se connecter".

Encore de la faute de Linux... De plus, la hotline du FAI annonce à tous les clients désirants un support sous un windows inférieur à XP que "cette version n'est pas supportée, vous devez upgrader à Windows XP".

Bref, difficile d'expliquer à ma mère que, quand le FAI est de mauvaise foi, ça ne sert à rien d'être sous windows plutôt que Linux.

A moins que... ben oui, justement ! L'ordinateur Linux a tout seul hier à 15h modifié ses paramètres de connection et le portable windows en a fait de même pendant la nuit quand personne ne l'a entendu démarrer ! ça doit être ça.. et avec XP on aurait pas eu ces problèmes là...
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  . Évalué à 1.

    C'est qui ton FAI ?
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  (site Web personnel) . Évalué à 3.

      skynet
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  . Évalué à 0.

        qui s'est qui l'a plussé pour avoir répondu skynet ? :-) c'est pour l'encourager ? :)
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  (site Web personnel) . Évalué à 3.

        Bon, je préviens tout de suite, je travaille pour la hotline de skynet adsl (peut-être pas dans le même call-center que la personne sur qui tu es tombé, cependant).

        Effectivement, pour Linux, c'est "No support", mais ça ne nous empêche pas de faire un test de synchro, vérifier la ligne, vérifier les tentatives sur le radius, l'état de l'abonnement, etc.

        Et si Linux n'est pas supporté, on a quand même des posts sur la m-l interne qui donnent des url sur la config de certains modems, qu'on peut toujours filer au client (oui, s'il n'a pas le net, c'est bête, mais ya moyen d'aller voir et imprimer chez un pote). En gros, si on sait, on donne des indications. Mais c'est tout.
        Ensuite, normalement, on supporte win95 et +, et macos 8.x et +

        Bref, tu es vraiment tombé sur un naze qui ne pense qu'à améliorer ses stats de temps d'appel, on dirait.
        • [^] # Re: C'est la faute à Linux ! Toujours Linux !

          Posté par  (site Web personnel) . Évalué à 1.

          Bref, tu es vraiment tombé sur un naze qui ne pense qu'à améliorer ses stats de temps d'appel, on dirait.

          Il faut donc que vous réfléchissiez à la façon dont vous mesurez la productivité de vos employés en centre d'appel :)

          Peut-être que le fait de mesurer leur temps d'appel n'est pas une panacée non ?
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  . Évalué à 1.

    Ben t'as de la chance moi, je vient juste de perdre tous mes mails avec kmail (pas sauvegardé depuis quinze jours).
    Les manips: loggé en tant que root en console, je renomme mon répertoire utilisateur. Reboot et install Mdk9.2 en remplacement de la 9.1
    Je me logue en user, su, chown -R user:suer /mon/ancien_home. ctrl D, move (et oui là est l'erreur) mon rép MAIL dans mon nouveau /home.
    Ouverture de kmail, miracle,tous mes mails sont là. Je referme, je fais autre chose, puis ouverture de Kmail et là; core dump et pouf ! plus de rép Mail.
    Du coup je passe au lecteur de mails de Mozilla.
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  (site Web personnel) . Évalué à 1.

    Ah ces F.A.I.

    je déménage en gardant ma ligne telephonique.
    Le soir, je branche ma passerelle dans mon nouveau logement (2 ans de connections sans pb dans l'ancien).... le soir même ca marche nickel
    le lendemain matin, plus rien ...

    hotline, le mec me demande sous quoi ca fonctionne ... je lui dit , un linux debian, 2 ans que ca tourne 24/24 7/7, le modem clignote donc pas de synchro... ben ils veulent quand même que l'on soit sous xp pour être sûr ...

    lamentable!
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  . Évalué à 1.

      Pourquoi vous ne balancez pas systématiquement les FAI!?
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  . Évalué à 1.

      salut

      Moi je vous conseille le lecteur de mail sylpheed.
      C'est d'origine japonais, donc de qualité très sérieuse :) Treve de plaisanterie, c'est super stable et y a de bonnes fonctions. Ca fait longtemps que je l'utilise.

      http://sylpheed.good-day.net/(...)
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  . Évalué à 1.

        Tant qu'à faire, je conseille Sylpheed-Claws (branche expérimentale du susnommé). C'est un peu moins japonais mais ça marche très bien aussi. Et c'est généralement plus fourni en fonctionnalités (quoique j'ai pas testé la branche officielle depuis un moment, et comme il paraît qu'elles se synchronisent souvent).

        Enfin il manque encore et toujours un truc capital à Sylpheed (autant une branche que l'autre): le support des Maildirs. Et puis ça reste en GTK1, ça peut déplaire.
        • [^] # Re: C'est la faute à Linux ! Toujours Linux !

          Posté par  . Évalué à 1.

          « Et puis ça reste en GTK1, ça peut déplaire »

          C'est un choix ou une question de temps ?
          • [^] # Re: C'est la faute à Linux ! Toujours Linux !

            Posté par  . Évalué à 2.

            L'ennui c'est que d'après les MLs, ça pourrait bien rester une question de choix. Les gens qui tournent au tour ont l'air d'avoir tous des bureaux GTK1-only, et refusent de voir leur outil passer de l'autre côté. C'est assez dommage, surtout que Pango serait bien pratique pour la gestion du japonais (comme ça a déjà été dit, c'est un soft japonais à la base).

            Il y'a bien un patch non-officiel pour faire tourner le biniou en GTK2, mais la dernière fois que j'ai testé c'était assez moyen et pas stable du tout. Et puis de toutes manières c'est pas une solution.

            Enfin je n'ai regardé que sur les MLs de -claws, peut-être que le monsieur de la branche de base (le japonais) est plus ouvert à ce genre de fantaisies (im-ja, c'est que du bonheur!)
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  . Évalué à 0.

      Tu sais les gens de la hotline, ce ne sont pas en général des gens avec bcp d'étude et ils ne font que suivre "un protocole" de dialogue.
      On vous dit "linux" => vous répondez "installez windows"

      Par contre, ce qu'ils ne disent pas, c'est que chez les opérateurs, leurs serveurs ne tournent pas sous windows...

      C'est juste de la mauvaise volonté, histoire de se débarrasser vite d'un appel d'un client.
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  . Évalué à 4.

        Tu sais les gens de la hotline, ce ne sont pas en général des gens avec bcp d'étude

        Si j'étais hotliner, je serais franchement vexé, c'est de la généralisation à 2 balles. Par ailleurs, tu peux être compétent sans avoir fait un mastère d'info au MIT.

        D'ailleurs, toi qui es probablement à bac+7, tu devrais savoir que des gens "avec beaucoup d'études", c'est du mauvais français. Enfin ce que j'en dis...
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  (site Web personnel) . Évalué à 1.

        Tu sais les gens de la hotline, ce ne sont pas en général des gens avec bcp d'étude et ils ne font que suivre "un protocole" de dialogue.

        C'est 'allergy' (voir postes plus ht) qui va être content.

        On vous dit "linux" => vous répondez "installez windows"

        Ca par contre, c'est un peu vrai, ils ont un protocole à suivre.
        • [^] # Re: C'est la faute à Linux ! Toujours Linux !

          Posté par  (site Web personnel) . Évalué à 4.

          C'est quand même pas à ce point-là non plus. Le protocole qu'on doit suivre touche plus à la manière de répondre à l'appel.

          Maintenant, imaginez ce scénario:
          Client: Je n'arrive pas à surfer, ya internet qui ne fonctionne plus.
          Hotline: Je vois que vous n'êtes pas connecté.
          Typique, classique, hyper courant (je passe les problèmes de synchro, on imagine qu'elle est ok).

          Si le type est sous win, je lui demande de double-cliquer sur sa connexion et soit ça marche, soit ya un numéro d'erreur qui s'affiche. A partir du numéro, on a une db qui reprend les "solutions".
          Pareil pour les erreur données par Outlook [express]. Alors, oui, quand la queue sur le téléphone est de 12 personnes, tu es bien content d'avoir ce genre de facilités.

          Et si le type est sous linux (surtout si c'est quelqu'un comme mon père, par exemple, qui sait à peine que sa distrib est une debian), je lui demande de faire un grep sur /var/log/xyz ?

          On ne va jamais demander au client d'installer Windows ! Mais il est évident que si le client ne sait pas d'où vient le problème, et que ça ne semble pas venir de chez nous, on va lui demander s'il peut tester la connexion depuis une machine sous Windows. Pas parce que le problème vient de linux : simplement pour avoir accès rapidement et facilement aux infos sur le problème.

          S'il sait quel est le problème (login/pass invalide, par exemple), on peut vérifier les logs du radius, et voir avec lui s'il a bien mis les bons. Mais je ne pourrai pas le guider tout simplement parce que je n'ai pas l'adsl moi-même, je ne saurais pas où chercher :)

          Note: je n'ai ni Windows ni, comme je viens de le dire, l'adsl.
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  (site Web personnel) . Évalué à 3.

      Et le menssonge vous connaissez ?

      Il suffit de lui dire que oui c'est de l'XP moderne 100% garanti.

      Surtout quand la diode de "perte de synchro" clignotte, ne pas hésiter à lui demander une verification immédiate.
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  (site Web personnel) . Évalué à 1.

      Mais pourquoi vous mentez pas ? J'ai toujours dit à mes FAI que j'étais sous Windows. ça leur a permis à chaque fois de trouver que le problème était de leur côté.

      Bon ok, je n'ai plus besoin de mentir maintenant que je suis chez Nerim ;-) mais c'était indispensable pour la plupart des autres que j'ai essayé avant...
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  . Évalué à 1.

    "cette version n'est pas supportée, vous devez upgrader à Windows XP"

    Ben ça va chez skynet, ils poussent à la consommation... ils offrent le prix de la mise à jour ?
  • # Re: C'est la faute d'orthographe

    Posté par  . Évalué à 1.

    s/connection/connexion/
  • # De la mauvaise volonté des FAI

    Posté par  . Évalué à 6.

    Par chez moi on est garnis à ce niveau. Anciennement j'étais en câble chez notre "pro-videur" local (net2000 pour ne pas les citer). Parmi beaucoup, beaucoup d'autres problèmes, un jour *pouf* je reçois une IP en 192.168.16.x. Là, je "!?!?!?!?!?". Hop, téléphone au FAI pour qu'ils me flushent mon entrée DHCP et qu'ils règlent le problème, je paye pas ma connexion permanente pour n'en profiter qu'aux 20%.

    - "Net2000 support technique bonjour"
    - "Bonjour, L. R., bla bla bla client machin bla bla bla."
    - "Oui ?"
    - "Je pense q'il y a un problème avec votre serveur DHCP"
    - "Hein ?"
    - "Il distribue des adresses IP en 192.168.16.x"
    - "C'est un problème de configuration Windows."
    - "... !?"
    - "Oui, quand Windows n'arrive pas à obtenir d'adresse IP il prend une IP en 192.168.16.x par défaut"
    - "Depuis quand ? C'est une adresse en cent soixante quelque chose s'il fait ça. De plus, ma passerelle ne tourne pas sous Windows."
    - "Mais si ça fait ça. Et c'est pareil sous Linux : c'est la carte réseau qui donne cette adresse IP."
    - "Quoi ??? C'est quoi ce délire ? Là, sous les yeux, sur le terminal de ma passerelle sous FreeBSD je vois les logs des requêtes et réponses DHCP entre ma passerelle et votre serveur DHCP, et il me donne systématiquement une IP en 192.168.16.x !"
    - "Monsieur c'est un problème chez vous, nous ne supportons pas Linux, merci d'avoir fait appel à nos services."
    -- ligne se referme -- (en gros ceci fut l'appel)

    Il a fallu que j'aille chez eux avec les logs à la main pour qu'ils daignent flusher mon DHCP et que j'obtienne une nouvelle IP, correcte. Peut-être ont-ils fixés le problème maintenant ? J'en sais rien, peu après j'étais allé voir ailleurs si j'y suis, marre de ces providers à deux balles.
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  (site Web personnel) . Évalué à 1.

    J'ai repris un abonnement adsl il y a peu.
    Comme je suis fauché j'ai pris télé2 , en m'attendant a avoir pas mal de merdes... bon ça va plutot bien pour l'instant.

    Seulement lors de la première connexion je les ai appelé pour avoir l'adresse de DNS (evidement pas fourni avec les identifiants de connexions).
    Premier appel, on me dit d'appeller tel service (on me file un n°).
    Deuxième appel, on me dit d'appeller tel autre service(on me file un autre n°).
    Troisième appel, on me dit d'appeller tel autre service... j'interromps le type et lui demande s'il se fout de moi, c'est quand meme pas très sorcier, il a juste a demander a un type à coté ou a aller voir sur la page d'accueil de télé2. Evidement il le prend mal...

    Au final, j'ai rebranché un 56k, j'ai été voir sur le site de télé 2. Ca m'a couté 10 fois moins cher et ça m'a pris 10 fois moins longtemps.

    En fait je soupçonne certains FAI de gagner plus d'argent avec le hotline qu'avec les abonnements.
  • # Re: C'est la faute à Linux ! Toujours Linux !

    Posté par  . Évalué à 2.

    Si les fournisseurs d'acces francais etaient serieux, et abandonnaient les modems USB pour des modems ethernet uniquement, il y aurait moins de problemes.

    Pas d'histoires de login/mot de passe ou autre, tu branches, DHCP et zou c'est parti. Apres le modem se debrouille tout seul pour se connecter, il dit si ca va bien ou pas avec ses diodes et ca reste independant de l'ordi. L'ordi il n'a qu'a faire du DHCP pour que ca marche.
    • [^] # Re: C'est la faute à Linux ! Toujours Linux !

      Posté par  (site Web personnel) . Évalué à 1.

      Si les fournisseurs d'acces francais etaient serieux, et abandonnaient les modems USB.

      Et si mon modem n'était pas USB, je ne pourrais pas me servir de ma carte réseau pour me connecter à mon autre ordinateur !
      Alors je suis bien content que les FAI fournissent un modem avec un branchement USB !
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  . Évalué à 1.

        Routeur avec translation d'adresse, dans les 50 euros. Je branche mon modem ethernet dessus, ainsi que toutes mes machines, et voila. J'ai mon reseau local connecte au net. Si je veux des adresses fixes je vais sur l'interface web de configuration de mon routeur.

        C'est pas complique, beaucoup de familles font ca ici sans qu'il y ai besoin d'un informaticien a la maison (c'est juste des cables ethernet a brancher et ca marche sans rien configurer => DHCP).
      • [^] # Re: C'est la faute à Linux ! Toujours Linux !

        Posté par  . Évalué à 1.

        Dans ce cas les provider non seulement fourniraient un modem ethernet, mais en plus la carte réseau qui va bien avec ou alors t'en achètes une à 15,- euros chez ton assembleur du coin... 2 cartes dans la babasse, si si, c'est possible (perso, c'est mon cas: modem ADSL/ethernet sur passerelle/firewall linux => no souçaïe )
        Bon, évidemment, faut pas avoir peur d'ouvrir sa bécane pour y insérer ladite carte...

        En fait, je pense qu'il serait bien d'avoir cette possiblité dans les abonnements incluant le modem... sachant que le branchement USB est tout de même plus facile pour les non initiés. Toutes les machines n'ont pas encore une carte réseau intégrée mais il y en a de plus en plus...

        Moi en tout cas, je suis trés content de mon modem Speedstream acheté d'occase sur un site d'enchères...
        • [^] # Re: C'est la faute à Linux ! Toujours Linux !

          Posté par  . Évalué à 1.

          Ca se vend encore, des PC sans carte reseau ?
        • [^] # Re: C'est la faute à Linux ! Toujours Linux !

          Posté par  (site Web personnel) . Évalué à 1.

          t'en achètes une à 15,- euros chez ton assembleur du coin... 2 cartes dans la babasse

          Oui mais non !

          Je pense qu'une deuxième PCMCIA ne rentrera jamais dans mon portable tant que j'y laisserai la première, et je ne pense pas trouver de PCMCIA à 15 euros, loin de là :-)

          Ceci dit, le "multi-carte", sur machine classique, je sais que ça existe (j'en ai montée 3). Et quand j'ai le choix, c'est vrai que je préfère quand même les modem ethernet...

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.