Journal Kde 3.5.4 est out !

Posté par .
Tags : aucun
0
3
août
2006
Surtout des corrections de bogues.
Et aussi un meilleur support de hal pour les montages automatiques:

Significant enhancements include:

* Improved removable device support in Linux (users can now mount all devices supported by FreeDesktop's HAL and control how it will be done)
* Speed optimisations in Konsole and Kate
* Multiple holidays can now start on the same date in KOrganizer
* Lots of fixes in Konqueror's HTML engine, KHTML
* The dialog for sending client-side SSL certificates is now more usable
* KNetworkConf now supports Fedora Core 5 and handles WEP keys better


http://www.kde.org/announcements/announce-3.5.4.php
http://kubuntu.org/announcements/kde-354.php

Des paquets pour les principales distribs:
http://www.kde.org/info/3.5.4.php

Ark Linux
Arch Linux
Kubuntu
Pardus
KDE RedHat (unofficial) Packages
Slackware
Slamd64
Suse Linux
  • # et ubuntu ?

    Posté par (page perso) . Évalué à -10.

    Y'a pas de package pour ubuntu ?

    nan paske bon, pour debian, je comprends bien, faudra attendre que tout le reste soit prêt, mais pour ubuntu ?
    • [^] # Re: et ubuntu ?

      Posté par . Évalué à 7.

      Et Kubuntu c'est quoi ?
    • [^] # Re: et ubuntu ?

      Posté par (page perso) . Évalué à 3.

      Regarde mieux le deuxième lien !!
    • [^] # Re: et ubuntu ?

      Posté par . Évalué à 4.

      Enfin bon, la rapidité ne faisant pas la qualité, il ne vaut mieux pas les installer : http://kubuntu.org/packages/kde-354/README
      These packages contain a bug which stops /etc/kderc and therefor the kubuntu-default-settings files from being used.

      We do not know the cause of this bug but we currently do not advise upgrading to these packages.

      Jonathan Riddell 2006-08-01
      • [^] # Re: et ubuntu ?

        Posté par (page perso) . Évalué à 5.

        si c'est un bug qui empeche les bidouillages d'UI fait par Kubuntu, c'est plutot un bug-fix alors, parce que le coup de pas pouvoir intégrer le terminal dans konqui a cause de leur truc... bref.
      • [^] # Re: et ubuntu ?

        Posté par . Évalué à 2.

        Ce problème c'était il y a deux jours.
        Aujourd'hui c'est résolu et c'est pourquoi l'annonce sur Kubuntu.org n'a été faite qu'aujourd'hui alors que les paquets étaient préts depuis quelques jours.
        Le Redme n'a pas été effacé, c'est tout.
        Donc on peut les installer (je l'ai fait sur 2 machines).
    • [^] # Re: et ubuntu ?

      Posté par (page perso) . Évalué à 8.

      Ca fait déjà quelques jours (oui avant l'annonce) que les paquets pour Debian (SID) sont prêts ... Dommage pour ta pique !

      ls -l l | grep -i kdelibs
      -rw-r--r-- 1 root root 31784 2006-07-27 20:32 kdelibs_4%3a3.5.4-1_all.deb


      Jérôme.
  • # Garanties

    Posté par . Évalué à 10.

    KDE 3.5.4, toujours garanti sans technologies microsoft (.NET et compagnie)

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: Garanties

      Posté par . Évalué à 10.

      On n'est pas vendredi...
      • [^] # Re: Garanties

        Posté par . Évalué à 6.

        demain vendredi je révèle en exclusivité quel autre bureau commence à se cribler de technologies microsoft, et risque d'y perdre son âme (indice : cela commence par un G, mais ce n'est pas GNUstep)

        Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

        • [^] # Re: Garanties

          Posté par . Évalué à 5.

          bon ben finalement contre toute attente cela risque d'être tout simplement le Gouvernement ! (DRM toussa...)
          http://linuxfr.org/~clemux/22331.html

          Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

          • [^] # Re: Garanties

            Posté par (page perso) . Évalué à 4.

            Arf... Je me suis planté...
            En même temps, tout le monde me soufflait gnome alors bon...
  • # quelqu'un a des explications/nouvelles ?

    Posté par . Évalué à 1.

    KTHML
    [...]
    Support Mozilla extensions like Element.prototype used in some JavaScript frameworks. Fixes bugs 129386, 127237 and 52555. See SVN commit 557310.


    sur ce que ca inclut ?

    et si kwin ne plante plus quand on change le wallpaper par glissé/déposé ?
  • # Slackware

    Posté par (page perso) . Évalué à 1.

    La version proposée sur KDE.org est une version non officielle.

    Cependant Patrick Volkerding a intégré KDE 3.5.4 dans Current cette nuit :
    Thu Aug 3 01:26:43 CDT 2006
    ...
    l/arts-1.5.4-i486-1.tgz: Upgraded to arts-1.5.4.
    kde/*: Upgraded to KDE 3.5.4. I know I told at least a few people that I
    wasn't planning on including this in Slackware 11.0 at the last minute,
    and there have been a couple of patches needed for it already.
    Please test quickly. :-)
    kdei/kde-i18n*: Upgraded kde-i18n packages for KDE 3.5.4.
    ...

    http://www.slackware.org/changelog/current.php?cpu=i386

    On peu aussi y voir sa volonté de sortir la version 11.0 de la meilleur distribution du monde dans les meilleurs délais.

    PS : Malgrès toute la rigueur que j'ai apporté à ce commentaire, il se peut qu'un troll se soit glissé à l'insus de mon plein grès.
    • [^] # Re: Slackware

      Posté par . Évalué à -2.

      À l'insu de ton plein gré, ce sont surtout des fautes qui s'y sont glissées...
  • # Déjà disponible sous mandriva (cooke future 2007 pour septembre-octobre)

    Posté par (page perso) . Évalué à 4.

    Bon laurent montel a été rapide ce coup ci ;)

    On avais déjà kde 3.5.3 lourdement patché pour régler les divers crash de khtml, désormais ce sera la 3.5.4 ;)

    Malheureusement les isos de la beta on été générés avant la sortie des paquets, donc on va devoir attendre les prochaines iso ou upgrader avec urpmi ;)

    En tout cas la différence par rapport a la vielle 3.4.x est vraiment énorme, si vous avez des connaissances correcte n'hésitez pas a tester la cooker, a part les entrées menu pas visibles et quelques petits bugs triviaux (driver 3d proprio et polices) c'est très stable.
    • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

      Posté par . Évalué à 4.

      On avais déjà kde 3.5.3 lourdement patché pour régler les divers crash de khtml, désormais ce sera la 3.5.4 ;)


      Sans vouloir jouer les mauvaises langues, depuis que je ne suis plus sous Mandriva, je ne connais plus tous ces plantages de KDE, et pourtant, cela fait maintenant quelques jours que je suis sous KDE 3.5.4.

      Bref, cela me persuade encore plus que la politique maison de Mandriva de rester sur leur version de KDE@Mandriva et de la patcher dans tous les sens en backportant une partie seulement des améliorations de la nouvelle version de la branche officielle de KDE n'est pas la bonne.
      • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

        Posté par . Évalué à 2.

        Bof, la seule chose qui a posé des problèmes aux utilisateurs de Mandriva a été Kat, le service de recherche de documents, qui est spécifique a Mandriva. Moi j'ai pu le configurer pour ne pas avoir de problèmes et une fois que ça marche, c'est un bon truc.

        lmontel est quand même le développeur qui fait le plus de commit, parmis ceux listés dans les kde commit-digest. Il n'est plus le seul a maintenir les paquetages KDE de Mandriva, pour préparer KDE4.

        Quand on voit le nombre de news sur Kubuntu, parce que jriddel est payé par Ubuntu, on remarque le génie de Mark Shuttleworth ...
        • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

          Posté par . Évalué à 0.

          Ah bon ? La seule chose ?

          Et les fenêtres konqueror qui se crashent régulièrement (pouf ! fermée !) ?

          Et les raccourcis kfmclient qui une mise à jour sur deux ne fonctionnent plus ? (pourtant, la commande « konqueror », elle, fonctionne)

          Et Klipper qui ne reste pas lancé (et qui d'ailleurs ne veut même pas s'intégrer dans la boîte à miniatures) ?

          Et les mises à jour de KDM qui régulièrement empêchent tout simplement d'accéder à son environnement de bureau tant que l'on n'aura pas remplacer le fichier kdmrc par sa nouvelle version (voire retouché le fichier mal formatée) ?

          Etc.

          C'est réglé tous ces problèmes ? Parce que bon, en plusieurs années de Cooker, je les ai eu à gaver. Bizarrement, depuis que je suis passé sur une autre distribution pourtant réputée instable, je n'ai plus jamais rencontré un problème de ce genre.
          • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

            Posté par . Évalué à 4.

            Et les fenêtres konqueror qui se crashent régulièrement (pouf ! fermée !) ?
            Je ne vois pas de quoi tu parles. Ca crashe autant qu'ailleurs (c'est à dire que je ne me rappelle plus de la dernière fois que c'est arrivé).

            Et les raccourcis kfmclient qui une mise à jour sur deux ne fonctionnent plus ? (pourtant, la commande « konqueror », elle, fonctionne)
            C'est dû au système de menu Debian qu'avait pris Mandriva. Ca tombe bien, ça n'existera plus avec la 2007.

            Et Klipper qui ne reste pas lancé (et qui d'ailleurs ne veut même pas s'intégrer dans la boîte à miniatures) ?
            Chez moi ça marche !

            Mandriva n'est pas la panacée, mais dire qu'elle est plus instable qu'une autre, c'est de la profonde mauvaise foi.
            • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

              Posté par . Évalué à 0.

              La mauvaise foi, c'est de refuser la critique, surtout que toutes les remarques que j'ai formulées peuvent facilement être appuyées par les nombreux rapports de bogues postés de manière récurrente à leur sujet.

              Et comme moi je ne me contente pas d'un « chez moi ça marche », je file les liens :
              http://archives.mandrivalinux.com/cooker/2005-01/msg02317.ph(...) (klipper incapable of running in log in)
              http://qa.mandriva.com/show_bug.cgi?id=22468 (Can't start konqueror from menu/using kfmclient)
              http://archives.mandrivalinux.com/cooker/2004-09/msg02739.ph(...) (kdebase-kdm broken )
              Et pour ceux qui veulent se faire une opinion plus complète, je vous laisse chercher la récurrence de ces problèmes à l'aide du moteur intégré.

              Perso, je m'en tape complètement que Mandriva soit moins instable que d'autres distributions, ce que je vois, c'est que ma nouvelle distribution, bien qu'également considérée comme « unstable » est beaucoup plus stable, et cela me convient parfaitement. Tous les bogues KDE que j'ai connu avec Mandriva était dus au fait que Mandriva utilisait sa propre version de KDE patchée dans tous les sens. Du coup, les nombreux rapports de bogues mettaient longtemps avant d'être traités et corrigés, et il était de surcroît impossible de remonter les problèmes à l'équipe de développement de KDE, car ces problèmes n'existaient pas dans la version officielle de KDE. Ce n'étaient que des bogues induits par l'équipe KDE de Mandriva.

              Maintenant, si tu es heureux avec tes problèmes, tant mieux pour toi, je ne chercherai surtout pas à te faire changer de distribution, mais j'en ai un peu ma claque de ce voilage de face sur les problèmes de cette distribution française. Le chauvinisme n'excuse pas tout.
              • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

                Posté par . Évalué à 3.

                Tu te fous de moi, c'est ça ?
                Tu pars d'un mail de janvier 2005 pour parler de klipper, je te réponds qu'aucun (zero bug) n'est présent dans le bugzilla à propos de son démarrage avec KDE. Je te dis aussi qu'à la fois sur Mandriva 2006 et sur Cooker, ça marche sans intervention de ma part.
                Ensuite, tu me parles de kfmclient, je t'explique que c'était dû au changement de gestion des menus (en gros, ça sera beaucoup moins patché et standard). Ce genre de bug n'existera plus la transition effectuée. Au contraire, Mandriva travaille pour que ça ne revienne plus, c'est un très mauvais exemple.
                Enfin, tu parles de KDM avec un mail du 14 Septembre 2004, je ne comprends même pas pourquoi je devrais répondre à ça.

                Que la distribution de développement de Mandriva soit instable, c'est un peu son rôle. Faire des transitions, parfois douloureuses, c'est normal.

                Mes deux distributions sont Mandriva et Debian Testing, chacunes ont leurs bugs, et les deux ont très peu de bugs sous KDE. Ce n'est pas comme la malheureuse Kubuntu... Ce n'est pas parce qu'une distribution est française qu'il faut s'acharner dessus !
                • [^] # Re: Déjà disponible sous mandriva (cooke future 2007 pour septembre-octo

                  Posté par . Évalué à -3.

                  C'est quoi ce fud à deux balles ! Tu l'as testée la "malheureuse" Kubuntu. Parceque justement j'ai l'impression que c'est la moins buggée du lot. Bon j'avoue Mandriva j'ai plus testé depuis un moment et je suis pas pret de le faire. Quand à Debian, désolé mais je suis resté pas mal de temps en Testing et je ne compte pas les fois ou j'ai eu Kde tout cassé (ou ses collèges genre K3b).
                  Quand à s'acharner sur Mdv parcequ'elle est française, c'est quand même un peu l'inverse qui s'est produit jusqu'à ce que certains en aient eu marre pour diverses raisons.

                  Sérieusement cette haine anti Ubuntu commence à m'éxaspérer.
                  Si Mandriva se casse la gueule c'est de sa faute. Avant qu'Ubuntu n'existe j'avais déjà migré et j'étais surement pas le seul sur Suse et Debian. Puis Ubuntu s'est avérée plus près de mes besoins: une Debian entre stable (pour les mises à jour de sécu) et Testing (pour la fraicheur des paquets).

                  Perso, aujourd'hui, Mandriva j'en ai rien à secouer même si j'espère de tout coeur qu'elle ne disparaisse pas.

                  Alors si, au lieu de cracher sur les autres pour sauver son petit pré carré on bossait ensemble pour avoir "les" meilleures distro du monde. Il y a assez à faire comme ça.

                  Très franchement des réactions de ce type ça donne presque envie de passer sur Mac OS voir WinXP.
  • # Pas si mineure que ça.

    Posté par . Évalué à -5.

    Vu sur http://www.kde.org/announcements/visualguide-3.5.php

    - Le support des ACL si la partition le supporte.
    - Adblock pour konqueror
    - konqueror passe le test ACID2 :-)

    bref, plein de trucs sympa qui fait que cette release n'est pas si anodine
    • [^] # Re: Pas si mineure que ça.

      Posté par (page perso) . Évalué à 5.

      Ton lien mentionne les nouveautés de kde 3.5.
      Ce journal parle de la sortie de KDE 3.5.4 qui n'est qu'une mise à jour de maintenance (+ quelques petites fonctionnalités)
  • # les périphériques amovibles

    Posté par (page perso) . Évalué à 4.

    j'ai fait cette requéte sur kde.org : http://bugs.kde.org/show_bug.cgi?id=127788 et aurait aimé savoir si le "Improved removable device support" concerne aussi cette requéte. Comme je n'ai plus la possibilité de faire l'upgrade est ce que quelqu'un pourrait me le confirmer?

    Merci d'avance.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.