Journal GIMP roule aussi sur P4

Posté par (page perso) . Licence CC by-sa
43
28
mai
2018

Bonjour Nal,

Je voulais te faire partager ma récente expérience avec GIMP. Notre association a organisé une Journée du Logiciel Libre ce samedi, et la nouveauté cette année a été la mise en place d'un atelier de retouche d'image. Notre association ayant peu de moyens, on a sorti du placard de vieux coucous sur lesquels on a mis une Debian 9 LXDE, et on a acheté quelques écrans pour pas cher. On a ainsi pu avoir 7 stations de travail fonctionnelles.

La salle de l'atelier

J'ai présenté quatre exercices: recadrer une image, extraction de premier plan, montage avec des calques, plugin inpaint de G'MIC et l'outil de retouche. Les participants ont pu réaliser tous ces exercices dans de bonnes conditions, malgré l'utilisation d'ordinateurs dépassés.

Un ordinosaure

Détails techniques: on a utilisé GIMP 2.8 et le G'MIC qui était dans les dépôts, avec des images de taille réduite (pas plus de 1000px de large) et 1Go de RAM. J'ai voulu tester avec GIMP 2.10 via flatpak, mais je n'ai pas pu le lancer sur ces machines (j'imagine que le jeu d'instruction des processeurs ne le permettait pas… je n'ai pas vu de message d'erreur).
De nos jours les logiciels sont de moins en moins compatibles avec ces vieilles machines (Ubuntu ne fait plus que du 64bits par exemple), et c'est normal, il faut évoluer. Néanmoins, c'est grâce à Debian qui maintient un noyau 32bits et non PAE, qu'on a pu proposer cet atelier.

On partagera prochainement le compte rendu de notre journée sur notre site web. À bientôt!

  • # Gimp 2.10

    Posté par . Évalué à 3 (+2/-0). Dernière modification le 29/05/18 à 02:30.

    J'ai voulu tester avec GIMP 2.10 via flatpak, mais je n'ai pas pu le lancer sur ces machines (j'imagine que le jeu d'instruction des processeurs ne le permettait pas

    J'ai installé sans probléme Gimp 2.10 sur une debian stable à partir des dépôts unstable. voir ce message. Certes, ma debian est 64 bits, mais tu peux toujours essayer pour voir si le 32 bits s'installe aussi bien.

    • [^] # Re: Gimp 2.10

      Posté par (page perso) . Évalué à 3 (+1/-0).

      Le service rendu n'est pas le même : avec Flatpak tu gardes ton logiciel stable installé, alors qu'avec les dépôts unstable tu le remplaces.

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

    • [^] # Re: Gimp 2.10

      Posté par (page perso) . Évalué à 1 (+0/-0).

      Ça peut être une solution, à tester peut-être l'année prochaine. Mais je doute quand même que le logiciel se lance sue ces machines, même si il est installé correctement. Et puis utiliser la version des dépôts main, c'est quand même plus sûr pour faire une présentation (plus stable)

      Un LUG en Lorraine : https://enunclic-cappel.fr

  • # Debian

    Posté par (page perso) . Évalué à 10 (+10/-0).

    Mais que ne ferait-on sans Debian ;-)

    • [^] # Re: Debian

      Posté par . Évalué à 9 (+9/-1).

      On installerait Fedora

      • [^] # Re: Debian

        Posté par (page perso) . Évalué à 2 (+2/-1).

        Oulà ou pas. Je doute que Fedora cherche à maintenir une compatibilité sur des archis aussi vieille, et d'expérience personnelle, c'est pas foufou à l'usage (après j'avais testé la version KDE).

        Opera le fait depuis 10 ans.

    • [^] # Re: Debian

      Posté par (page perso) . Évalué à 9 (+7/-0).

      C'est clair !!!
      Je me suis réinstallé une Debian Potato la semaine dernière sur mon 486sx25 , super simple :
      3 disquette(rescue, driver et rootfs), un CD (tout est toujours disponible sur http://archive.debian.org/debian/dists/Debian-2.2/main/disks-i386/2.2.26-2001-06-14/ )

      On change dans /etc/apt/sources.conf le stable en potato et ça marche, apt-get et c'est parti !!!

      C'est bien une distrib qui garde ses anciennes versions accessibles.

      S'il y a un problème, il y a une solution; s'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

      • [^] # Re: Debian

        Posté par (page perso) . Évalué à 1 (+0/-0).

        Un jour HTTP sera remplacé par un protocol qui garde X copies toujours disponibles sur le réseau.

        Ca évitera que les "maintainers" ne bougent sans cesse les serveurs d'archives, ou au mieux, les fassent disparaître.

        • [^] # Re: Debian

          Posté par . Évalué à 5 (+3/-0).

          http c'est un protocole de transfert, c'est pas vraiment à lui de répondre à ce point précis.

  • # P4 ?

    Posté par . Évalué à 2 (+1/-0).

    C'est quoi P4 ?

    • [^] # Re: P4 ?

      Posté par . Évalué à 9 (+7/-0). Dernière modification le 29/05/18 à 13:44.

      Dans le contexte (32bits, non-pae) j'en ai déduis un pentium 4.

      • [^] # Re: P4 ?

        Posté par . Évalué à 1 (+1/-0).

        Moi aussi.

        Surtout qu'avec aucune référence au service militaire et vu la relative du lectorat de DLFP, ça ne peut pas être une référence au Psychologie=4 du SIGYCOP

        Ok, je ---->[]

      • [^] # Re: P4 ? -> non PAE

        Posté par . Évalué à 0 (+0/-0).

        Je profite de ce sujet "ordinosaures" pour savoir s'il reste beaucoup de distrib 32bit non PAE.
        Je possède un Hercules eCafé 800 propulsé par un Geode LX 800 et je suis pour l'instant "bloqué" sur un Mageia 4, l'upgrade vers la 5 ayant été un échec potentiellement à cause de l'absence de PAE.
        Outre Debian (qu'il faudra que je teste…), quelle distribution mainstream propose encore du 32bit non-PAE ?

        • [^] # Re: P4 ? -> non PAE

          Posté par . Évalué à 4 (+2/-0).

          C'est pas vraiment mainstream mais j'ai longtemps utilisé du openbsd sur une machine qui n'avait pas de pae. Avec les ports tu peux arriver à avoir un desktop correct. Dans mon cas je n'avais pas de gros prérequis puisque le but c'était de pouvoir avoir un terminal pour lancer des ssh et du desktop "déporté" depuis une machine plus grosse qui tournait sous linux via le ssh X-forwarding.

      • [^] # Re: P4 ?

        Posté par (page perso) . Évalué à 3 (+2/-0).

        d'ailleurs pourquoi Non-PAE ? c'est supporté depuis le Pentium Pro au moins

        • [^] # Re: P4 ?

          Posté par (page perso) . Évalué à 3 (+1/-0).

          Je confirme, y'avait certains Pentium M qui n'étaient pas PAE mes les Pentium 4 l'étaient.

          Dans les distributions grand public, Ubuntu ne s'installe plus sur les CPU non-PAE depuis avril 2012, ce qui ne nous rajeunit pas :D

          La connaissance libre : https://zestedesavoir.com

        • [^] # Re: P4 ?

          Posté par . Évalué à 4 (+3/-1).

          Comme dit plus haut, les gammes Pentium "Centrino" / Pentium-M pour les portables étaient souvent (toujours?) sans PAE. J'ai longtemps ( jusqu'à la mort de son disque dur) gardé un laptop qui en était équipé et qui limitait mon choix de distro pour cette raison.

          • [^] # Re: P4 ?

            Posté par . Évalué à 2 (+1/-0).

            J'utilise toujours un portable IBM à base de Pentium M (family 6, model 13, rev. 8). Non seulement il fonctionne très bien sur un système récent (avec bureau Mate), mais l'extension PAE est bien présente, donc pas toujours, non…

            • [^] # Re: P4 ?

              Posté par (page perso) . Évalué à 2 (+0/-0).

              Certains ont bien le PAE mais ne présentent pas l’extension au système. Il donc existe des bidouilles pour tromper /proc/cpuinfo afin de ne pas échouer à l’installation d’un noyau PAE sur un ordi avec un CPU qui dit ne pas savoir faire alors qu’il sait faire (sous Debian/Ubuntu le gestionnaire de paquet essaie de vérifier si ce que tu fais a du sens, mais là il est trompé…)

              J’ai parfois sous-la main un Thinkpad R51 comme ça. Pour ce portable précis c’est connu que le CPU en question ne dise pas qu’il sait faire du PAE alors qu’en fait il sait le faire et qu’une fois installé, le noyau PAE fonctionne très bien.

              ce commentaire est sous licence cc by 4 et précédentes

              • [^] # Re: P4 ?

                Posté par . Évalué à 3 (+1/-0).

                Quel est l'intérêt du CPU à ne pas dire qu'il sait gérer le PAE ? Comment trompe-t-on /proc/cpuinfo, dans ce cas ?

                • [^] # Re: P4 ?

                  Posté par (page perso) . Évalué à 4 (+2/-0).

                  Quel est l'intérêt du CPU à ne pas dire qu'il sait gérer le PAE ?

                  Parce que c’est Intel je dirai « segmentation du marché », mais pour le PAE ça ne fait pas sens ! Je ne vois aucune raison de segmenter le marché entre le PAE et le non-PAE surtout des années après que tous les CPU du commerce le font ! Erreur ?

                  J’ai aussi sous la main des CPU au sujet desquels Intel dit qu’ils ne prennent en charge que le 32bits, mais officieusement ils tournent très bien en 64bit. Je ne sais pas pourquoi Intel n’annonce pas officiellement le support 64bit mais ça tourne en production sans interruptions depuis de nombreuses années sans sourciller (j’ai ça dans des routeurs)…

                  Comment trompe-t-on /proc/cpuinfo, dans ce cas ?

                  Tu crées un nouveau fichier en rajoutant le mot clé pae dans la ligne flags de tes cpu, puis tu monte le fichier modifié sur le chemin original :

                  sed -e '/^flags[ \t]/s/: /: pae /' /proc/cpuinfo > /etc/cpuinfo.pae
                  mount -o bind /etc/cpuinfo.pae /proc/cpuinfo

                  Le mount -o bind est pratique : tout ce que tu écriras dans /etc/cpuinfo.pae sera vu par toute application qui lira /proc/cpuinfo. Le fichier modifié survivra au reboot mais pas le mount -o bind. Faire ainsi permet de tromper les scripts d’installation qui vérifient la présence du flag pae. Le noyau s’en fout, lui. Il y avait un paquet Debian qui automatisait ça il me semble.

                  ce commentaire est sous licence cc by 4 et précédentes

          • [^] # Re: P4 ?

            Posté par . Évalué à 2 (+0/-0).

            C'est loin d'être toujours vrai, très loin.

            J'ai plusieurs ordis avec des Pentium M (des Thinkpad T43 pour être précis), et ils ont bien le PAE.

            "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

          • [^] # Re: P4 ?

            Posté par (page perso) . Évalué à 2 (+0/-0).

            Apparemment ça dépend de la série. Une autre source dit que ceux avec un FSB à 400 MHz n'ont pas de PAE.

            La connaissance libre : https://zestedesavoir.com

            • [^] # Re: P4 ?

              Posté par (page perso) . Évalué à 3 (+1/-0).

              The Banias family processors internally support Physical Address Extension (PAE) but do not show the PAE support flag in their CPUID information; this causes some operating systems (primarily Linux distributions) to refuse to boot on such processors since PAE support is required in their kernels.[3]

              Cette phrase n’est pas correcte, le noyau ne refuse pas de démarrer sur ce type de processeur, c’est le système de paquet qui refuse d’installer un tel noyau sur un système qui possède un tel processeur, mais comme dit plus haut une fois installé en falsifisant /proc/cpuinfo, le noyau démarre très bien au reboot suivant (la falsification n’est utile que pour l’installation).

              ce commentaire est sous licence cc by 4 et précédentes

        • [^] # Re: P4 ?

          Posté par (page perso) . Évalué à 1 (+0/-0).

          Dans mon cas, au moins un PC portable n'avait pas l'extension PAE, je n'ai pas vérifié pour les autres machines.

          Un LUG en Lorraine : https://enunclic-cappel.fr

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.