eric a écrit 66 commentaires

  • [^] # Re: marche pô

    Posté par . En réponse au message xtightvncviewer et serveur double écran. Évalué à 1.

    oui c'est exactement ça.
    c'est a peu près faisable , en utilisant ultra vnc sur le pc XP, en choisissant le moniteur 'virtuel' comme principal dans les préférence d'affichage de win, quand j'ouvre une xtighvncviewer sur la machine , j'ai bien mon deuxième écran ' virtuel' dans une fenêtre vnc.
    Le truc super pas pratique ( dû a win) c'est que lorsque j'appelle une fenêtre dialogue système, comme lorsque l'on veut arrêter ou redémarrer le PC, ces fenêtres systèmes s'ouvrent sur l'écran principal ( qui n'a pas de moniteur matériel dans mon cas ) , donc je suis obligé de lancer mon client vnc…

    merci a tous,et si vous avez plus d'info ou d'astuce, je suis prenneur

  • [^] # Re: marche pô

    Posté par . En réponse au message xtightvncviewer et serveur double écran. Évalué à 1.

    Bonjour,

    pour ce qui est de ma version de xtightvncviewer :
    ~$ xtightvncviewer -?
    TightVNC Viewer version 1.3.9

    en fouillant un peu le site DemoForge, je me suis aperçu qu'il y avait une appli win32 tightvnc que j'ai essayé :

    Là effectivement, xtighvncviewer me permet d'afficher les 2 écrans dans la même fenêtre, avec cette commande :
    xtightvncviewer -compresslevel 3 -quality 9 -depth 0 -passwd ~/.vncpasswd -geometry 2880x1200 machineXP

    mais c'est pas encore génial, déjà je voudrais qu'un seul des écrans.
    ensuite il faut que l'écran principal de xp soit à gauche (et chez moi c'est l'inverse) : xtightvncviewer affiche les 2880x1200 pixel ( 2880 en largeur parce que j'ai un écran en 1600x1200 et l'autre en 1280x1024 )à partir de l'origine de l’écran principal, donc si l’écran secondaire et à gauche du principal ben, dans le fenêtre xtighvncviewer, on a le bureau de l’écran principal et à droite un espace de 1280x1200 pixel noir qui sert à rien…

    je continue mes recherche

  • [^] # Re: marche pô

    Posté par . En réponse au message xtightvncviewer et serveur double écran. Évalué à 2.

    Donc récapitulatif : je recherche encore le moyen d'afficher le deuxième écran d'un pc Windows XP dans une fenêtre sous mon système Gnu linux.
    j'ai essayé xtightvncviewer, ssvnc ainsi que krdc.
    Le protocol RDP ne fonctionne pas pour ce que je veut faire car coupe la session en local.

  • # marche pô

    Posté par . En réponse au message xtightvncviewer et serveur double écran. Évalué à 2. Dernière modification le 09/07/12 à 15:26.

    Merci à tous de ces réponses.

    Cependant , ça le fait toujours pas :
    En RDP, ok je me connecte , mais le souci avec ce protocole c'est que la session local se ferme pour laisser place à la session à distance.

    Du coup, moi qui voudrais une fenêtre dans mon environnement linux qui soit mon deuxième écran de Win XP, en plus de mon écran physique branché à la machine Windows; et bien je me retrouve avec une fenêtre dans mon linux qui correspond à l’écran principal de Windows Xp ( plutôt que du secondaire ) et en plus l’écran physique du pc Windows ne sert plus à rien puisque j'ai la page de logon de Win (et bien sur, si je me log en physique, la connexion RDP lâche)

    Si qq'un d'autre à de l'idée

    merci

  • [^] # Re: activé le protocole "remote desktop" de windows

    Posté par . En réponse au message xtightvncviewer et serveur double écran. Évalué à 1.

    Merci NeoX,

    de quel client parle tu?

    en plus de xtightvncviewer, j'ai essayer krdc ainsi que ssvnc.
    Mais je n'y arrive pas plus.

  • [^] # Re: zonescreen

    Posté par . En réponse au message se servir d'un écan d'un autre pc comme second écran . Évalué à 0.

    MErci ,

    j'ai été voir , malheureusement ça ne fait pas ce que je veux, juste l'inverse.
    le serveur zonescreen doit être sous windows, linux peut juste recevoir le display pas l"envoyer.
    La machine que j'utilise le plus est la Debian ( forcement), le windows me sert que pour des petites taches régulières.

    Je ne veut pas passer par une solution de virtualisation parce que ça rame...

    et en X c'est pas possible? genre configurer le serveur X de debian pour le multi-écran et forwarder le display 0:1 vers le display du X de windows...

    merci de vos éclaircissements

  • [^] # Re: synergy-plus

    Posté par . En réponse au message se servir d'un écan d'un autre pc comme second écran . Évalué à 0.

    Merci ,
    j'utilise déjà synergy pour n'utiliser qu'un seul couple clavier souri, bien qu'il y ai encore des ratés qui m'oblige à laissé un vrai clavier sur ma machine Debian : les caractères accentués ou les symboles comme le arobase ne passent pas avec synergy ( win en serveur et debian en client.)...
    Cependant je que je voudrais c'est que mon pc windows ai une fenêtre X, laquelle serai le deuxième écran (virtuel) de ma machine Debian

  • [^] # Re: Changement de matériel

    Posté par . En réponse au message Point d’accès wifi avec contrôle des utilisateurs et du contenu. Évalué à 0.

    Je viens de recevoir un wrt54gl, je me suis décidé sur celui ci car moins cher, largement suffisant pour ce que je veut en faire (portail captif + contrôle "parental"),et que openwrt, ddwrt, tomato ou autre fonctionne (normalement) parfaitement dessus.

    Je vais installer ça mardi ou mercredi, si en attendant qq'un a des conseil a me donner, je suis preneur.

  • # Changement de matériel

    Posté par . En réponse au message Point d’accès wifi avec contrôle des utilisateurs et du contenu. Évalué à 0.

    Salut à tous,

    Le PC dont je voulait me servir est en fait HS, et , en surfant un peu je suis tomber sur une solution intéressante : openwrt sur un routeur.

    Apparemment cela me permettra de faire ce que je veux, càd un point d’accès wifi avec un portail captif et un "contrôle parental", et le mieux c'est que ça me coutera pas trop cher, que l'encombrement est minimum, et certainement plus simple et plus fiable qu'un serveur dédié avec un AP wifi, surtout que l'utilisateur final a 80 ans passé !

    Quelqu’un a t'il déjà mis cette solution en œuvre? J'hésite à l'achat entre un WRT54GL, WRT160NL ou une Fonera 2.
    j'ai vu aussi qu'il y avait plusieurs distribs de linux pour routeur

    quelqu'un peut il me conseiller sur la distrib et le routeur ( le plus simple à installer et utiliser) ?

  • [^] # Re: détails

    Posté par . En réponse au message Point d’accès wifi avec contrôle des utilisateurs et du contenu. Évalué à 1.

    http://www.alcasar.info/ a l'air sympathique et surtout simple à mettre en œuvre, quelqu'un connait, me le conseil, le déconseil?

  • # détails

    Posté par . En réponse au message Point d’accès wifi avec contrôle des utilisateurs et du contenu. Évalué à 1.

    merci pour vos réponse.

    C'est effectivement ce genre de solution que j'aimerais mettre en place, j'ai commencé à regarder les différentes solutions de portail.

    Peut être pouvez vous m'orienter sur la solution adapté à mes besoins, donc en détail :
    C'est pour une association d'accueil des marins, ceux ci viennent de partout et ont besoin de communiquer par le biais de skype ou autre logiciel.
    Beaucoup sont équipés d'ordi portables de demande à utiliser le wifi.
    Cette association est gérée par des retraités, donc besoin d'une solution assez simple à utiliser.
    Je m'occuperais de l'administration et de la maintenance.

    le but est de créer un point accès wifi qui permet à l'association de :
    - revendre du temps de connexion.
    - empêcher l’accès au site porno, warez, pédo... (comme un contrôle parental) afin de ne pas risquer de problème de légalité.
    - empêcher l’accès aux ports de peer2peer pour éviter la saturation de la ligne.
    - laisser accès aux ports utile pour la télécommunication ( SIP, Skipe, msn, yahoo..)
    - fournir facilement un couple login/password lors de la demande par un client.

    Au niveau des ressources : une connexion adsl, un vieux PC celeron 700, carte wifi que je vais acheter pour l'occasion ( d’ailleurs question subsidiaire : quelle carte wifi me conseillez vous?)

    merci

  • [^] # Re: statique

    Posté par . En réponse au message GPGPU : lancer une CG sans écran. Évalué à 2.

    Bonjour,

    je n'ai pas activé le crossfire, dans mes test précédent je me suis rendu compte que lorsque j'utilisais le SLI (donc sur Nvidia) j'avais des pertes de performance. Du coup j'ai mis de côté ces techno (SLI & crossfire)
    j'ai trouvé comment avoir mes Devices -> export DISPLAY=:0
    cela fonctionne.

    Pour améliorer les choses, j'aurais encore besoin de quelques astuces eclairées :
    Mon but est de me passer de mes 5 écrans et d'en gardé juste un branché sur mon chipset graphique integré
    Donc pour l'instant , un fois que X s'est lancé et donc que mes écrans sont ok & mes pilotes sont activés, je retourne sur la console 1 (ctrl+alt+1) afin de lancer un programme CAL, celui ci s'éxecute mais reste en attente... pour que celui ci me donne mes résultat , je suis obligé de reswitcher sur la console graphique (ctrl+alt+7) que le calcul se fasse , puis revenir sur ma console 1 pour apprécier ma sortie.
    Une question : est ce que X coupe les pilotes lorsque l'on coupe la console graphique. si oui comment y remédier?
    et même question également que ma première, quelqu'un connaît d'autres options pour mon Xorg afin que je ne soit pas obligé de brancher un écran par carte?
    le problème de la solution de fcartegnie, c'est qu'une fois mis en place , je lance le catalyst center (aticccle) et ce dernier m'indique pour les cartes où j'ai ajouté les options pour feinter l'écran , il m'affiche qu'il ne sait pas si il y a un écran ou deux , donc n'active pas le pilote .

    je suis ouvert à toute infos.

    merci
  • [^] # Re: statique

    Posté par . En réponse au message GPGPU : lancer une CG sans écran. Évalué à 2.

    Merci pour ta réponse.

    J'ai testé mais sans succès, en executant amdcccle, il ne detecte que les écran phisique..
    Pour l'instant et pour mes test j'ai branché un écran par carte.

    Cela dit, j'ai un soucci avec CAL (Compute Abstraction Layer : en gros le cuda de AMD, sauf que c'est pas du C-like mais un assembleur-like) : malgrés que mes cartes soient bien activées car équipées d'écran et que j'ai les badges AMD qui me précisent bien que j'utilise le pilote proprio sur mes carte, mes carte sont repérées par AMDCCCLE et par aticonfig --list-adapter lorsque je demande le nombre de Devices ( de GPU) il me retourne 1 (j'ai 4 cartes de branchées...)



    [vieurou@localhost x86_64]$ aticonfig --list-adapters
    * 0. 13:00.0 ATI Radeon HD 5800 Series
    1. 0c:00.0 ATI Radeon HD 5800 Series
    2. 8d:00.0 ATI Radeon HD 5800 Series
    3. 86:00.0 ATI Radeon HD 5800 Series

    * - Default adapter


    [vieurou@localhost x86_64]$ ./FindNumDevices
    Supported CAL Runtime Version: 1.3.185
    Found CAL Runtime Version: 1.4.467
    Use -? for help
    CAL initialized.
    Finding out number of devices :-
    Device Count = 1
    CAL shutdown successful.

    Press enter to exit...





    Quelqu'un qui fais du GPGPU avec CAL qui aurait une idée?
  • [^] # Re: ben faut installer la lib correspondante

    Posté par . En réponse au message glibc. Évalué à 1.

    le probleme c'est que ce paquet n'est pas disponible.
    y a t'il moyen de trouver les sources, afin de le compiller?
  • [^] # Re: libtool

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    bonjour,
    j'ai l'impression que le fait que ce soit compilé en librairie cause une grosse perte de perf , je m'explique : lorsque je compile mon code en exécutable j'ai des performance deux fois plus rapide que si je compile une librairie et que je crée un exécutable appelant celle ci,
    comment pourrais-je améliorer les perf de la librairie?
  • [^] # Re: libtool

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    bonjour ,
    merci pour ces précisions

    avec libtool tout se passe apparemment bien que ce soit pour compiler en 64 ou en 32.
    très bon outils , évite pas mal de prise de tête.

    est ce que les lib .a on aussi cette perte de perf?
  • [^] # Re: libtool

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 2.

    merci beaucoup
  • [^] # Re: incompatibilité 32/64

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 2.

    merci , effectivement c'est ballot....
    une fois l'option -fPIC dans à la compilation , ça se compile
  • [^] # Re: libtool

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    j'ai apparemment réussie a compiler cette bibliothèque avec libtool en suivant ce document ftp://ftp.laas.fr/pub/ii/matthieu/make-trans.pdf

    donc je fais un sudo libtool --mode=link cc -rpath /usr/local/lib -o libLib.la Lib.lo && sudo libtool --mode=install install -c libLib.la /usr/local/lib/ && sudo libtool --mode=install install -c libLib.la /usr/local/lib/ && sudo ldconfig
    ce qui m'étonne c'est que je link pas (explicitement ) les librairies glut et glew... c'est normal ?? c'est libtool qui fais tout?, ou alors je m'y suis mal pris?
  • [^] # Re: libtool

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    salut , merci de ta réponse ,

    j'ai donc installé libtool avec un apt-get install , mais comment s'en servir ??? (j'ai lu le man , mais ça ma pas trop aidé...)
  • [^] # Re: incompatibilité 32/64

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    merci de cette reponse rapide .
    effectivement je clean bien tout le projet à chaque fois que je recompile.

    Comment installer sur ma 64bits ces librairie 32bits pour que je puisse compiller la mienne??
  • [^] # Re: ./Source/Lib.o

    Posté par . En réponse au message compilation d'une librairie .so recalcitrante. Évalué à 1.

    Bonjour , merci de vos réponses.

    Donc quand je compille en 32bit, eclipse me fait:Building target: libLib.so
    Invoking: GCC C++ Linker
    g++ -m32 -shared -o"libLib.so" ./Source/Lib.o -lGLEW -lglut
    /usr/bin/ld: skipping incompatible /usr/bin/../lib/libGLEW.so when searching for -lGLEW
    /usr/bin/ld: skipping incompatible /usr/bin/../lib/libGLEW.a when searching for -lGLEW
    /usr/bin/ld: skipping incompatible /usr/lib/libGLEW.so when searching for -lGLEW
    /usr/bin/ld: skipping incompatible /usr/lib/libGLEW.a when searching for -lGLEW
    /usr/bin/ld: cannot find -lGLEW
    collect2: ld a retourné 1 code d'état d'exécution
    make: *** [libLib.so] Erreur 1
    make: La cible « all » n'a pas pu être refabriquée à cause d'erreurs.
    Build complete for project Lib


    quand je compille en 64bit , j'ai :
    **** Build of configuration Debug for project Lib ****

    make -k all
    Building target: libLib.so
    Invoking: GCC C++ Linker
    g++ -m64 -shared -o"libLib.so" ./Source/Lib.o -lGLEW -lglut
    /usr/bin/ld: ./Source/Lib.o: relocation R_X86_64_32S against `x1a0' can not be used when making a shared object; recompile with -fPIC
    ./Source/Lib.o: could not read symbols: Bad value
    collect2: ld a retourné 1 code d'état d'exécution
    make: *** [libLib.so] Erreur 1
    make: La cible « all » n'a pas pu être refabriquée à cause d'erreurs.
    Build complete for project Lib


    donc je rajoute l'option -fPIC : **** Build of configuration Debug for project Lib ****

    make -k all
    Building target: libLib.so
    Invoking: GCC C++ Linker
    g++ -m64 -fPIC -shared -o"libLib.so" ./Source/Lib.o -lGLEW -lglut
    /usr/bin/ld: ./Source/Lib.o: relocation R_X86_64_32S against `x1a0' can not be used when making a shared object; recompile with -fPIC
    ./Source/Lib.o: could not read symbols: Bad value
    collect2: ld a retourné 1 code d'état d'exécution
    make: *** [libLib.so] Erreur 1
    make: La cible « all » n'a pas pu être refabriquée à cause d'erreurs.
    Build complete for project Lib


    peut être ça peut aidé , les includes de mon code :
    #include <stdio.h>
    #include <libio.h>
    #include <stdlib.h>
    #include <string.h>
    #include <math.h>


    #include <time.h>
    #include <sys/timeb.h>

    #include <GL/glew.h>
    #include <GL/glut.h>
    #include <GL/glx.h>

    #ifdef ACML
    #include </opt/acml4.0.1/gfortran64_mp_int64/include/acml.h>
    //#include </opt/acml3.6.1/gfortran64_mp/include/acml.h> //3.6 en 64 multiproc
    #endif



    #include <sys/types.h>
    #include <sys/stat.h>
    #include <unistd.h>


    je ne défini pas ACML
  • [^] # Re: en vrac

    Posté par . En réponse au message 2 x ATi HD2900XT sous ubuntu 7.10 x86_64. Évalué à 1.

    j'ai parlé avec un gars de chez ATI qui m'as dit que les pilotes fglrx ne supportait pas le multiGPU, donc forcement j'aurais pu chercher longtemps...
    le support multiGPU est par contre supporté sur windows.
    j'espere que la situation s'arrangera quand les pilotes radeonHD seront au point, ou que ATI en sorte des nouveaux (le support multigpu est apparement prevu).
  • [^] # envy

    Posté par . En réponse au message Help me. Évalué à 1.

    pour installer des cartes ATI ou NVIDIA sous une ubuntu , j'utilise envy qui à toujours fonctionné correctement
    la page de ce projets sur le site de son auteur : http://albertomilone.com/nvidia_scripts1.html

    je n'ai pas essayer mais apperement c'est compatible avec debian
  • [^] # Re: Extrait de la page du projet

    Posté par . En réponse au message pofiler et C++. Évalué à 1.

    merci pour la réponse ,
    néanmoins , même en suivant la page du liens , j'arrive a compiller l'appli avec gcc et l'option -lccmalloc mais quand je lance l'appli (il faut compiller puis ensuite lancer l'appli), je vois bien le petit tableau de ccmalloc mais apres j'ai un "segmentation fault"...

    si quelqu'un connais un autre profiller?