Forum général.général La fibre chez SFR

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
3
24
jan.
2021

Salut tout le monde !
Je suis l'heureux possesseur depuis hier d'une connexion fibrée chez sfr et j'ai remarqué deux trois problèmes qui sont un peu techniques à expliquer au sav, je viens donc vers la sublime communauté de linuxfr pour voir si vous n'avez pas une idée.

J'ai d’abords voulu faire un test de vitesse,je suis aller là : https://www.speedtest.net/fr

Bon, 40 secondes pour avoir la page, j'ai pas trop cherché, et ensuite une à deux minutes pour avoir un serveur. C'est chaud.
J'ai à l'issue du test une connexion comme ça :

  • Ping : 33ms
  • Descendant Mbps : 78.64
  • Ascendant Mbps : 93.68

Bref, venant de l'adsl ça semble énorme, et j'ai bien un bon débit en pratique mais la navigation internet est parfois aux fraises.
Si je regarde dans les outils de firefox je constate que le temps de blocage des requêtes ainsi que la résolutions dns peuvent être très longue ! Par exemple :

Minutage des requêtes
Bloqué :
10,08 s
Résolution DNS :
10,03 s
Connexion :
19 ms
Établissement liaison TLS :
27 ms
Envoi :
0 ms
Attente :
141 ms
Réception :
0 ms

Je ne connaissais pas ces soucis avec l'adsl; je passe par un switch ethernet (acheté à prix d'or chez mr bricolage…), ça peut venir de là ? je testerai en direct pour voir mais bon…

Une idée ?
Poutou.

Edit :

Bon je vais mettre à jour le post, alors déjà le problème de débit venait de mon switch, qui bêtement ne délivre que 100Mb/s; en direct le débit descendant était de quasi 1Gb/s, et de +- 500Mb/s en ascendant. Ce soir c'est 650 et 350 Mb/s.

Ensuite, effectivement changer de DNS pour Cloudflare, Google ou la FDN arrange mes le soucis du temps de résolution de certaines requêtes et le surf est du coup très rapide.

Par contre j'ai remarqué que certains sites étaient inexplicablement inaccessibles… Genre ldlc.com ne me répond pas, un traceroute ldlc.com sort ça :

traceroute to www.ldlc.fr (91.211.165.65), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  0.611 ms  0.593 ms  0.763 ms
 2  * * *
 3  10.205.223.213.rev.sfr.net (213.223.205.10)  4.462 ms  5.400 ms  5.397 ms
 4  5.203.223.213.rev.sfr.net (213.223.203.5)  6.468 ms  6.470 ms  6.466 ms
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Ça fonctionne en passant par un VPN (même si le traceroute n'aboutit pas plus), ou en 4G.
Ça fait ça avec d'autres sites du groupe LDLC ou apparemment s'appuyant sur LDLC (comme hardware.fr), et sur d'autre encore.
J'ai jamais eu des problèmes pareils.

J'ai voulu voir si ça ne pouvait pas venir de moi, j'ai un debian et une archlinux et ça le fait sur les deux. Ce poste parle d'une possible bafouille avec un paramètre ipv4 : https://www.hivelocity.net/kb/why-is-there-access-problems-with-some-websites-2/
à voir. (je ne peux accéder à ce site qu'au travers de mon vpn d'ailleurs :) )

Re Edit :

Ça ne semble rien changer.

  • # et si tu changes de DNS ?

    Posté par  (site Web personnel) . Évalué à 3 (+1/-0).

    tout est dans le titre

    • [^] # Re: et si tu changes de DNS ?

      Posté par  . Évalué à 2 (+2/-1).

      Mais c'est mieux en proposant quelques alternatives.

      Solutions de repli faciles :

      • en passant par Cloudflare : 1.1.1.1
      • en passant par Google : 8.8.8.8 et 8.8.4.4

      Ils en proposent d'autres mais je ne les connais pas tous par cœur.

      Il existe également des solutions plus ou moins libres. Attention, il me semble que OpenDNS n'est pas si open que ça.

      Pour aller plus loin : Pi-hole. pas forcément besoin d'un Raspberry Pi (le miens tourne dans une VM amd64). Tu installes ça chez toi, tu t'en sers comme unique DNS, et il se charge de résoudre les noms, et surtout, de ne pas résoudre ceux qui sont blacklistés (pub & autres saloperies …).

      Quant à speedtest, attention au serveur auquel il se connecte. Le résultat peut varier dans des proportions non négligeable. Ça devient un "gros" problème depuis que la fibre se démocratise : de plus en plus de serveurs de test n'ont pas la capacité pour encaisser nos "super débits".

      • [^] # Re: et si tu changes de DNS ?

        Posté par  . Évalué à 4 (+2/-0).

        Installe-toi un serveur DNS reccursif, il y en a un dans Pi-hole et les projets similaires.

        Utiliser Cloudflare ou Google, c'est tentant mais c'est prendre un gros risque.

        Les DNS des fournisseurs d'accès Internet sont des DNS menteurs, et sont lents.

        Probable que tu ais aussi des difficultés, il y a des fournisseurs d'accès à Internet qui bloquent les requêtes DNS (j'avais constaté ça chez Bouygues il y a quelques années), et dans ce cas il te faudra utiliser un VPN. Bloquer une partie d'Internet ce n'est pas un accès Internet… chez Free ils ne te cassent pas les pieds sur ça en tout cas.

      • [^] # Re: et si tu changes de DNS ?

        Posté par  . Évalué à 8 (+6/-0).

        Il existe également des solutions plus ou moins libres

        En plus libre il y a les DNS de la FDN.

        En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

        • [^] # Re: et si tu changes de DNS ?

          Posté par  . Évalué à 7 (+5/-0).

          Et pour les flemmards:

          Ils sont disponibles aux adresses IPv4 et IPv6 suivantes :

          ns0.fdn.fr : 80.67.169.12 ou 2001:910:800::12
          ns1.fdn.fr : 80.67.169.40 ou 2001:910:800::40

  • # résolution DNS lente ?

    Posté par  . Évalué à 3 (+1/-0).

    Vu tes délais DNS
    Je dirai que changer les serveurs DNS prédéfini par SFR par d'autres dans ta config de la box et reteste (par ceux de la FDN, google ou autres) seraient une idée.

  • # Les DNS...

    Posté par  . Évalué à 1 (+0/-0).

    Le problème venait bien des DNS de SFR. Merci à vous !
    Je les ai changé dans sur ma debian (pour ceux de google, on verra plus tard pour en mettre d'autres), mais je ne suis pas bien satisfait du résultat, ça marche et tout mais c'est plutôt casse pied de devoir changer ça sur chaque machine.
    Apparemment je ne peux pas modifier les DNS de la box (une NB6VAC) ce qui est bien dommage. Je prendrais peut être un routeur un des ces 4 si ça devient trop chiant, apperement ça se fait.
    Enfin bref merci.

    • [^] # Re: Les DNS...

      Posté par  . Évalué à 2 (+1/-0).

      J'essayerai de faire ça : https://discourse.pi-hole.net/t/how-do-i-use-pi-holes-built-in-dhcp-server-and-why-would-i-want-to/3026
      Ça m'a l'air pas mal du tout comme combine, à voir !

    • [^] # Re: Les DNS...

      Posté par  . Évalué à 3 (+1/-0).

      Installe pdns-reccursor
      Dans ton fichier /etc/resolv.conf tu mets 127.0.0.1
      Mais, si tu as un serveur DHCP, il faudrait que le server DHCP indique 127.0.0.1, ce qui va poser problème à ceux qui n'ont pas de résolveurs… (sinon, une machine de ton lan pourrait servir à ça, un pi-hole).
      Enfin, toujours le cas avec un serveur DHCP, si tu ne peux pas changer ce que dit ta box, tu dois ajouter des lignes dans la config de ton client dhcp. En changeant la ligne ou en ajoutant :

      prepend domain-name-servers 127.0.0.1;
      Bonne soirée

      • [^] # Re: Les DNS...

        Posté par  . Évalué à 3 (+1/-0). Dernière modification le 25/01/21 à 11:40.

        Sinon, les bons outils de gestion réseau permettent de surcharger ça en théorie. Je parle de théorie parce que jamais utilisé, mais ça permets d'éviter 1) d'installer un nouvel outil 2) d'être indépendant du DHCP utilisé (le wifi, c'est pour bouger…)

  • # connexion entre la box et le PC de test

    Posté par  . Évalué à 5 (+3/-0). Dernière modification le 25/01/21 à 08:05.

    les performances données ne sont pas ouf du tout, notamment le ping. tu testes comment ? tu as un cable RJ45 entre ton PC de test et ta box ? ou c'est par WiFi ?

    tu es censé avoir un ping environ de moitié, et pour le débit, plus ou moins celui qui est donné dans l'abonnement (et SFR ne propose pas de 100/100). même si il n'est pas garanti, l'expérience montre qu'on n'en est jamais loin.

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

    • [^] # Re: connexion entre la box et le PC de test

      Posté par  . Évalué à 1 (+0/-0).

      Salut, oui normalement je devrais avoir quelque chose comme 1Gb/s, comme on m'a installé la fibre samedi je pensais que ça se monterai peut être ! Mais bon j'habite dans un village j'ai été méchamment surpris d'avoir la fibre j'avais jamais eu ce débit, je m'en contenterai ^ M'enfin je demanderai au sav. Concernant le débit quasi symétrique j'ai lu que ça pouvait arriver avec les offres FTTH (fiber to the home).

  • # La réponse du sav

    Posté par  . Évalué à 1 (+0/-0).

    Alors j'ai eu le SAV, il m'ont transféré plusieurs fois, au final le dernier technicien m'a dit qu'il faisait une manœuvre technique pour régler mes PB de débit qui prendrait 24h.
    J'ai demandé, il m'a expliqué qu'il mettait à jour le DHCP de ma box.
    Je suis pas super calé en réseau mais il peut y avoir un rapport entre le DHCP et la vitesse de ma coo ? Je pensais que ça servait uniquement à obtenir une IP sur le réseau local.

    • [^] # Re: La réponse du sav

      Posté par  (site Web personnel) . Évalué à 4 (+1/-0).

      Je suis pas super calé en réseau mais il peut y avoir un rapport entre le DHCP et la vitesse de ma coo ? Je pensais que ça servait uniquement à obtenir une IP sur le réseau local.

      Et à obtenir la liste des résolveurs DNS. Peut-être a-t-il modifié la liste que le modem-routeur envoie à l'ordinateur en DHCP.

      • [^] # Re: La réponse du sav

        Posté par  . Évalué à 2 (+1/-0).

        Peut être.
        En tout cas je me sens très bête, j'ai un switch sur mon installation, je pensais que c'était un gigabyte, ben en fait non. J'ai un débit de 1Gb/s en descendant et 500 en montant en direct. J'étais sur d'avoir vérifier, je suis trop un gros gouniafier !

  • # Problème de DNS aussi, câble chez SFR

    Posté par  (site Web personnel) . Évalué à 4 (+1/-0).

    C'est curieux, j'ai rencontré un problème de DNS aussi, depuis une connexion câblée chez SFR. C'était plus spécial, ceci dit : j'utilise depuis longtemps mon propre résolveur. Et, je ne sais trop comment, les requêtes DNS qu'il faisait se retrouvaient bloquées, jetées, ou les réponses n'étaient pas transmises, bref, ça ne marchait plus du tout.

    Un redémarrage du modem-routeur, et c'est rentré dans l'ordre. Je n'aime pas ça du tout.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.