Forum Linux.debian/ubuntu empecher /etc/resolv.conf de se mettre a jour automatiquement

Posté par .
Tags : aucun
0
4
oct.
2005
Apres plusieurs heures de recherches sur "pourquoi je n'arrive pas a aller sur internet avec linux alors que windows y arrive tres bien", j'ai finalement trouvé que le dns de mon routeur était buggé. Une petite modification du resolv.conf et hop à moi la toile. Mais le probleme c'est que ce fameux fichier se remet de temps en temps a zéro avec l'adresse de mon routeur en nameserver :( .
Que dois-je donc faire pour que resolv.conf ne se modifie plus tous seul?
  • # Re: empecher /etc/resolv.conf de se mettre a jour automatiquement

    Posté par . Évalué à 1.

    On dirait bien que tu es en DHCP et que c'est ton routeur qui t'envoie tes informations pour configurer ta connexion, dont les serveurs DNS.

    Peut-être que tu as la possibilité de modifier la configuration de ton routeur pour envoyer les DNS de ton FAI à la place du routeur lui-même.

    Peut-être que ton client DHCP te permet d'ignorer tout ce qui concerne la configuration des DNS (et la modification du fichier /etc/resolv.conf).

    Peut-être modifier ton fichier /etc/resolv.conf pour avoir en même temps l'adresse IP de ton routeur et des DNS de ton FAI (bof bof comme solution).

    Peut-être en mettant le fichier /etc/resolv.conf en lecteur seule avec uniquement les DNS de ton FAI (vraiment très très moyen comme solution).

    Ou finalement, une autre solution que je ne connais pas :)
    • [^] # Re: empecher /etc/resolv.conf de se mettre a jour automatiquement

      Posté par . Évalué à 1.

      exact je suis en dhcp.

      1) en faisant ça c'est windows qui marche plus

      2) j'ai rien trouver la dessus :(

      3) solution essayée mais le resolv.conf est remis a 0 :(

      4) solution essayée également mais idem :(
      • [^] # Re: empecher /etc/resolv.conf de se mettre a jour automatiquement

        Posté par . Évalué à 4.

        Gerald a donné la solution au point 2.

        Edite ton fichier /etc/dhclient.conf, tu devrais voir une ligne commentée qui ressemble à ça :
        prepend domain-name-servers 127.0.0.1;

        Décommente cette ligne et remplace l'adresse IP par celle de ton DNS.

        Tu auras alors un /etc/resolv.conf qui ressemblera à ça :
        nameserver 127.0.0.1
        nameserver <DNS fourni par ton routeur>

        Si tu utilises supersede à la place de prepend, tu auras uniquement le DNS que tu as spécifié.

        Je te conseille de lire le man de dhclient.conf parce que j'ai pas testé ce que je viens de t'expliquer, alors peut-être que ça marchera pas du permier coup :)

        Et merci à Gerald pour la solution.
  • # /etc/network/interfaces

    Posté par . Évalué à 4.

    J'avais le même genre de souci avec la freebox qui venait changer mon resolv.conf pour mettre les dns de free alors que je voulais utiliser mon dns à moi que j'ai. J'ai fini par m'en sortir en rajoutant
    dns-nameservers <ip du dns>

    dans le fichier interfaces pour l'interface concernée par le dhcp.

    Dans ce cas là, le client dhcp va toujours modifier le resolv.conf, mais il préserve le dns que tu veux.
  • # re

    Posté par (page perso) . Évalué à 6.

    Regarde l'option supersede que tu peux mettre dans ton dhclient.conf.
    man dhclient.conf te donnera plus de détails.
  • # empecher /etc/resolv.conf de se mettre a jour

    Posté par . Évalué à 2.

    1. Quel routeur as-tu ? freebox ou autre ?
    2. Si tu utilises dhcp, quel client utilises-tu ?

    Modifie le fichier qui lance ton client en lui passant les bonnes options !

    Si tu utilises dhcpcd, regarde man dhcpcd : tu y trouveras une option qui empêche dhcpcd de modifier le fichier /etc/resolv.conf
  • # resolvconf

    Posté par (page perso) . Évalué à -1.

    Je pense que tu devrais lire la page manuel de resolvconf.
  • # reposons la question dans le bon sens.

    Posté par (page perso) . Évalué à 1.

    Pourquoi est ce que tu n est pas content quand ton PC herite des DNS offerts par ton server DHCP ?

    AMHA, tout simplement parce que le server DHCP n a jamais ete bien configure ...

    car, tout ce que tu peux mettre dans ton resolv.conf, tu peux aussi le mettre dans ton routeur.

    Si tu ne met pas a jour le server, tes amis qui viennent avec leurs portables devront tout faire a la main, alors que si tu met a jour le server, ce sera mieux pour tout le monde.

    Et si tu n a pas d amis qui ont des portables, pourquoi utilises tu un DHCP et pas un adressage fixe ?
    • [^] # Re: reposons la question dans le bon sens.

      Posté par . Évalué à 1.

      euh crois moi que c'est bien le premier truc que j'ai essayer mais une recherche sur le web m'a prouvé que mon routeur D-link 601 a un bug dans la gestion du dns.
      Quand a mes amis qui viennent avec leurs portables ils sont plutot sous windows et comme je l'avait dit ça marche bien sous windows.
      • [^] # Re: reposons la question dans le bon sens.

        Posté par (page perso) . Évalué à 1.

        une resolution DNS est la meme sous Windows et sous Linux ...

        la ou j ai eu un soucis, c est cote DHCP, ou windows 2000 trouvait mon server Linux pas assez expensif ...

        un bug dans un cache DNS qui n affecte que linux et pas win ... ca m etonne.

        Mais ca n explique pas non plus pourquoi TOI tu ne passe pas en adressage fixe ... ce qui resoudrait TRIVIALEMENT ton probleme ... apres avoir bien entendu verifie sur le server DHCP qu il ne travaille que dans une plage reduite (genre 21-199) afin qu il ne puisse pas attribuer ton IP (2<20 ou 200<253) a quelqu un d autre du reseau ... car les mix DHCP-fix mal fait, ca pete assez bien chez les autres ...

        chez moi ca marche tres bien.com
        • [^] # Re: reposons la question dans le bon sens.

          Posté par (page perso) . Évalué à 1.

          et dans Gentoo il y a un parametre qui dit de ne pas enregistrer les DNS du DHCP, mais de les forcer via ceux d un autre fichier de conf ... j ai la flemme de mater dans ma Debian si les deb recentes supportent ce truc.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.