Forum Linux.debian/ubuntu SystemD, mount NFS, comment !?.

Posté par (page perso) . Licence CC by-sa.
Tags :
1
14
juil.
2018

C'est toujours le même problème qui revient, d'une version à l'autre d'Ubuntu ou LinuxMint… C'est le problème de concourt entre le réseau et le montage NFS…

Oui, théoriquement, « 'y a qu'à » ajouter l'option _netdev Sauf que non, ça suffit pas.

C'est à dire qu'une fois le système démarré, authentification faite, le dossier n'est pas monté ! J'ouvre un terminal et en root, la commande # mount -a fonctionne alors directement, le dossier est monté.

J'ai remplacé la ligne suivante du fstab :

monserveur:/donnees/reseau /donnees/reseau nfs user,rsize=4096,wsize=4096,hard,intr,_netdev 0 0
Par une unité systemd, fichier /etc/systemd/system/donnees-reseau.mount

[Unit]
Description=Donnees reseau sur Armanoid
After=network.target

[Mount]
What=monserveur:/donnees/reseau
Where=/donnees/reseau
Type=nfs
Options=_netdev,auto,exec,hard,intr,rsize=4096,wsize=4096

[Install]
WantedBy=multi-user.target

Hé ben, ça ne fonctionne toujours pas :(

Au démarrage, authentification, le dossier n'est pas monté et je dois dans un terminal exécuter la commande # systemctl start donnees-reseau-unionfs.mount ; le dossier est alors monté.

Pourquoi ?
La ligne After=network.target ne suffit-elle pas ?
Que puis-je ajouter ?
Ou alors, par quoi pourrais-je remplacer WantedBy=multi-user.target pour que cela se fasse juste un peut plus tard ? Car j'imagine qu'il y a un mauvait concourt de circonstance…

Où et comment puis-je voir les messages d'erreur suite à la considération automatique de mon unité systemd ?

Merci d'avance.

  • # Retire le fichier mount

    Posté par . Évalué à 1.

    Salut,

    J'ai essayé sous debian de gérer des fichiers .mount, mais ça marche pas bien. Le mieux c'est d'ajouter automount dans les options (à vérifier) dans ton fstab : si le montage ne démarre pas au démarrage, il démare quand tu essaies d'aller dessus… C'est encore mieux !

    Le _netdev reste nécessaire !

    Courage !

  • # autofs

    Posté par . Évalué à 1.

    Et utiliser autofs a la place de fstab ça serait pas mieux ? Ça fait 4 ans que j'ai remplacé fstab et gfvs par autofs et je reviendrai pas en arrière. Ceci dit utilisé pour un montage smb seulement, pas testé NFS.

  • # bg/autofs/bug

    Posté par . Évalué à 1.

    Bonjour,
    Je voie 3 options possibles:

    • il y a une option "bg" pour un mount en nfs, je l'utilise sans problème et ça devrait fonctionner aussi dans ton cas à la place de "_netdev";

    • comme suggéré par thierrybo ci-dessus; cela fonctionne parfaitement pour moi (et pas de problème a attendre avec NFS, cela a été prévu pour à la base);

    • quand tu dis que le problème reviens à chaque version, je me pose la question: as-tu pensé a signaler le bug à la distribution? Si ça n'est pas le cas, c'est plutôt normal qu'il revienne. Si tu l'as signalé, effectivement, va falloir partir sur un plan B…

    Sinon, pour l'option "_netdev", elle demande au système de ne pas monter le filesystem maintenant, mais y a-t'il bien, plus tard, le "mount -a" qui va faire les montages complémentaires?
    De mon côté (debian), je voie que le "mount -a" dans /etc/init.d/mountall.sh filtre déjà nfs, donc pas besoin de de rajouter _netdev. Mais je ne connais pas la procédure de démarrage précisément, c'est juste une hypothèse.

  • # After ne suffit pas

    Posté par . Évalué à 3.

    Non, After ne suffit pas, d'après la documentation de systemd (man systemd.unit), Before et After servent à déterminer l'ordre de démarrage quand les unités sont démarrées en même temps, mais c'est orthogonal avec les dépendance.
    Puisque ton unité à besoin du réseau pour fonctionner, il faut ajouter aussi un Requires.

    En plus de ça, ce n'est pas network.target que tu dois viser, mais plutôt network.service (ou autre nom du service qui démarre vraiment le réseau).

  • # Les montages n'ont jamais bien marché

    Posté par (page perso) . Évalué à 1. Dernière modification le 15/07/18 à 21:56.

    C'est fou, depuis que GNU/Linux existe, j'ai aussi toujours rencontré des soucis avec les clés USB, avec VirtualBox, avec les dossiers partagés avec Windows (là, c'est le pire) ou entre postes GNU/Linux. NFS plante, Samba est une horreur à paramétrer.
    Sur ce point, Windows est largement plus simple et fiable.

    • [^] # Re: Les montages n'ont jamais bien marché

      Posté par . Évalué à 1.

      non pas moi: uniquement des bugs avec NFS et souvent c'était due a des versions differentes du protocol. Par contre oui, le démarrage auto de NFS est casse tete.
      Par contre, Les clés usb montent niquel depuis un bout de temps déjà sous linux (meme debian stable :) ). Accéder à des partages windows (les rares fois où j'en ai eu besoin) ne m'a jamais parus compliqué depuis une machine linux (tant qu'on a un login/mot de passe).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.