Forum Linux.débutant Install sur Lenovo

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
23
nov.
2018

Bonjour,

Je tente d'installer Ubuntu sur les PC portable Lenovo (X220i & S230u) sous Win 8 en vu d'une formation.

Au niveau Bios, j'ai bien mis USB HDD en premier mais aucune de mes clefs n'a l'air d’être reconnu …

Le Bios est particulier et j'ai l'impression que Windows en fait ce qu'il veut.

Quelqu'un a déjà rencontré ce genre de chose ?

Merci d'avance.

  • # Secureboot ?

    Posté par  . Évalué à 2.

    Verifie dans la config du bios si il y une option secureboot
    si c'est le cas il faut la désactiver pour que ton disque usb soit effectivement reconnu

    Ce commentaire passe-t-il les trois tamis de Socrate ? -- https://linuxfr.org/suivi/autoriser-la-correction-limitee-de-commentaires-apres-les-5min

    • [^] # Re: Secureboot ?

      Posté par  . Évalué à 1.

      Je n'ai vu nulle part de mention de SecureBoot…

      J'ai ouvert plein de choses, au point ou ça peut devenir dangereux, je trouve.
      USB UEFI BIOS support : Enabled
      Always On USB : Enabled
      Always On USB Charge on Off Mode : Disabled
      Security Chip : Inactive
      Flash BIOS Updating by End-Users : Enabled
      Flash Over LAN : Enabled
      Memory protection, Execution Prevention : Disnabled
      UEFI/Legacy Boot : Legacy Only
      Boot Mode : Quick

    • [^] # Re: Secureboot ?

      Posté par  . Évalué à 1. Dernière modification le 23/11/18 à 11:08.

      oups

      • [^] # Re: Secureboot ?

        Posté par  . Évalué à 1.

        Sur le 2eme Lenovo, il y a l'option mais même Desabled, ça ne boot pas sur la clef …

        • [^] # Re: Secureboot ?

          Posté par  . Évalué à 2.

          De mémoire, il faut désactiver le SecureBoot et activer le legacy boot comme avec cette option que tu cites:

          UEFI/Legacy Boot : Legacy Only

          ensuite il doit y avoir un moyen d'accéder à un menu de boot du bios qui te permet de choisir sur quel disque tu veux booter en appuyant sur une touche F?? juste après le démarrage. Ça doit être indiqué sur l'écran de boot

          Ce commentaire passe-t-il les trois tamis de Socrate ? -- https://linuxfr.org/suivi/autoriser-la-correction-limitee-de-commentaires-apres-les-5min

          • [^] # Re: Secureboot ?

            Posté par  . Évalué à 1.

            Apres différents essais de modifications dans le Boot, j'arrive enfin a avoir la clef USB dans la liste des périphériques accessibles depuis la touche F12.
            Ubuntu se lance depuis la clef.
            Mais …. et oui, je crois que je vais passer par toutes les étapes … "Unable to find a medium containing a live file system"….

  • # des questions betes, mais parfois ca aide

    Posté par  . Évalué à 3. Dernière modification le 23/11/18 à 14:29.

    ta clef USB ubuntu, tu l'as obtenue/faite comment ?

    ton PC est réglé pour booter en mode "Legacy" (BIOS), mais ubuntu sait maintenant booter en mode "UEFI", il faut juste desactiver le secureboot.

    du coup si ta clef est bien faite, mais en UEFI, et que le PC cherche à demarrer uniquement en mode 'BIOS' (reglage LEGACY ONLY dans ton BIOS) alors la clef ne sera jamais vue

    ensuite il y a surement une touche pour changer le peripherique de demarrage, sans chercher le reglage dans le bios, parfois c'est F8 ou F12, ca depend des constructeurs

    de là tu selectionnes la clef USB qui devrait apparaitre (à condition de l'avoir branchée AVANT demarrer le PC)

  • # Créateur de clé

    Posté par  (site Web personnel) . Évalué à 2.

    Tu as créé ta clé comment? Tu peux essayer de la refaire en utilisant une autre méthode (Rufus, dd, "Créateur de clé USB", unetbootin…)

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # Pb ?

    Posté par  . Évalué à 2. Dernière modification le 25/11/18 à 09:47.

    X220 :

    a) Bios SETUP = remettre toutes les valeurs par défaut, rebooter
    b) Bios SETUP = désactiver secureboot
    c) Booter sur la clef usb contenant Fedora / CentOS / Ubuntu / Debian, ce que tu veux

    Si c) ne fonctionne pas tel que tu le décris plus haut, alors c'est bien probablement un pb avec la clef car : le bioss accepte de lancer le bootloader dessus (= ta clef est bien uefi) et le bootloader dessus charge le noyau, qui lui même boot correctement, puis c'est l'étape du changement de partition racine qui ne se fait pas (le moment où la racine du micro système contenu dans l'initrd/init-ramFS est passée puis abandonnée pour passer sur la racine du système). C'est peut être un problème avec le live de ubuntu mais plus probablement un pb lors de la création de la clef. Rien de grave, toutes les distros bootent dessus depuis longtemps.

    Concernant les points a) et b), j'attire ton attention vers ça :

    • The X220 cannot/will not boot GPT disks using Legacy BIOS, you must setup UEFI. (ce modèle ne boot pas sur un disque GPT avec le bios legacy, il FAUT mettre UEFI)
    • The X220 will not boot /efi//.efi unless "signed"(?) into BIOS, you have to copy it to /efi/boot/bootx64.efi. (ce modèle ne boot pas le bootx64.efi s'il n'est pas signé, il faut le copier à la main) Ajout perso : désactiver le secureboot devrait suffire
    • Disabling the BIOS setting "USB UEFI BIOS Support" disables all USB booting, ie, both UEFI and legacy BIOS. (ne PAS désactiver 'usb uefis bios support', sinon plus rien en usb ne boot ni en uefi ni en legacy)

    De référence. Avec laquelle on apprends aussi que le BIOS limite artificiellement la vitesse de la RAM, mais également cantonne le port SATA à du SATA-1 alors que c'est du SATA-2, qu'il y a une limitation sur le port M2 … Bref, perso je virerai cette gr**** b***e pour mettre un coreboot.

    muny@twitter.com

    • [^] # Re: Pb ?

      Posté par  . Évalué à 2.

      En plus coreboot est OK sur ce modèle x200i (tuto étape par étape) et on peut même neutraliser l'Intel MEI.
      Cool.

      c'est hors sujet avec ta question, juste un complément à mon précédent commentaire. :p

      muny@twitter.com

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.