Forum Linux.général connecter 2 pc en ethernet

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
27
juin
2017

Bonjour,

j'ai besoin de connecter deux systèmes linux par ethernet (pour que le premier, utilisant uboot, aille chercher son système sur le second, qui contient un serveur nfs+tftp).
Je n'ai pas de switch à disposition, je n'ai pas de cable croisé, mais il me semble qu'il est possible de faire une connexion directe avec un cable ethernet classique. Mes questions sont donc les suivantes, avec un cable ethernet classique:

1- comment vérifier que je peux faire cette connexion sans cable croisé?
2- comment configurer les connexions ?
j'ai essayé sur mon serveur:

ifconfig enp0s25 192.168.1.2 netmask 255.255.255.0

et sur ma mini-machine:

ifconfig eth0 192.168.1.1 netmask 255.255.255.0

Cela ne fonctionne pas (un simple ping ne répond rien, la phase de boot encore moins). Est-ce un problème de passerelle? Comment faire la connexion?

Merci pour votre aide

  • # =>câble croisé

    Posté par  (site Web personnel) . Évalué à 2.

    A ma connaissance, il faut un câble croisé. Seuls certains switch reconnaissent les câbles croisés ou pas.

    • [^] # Re: =>câble croisé

      Posté par  . Évalué à 1. Dernière modification le 27/06/17 à 19:42.

      Seuls certains switch reconnaissent les câbles croisés ou pas.

      Je viens de checker sur LDLC et même les switch les moins chers (-10€) sont en auto MDI-I/MDI-X.

      Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

  • # Il te semble mal ....

    Posté par  . Évalué à 0.

    il me semble qu'il est possible de faire une connexion directe avec un cable ethernet classique.

    Peut-être que c'est possibles avec certaines cartes, maispour ma part je n'en ai jamais rencontré.

    • [^] # Re: Il te semble mal ....

      Posté par  . Évalué à 8. Dernière modification le 27/06/17 à 18:52.

      Au contraire, chez moi, ça fait bien longtemps que ça marche et que je n'ai plus eu à avoir recours à un câble croisé. En fait, il suffit qu'un seul des points de terminaison soit capable de se « retourner ». Et généralement, à moins d'avoir un produit d'entrée de gamme, les puces Ethernet des cartes-mères sont capables de le faire seul.

  • # MDI-X

    Posté par  . Évalué à 3.

    Pour cela, il faut que au moins un de tes serveurs aie un port Ethernet qui supporte le MDI-X et qu'il ne soit pas désactivé dans le bios.
    Le problème est que ce n'est pas toujours clairement indiqué.

  • # parce que c'est possiblement un peu plus compliqué

    Posté par  . Évalué à 4.

    pour que le premier, utilisant uboot, aille chercher son système sur le second, qui contient un serveur nfs+tftp.

    il te faut donc un serveur TFTP configurer pour repondre au requete TFTP du client

    dans mon cas, je regardes les tutos pour faire du boot PXE, qui explique comment monter :
    1°) un serveur DHCP à qui ont dit ou aller pour faire du PXE
    2°) un serveur PXE/TFTP qui va repondre avec un noyau minimaliste et des fichiers de configs pour faire un multiboot
    3°) dans les menus du multiboot, lui dire quel noyau il va booter et comment il accede à son systeme (via NFS dans ton cas)

    maintenant si tes deux machines ont deja demarré et que tu configure le reseau, alors cela devrait fonctionner,
    car les machines recentes (ton serveur) sont capables de faire du MDI-X et donc de croiser le cable elles-meme.

  • # c'est quoi cette interface :

    Posté par  . Évalué à 3.

    enp0s25

    après le ping suivant ton parfeu, il peu ne pas passer

    moi je regarde :

    RX packets:164351133 errors:0 dropped:0 overruns:0 frame:0
    TX packets:160700102 errors:0 dropped:0 overruns:0 carrier:0
    qui peut donner une indication, et aussi les leds sur le connecteurs reseau pour au moins valider que le cable est bon.

  • # bilan

    Posté par  . Évalué à 1.

    Merci pour vos commentaires. Effectivement, ce mode MDI-X n'est pas présent sur toute les cartes réseau, et notamment la mienne (en tous cas, je n'ai pas trouvé l'option dans le bios).

    Avec un cable croisé, ça marche simplement avec la configuration mentionnée dans ma question.

    merci encore

    • [^] # Re: bilan

      Posté par  . Évalué à 2.

      Merci pour vos commentaires. Effectivement, ce mode MDI-X n'est pas présent sur toute les cartes réseau, et notamment la mienne (en tous cas, je n'ai pas trouvé l'option dans le bios).

      le MDI-X n'est pas une option du bios, c'est une capacité physique de la carte reseau
      si la machine ou la carte est trop vieille, c'est simplement pas disponible et il te faut mettre un switch entre les deux machines

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.