Forum Linux.général Probleme wifi

Posté par  . Licence CC By‑SA.
Étiquettes :
1
19
juil.
2017

Bonjour !

Débutante, je suis face un problème que je n'arrive pas à résoudre.
J'ai installé Linux Mint sur mon ordi.
Pendant l'installation, ma clé wifi, une Belkin n300 est bien reconnue, et toute l'installation se fait sans soucis, aucune déconnexion.
Mais une fois le système installé, au reboot, ma connexion ne dure que dix minute et je dois redémarrer. Pourtant, le symbole de connexion apparaît bien en das en droite…
Comment se fait-il que ma connexion se perde comme ça et que faire pour régler ce problème ?

Merci et bonne journée

  • # Mystère

    Posté par  (site Web personnel) . Évalué à 3.

    Pourquoi redémarrer ? On n'est pas sous Windows, en principe, redémarrer seulement le démon réseau devrait suffire. Mais ça n'enlève pas la question de pourquoi ça se déconnecte au bout de 10 minutes.

    • [^] # Re: Mystère

      Posté par  . Évalué à 1.

      Sous Windows, il n'y a pas besoin de redémarrer non plus.

      Non seulement, il y un service associé au réseau, et on peut désactiver/réactiver la carte réseau, mais en plus le problème ne se serait certainement pas produit en premier lieu.

      Hop, moi.

      -----> []

      "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

    • [^] # Re: Mystère

      Posté par  . Évalué à 1.

      Je sais bien qu'on n'est pas sous Windows..Je me suis peut être mal expliquée. Mon wifi fonctionne très bien pendant l'installation,donc ma clé est très bien reconnue, et aucune coupure. Puis a des déconnections lors de la première utilisation de linux…

  • # drivers

    Posté par  (site Web personnel) . Évalué à 1.

    Les drivers installés sont-ils les même que ceux utilisé durant l'installation ?
    Moi, pour Mint, j'avais beau tout configurer avant l'installation, une fois l'installation faite, c'était retour à zéro …

    Essaie pour vivre sans brider les utilisateurs https://www.indiegogo.com/projects/iwinote

    • [^] # Re: drivers

      Posté par  . Évalué à 1.

      Et tu as trouvé quelle solution ?

  • # Firmware

    Posté par  . Évalué à 2.

    Salut,
    À vue de pif, ça ressemble à un souci de firmware.

    Tu peux essayer de lancer les commandes suivantes:

    sudo apt-get update
    sudo apt-get install linux-firmware linux-firmware-nonfree

    Avec un peu de bol, ta connection wifi devrait fonctionner après ça

    • [^] # Re: Firmware

      Posté par  (site Web personnel) . Évalué à 2.

      Alors pourquoi ça marche pendant 10min et hop le pilote s'envole !

      « Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes. »

      • [^] # Re: Firmware

        Posté par  . Évalué à 2.

        Parce que les chips Realtek sont taquins ! ;-)

        • [^] # Re: Firmware

          Posté par  . Évalué à 2.

          Tu est bien gentil avec eux.

        • [^] # Re: Firmware

          Posté par  . Évalué à 3.

          C'est effectivement fréquent avec certaines puces Realtek. Ceci peut aider : https://wiki.debian.org/fr/rtl819x#D.2BAOk-pannage à condition de connaître le pilote utilisé par linux.

          • [^] # Re: Firmware

            Posté par  . Évalué à 2.

            Malheureusement ça ne suffit pas dès fois. J'ai eu exactement le même problème. Rien à l'install et des problèmes après. Le puce du portable, je n'ai jamais réussi à la faire tenir plus de 5min. Avec une clé chipset realtek, j'obtiens ~ 20min avec ces bidouilles. Il suffit de la reconnecter au réseau pour repartir. J'ai remarqué qu'avec un flux continu ( ping par exemple ), ça tient mieux. Avec une autre clé sans realtek, pas de soucis.

            J'avais dans l'idée d'aller voir les paramètres de l'installateur et voir les différences de paramètres. Ça me prendra peut-être un soir.

  • # Box

    Posté par  . Évalué à 6.

    Est ce que ta box est configurée pour rester sur le même canal ou pour chercher le meilleur disponible ? Dans le 2e cas, passer sur un canal fixe.

    • [^] # Re: Box

      Posté par  . Évalué à 7.

      Ouiiiii ! Oufff ! Un passage du 11 au 7….et la magie a opéré ! Merci à ceux qui ont pris le temps de me répondre

      • [^] # Re: Box

        Posté par  . Évalué à 2. Dernière modification le 21/07/17 à 01:10.

        C'est très courant si tu es dans un immeuble ou simplement en ville avec une forte concentration de réseaux wifi. Les canaux 1 et 13 sont les meilleurs spots pour éviter les perturbations avec les voisins.

        Au final tu t'en sors bien, le wifi est toujours délicat sur GNU/Linux même avec des pilotes libres. C'est ma hantise.

        • [^] # Re: Box

          Posté par  . Évalué à 2.

          Merci pour les infos, j'ai appris plein de trucs sympas (et notamment la raison probable pour laquelle mon µ-onde faisait planter le wifi dans mon dernier appart).

          Ceci dit, l'info que je retiens surtout, c'est qu'il faut garder 3 canaux libres entre les canaux déjà utilisés et celui que l'on veut utiliser pour des perfs maximale, et si on ne peux pas, utiliser le canal le moins utilisé.
          DU coup, reste à savoir comment savoir quels canaux sont utilisés. En ligne de commande, iw list | less fait le taf (me semble juste qu'il ne faut être connecté à aucun réseau pour que la commande fonctionne), je ne sais pas si les outils graphiques le font.

          • [^] # Re: Box

            Posté par  . Évalué à 1.

            notamment la raison probable pour laquelle mon µ-onde faisait planter le wifi dans mon dernier appart

            Et oui, les micro-ondes ne sont pas des cages de Farraday parfaites. C'est aussi la raison pour laquelle on dit que laisser son téléphone dans sa poche de pantalon peut rendre stérile à long terme.

            je ne sais pas si les outils graphiques le font.

            wicd-gtk et wicd-curse le font donc j'imagine qu'ils le font tous :)

            • [^] # Re: Box

              Posté par  . Évalué à 2.

              laisser son téléphone dans sa poche de pantalon peut rendre stérile à long terme.

              Sauf si c'est un monsieur équipé de c******* en plomb :p (souvenir d'une vieille chanson de gamin)

          • [^] # Re: Box

            Posté par  . Évalué à 4.

            DU coup, reste à savoir comment savoir quels canaux sont utilisés. En ligne de commande, iw list | less fait le taf (me semble juste qu'il ne faut être connecté à aucun réseau pour que la commande fonctionne), je ne sais pas si les outils graphiques le font.

            Il me semble que par principe il suffit d’observer sur quels canaux sont les AP dont on capte le mieux le signal, donc qui sont grosso modo les AP les plus proches, et s’écarter de ces bandes-là. Donc n’importe quel « scanner wifi » devrait faire l’affaire.

  • # infos complémentaires

    Posté par  . Évalué à 4.

    • lspci et lsusb permettront de lister le matériel installé sur ta machine avec leurs identifiants
    • dmesg -T permet d'avoir des informations issues du noyau.
    • lsmod permet de voir quels sont les pilotes noyaux installés

    bonne introspection a toi.

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.