Forum Linux.général [Résolu] Calibrer l'interface tactile d'un second écran tactile

Posté par  . Licence CC By‑SA.
0
12
nov.
2020

Bonjour à tous,

J'ai branché un écran tactile à mon pc portable sous fedora 32 avec xfce comme bureau.

Cela se passe plus ou moins correctement si ce n'est que l'ordinateur considère que l'écran tactile à la taille des deux écrans.

En d'autres mots, au niveau vertical, le pointeur se place effectivement à la hauteur à laquelle on touche l'écran. En horizontal par contre, d'un côté tout au bord, le curseur se met bien à l'endroit où l'écran est touché mais si on s'éloigne de ce bord là, le curseur va bien plus vite et se retrouve en buté sur l'écran non tactile quand on arrive au bout de l'écran tactile.

Des pistes de solutions ?

  • # Drivers spécifiques

    Posté par  . Évalué à 4 (+2/-0).

    Ça ressemble bcp à un pb que ma fille a eu après avoir branché un XP-Pen Pro 15.6

    En mettant les drivers qui justement permettent de régler la portée du tactile, ça a résolu le pb (https://www.xp-pen.com/faq-56-210.html).

    Cela dit, je doute que les drivers gèrent le tactile directement, ils doivent faire un réglage précis sur le window manager. Peut-être que la doc Archlinux pourrait t'aider ? https://wiki.archlinux.org/index.php/touchscreen#Using_a_touchscreen_in_a_multi-head_setup

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

    • [^] # Re: Drivers spécifiques

      Posté par  . Évalué à 3 (+1/-0).

      La doc Archlinux donne effectivement la solution.

      Il faut juste savoir que xinput_calibrator n'a pas à être installé sur Fedora 32, la commande xinput est déjà disponible.

      Surtout, ne pas tout prendre au sérieux !

  • # Xinput

    Posté par  (site Web personnel) . Évalué à 3 (+1/-0).

    A priori, tous ces réglages sont maintenant accessibles via Xinput, avec la ligne de commande correspondante « xinput ».

    « xinput list » liste les périphériques d’entrée branchés (dont normalement les écrans tactiles). Ensuite, la commande « xinput --map-to-output $device $crtc » permet d’associer un périphérique d’entrée à un écran.

    Par exemple, chez moi, avec ma tablette XP-pen (en enlevant des lignes inutiles), la commande « xinput ⋄ retourne :

    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    […]
    ⎜ ↳ UGTABLET 10 inch PenTablet Mouse id=20 [slave pointer (2)]
    ⎜ ↳ UGTABLET 10 inch PenTablet Pen (0) id=21 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    […]

    Mes écrans, avec la commande « xrandr » :

    Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
    eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
    1920x1080 60.05*+ 60.01 59.97 59.96 59.93 48.04

    […]
    DP-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    1024x768 60.00*
    […]

    Ainsi mon stylo sur la tablette correspond ici au $device 21 (attention, ça peut changer en fonction de l’ordre de branchement des périphériques). Donc pour l’associer à mon deuxième écran ($crtc DP-1), j’utilise la commande : « xinput --map-to-output 21 DP-1 ».

    Et voilà !

    En lisant les manuels et ou en fouillant dans un moteur de recherche, tu trouveras même les bonnes options à passer à xrandr et xinput pour faire un one-liner qui résout ton problème.

    Bon week-end.

    • [^] # Re: Xinput

      Posté par  . Évalué à 2 (+0/-0).

      Yeah, ça marche !

      Enfin, pas encore essayé le one-liner mais au moins, je peux utiliser mon écran tactile un peu plus facilement et complètement.

      Merci !

      Surtout, ne pas tout prendre au sérieux !

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.