Forum Linux.redhat Bug WTF d'audio HDMI avec Firefox et Radeon, vous pouvez le reproduire aussi ?

Posté par . Licence CC by-sa.
4
26
août
2018

Salut à tous,

De temps en temps, le son joué sur mon PC (carte Radeon branchée en HDMI sur ma TV) devenait complètement grésillé, métallique et avec un léger décalage (genre le son continue à être joué pendant encore une demi-seconde après coupure du logiciel de lecture), donc complètement inaudible quoi. La seul moyen de corriger le bug est de rebooter le PC.

Ça pouvait survenir aléatoirement.

Puis un jour je me suis rendu d'un truc. J'arrivais à reproduire systématiquement le bug en… activant le mode lecture de Firefox ! Allez comprendre le rapport ! Enfin si, aujourd'hui les navigateurs font appels au GPU, donc j'imagine qu'en activant ce mode lecture, Firefox mets le doigt sur un truc bugué dans la partie Radeon avec un effet de bord sur l'audio ?

Vu que c'est facile à tester, j'aurais aimé savoir si vous arriviez à le reproduire aussi ?
Sachant que voilà ma config actuelle :
- Radeon RX 570
- Sortie audio en HDMI depuis la carte Radeon
- Fedora 28 (+ kernel avec option "amdgpu.dc=1" pour avoir l'audio HDMI activé)
- Firefox 61

Procédure de test :
- Lancer une lecture audio (depuis un onglet de Firefox ou de VLC)
- Ouvrir un nouvel onglet et passer en mode lecture de Firefox (icône à droite dans la barre d'URL)
- Le son grésille maintenant ?

  • # test

    Posté par (page perso) . Évalué à 5.

    J'ai lancé une vidéo youtube, ouvert un autre onglet sur le blog de mozilla pour avoir le mode lecture et le son est toujours bon.
    La procédure est bonne ?

    Ma config :
    - Radeon HD 5450 avec driver libre
    - Sortie audio en HDMI via pulseaudio (vers ampli)
    - Ubuntu 18.04
    - Firefox 61

    S'il y a un problème, il y a une solution; s'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

    • [^] # Re: test

      Posté par . Évalué à 4. Dernière modification le 26/08/18 à 21:39.

      Oui c'est bien la bonne procédure.

      Du coup ça me laisse penser que ça doit plutôt uniquement se produire sur les cartes qui utilise le framework AMD DC/DAL pour l'audio sur HDMI. Autrement dit uniquement les Radeon depuis GCN v3 (Volcanic Island) (càd les R9 285, R9 380, R9 Fury, RX 400/500).

      Merci pour ton retour.

  • # bug pulseaudio amdgpu

    Posté par . Évalué à 5. Dernière modification le 27/08/18 à 02:47.

    Salut

    J'ai le même problème depuis des mois sur ma config.
    Par contre j'utilise le circuit audio intégré de ma carte mère (en jack)

    Pour "régler le problème" sans rebooter, je kill pulseaudio (-k) et le relance (--start) en console

    Ma config
    -Fedora 28 (vanilla + rpmfusion free/nonfree)
    -Radeon Vega 56 (amdgpu obligatoire)
    -Gigabyte GA-AX370-Gaming 5 avec Realtek ALC1220

    Je vais tester en désactivant la sortie audio DP (que mon écran n'utilise pas).

    • [^] # Re: bug pulseaudio amdgpu

      Posté par . Évalué à 4.

      Ah moi j'ai pas le soucis avec la puce Realtek de ma carte mère. Quand le son HDMI de ma Radeon devient grésillant, si je bascule la sortie audio sur mon casque branché en jack sur ma carte mère, le son est propre.

  • # idem

    Posté par . Évalué à 4.

    Même problème avec une RX 560 depuis des mois, je n'avais jamais fais le rapprochement, bravo ^

    • [^] # Re: idem

      Posté par . Évalué à 3.

      Merci beaucoup de ton retour !
      Tu es sur quel OS ?

      • [^] # Re: idem

        Posté par . Évalué à 2.

        fedora 28, dernier kernel sans aucune modification dans les options mais avec des enceintes reliées en jack sur la cm GIGABYTE AB350-GAMING 3

        • [^] # Re: idem

          Posté par . Évalué à 3.

          Ah mais donc il n'y a pas de rapport avec le HDMI ni avec la Radeon dans ton cas ?!

          • [^] # Re: idem

            Posté par . Évalué à 2.

            @WhiteCat quel est votre carte mère ? du AMD ? Ryzen ?

            • [^] # Re: idem

              Posté par . Évalué à 2.

              Non c'est du Intel Sandy Bridge (i5-2500K).

              • [^] # Re: idem

                Posté par . Évalué à 3.

                Je viens de tester l'ajout "tsched=0" dans le fichier de conf pulseaudio (https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1716654/comments/7)

                Pour le moment j'ai plus le problème présent, mais dans les commentaire suivant, il n'avait pas l'avoir d'avoir résolu le problème.

                • [^] # Re: idem

                  Posté par . Évalué à 2. Dernière modification le 27/08/18 à 21:42.

                  Je viens d'essayer et en effet j'ai plus le problème avec cette option.

                • [^] # Re: idem

                  Posté par . Évalué à 2.

                  Idem, ça a résolu le problème, un grand merci !

                  Par contre j'ai un drôle d'alignement des étoiles avec un magnifique reboot sauvage au premier essai au moment où j'ai validé mon :wq - abrt me signale une erreur kernel-core sans aucune trace exploitable…

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.