Sortie de Mplayer 0.90-pre10

Posté par (page perso) . Modéré par Pascal Terjan.
Tags :
0
11
nov.
2002
Audiovisuel
A l'occasion du 2ème anniversaire de Mplayer, voici une nouvelle release. Au menu du Changelog, on pourra noter le portage pour GNU/Hurd, un kilo de bugfixes, l'apparition de filtres divers et variés, enfin bref que du bon, comme d'habitude. Le détail du CHANGELOG:

Docs:
* sections dvd auth, vcd étendues (DOCS/cd-dvd.html)
* sections *BSD unifiées, cygwin étendue

Correctifs:
* message d'erreur LIRC (Error while reading cmd fd X : Success) corrigé
* lecture de divx (streaming ?) corrigée, démarrage avec des non-I frames.
* -vo png corrigé (suppression du support natif YV12 support, suppresion de l'OSD)
* quelques segfaults sur des .mp3 corrigés
* colorkey du vidix mach64 sur PPC corrigée
* -ao sdl gère maintenant des cartes son "featureless"
* -vo zr corrigé
* sig11 si vo init manqué corrigé
* divers corrigés dxr2 and dxr3
* buffering v4l corrigé
* correction de lectures multiples (mjpeg.c, mach64_vid.c)
* nettoyage du code de postprocessing - maintenant, il est threadsafe
* portage pour GNU/Hurd
* nettoyage de la gestion des AVI pts (timestamp)
* nettoyage du code de sync A-V - utilisation de timers relatifs au lieu d'absolus
* nettoyage du code de la GUI
* pas mal de bugfixes, notamment d'endianess
* mencoder: option -pass supprimée, utiliser -divx4opts pass=N / -lavcopts vpass=N
* mencoder: "ff_rate_estimate_qscale: Assertion `q>0.0' failed" corrigé !
* mencoder: -ovc xvid correctifs, améliorations
* réactivation du screensaver/dpms corrigés
* correctifs du démultiplexeur realvideo

Fonctionnalités:
* -ao win32 (pour le port Win32)
* libavcodec: décodage natif WMA v1/v2
* accélération hardware pour -vo x11 et gl2
* support du format de sous-titres jacosub (*.js)
* -vo dxr3 : nouveau "syncengine", ':sync', support de l'overlay natif, activer avec ':overlay'
* support QDMC/QDM2/MACE, en utilisant les DLLs Win32 QuickTime 5 (libwine!)
* libavcodec: correctifs divers
* améliotations mencvcd, support sox/toolame
* -vo dfbmga - lire une vidéosur le second head de la Matrox G400 avec direcfb
* support RealAudio ATRC (sony atrac3)

Filtres:
* nettoyage des options -af/-af-adv
* insertion automatique de -vop lavc
* API des filtres vidéo documentée
* meilleur filtre de débloquage (-vop pp), syntaxe pp/npp changée
* -vop 2xsai - 2x pour les images animées (cartoons avec peu de couleurs)
* -vop unsharp - filtre de blur, joli mais lent
* -vop il - désentrelacement
* -vop swapuv - devinez
* -vop boxblur - box blur...
* -vop perpective
* -vop sab
* -vop smartblur

Aller plus loin

  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par . Évalué à 10.

    * libavcodec: native WMA v1/v2 (aka. DivX audio) decoder

    Autrement dit : on peut enfin se passer des .dll win32 pour décoder le WMA. Et donc c'est la première fois qu'on a un décodeur WMA qui passe sur plateformes non x86. C'est une première !

    Comme le dit l'auteur sur le site du projet : "La vitesse du décodeur est équivalente à celui de windows, mais il faut maintenant l'optimiser"...

    Bref, c'est pratique pour enfin pouvoir écouter des radios en lignes sur autre chose que des PCs.
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à -1.

      ça fait un certain temps déjà, qui est là ;)
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 4.

      Chez moi, il lui faut toujours les dll de merde. Y a une manipe spéciale à faire pour utiliser le lecteur libre ?
      • [^] # Re: Sortie de Mplayer 0.90-pre10

        Posté par . Évalué à 2.

        chez moi il utilise bien libavcodec, mais ça marche pas: j'écoute ouifm pendant 30 secondes, et ensuite *couic* fini plus rien :-((
        il continue de mettre en mémoire tampon par contre.. là j'en suis à 5659 % et ça augmente...
        par contre gmplayer commence a être vraiment bien utilisable, c cool !
  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par . Évalué à -1.

    Je cite: "un kilo de bugfixes".
    T'as voulu faire un troll, avoue ! Ta référence croisée douteuse entre Hurd et Kilobug, tu croirais que personne la verrait, hein ? Petit coquin, va !

    [j'ai trop honte, mais je peux pas me mettre "-1"]
  • # gui toujours casse chez moi

    Posté par (page perso) . Évalué à 3.

    J'ai toujours le meme probleme avec le GUI....

    Il ouvre une video dans une seconde fenetre et ca bloque le GUI. Un gmplayer avec une fenetre noir et une avec la video....

    Quelqu'un a le meme probleme? (j'ai compile avec DEB_BUILD_OPTIONS="--enable-streaming" fakeroot debian/rules binary comme indique dans la doc)
    • [^] # Re: gui toujours casse chez moi

      Posté par . Évalué à 3.

      Chez moi sous noyau 2.4.18, XFree 4.2.0 et GTK 1.2.10 (en fait bureau KDE 3), pas de souci avec le GUI.
      Mon configure est le suivant :
      ./configure --enable-gui --disable-lirc --disable-tv --disable-mpdvdkit
      En fait les 3 dernières options sont là pour enlever des warnings et j'ai pas de DVD. Par contre la compil échoue et je dois corriger une ligne dans Gui/mplayer/mw.h (leurs #ifdef sont pas toujours bien placés j'ai remarqué).

      A chaque nouvelle version de mplayer, je renomme mon ancien répertoire ~/.mplayer et éventuellement je recopie mes anciens fichiers (police, skin) vers le nouveau répertoire. C'est presque obligatoire de fonctionner comme ça car le fichier codecs.conf change souvent, et c'est plus propre de toutes façons.
      • [^] # Re: gui toujours casse chez moi

        Posté par (page perso) . Évalué à 0.

        Mon dieu. Pour le codecs.conf, soit tu fais un lien, généralement ln -s /etc/mplayer/codecs.conf ~/.mplayer/codecs.conf soit tu ne mets pas le fichiers dans ton répertoire perso puisque, si MPlayer ne le trouve pas dans ce dernier, il ira ensuite jeter un oeil dans /etc/mplayer/ ...

        Il n'y a franchement pas besoin de supprimer ~/.mplayer à chaque fois. Encore heureux d'ailleurs :)
        • [^] # Re: gui toujours casse chez moi

          Posté par . Évalué à 1.

          Pour le codecs.conf, soit tu fais un lien, généralement ln -s /etc/mplayer/codecs.conf ~/.mplayer/codecs.conf

          A vrai dire je n'installe pas mplayer proprement, je me contente de copier le binaire dans mon ~/bin . Le fichier codecs.conf étant seulement dans l'arborescence des sources extraites, et l'arborescence étant sujette à suppression, le "ln -s" ne serait pas prudent :-)

          Il n'y a franchement pas besoin de supprimer ~/.mplayer à chaque fois.

          En effet il n'y a pas besoin, d'ailleurs je ne le supprime pas mais je le renomme. Quand je change de version de logiciel, je ne suis jamais sûr que le fichier de préférence/configuration n'a pas changé, et par précaution je renomme le ".monsoft" en ".monsoft.old".

          Voilà pour les explications.
  • # Compilation

    Posté par (page perso) . Évalué à 1.

    Bon, je viens de le compiler, et rien à dire, c'est une fois de plus du bon boulot mais pas moyen de le linker avec le CVS de la libdvdnav.

    Pour info voici les options que je passe au Configure :

    ./configure --cc=gcc-3.2 --enable-gui --enable-libfame --disable-runtime-cpudetection --disable-rtc --with-win32libdir=/usr/lib/w32codec/ --with-extraincdir=/usr/local/src/MPlayer/libdvdnav/src/ --with-libdvdnav=/usr/local/lib/ --with-dvdnav-config=/usr/local/bin/dvdnav-config --with-reallibdir=/usr/local/real/Codecs/

    Le Configure passe sans problème, par contre ensuite à la compilation :
    mplayer.c: In function `main':
    mplayer.c:2461: too few arguments to function `dvdnav_upper_button_select'
    mplayer.c:2464: too few arguments to function `dvdnav_lower_button_select'
    mplayer.c:2467: too few arguments to function `dvdnav_left_button_select'
    mplayer.c:2470: too few arguments to function `dvdnav_right_button_select'
    mplayer.c:2477: too few arguments to function `dvdnav_button_activate'
    make: *** [mplayer.o] Error 1

    Alors que ça marchait nickel avant.

    Strange.
  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par . Évalué à 2.

    Quelqu'un peut-il m'expliquer comment utiliser mencoder avec comme source la TV. Pour la video je n'ai pas de problème mais je n'arrive pas à enregistrer le son. La doc n'est pas très claire sur ce point pour moi.

    J'ai une carte BT848 qui envoi le son à l'entrée "Line" de ma carte son. La carte est full-duplex sous alsa et marche très bien avec xawdecode.

    Ce qui me tracasse dans la doc c'est :

    tv <option1:option2:...>

    MPlayer doesn’t accept colons so type dots instead in the device
    ID (e.g. hw.0,0 instead of hw:0,0).

    adevice=<value> set an audio device
    /dev/... for OSS
    hardware ID for ALSA (?????????)

    Quelqu'un a des infos ?
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 10.

      Voici un exemple qui marche chez moi

      mencoder -tv on:driver=v4l:norm=PAL:width=640:height=480 -ovc lavc -lavcopts vcodec=mpeg1video:vbitrate=8000 -oac mp3lame -lameopts cbr:br=128 -endpos 00:01:00 -o essai3.avi

      expliquation:

      • -tv on:driver=v4l:norm=PAL:width=640:height=480:audiorate=22050 on utilise l'entrée v4l en PAL avec une taille d'image de 640x480.

      • -ovc lavc utiliser lavc (la lib de ffmpeg) pour l'encodage.

      • -lavcopts vcodec=mpeg1video:vbitrate=8000 options pour lavc, on encode en mpeg1 (plus rapide que le divx) avec un bitrate de 8000 (c'est beauoup!) pour être sur de la qualité.

      • -oac mp3lame encoder le son avec lame.

      • -lameopts cbr:br=128 options de lame, bitrate constant (cbr) de 128.

      • -endpos 00:01:00 enregistrer pendant 1 minute.


      Voilà, j'espère que ça aide.
      • [^] # Re: Sortie de Mplayer 0.90-pre10

        Posté par . Évalué à 1.

        J'oubliais, pour le son il faut choisir avec un programme de mixer (kmix par exemple) à partir de quelle entrée tu veut enregistrer.
      • [^] # Re: Sortie de Mplayer 0.90-pre10

        Posté par . Évalué à 1.

        C'est bien comme çà que je vois les choses. malheureusement, si j'utilise t'on exemple (j'ai ajouté device=/dev/video0 pour ma configue) j'ai :
        --------------------------------------------------------
        $ mencoder -tv on:device=/dev/video0:driver=v4l:norm=PAL:width=640:height=480 -ovc lavc -lavcopts vcodec=mpeg1video:vbitrate=8000 -oac mp3lame -lameopts cbr:br=128 -endpos 00:01:00 -o essai3.avi
        Using GNU internationalization
        Original domain: messages
        Original dirname: /usr/share/locale
        Current domain: mplayer
        Current dirname: /usr/share/locale


        MEncoder 0.90pre10-3.2 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

        CPU: Advanced Micro Devices Athlon 4 PM Palomino/Athlon MP Multiprocessor/Athlon XP eXtreme Performance (Family: 6, Stepping: 2)
        CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
        Reading /home/f.matias/.mplayer/codecs.conf: can't open '/home/f.matias/.mplayer/codecs.conf': Aucun fichier ou répertoire de ce type
        Reading /etc/mplayer/codecs.conf: 44 audio & 110 video codecs
        File not found: 'frameno.avi'
        font: can't open file: /home/f.matias/.mplayer/font/font.desc
        Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
        success: format: 0 data: 0x0 - 0x0
        Detected TV! ;-)
        Selected driver: v4l
        name: Video 4 Linux input
        author: Alex Beregszaszi <alex@naxine.org>
        comment: under development
        Selected device: BT848A(MIRO PCTV)
        Capabilites: capture tuner overlay clipping frameram scales
        Device type: 235
        Supported sizes: 48x32 => 924x576
        Inputs: 4
        0: Television: tuner audio tv camera (tuner:1, norm:secam)
        1: Composite1: audio camera (tuner:0, norm:secam)
        2: S-Video: audio camera (tuner:0, norm:secam)
        3: Composite3: audio camera (tuner:0, norm:secam)
        --------------------------------------------------------
        Ici le programme reste en attente de lecture du son et le fichier essai3.avi n'est même pas créé.

        un strace me donne :
        --------------------------------------------------------
        open("/dev/dsp", O_RDONLY|O_LARGEFILE
        --------------------------------------------------------
        mencoder reste en attente ici.

        J'ai essayé avec "-tv ...:alsa:adevice=hw.0,0:audiorate=44100:forceaudio" et c'est pas mieux. Et aussi avec hw.0,[1...20] mais dans ce cas j'ai "no such file".

        Alsa me semble correctement configurer. Un "/usr/sbin/alsactl store -f -" le donne :
        [...]
        control.24 {
        comment.access 'read write'
        comment.type ENUMERATED
        comment.item.0 Mic
        comment.item.1 CD
        comment.item.2 Video
        comment.item.3 Aux
        comment.item.4 Line
        comment.item.5 Mix
        comment.item.6 'Mix Mono'
        comment.item.7 Phone
        iface MIXER
        name 'Capture Source'
        value.0 Line
        value.1 Line
        }
        [...]

        Ce qui est correcte.

        J'ai également rapidement fouillé la mailing-list user-mplayer mais je n'ai rien trouvé qui corrige mon problème. Pour info j'ai une "Ensoniq AudioPCI ES1371".
        Merci pour ton attention.
      • [^] # Petite correction

        Posté par . Évalué à -1.

        NB: expliquation => explication

        Petit rappel, on dit coder, pas encoder, si on veut être nickel (sinon anglicisme), ainsi que codage et codé comme dans "message codé" (et codec = codeur/décodeur).

        => "-ovc lavc utiliser lavc (la lib de ffmpeg) pour le codage."

        => "-lavcopts vcodec=mpeg1video:vbitrate=8000 options pour lavc, on code en mpeg1 (plus rapide que le divx) avec un bitrate de 8000 (c'est beaucoup!) pour être sûr de la qualité.

        => "-oac mp3lame coder le son avec lame."
        • [^] # Re: Petite correction

          Posté par . Évalué à 0.

          Ou sinon on accpte qu'une langue est vivante, que de fait elle évolue, et que certains mots s'imposent d'eux memes.
          • [^] # Re: Petite correction

            Posté par . Évalué à 0.

            Ou sinon on accpte qu'une langue est vivante, que de fait elle évolue, et que certains mots s'imposent d'eux memes.

            Je te parle d'anglicisme, pas de création de mot utile qui vient pallier un manque du français. En l'occurrence, le terme "codage" existe depuis fort longtemps et en mathématique/algorithmique on parle de "coder" et par exemple de "codage préfixe" (codage de Huffman par ex). Le codage est une transformation générale, ce qui inclus la compression de données et les changements de format (JPG, MPG, Ogg, etc sont des codages).

            Si tu trouves que c'est une avancée qu'on dise systématiquement "coach" au lieu ""d'entraîneur", "skipper" au lieu de "barreur" ou "capitaine", "opportunité manquée" au lieu de "occasion manquée"...

            Là où la langue évolue c'est avec la création d'un verbe comme "positiver" qui n'avait pas vraiment d'équivalent, avant on était obligé de faire plus long et dire "être positif".
            • [^] # Re: Petite correction

              Posté par . Évalué à 1.

              "En l'occurrence, le terme "codage" existe depuis fort longtemps et en mathématique/algorithmique"

              Il y a 100 ans, 'entendre' voulait dire comprendre en français. Aujourd'hui on ne croise plus grand monde l'utilisant de cette façon. Comme quoi l'évolution de la langue, c'est aussi l'évolution du sens de certains mots par rapport à l'utilisation générale meme si celle ci est fausse.

              "Si tu trouves que c'est une avancée qu'on dise systématiquement "coach" au lieu ""d'entraîneur", "skipper" au lieu de "barreur" ou "capitaine", "opportunité manquée" au lieu de "occasion manquée"... "

              Pas forcément effectivement, encore que tout dépend du contexte. Coach se comprend différement d'entraineur par exemple, il est plus utilisé par les joueurs pour appeler leur entraineur justement et dans ce cas, les 2 peuvent très bien cohabiter. Mais je trouve d'une stupidité remarquable la mode des traductions de termes informatiques.

              "Là où la langue évolue c'est avec la création d'un verbe comme "positiver" qui n'avait pas vraiment d'équivalent, avant on était obligé de faire plus long et dire "être positif". "

              C'est vrai, mais l'évolution c'est aussi la modification du sens des mots. Je pourrais te citer des tas d'exemples de mots qui au fil du temps ont pris un sens totalement différent de celui d'origine non pas par la décision d'académiciens mais parce que la vox populis qui reste la maitresse de sa langue en a décidé ainsi. D'où mon profond agacement également contre le fameux "au temps pour moi" très en vogue aussi, 100% vrai grammaticalement, totalement faux dans l'utilisation de la langue puisque le "autant pour moi" -meme si il est faux- s'est définitivement imposé.
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 1.

      moi j'avais le même genre de problème j'avais un joli son blanc et en fait il suffisait juste de régler le gain avec aumix par exemple

      j'espere que çà peut t'aider
  • # Mplayer vs. Xine ?

    Posté par . Évalué à 1.

    Voilà, tout est dans le titre. J'utilise xine pour mes maigres besoins, quel avantage éventuel y a-t-il à passer à mplayer ?
    • [^] # Re: Mplayer vs. Xine ?

      Posté par . Évalué à 2.

      J'ai compilé la dernière version stable de Xine (la 0.9.13) mais elle a tendance à lire nettement moins de trucs que MPlayer, et pire à planter. Pourtant je suis sous XFree 4.2 avec une carte Matrox G400, noyau 2.4.18. MPlayer me lit très bien tous les MPG et WMV de cvl que je trouve sur www.stileprojet.com ;-)

      Je n'ai qu'un seul exemple où Xine marche mieux que MPlayer, c'est pour lire un des fichiers avi de l'émission d'Arte sur le logiciel libre. Le son est accéléré sur MPlayer, et passe bien sur Xine. Sinon Xine a qq trucs en plus, comme le ralenti et l'accéléré.
      • [^] # Pb de son sur cette video

        Posté par . Évalué à 2.

        il te suffit de jouer avec les options de choix de codec audio, si je me souviens bien, un petit -afm 4 bien placer t'aidera a lire la video sans probleme. Je pense cela dit que ca necessite les codecs audio windows
        • [^] # Re: Pb de son sur cette video

          Posté par . Évalué à 2.

          il te suffit de jouer avec les options de choix de codec audio, si je me souviens bien, un petit -afm 4 bien placé t'aidera a lire la video sans probleme. Je pense cela dit que ca necessite les codecs audio windows

          Merci pour ta suggestion, mais avec mplayer ça ne change rien (et j'ai les codecs Windows je pense, j'ai /usr/lib/win32 plein de trucs). Bizarre, sur les 3 autres fichiers, le son est détecté comme étant :
          AUDIO: 11025 Hz, 2 ch, 16 bit (0x10), ratio: 2000->44100 (16,0 kbit)
          et sur le fichier qui déconne, c'est :
          AUDIO: 24000 Hz, 2 ch, 16 bit (0x10), ratio: 7000->96000 (56,0 kbit)
          alors que ça doit être 11025 aussi mais il le joue plus de 2 x plus vite (11.025 -> 24 et ça s'entend :-) .
          Dans les 2 cas, il est marqué juste après la ligne citée :
          Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
        • [^] # Re: Pb de son sur cette video

          Posté par . Évalué à 2.

          J'ai essayé de jouer avec le switch "-afm", qui permet ceci ("mplayer -afm help") :

          Available (compiled-in) audio codec families/drivers:
          afm: info: (comment)
          mp3lib MPEG layer-2, layer-3 (Optimized to MMX/SSE/3Dnow!)
          liba52 AC3 decoding with liba52
          hwac3 AC3 pass-through SP/DIF
          ffmpeg FFmpeg/libavcodec audio decoders
          pcm Uncompressed PCM audio decoder
          dvdpcm Uncompressed DVD/VOB LPCM audio decoder
          alaw aLaw/uLaw audio decoder
          imaadpcm IMA ADPCM audio decoder
          msadpcm MS ADPCM audio decoder
          dk3adpcm Duck Corp. DK3 ADPCM decoder
          roqaudio Id RoQ File Audio Decoder
          msgsm native GSM/MSGSM audio decoder
          dshow Win32/DirectShow decoders
          acm Win32/ACM decoders
          realaud RealAudio decoder (binary real audio codecs)


          (Au fait, d'où tu sors le "4" de "-afm 4" ?)

          Par défaut il prend la mp3lib chez moi.
          Avec "-afm dshow" j'avais le même résultat (son joué trop vite).
          Avec "-afm acm" ça a fini par marcher. Et maintenant j'ai :

          Trying to force audio codec driver family acm ...
          Opening audio decoder: [acm] Win32/ACM decoders
          Loading codec DLL: 'l3codeca.acm'
          Loaded DLL driver l3codeca.acm
          AUDIO: 11025 Hz, 1 ch, 16 bit (0x10), ratio: 1991->22050 (15,9 kbit)
          Selected audio codec: [mp3acm] afm:acm (MPEG layer-3)


          Merci pour le tuyau.
    • [^] # Re: Mplayer vs. Xine ?

      Posté par . Évalué à 6.

      Y a longtemps que j'ai pas utilisé xine. Mais je me lance.

      Mplayer :
      - rapidité, beaucoup d'accélération hardware. J'ai une ATI Rage pro IIC sans accélération hard et çà passe sans problème sur un athlon XP 1600 en 1024x768.
      - meilleur synchro video/audio.
      - support de beaucoup de format de fichier.
      - mencoder qui permet d'encoder des videos (excellent résultat dans l'encodage de dvd).
      - mencoder pour encoder un flux tv en temps réel (malheureusement j'arrive pas a encoder le son actuellement).
      - fiabilité.
      - paramétrage "touffu" en ligne de commande.

      Xine :
      - interface
      - simplicité
      - support raw dvd

      Bref, pour moi Mplayer est meilleur.
      • [^] # Re: Mplayer vs. Xine ?

        Posté par . Évalué à -2.

        mencoder qui permet d'encoder des videos (excellent résultat dans l'encodage de dvd).

        Petit rappel, on dit coder, pas encoder, si on veut être nickel (sinon anglicisme), ainsi que codage et codé comme dans "message codé" (et codec = codeur/décodeur).

        -> "mencoder qui permet de coder des videos (excellent résultat dans le codage de dvd)."
    • [^] # Re: Mplayer vs. Xine ?

      Posté par (page perso) . Évalué à 5.

      Personnellement j'utilise Xine pour lire mes DVD, et MPlayer pour lire absolument tout le reste (niveau vidéo, j'entends).

      Parce que :
      - MPlayer est plus lèger que Xine
      - On peut tout faire en ligne de commande
      - MPlayer gère un plus grand nombre de codecs que Xine
      - Xine gère parfaitement les menus dans les DVD, pas MPlayer
      • [^] # Re: Mplayer vs. Xine ?

        Posté par . Évalué à 1.

        Une question me turlupine. Il me semble que KDE utilise Xine pour lire les vidéos (en gros un logiciel demande à arts de lire une vidéo et celui-ci demande à xine). Mais pourquoi ont-ils choisi Xine plutôt qu'un autre, comme MPlayer par exemple? Une histoire d'API? Si quelqu'un connait la réponse, je serais curieux de la connaître. Ou bien est-ce que j'ai rêvé en entendant ça?
        • [^] # Re: Mplayer vs. Xine ?

          Posté par . Évalué à 1.

          Peut-être parce que le projet Xine a débuté avant Mplayer.
          • [^] # Re: Mplayer vs. Xine ?

            Posté par . Évalué à 2.

            Ou parce que pendant longtemps mplayer ne pouvait pas être distribué sous forme binaire ? Je pense que ça doit jouer.
            • [^] # Re: Mplayer vs. Xine ?

              Posté par . Évalué à 1.

              Maintenant qu'on peut distribuer sous forme binaire, ce serait bien d'avoir une interface arts/mplayer (mplayer peut déjà jouer du son sur arts, "y'a plus qu'à" sortir de la vidéo). M'en vais remplir un "wish" sur le site de KDE :) Ça permettrait d'avoir tout plein de formats à portée de clic, directement intégré dans KDE. Et puis avoir le choix entre xine et mplayer ne nuirait pas, la concurrence crée un cercle vertueux. Et puis chacun pourrait avoir ce qu'il préfère. Ah, que c'est beau, le choix!
        • [^] # Re: Mplayer vs. Xine ?

          Posté par . Évalué à 1.

          Non, arts n'est qu'un serveur de son, il n'a rien à voir avec de la vidéo.
          Et si c'est xine qui est démarré c'est juste une question de configuration dans l'association des programmes aux types de fichiers.
          • [^] # Re: Mplayer vs. Xine ?

            Posté par . Évalué à 2.

            Effectivement. Je viens de lire ça. Mais il y avait un projet pour étendre arts à la vidéo. Apparemment celui-ci se s'est pas concrétisé (manque d'intérêt). Cependant Xine est bel est bien utilisé par KDE via son plugin xine-arts. Si j'en crois le changelog pour 3.1 :
            Write video thumbnail creator using xine-arts. (Simon MacMullen)
            Il est donc envisageable d'avoir la même chose mais avec mplayer sans trop de difficulté je pense.
            • [^] # Re: Mplayer vs. Xine ?

              Posté par . Évalué à 1.

              Pourtant il semblerait que ca continue ... c juste qu'ils prennent leur temps sur leur API et quil hesitent a la transformer en un wrapper au dessus de gstreamer

              FeniX
        • [^] # Re: Mplayer vs. Xine ?

          Posté par . Évalué à 3.

          Ben en fait il y avait a l'origine trois groupes pour creer une integration aRts/Video avec des solutions differentes (suite a une longue discussion sur irc). (http://lists.kde.org/?l=kde-multimedia&m=101208418317577&w=(...))
          Mplayer avait ete rapidement ecarte du fait que l'on ne pouvait le distribuer sous forme binaire.

          La version la plus rapidement stable fut celle de l'intergration xine/aRts/Video cela sert de base a implementer une API suffisement generique pour pouvoir "plug-er" plus tard d'autres plugins (surement gstreamer et si qqun le fait, mplayer).

          Le cote bof de xine c que ca ne sert que comme player video alors que l'API arts/video devrait permettre plus de chose (cf gstreamer)

          FeniX
    • [^] # Re: Mplayer vs. Xine ?

      Posté par . Évalué à 3.

      Sur les avis incomplets, Xine marche mieux. Sinon j'ai toujours l'impression que mplayer met le fichier complet en mémoire avant la lecture, Xine démarre tout de suite. Mplayer n'arrive pas a afficher en full screen une vidéo sur mon portable avec un serveur X limité, Xine oui. Sinon mplayer est la référence des codecs.
      • [^] # Re: Mplayer vs. Xine ?

        Posté par (page perso) . Évalué à 3.

        Rectificatif: mplayer scanne le fichier pour refaire les index. Apres, tu peux aller a n'importe quel endroit du film instantanement. Sans index, tu dois decompresser tout ce qui a avant le point auquel tu veux aller.
        Enfin je crois
        • [^] # Re: Mplayer vs. Xine ?

          Posté par . Évalué à 1.

          Nan, mplayer refuse purement et simplement de seeker si l'index est pas là (oui, paske les inventeurs de l'avi ont eu l'idée géniale de mettre l'index à la fin..). Apres, si tu fais un mplayer -idx, il recrée l'index, et effectivement ca prends du temps
          • [^] # Re: Mplayer vs. Xine ?

            Posté par . Évalué à 2.

            Pour les index absent des fichiers avi, xine utilise une autre technique pour ne pas devoir attendre longtemps.

            il recrée l'index au fur et a mesure du film, comme ca on attend pas au debut, et on ne remarque meme pas qu'il y avait pas d'index, si on fait un seek plus loin dans le fichier et que l'index arrive pas encore la, et bien on a a petit delai, mais dans la pratique ca marche vachement mieux que de recreer l'index au debut.
      • [^] # Re: Mplayer vs. Xine ?

        Posté par (page perso) . Évalué à 1.

        mplayer a par défaut un cache de 8 Mo, ce qui est relativement beaucoup (mais c'est qu'une bête option à régler)...

        Pour un utilisateur lambda, la grosse différence entre mplayer et xine, c'est que mplayer est beaucoup moins "plug and play" que xine : bref, avec mplayer, il ne faut pas avoir peur d'utiliser une ligne de commande avec moultes options... zavez qu'à voir la longueur de "man mplayer" pour comprendre... surtout que le man n'est pas exhaustif.

        <troll> En fait xine et mplayer, c'est comme windows et linux : ce sont tous les deux des OS, et le meilleur, c'est celui qui correspond le mieux à votre besoin </troll>
    • [^] # Re: Mplayer vs. Xine ?

      Posté par . Évalué à 2.

      J'ajouterai :
      * mplayer a aussi une tripotée de filtres vidéo et audio (-vop help) [d'ailleurs, j'arrive pas à avoir les filtres audio dans mencoder, bug ?]
      * mplayer supporte plein de formats de sous-titrages, avec sous titres alpha-blendés sur la vidéo, et linkable sur freetype
      * paradoxe d'avoir un code crade : mplayer est tres facilement "hackable" (je me souviens m'etre fait un machin pour me timer un karaoké en ajoutant moins de 10 lignes de code dans le main() et 2 dans input.conf). Il a aussi une interface "slave" (xine doit pouvoir faire ca aussi, mais via sa lib, cf "sinek"). Meme sans hacker, il est très customisable de part ses tonnes d'options
      * mplayer a tendance à être plus tolérant aux flux endomagés (il m'est arrivé de réparer des vidéos rien qu'avec le mode copy de mencoder)
    • [^] # Gouts et couleurs, comme d'hab

      Posté par . Évalué à 1.

      Le choix entre les deux est comme bien souvent une affaire de gout et de couleurs. Si tu regardes les autres commentaires, tu en vois certains qui te disent que mplayer est plus tolérant tandis que d'autres te disent le contraire.
      En pratique, ce qui est vraiment important, c'est que l'un ou l'autre lisent correctement les fichiers et media que tu veux visualiser. Si tout va bien, ne change rien. Si un fichier ne passe pas, essaye l'autre.
      Personnellement, j'utilise Xine. Il lit tous mes fichiers et mes DVD sans problèmes, je n'ai aucun des problèmes de ressources et de lenteur que certains lui attribuent, et en plus j'aime bien lire leur ML développement car il y a vraiment un bon esprit (ca n'a rien a voir avec le programme lui-même mais bon...). Je trouve sympa d'ailleurs que les dev de Xine et de Mplayer interviennent dans les deux ML respectives : ca fait avancer les deux projets.
      Quant à l'intégration de Xine dans d'autres projets, comme KDE, j'ai l'impression que c'est du à sa structure séparant clairement librairies-interface, ce qui rend l'utilisation des librairies dans d'autres logiciels très simple, à commencer par les différentes interfaces et plugins existants.
      Le fait de pouvoir encoder avec mplayer est certainement un plus. D'après la ML Xine, l'un de leurs futurs développements sera d'étendre les lib-xine pour pouvoir faire de même, et en particulier pour en faire une base complète pour tout logiciel de manipulation video.

      Cordialement,
  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par (page perso) . Évalué à 4.

    Bon comme j'avais du mal à faire fonctionner Xvideo pour ma vieille ATI Xpert@plop sur une debian, et que ça m'a pris un peu de temps pour trouver la solution (<troll>ce driver est inclus par défaut dans le xfree de la mdk</troll>) , voila le serveur X qu'il faut utiliser:
    http://penguinppc.org/~daenzer/debian/dri-mach64/(...)
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 2.

      Pourquoi troll?

      Tu as dit que Y était plus facile sous mdk que debian, et alors?

      Ce serait un troll si c'était faux ou que tu l'avais dit d'une manière désobligeante, mais j'espere qu'il est encore possible de comparer les distributions sans que cela dégénère en flamewar systèmatiquement.
      • [^] # Re: Sortie de Mplayer 0.90-pre10

        Posté par (page perso) . Évalué à 0.

        t'as pas tort.. les balises étaient là pour signaler que comme la debian n'est installée que depuis hier, j'évite soigneusement de porter des jugements définitifs sur le truc.

        > j'espere qu'il est encore possible de comparer les distributions sans que cela dégénère en flamewar systèmatiquement.

        bien caché dans les commentaires au fond d'une news ça doit pouvoir passer ;-)
  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par (page perso) . Évalué à 1.

    Suis-je le seul à avoir le problème suivant lors de la lecture d'un dvd chiffré ?

    Je regarde bien tranquillement le film avec xine ou mplayer et le film s'arrête brusquement (soit entre deux chapitres soit carrément au milieu d'un chapitre). Pas moyen d'aller plus loin, même en essayant les chapitres suivants...

    La seule solution que j'ai trouvé (redémarrer sous win2000) ne me satisfait pas, avez-vous déjà rencontré ce problème ?


    ps: le problème apparaît sous une mdk et une gentoo
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 1.

      Tu utilises quoi comme ligne de commande ?
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 1.

      Je n'ai jamais rencontré ce problèmes, que ce soit avec mplayer (en ligne de commande) depuis la version 0.50, ogle ou vlc. As-tu essayé ces derniers?
      Si tu obtient le même problème avec des programmes complètement différents, c'est que le problème viens d'ailleur, peut-être une mauvaise configuration du lecteur.
      • [^] # Re: Sortie de Mplayer 0.90-pre10

        Posté par (page perso) . Évalué à 2.

        J'ai essayé avec xine (0.9.13) et mplayer (0.90-pre8-3.2), cela doit donc venir d'ailleurs que le logiciel, mais quoi ?

        Le lecteur dvd a configuré automatiquement à l'installation (sous mdk et gentoo), peut-être est-ce du au montage ? Faut-il passer des paramètres particuliers en plus par rapport à un cdrom ?
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 1.

      J'ai rencontré une seule fois ce problème, avec un DVD particulier (Strange Days). Il s'arrêtait en plein milieu d'une scène. Je n'ai jamais réessayé, peut-être que c'est corrigé depuis ?
    • [^] # Re: Sortie de Mplayer 0.90-pre10

      Posté par . Évalué à 1.

      T'as qu'a pas regarder de DVD chiffrés, ces saloperies de la MPAA (qui a dit, rappellons-le, que "opensource = piratage" et qui amène les flics chez Jon Johansen)...
      Finalement, ta solution de rebooter sous un OS crée par une boite aux pratiques illégales dans son pays est surement la meilleure solution.. au moins, ca ne salit pas le monde Linux

      (et avant que le fan club de BruceWillis et MichaelEisner ne me score à -50, je file deux liens http://opendvd.org(...) et http://eff.org(...) )
  • # Mplayer & DivX ... bof

    Posté par . Évalué à 1.

    J'espere que ca corrige certains pb relatifs a la lecture de fichiers DivX, car, meme en ayant essaye 10.000 options sur la syncro, les delais, les framesdrop et divers video/audio output, voir le reconctruction de l'index, certains DivX ont un gros pb: le son est fortement en retard sur l'image ...

    Ce probleme est inexistant avec aviplay ...
    • [^] # Re: Mplayer & DivX ... bof

      Posté par (page perso) . Évalué à 1.

      mwé, en général ça vient du divx qui n'est pas encodé par un programme digne de ce nom... :p

      En ce qui me concerne j'ai eu que très peu de divx dans ce cas, et un mplayer -forceidx résoult le problème...

      Pour les cas vraiment récalcitrant, tu peux utiliser les touches + et - du pavé numérique, pour recaler manuellement le son et l'image.
  • # Re: Sortie de Mplayer 0.90-pre10

    Posté par . Évalué à 1.

    Et en plus, depuis hier, Mplayer-CVS peut maintenant lire le codec Sorenson (le codec des .qt). :)
    Il y a une news et un screenshot sur leur homepage...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.