babytux a écrit 6 commentaires

  • # rc.local

    Posté par  (site Web personnel) . En réponse au message Ipv6 fixe sous debian buster. Évalué à 1 (+0/-0).

    Sous Buster 2 lignes dans le rc.local et cela marche aussi : Avoir une 2ème ipv6 qui soit static.

    root@omega:~# cat /etc/rc.local 
    #!/bin/sh -e
    #
    # rc.local
    #
    # This script is executed at the end of each multiuser runlevel.
    # Make sure that the script will "exit 0" on success or any other
    # value on error.
    #
    # In order to enable or disable this script just change the execution
    # bits.
    #
    # By default this script does nothing.
    
    # Add static Ipv6 
    /sbin/ip -6 addr add 2a01:e0a:195:1040:cdaf:219b:207e:d823/64 dev enx001e06300937
    /sbin/ip -6 route add default via 2a01:e0a:195:1040::1
    
    exit 0
    root@omega:~#
    
  • [^] # Re: /e/n/i FTW?

    Posté par  (site Web personnel) . En réponse au message Ipv6 fixe sous debian buster. Évalué à 1 (+0/-0).

    J'ai essayé, mais cela ne marche pas

    root@omega:~# cat /etc/network/interfaces
    source /etc/network/interfaces.d/*
    ‡ Network is managed by Network manager
    auto lo
    iface lo inet loopback
    iface enx001e06300937 inet6 static
    address 2a01:e0a:195:1040:cdaf:219b:207e:d823
    netmask 64
    gateway 2a01:e0a:195:1040::1

    root@omega:~# ip address
    1: lo: mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: enx001e06300937: mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:1e:06:30:09:37 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.126/24 brd 192.168.0.255 scope global dynamic noprefixroute enx001e06300937
    valid_lft 42872sec preferred_lft 42872sec
    inet6 2a01:e0a:195:1040:89db:6067:6ec7:b31f/64 scope global dynamic noprefixroute
    valid_lft 86383sec preferred_lft 86383sec
    inet6 fe80::2692:7667:d36:5366/64 scope link noprefixroute
    valid_lft forever preferred_lft forever
    root@omega:~#

    Le réseau semble être géré par Network manager

    root@omega:~# nmcli connection show
    NAME UUID TYPE DEVICE

    Armbian ethernet c156e46c-4123-4747-be59-78a1dc94f2eb ethernet enx001e06300937
    root@omega:~# nmcli device show
    GENERAL.DEVICE: enx001e06300937
    GENERAL.TYPE: ethernet
    GENERAL.HWADDR: 00:1E:06:30:09:37
    GENERAL.MTU: 1500
    GENERAL.STATE: 100 (connected)
    GENERAL.CONNECTION: Armbian ethernet
    GENERAL.CON-PATH: /org/freedesktop/NetworkManager/ActiveConnection/1
    WIRED-PROPERTIES.CARRIER: on
    IP4.ADDRESS[1]: 192.168.0.126/24
    IP4.GATEWAY: 192.168.0.254
    IP4.ROUTE[1]: dst = 0.0.0.0/0, nh = 192.168.0.254, mt = 100
    IP4.ROUTE[2]: dst = 192.168.0.0/24, nh = 0.0.0.0, mt = 100
    IP4.ROUTE[3]: dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
    IP4.DNS[1]: 192.168.0.254
    IP4.DNS[2]: 8.8.8.8
    IP6.ADDRESS[1]: 2a01:e0a:195:1040:89db:6067:6ec7:b31f/64
    IP6.ADDRESS[2]: fe80::2692:7667:d36:5366/64
    IP6.GATEWAY: fe80::f6ca:e5ff:fe42:54ac
    IP6.ROUTE[1]: dst = fe80::/64, nh = ::, mt = 100
    IP6.ROUTE[2]: dst = 2a01:e0a:195:1040::/64, nh = ::, mt = 100
    IP6.ROUTE[3]: dst = ::/0, nh = fe80::f6ca:e5ff:fe42:54ac, mt = 100
    IP6.ROUTE[4]: dst = ff00::/8, nh = ::, mt = 256, table=255
    IP6.DNS[1]: fd0f:ee:b0::1

    GENERAL.DEVICE: lo
    GENERAL.TYPE: loopback
    GENERAL.HWADDR: 00:00:00:00:00:00
    GENERAL.MTU: 65536
    GENERAL.STATE: 10 (unmanaged)
    GENERAL.CONNECTION: --
    GENERAL.CON-PATH: --
    IP4.ADDRESS[1]: 127.0.0.1/8
    IP4.GATEWAY: --
    IP6.ADDRESS[1]: ::1/128
    IP6.GATEWAY: --
    root@omega:~#

  • # Mes 2 sous

    Posté par  (site Web personnel) . En réponse au journal [Covid-19] Une euthanasie déguisée des personnes les plus âgées ?. Évalué à 1.

    Certaines personnes hospitalisées pour détresse respiratoire reçoivent :

    1. Un analgésique -> contre la douleur
    2. Un somnifère -> pour les endormir (coma ?)
    3. Un  ? -> pour "endormir" le diaphragme et arrêter la respiration naturelle, oxygénation étant contrôlée par un respirateur artificiel (Ceux qu'on a pas assez)

    C'est peut être aussi dans ces cas que l'autorisation ce médicament est élargi aux cliniques et aux tentes ou tout autre lieu équipé de respirateurs artificiels.

    On a peu être des politiques bizarres, mais de là à inscrire au JO l'autorisation d'euthanasie.

    Une petite pensée à Roselyne Bachelot, qui avait commandé des masques. Beaucoup de monde lui était tombé dessus pour le coût exorbitant. Tu nous manque, revient !

    Arrêtez les complots, faire l'amour (Chez vous confinés)

  • [^] # Re: Kernel upstream ? UEFI ?

    Posté par  (site Web personnel) . En réponse au journal Marre des cartes ARM ?. Évalué à 0.

    Niveau BIOS∕UEFI Il y a de l'espoir.

  • [^] # Re: Kernel upstream ? UEFI ?

    Posté par  (site Web personnel) . En réponse au journal Marre des cartes ARM ?. Évalué à 2.

    Pour Xu2, la dernière image date d'août 2018.

    • Ubuntu 16.04.5
    • Kernel 3.4.106
    • Kodi 17.6 Krypton + MFC hw video acceleration
    • Plex Media Server 1.13.0

    Le problème vient de la communauté/des utilisateurs. Si il n'y plus personne pour s'en occuper, cela s’arrête de mort naturelle, comme sur PC. Les cartes ARM ont juste un développement plus rapide et donc un cycle de vie plus court.

    Hardkernel ne peut maintenir tout les kernels/distributions à vie. Mais ils semblent ouvert :

    Lien

    Pour l'Xu3/4 et ses descendants, ils fournissent tout, même de quoi se faire un uboot signé.

  • # depuis un raspberry vierge

    Posté par  (site Web personnel) . En réponse au message apt-get install / upgrade qui ne marche plus :(. Évalué à 0.

    sources apt :

    deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi
    deb http://archive.raspberrypi.org/debian/ wheezy main
    deb http://raspberrypi.collabora.com wheezy rpi

    pi@raspberrypi /etc/apt/sources.list.d $ apt-cache show mysql-server   
    Package: mysql-server
    Source: mysql-5.5
    Version: 5.5.46-0+deb7u1
    Installed-Size: 126
    Maintainer: Debian MySQL Maintainers <pkg-mysql-maint@lists.alioth.debian.org>
    Architecture: all
    Depends: mysql-server-5.5
    Size: 83010
    SHA256: 8df2e4974d4db4027d52dd104ee9908309608b8b879d717d86b1694e0a18a34a
    SHA1: be4eac4addae50cc0e07627c849fcd60739bd786
    MD5sum: 81ef5b29100064f710181a6e5edaa7f0
    Description: MySQL database server (metapackage depending on the latest version)
     This is an empty package that depends on the current "best" version of
     mysql-server (currently mysql-server-5.5), as determined by the MySQL
     maintainers. Install this package if in doubt about which MySQL
     version you need. That will install the version recommended by the
     package maintainers.
     .
     MySQL is a fast, stable and true multi-user, multi-threaded SQL database
     server. SQL (Structured Query Language) is the most popular database query
     language in the world. The main goals of MySQL are speed, robustness and
     ease of use.
    Homepage: http://dev.mysql.com/
    Section: misc
    Priority: optional
    Filename: pool/main/m/mysql-5.5/mysql-server_5.5.46-0+deb7u1_all.deb
    
    sudo apt-get update
    .....
    
    pi@raspberrypi /etc/apt/sources.list.d $ apt-cache show mysql-server
    Package: mysql-server
    Source: mysql-5.5
    Version: 5.5.47-0+deb7u1
    Installed-Size: 124
    Maintainer: Debian MySQL Maintainers <pkg-mysql-maint@lists.alioth.debian.org>
    Architecture: all
    Depends: mysql-server-5.5
    Size: 80100
    SHA256: 5ffa3d5e93bdbc87bd8a7e61e3ebbe7c80bf6c174844f683cc1f244942acdc95
    SHA1: c0f021d211cb3f97dd7f02f1f303bc15942b58ab
    MD5sum: a23f75b32b6e2dc1c4700a60e3330ffd
    Description: MySQL database server (metapackage depending on the latest version)
     This is an empty package that depends on the current "best" version of
     mysql-server (currently mysql-server-5.5), as determined by the MySQL
     maintainers. Install this package if in doubt about which MySQL
     version you need. That will install the version recommended by the
     package maintainers.
     .
     MySQL is a fast, stable and true multi-user, multi-threaded SQL database
     server. SQL (Structured Query Language) is the most popular database query
     language in the world. The main goals of MySQL are speed, robustness and
     ease of use.
    Homepage: http://dev.mysql.com/
    Section: misc
    Priority: optional
    Filename: pool/main/m/mysql-5.5/mysql-server_5.5.47-0+deb7u1_all.deb
    
    
    pi@raspberrypi ~ $ sudo apt-get install mysql-server 
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Les paquets supplémentaires suivants seront installés : 
      heirloom-mailx libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient16 mysql-client-5.5 mysql-common mysql-server-5.5 mysql-server-core-5.5
    Paquets suggérés :
      exim4 mail-transport-agent libipc-sharedcache-perl libterm-readkey-perl tinyca
    Paquets recommandés :
      mailx
    Les NOUVEAUX paquets suivants seront installés :
      heirloom-mailx libaio1 libdbd-mysql-perl libdbi-perl libhtml-template-perl libmysqlclient16 mysql-client-5.5 mysql-common mysql-server mysql-server-5.5 mysql-server-core-5.5
    0 mis à jour, 11 nouvellement installés, 0 à enlever et 70 non mis à jour.
    Il est nécessaire de prendre 9 822 ko dans les archives.
    Après cette opération, 90,8 Mo d'espace disque supplémentaires seront utilisés.
    Souhaitez-vous continuer [O/n] ? o
    Réception de : 1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libaio1 armhf 0.3.109-3 [8 944 B]
    Réception de : 2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-common all 5.5.47-0+deb7u1 [81,9 kB]
    Réception de : 3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdbi-perl armhf 1.622-1+deb7u1 [890 kB]
    Réception de : 4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libmysqlclient16 armhf 5.1.62-1 [1 828 kB]
    Réception de : 5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libdbd-mysql-perl armhf 4.021-1 [123 kB]
    Réception de : 6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-client-5.5 armhf 5.5.47-0+deb7u1 [1 462 kB]
    Réception de : 7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server-core-5.5 armhf 5.5.47-0+deb7u1 [3 411 kB]
    Réception de : 8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server-5.5 armhf 5.5.47-0+deb7u1 [1 612 kB]         
    Réception de : 9 http://mirrordirector.raspbian.org/raspbian/ wheezy/main heirloom-mailx armhf 12.5-2+deb7u1 [254 kB]                                                                                    
    Réception de : 10 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libhtml-template-perl all 2.91-1 [72,0 kB]                                                                                    
    Réception de : 11 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mysql-server all 5.5.47-0+deb7u1 [80,1 kB]                                                                                    
    9 822 ko réceptionnés en 7s (1 328 ko/s)                                                                                                                                                                 
    Préconfiguration des paquets...                                                                                                     
    Sélection du paquet libaio1:armhf précédemment désélectionné.                                                                       
    (Lecture de la base de données... 77851 fichiers et répertoires déjà installés.)                                                    
    Dépaquetage de libaio1:armhf (à partir de .../libaio1_0.3.109-3_armhf.deb) ...                                                      
    Sélection du paquet mysql-common précédemment désélectionné.                                                                        
    Dépaquetage de mysql-common (à partir de .../mysql-common_5.5.47-0+deb7u1_all.deb) ...                                              
    Sélection du paquet libdbi-perl précédemment désélectionné.                                                                         
    Dépaquetage de libdbi-perl (à partir de .../libdbi-perl_1.622-1+deb7u1_armhf.deb) ...                                               
    Sélection du paquet libmysqlclient16 précédemment désélectionné.                                                                    
    Dépaquetage de libmysqlclient16 (à partir de .../libmysqlclient16_5.1.62-1_armhf.deb) ...                                           
    Sélection du paquet libdbd-mysql-perl précédemment désélectionné.                                                                   
    Dépaquetage de libdbd-mysql-perl (à partir de .../libdbd-mysql-perl_4.021-1_armhf.deb) ...                                                                                                                
    Sélection du paquet mysql-client-5.5 précédemment désélectionné.                                                                                                                                          
    Dépaquetage de mysql-client-5.5 (à partir de .../mysql-client-5.5_5.5.47-0+deb7u1_armhf.deb) ...                                                                                                          
    Sélection du paquet mysql-server-core-5.5 précédemment désélectionné.                                                                                                                                     
    Dépaquetage de mysql-server-core-5.5 (à partir de .../mysql-server-core-5.5_5.5.47-0+deb7u1_armhf.deb) ...                                                                                                
    Traitement des actions différées (« triggers ») pour « man-db »...                                                                                                                                        
    Paramétrage de mysql-common (5.5.47-0+deb7u1) ...
    Sélection du paquet mysql-server-5.5 précédemment désélectionné.
    (Lecture de la base de données... 78200 fichiers et répertoires déjà installés.)
    Dépaquetage de mysql-server-5.5 (à partir de .../mysql-server-5.5_5.5.47-0+deb7u1_armhf.deb) ...
    Sélection du paquet heirloom-mailx précédemment désélectionné.
    Dépaquetage de heirloom-mailx (à partir de .../heirloom-mailx_12.5-2+deb7u1_armhf.deb) ...
    Sélection du paquet libhtml-template-perl précédemment désélectionné.
    Dépaquetage de libhtml-template-perl (à partir de .../libhtml-template-perl_2.91-1_all.deb) ...
    Sélection du paquet mysql-server précédemment désélectionné.
    Dépaquetage de mysql-server (à partir de .../mysql-server_5.5.47-0+deb7u1_all.deb) ...
    Traitement des actions différées (« triggers ») pour « man-db »...
    Traitement des actions différées (« triggers ») pour « menu »...
    Paramétrage de libaio1:armhf (0.3.109-3) ...
    Paramétrage de libdbi-perl (1.622-1+deb7u1) ...
    Paramétrage de libmysqlclient16 (5.1.62-1) ...
    Paramétrage de libdbd-mysql-perl (4.021-1) ...
    Paramétrage de mysql-client-5.5 (5.5.47-0+deb7u1) ...
    Paramétrage de mysql-server-core-5.5 (5.5.47-0+deb7u1) ...
    Paramétrage de mysql-server-5.5 (5.5.47-0+deb7u1) ...
    [ ok ] Stopping MySQL database server: mysqld.
    160219 17:42:02 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
    160219 17:42:02 [Note] /usr/sbin/mysqld (mysqld 5.5.47-0+deb7u1) starting as process 16405 ...
    160219 17:42:02 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
    160219 17:42:03 [Note] Plugin 'FEDERATED' is disabled.
    160219 17:42:03 InnoDB: The InnoDB memory heap is disabled
    160219 17:42:03 InnoDB: Mutexes and rw_locks use GCC atomic builtins
    160219 17:42:03 InnoDB: Compressed tables use zlib 1.2.7
    160219 17:42:03 InnoDB: Using Linux native AIO
    160219 17:42:03 InnoDB: Initializing buffer pool, size = 128.0M
    160219 17:42:03 InnoDB: Completed initialization of buffer pool
    160219 17:42:03 InnoDB: highest supported file format is Barracuda.
    160219 17:42:03  InnoDB: Waiting for the background threads to start
    160219 17:42:04 InnoDB: 5.5.47 started; log sequence number 1595675
    160219 17:42:04  InnoDB: Starting shutdown...
    160219 17:42:05  InnoDB: Shutdown completed; log sequence number 1595675
    [ ok ] Starting MySQL database server: mysqld . . ..
    [info] Checking for tables which need an upgrade, are corrupt or were 
    not closed cleanly..
    Paramétrage de heirloom-mailx (12.5-2+deb7u1) ...
    update-alternatives: utilisation de « /usr/bin/heirloom-mailx » pour fournir « /usr/bin/mailx » (mailx) en mode automatique
    Paramétrage de libhtml-template-perl (2.91-1) ...
    Paramétrage de mysql-server (5.5.47-0+deb7u1) ...
    Traitement des actions différées (« triggers ») pour « menu »...
    pi@raspberrypi ~ $ 
    

    Il me semble qu'une fois, l'upgrade n'a pas fonctionné car paquet-serveur-version n à besoin de paquet-client-version n, mais que paquet-client-version n ne peut être installé car le paquet-serveur-version n-1 est installé.

    Sauvegarde les bases, vérifie que c'est sauvegardé, puis désinstalle les paquets mysql*, avant de les réinstaller.