• # À tester

    Posté par  (site Web personnel) . Évalué à 3 (+1/-0).

    Il y a une solution donnée ici, en anglais:
    https://unix.stackexchange.com/questions/119593/is-there-a-way-to-change-device-names-in-dev-directory

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: À tester

      Posté par  . Évalué à 1 (+0/-0).

      Bravo pour avoir trouvé ce genre de topo.
      Il dit pourtant : "According to udev manual, there's no way to change the names of files in the /dev/ directory"
      En fait je ne veux pas réellement changer le nom (à moins que "changer de nom" soit ici équivalent à "rediriger vers"), je veux simplement "associer" /dev/cdrom à /dev/sr1 au lieu de /dev/sr0.
      C'est d'ailleurs curieux de tomber sur des logiciels imposant "/dev/cdrom" comme entrée obligatoire.
      Merci encore

      • [^] # Re: À tester

        Posté par  (site Web personnel) . Évalué à 5 (+4/-0).

        Ça tombe bien, c'est exactement ce qui est fait pour sr0 via :

        KERNEL=="sr0", SYMLINK+="cdrom", OPTIONS+="link_priority=-100"
        

        dans /lib/udev/rules.d/60-cdrom_id.rules.

        Il devrait te suffire de localiser le bon fichier avec une règle similaire, et de le mettre à jour pour obtenir l'effet désiré. Pour être sûr que la nouvelle règle soit bien prise en compte, le plus simple est probablement de redémarrer.

        Attention, modifier à la main un fichier sous contrôle d'un gestionnaire de paquets risque d'être oublié lors de la prochaine mise à jour du paquet concerné, donc la modification in situ n'est probablement appropriée que pour un test ponctuel.

        Il peut être nécessaire de mettre en place un fichier spécifique (e.g. dans /etc/udev/rules.d/, sous contrôle de l'admin), pour pérenniser la solution. Dans l'exemple donné ci-dessus, le lien symbolique en place est peu prioritaire. D'après udev(7) :

               OPTIONS
                   Rule and device options:
        
                   link_priority=value
                       Specify the priority of the created symlinks. Devices with
                       higher priorities overwrite existing symlinks of other
                       devices. The default is 0.
        

        donc il me semble que mettre en place une règle pour sr1 comme suit devrait fonctionner sur le long terme, par exemple dans /etc/udev/rules.d/60-custom-cdrom_id.rules :

        KERNEL=="sr1", SYMLINK+="cdrom"
        

        (Ne pas hésiter à mettre un commentaire et/ou une option link_priority explicite pour te souvenir de comment tu en es arrivé là…)

        Debian Consultant @ DEBAMAX

        • [^] # Re: À tester

          Posté par  . Évalué à 1 (+0/-0).

          merci bien,
          mais c'est peu "utilisateur final".
          Si c'est le seul moyen, je préfère utiliser une appli qui permet de définir l'entrée. Heureusement il y en a.
          En fait le sujet me semblait intéressant et je suis surpris qu'il n'existe pas de solution plus "normale".
          En tout cas merci pour l'aide, c'est intéressant mais je n'aime pas trop.
          Bonne fin de semaine

  • # Erreur ?

    Posté par  . Évalué à 2 (+0/-0).

    Sa modification par ln conduit à un message d'erreur.

    Peux-tu donner la commande exacte que tu as tapé, ainsi que le message d'erreur ?

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

    • [^] # Re: Erreur ?

      Posté par  . Évalué à 1 (+0/-0).

      Merci, du type :
      jam@tour:~$ ln /dev/cdrom /dev/sr1
      ln: impossible de créer le lien direct '/dev/sr1': Le fichier existe

      Bonne nuit

      • [^] # Re: Erreur ?

        Posté par  (site Web personnel) . Évalué à 3 (+1/-0).

        et ln /dev/sr1 /dev/cdrom voire ln -s /dev/sr1 /dev/cdrom ne fonctionne pas mieux ?

        ln c'est comme cp : source en 1er et destination en 2nd :-) (cf. le man ln).
        Bon après, c'est une erreur classique…

        • [^] # Re: Erreur ?

          Posté par  . Évalué à 2 (+0/-0). Dernière modification le 25/10/20 à 07:08.

          éventuellement supprimer /dev/cdrom d'abord, et le tout en sudo bien évidemment

          En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

          • [^] # Re: Erreur ?

            Posté par  (site Web personnel) . Évalué à 2 (+0/-0).

            et éventuellement le faire avec les droits appropriés :

            $ ls -l /dev/usb
            total 0
            crw-------. 1 root root 180, 96 24 oct.  18:46 hiddev0

            (je n'ai pas de lecteur CD)

            « Il vaut mieux mobiliser son intelligence sur des conneries que mobiliser sa connerie sur des choses intelligentes. »

          • [^] # Re: Erreur ?

            Posté par  . Évalué à 1 (+0/-0).

            oui, je n'ai pas encore essayé de supprimer /dev/cdrom.
            Une autre source m'a dit que le pb était de "monter" le CD.
            Le CD est bien vu par le système (Ubuntu 18) qui dit "disque audio".
            J'avoue que jusqu'ici (depuis 20 ans environ) je n'ai jamais monté de CD sur Linux, ils étaient accessibles sans problème, et heureusement le sont toujours avec des applis qui n'imposent pas cdrom (donc sr0 dans mon cas). J'ai demandé comment faire le montage, mais depuis la source s'est tue…
            Bonne fin de journée

        • [^] # Re: Erreur ?

          Posté par  . Évalué à 1 (+0/-0).

          oui, bien sûr.
          J'ai essayé avec différents paramètres…
          Merci

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.