Forum Linux.debian/ubuntu Casque usb : device descriptor read/64, error -32

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
1
14
juil.
2020

Hello

Config : Ubuntu 20.04 sur ordi fixe avec carte mère https://www.asus.com/fr/Motherboards/P8H77V
Je me suis récemment offert un casque usb (https://the-g-lab.tech/produit/korp-thallium).

J'ai un problème bizarre avec mon ordi : au bout d'un certain temps (ça peut être plusieurs minutes ou plusieurs heures), le casque semble se "déconnecter", il n'est plus reconnu.

La commande dmesg indique de messages du type :

[ 124.256179] usb 1-1.1: new full-speed USB device number 11 using ehci-pci
[ 124.336190] usb 1-1.1: device descriptor read/64, error -32
[ 124.524181] usb 1-1.1: device descriptor read/64, error -32
[ 124.632307] usb 1-1-port1: unable to enumerate USB device

Cela arrive, que je branche sur les ports en façade ou à l'arrière.
Est-ce un problème d'alimentation de ces ports usb ? Est-ce que je devrais prendre un hub usb alimenté ?

Merci

  • # mauvais contact ?

    Posté par  . Évalué à 3 (+2/-0).

    Salut,

    Ça pourrait être un problème d'alimentation ou un faux contact sur le câble ou la prise.

    J'imagine que tu as essayé sans la rallonge.
    Est-ce que ça le fait quand le casque est posé et que tu ne bouge pas le fil ?

    • [^] # Re: mauvais contact ?

      Posté par  . Évalué à 3 (+1/-0).

      Ça pourrait être un problème d'alimentation ou un faux contact sur le câble ou la prise.

      Oui, la première cause de panne ce sont les contraintes mécaniques. Hors tension, tester la continuité du câble (tout en le manipulant pour vérifier un court-circuit intermittent) puis passer un coup de nettoyant contact, enfin refondre les soudures des connecteurs (même si l'aspect a l'air bon, ça peut être foireux). Ça vaut pour toute sorte de branchements.

      Le problème d'alimentation est plus rare. Un périphérique USB déclare sa norme de vitesse et de puissance à la connexion et l'hôte s'y tient et à moins d'utiliser une carte type RPi qui ne peut pas fournir assez de courant, un périphérique USB 1 ou 2 ne pose généralement pas de soucis.
      Le plus fréquent dans ce cas de figure serait davantage une baisse de tension le long d'un cable mais ça serait étonnant pour celui fourni avec l'appareil. À tester tout de même à l'ohmètre et au voltmètre.
      Aussi, tester en désactivant les leds RGB puis dans le cas échéant en désactivant aussi le microphone.

      Une autre possibilité c'est la mauvaise conception ou le défaut de fabrication du casque qui peut entrainer une surchauffe du DAC, du microcontroleur ou des puces auxiliaires et un comportement erratique ou un plantage. Là aussi je suspecterai d'abord les leds, il s'est déjà vu des SSD qui plantaient à cause de la chaleur dégagée par leur rétroéclairage.

      Enfin après avoir écarté les problèmes matériels, on pourra soupçonner le logiciel (pilote, noyau, utilitaire). Ça coûte rien de chercher s'il y a des précédents.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.