Forum Linux.debian/ubuntu Gestion de xkb dans XWayland

Posté par  . Licence CC By‑SA.
Étiquettes :
4
23
août
2020

Salut ter'tous,

Je suis en train d'installer une Mint 20 sur une portable tout neuf pour ma fille, avec GNOME/Wayland comme bureau par défaut.

J'ai configuré fr-variant comme mapping de clavier par défaut, mais cette config n'est pas prise en charge dans les applis XWayland, comme firefox par exemple : le clavier reste en QWERTY. Dans les applis "natives" Wayland, le AZERTY est bien pris en compte.

Quand j'utilise la session Xorg, ça marche nickel avec le bon mapping.

Autre bizarrerie, quand j'ajoute un mapping dans la config de Gnome (en dessous de fr-variante), le mapping fr-variante se met à fonctionner dans firefox, mais ne marche plus après un reboot ou un reset de la session.

Avez-vous des idées ? Je peux continuer avec Xorg au pire, mais j'aime bien comprendre…

Merci d'avance !

  • # Gnome?

    Posté par  (site Web personnel) . Évalué à 2.

    Tu as installé Gnome manuellement alors, ou tu parles de Cinnamon?

    Ça a l'air d'être un bug, tu devrais poser la question sur les forums de Mint, ils seront plus à même de te répondre. Peut être que tu pourras ensuite ouvrir un rapport de bug.

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: Gnome?

      Posté par  . Évalué à 1.

      Salut,

      J'ai installé gnome-shell, gnome-session et gnome-core (+ gdm3 pour wayland) depuis les dépots de mint, puis désinstallé cinnamon

      …mais ça ressemble effectivement à un bogue dans mint.

      J'ai posté dans le forum de mint fr, mais je n'ai pas eu de réponse pertinente.

      Merci !

      • [^] # Re: Gnome?

        Posté par  . Évalué à 2. Dernière modification le 28/08/20 à 07:50.

        Salut,

        J'ai l'impression que ça ressemble au problème que j'ai évoqué il y a quelques temps.

        Par contre, désolé, pour le moment, je ne suis pas allé plus loin que la solution donnée :(

        Edit : et oui, à chaque reboot, il faut retaper la commande :(

        Matricule 23415

        • [^] # Re: Gnome?

          Posté par  . Évalué à 1.

          Retaper la commande à chaque reboot n'est pas une option pour ma fille… Je vais rester sur Xorg

          Merci !

          • [^] # Re: Gnome?

            Posté par  (site Web personnel) . Évalué à 2.

            Alors c'est pas une solution propre (ça résout pas la cause du problème), mais tu peux très bien faire exécuter cette commande automatiquement. Il y a un utilitaire "applications au démarrage" qui est fait pour ça ;)

            Un LUG en Lorraine : https://enunclic-cappel.fr

            • [^] # Re: Gnome?

              Posté par  . Évalué à 1. Dernière modification le 28/08/20 à 15:24.

              Salut,

              mais tu peux très bien faire exécuter cette commande automatiquement

              Ça, c'est du fix de fix :p

              Et probablement que le jour où tu te penchera sur le problème, tu aura juste oublié toute la chaine… parce que ce sera resté dans un coin (pan) sans tout mémoriser ou documenter.

              C'est le pire meilleur truc que je conseillerais. ;)

              Au moins, à chaque reboot, je me dis : faut que je pense à ça. Bon, j'oublie quasi instantanément vu que j'ai autre chose à faire de plus urgent, mais…. c'est toujours là ;)

              Matricule 23415

Suivre le flux des commentaires

Note : les commentaires appartiennent à celles et ceux qui les ont postés. Nous n’en sommes pas responsables.