Forum Linux.debian/ubuntu Problème de partage avec samba (et ordi sous W10)

Posté par  . Licence CC By‑SA.
Étiquettes :
0
21
août
2016

Bonjour à tous ! :)
Je viens à vous car j'ai un problème avec le partage de fichier de samba…
En effet depuis quelques mois je veux transformer une vieille tour en serveur NAS, j'ai donc installé Debian dessus mais je n'arrive pas a accéder aux fichiers partagés depuis windows 10 (j'ai suivis ce Tuto mais après l'avoir biens suivit je vais dans "Réseau" (toujours sous windows 10) je vois mon serveur, vais dessus, me connecte a un dossier, rentre un id, là ça fonctionne.
Mais quand je reviens en arrière (pour choisir un autre fichier) il y a le "home" de l'utilisateur avec qui je viens de me connecter qui apparait en fichier partagé et si je vais sur un autre fichier partagé et que je rentre un autre id ça me met une erreur comme quoi je n'ai pas les autorisations etc…
Je ne sais pas ce qui ce passe, je n'ai pas du tout modifié le fichier de config (a part pour ajouter les fichiers partagés), j'avais déjà fait des tests avant mais j'ai désinstallé et re installé samba par la suite… ça pourrais venir de la ?

n'hésitez pas a me demander plus de détails ou informations :)

En tout cas merci pour vos réponses ! :)

  • # As tu essayé la deconnexion ?

    Posté par  . Évalué à 2. Dernière modification le 24/08/16 à 15:41.

    Lu dans le tuto suscité:

    Nano est l'éditeur de texte de Linux, c'est l'équivalent de Word sous Windows.

    C'est sur qu'avec ce genre de rapprochement, linux sur le desktop c'est pas pour demain…

    Bref:
    Si je comprends bien, tu essayes de te connecter sur ton serveur , depuis le même client/session windows, avec des ID différents et simultanément ?
    1) Est ce que tes utilisateurs ont tous un compte sur le PC client ? (ou y a t'il plusieurs PC?)
    2) As tu d'abord essayé de te déconnecter du serveur samba avec ton 1er ID , puis tenté une connexion avec un second ID ? (déjà pour tester les comptes sur le serveur de fichier)

    Attention, je n'ai plus utilisé de winmachin depuis XP et la notion de groupe de travail qui était en vigueur semble obsolète sur win7/8/10. mais je doute que tu puisse avoir des connexions simultanées depuis la même session win de cette façon (façon = tuto openclassroom)
    ++

    PS: je me suis posé la question , donc pour se déconnecter de samba depuis win ça se passe comme ça selon Debian (et j'aime bien le "presque plus" du 2eme message..)

    • [^] # Re: As tu essayé la deconnexion ?

      Posté par  . Évalué à 3.

      Nano est l'éditeur de texte de Linux, c'est l'équivalent de Word sous Windows.

      Hihihi… Ahahah… OHOHOHOHOHOHOHOHOHOHOHOHOHOHO… Pfffff! L'équival… Pouahahhahahah !
      AHAHAHAHAHAHAHAHAAHAHAHAHAHAHAHAHAHAHAHAHAHAHAAHAHAHAHAHAHAHAHAHAHAHAHAHAHAAHAHAHAHAHAH…

      Ça fait longtemps qu'un fanboy linux ne m'avais pas autant fait rire. :')

      Merci ! Ça fait un bien fou !

      "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

  • # Impossible de ce déconnecter

    Posté par  . Évalué à 1.

    Bonjour et merci de vos réponses ! :)

    Déjà pour ma défense je n'avais pas vu cette ligne ! XD

    Oui en gros c'est ça (enfin pas simultanément par ce que je ne pense pas ça possible mais au moins pouvoir me déconnecter)

    Non, les utilisateurs ont seulement un compte serveur (pour pouvoir être accessible via n'importe quel PC chez moi) et la je teste depuis mon PC mais il y en a d'autre "connectables"

    En fait je pense que c'est ça le problème prsq je n'arrive pas a me déconnecter a moins de redémarrer l'ordi !
    Mais sinon en faisant ça j'ai testé les utilisateurs et ils fonctionnent, sur ça as de problème (enfin si, juste un, quand ils sont connectés leur /home apparait dans la liste des dossiers partagés ce que je ne veut pas !)

    Ce n'est pas un problème ^ Mais qu'entend tu par obsolete ?
    Prsq il y a biens un groupe de travaille dans w 7 et 10 :)

    Mais de toute façon mon but n'est pas d'avoir des connections simultanés mais pouvoir les couper

    Et je suis allé voir sur le liens que tu a mis et dans w10 il faut aller dans "Ce pc" --> gérer --> Gestion de l’ordinateur (local) --> Partage et tout est la mais même si je suis connecté au serveur (dossier ouvert, utilisateurs identifié etc) il détecte pas de de partage ou de sessions…

    (D'ailleurs je ne vois plus Samba dans l'onglet Réseau, j'ai du rentrer l'ip a la main dans la barre de recherche c'est peut etre ça)

    Bref, merci de vos réponses !! :)

    • [^] # Re: Impossible de ce déconnecter

      Posté par  . Évalué à 2.

      En fait je pense que c'est ça le problème prsq je n'arrive pas a me déconnecter a moins de redémarrer l'ordi !

      sous windows, pour se deconnecter d'un lecteur reseau, il faut faire :
      - clic droit sur le lecteur -> deconnecter
      ou
      - dans le navigateur de fichier, touche 'ALT' pour faire apparaitre le menu, et affichier le menu "outils" et choisir "deconnecter"

      • [^] # Re: Impossible de ce déconnecter

        Posté par  . Évalué à 1.

        Quand je crée un lecteur réseau et que je fais clique droit dessus ile me propose pas de me déconnecter et quand j'appuie sur Alt dans le partage il me propose pas un menu spécifique avec "Options"

        Et je viens de remarquer quelque chose, je me suis connecté en tapant l'ip du serveur dans la barre de recherche Windows et me suis connecté avec un utilisateur, et la mon serveur est réapparue dans l'onglet réseau de Windows et en cliquant dessus j'ai pu me connecter avec un autre identifiant (alors que j'avais la 1er fenêtre déjà ouverte)

        Merci

        • [^] # Re: Impossible de ce déconnecter

          Posté par  . Évalué à 2.

          pour la deconnexion faut que j'ouvre un windows10 pour te dire.

          pour la connexion,
          je penses que c'est le couple serveur/login qui est stocké
          donc selon que tu passes par nomduserveur/login ou IP/login, ca va changer la maniere dont le couple est stocké.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.