Forum Linux.debian/ubuntu problème de swap

Posté par (page perso) . Licence CC by-sa.
Tags : aucun
2
11
mai
2019

Bonjour à tous,
Pour une raison inexpliquée, le swap n'est pas actif : il y a bien eu une partition de faite à l'install
Mais au démarrage, il fait
bklid erreur
-t needs NAME=value pair
puis le swap n'est pas activé (d'ailleurs, j'ai déjà eu ce Pb sous Mageia)
Après quelques recherches, il est dit que sous Debian/Ubuntu, il faut utiliser les commandes mkswap et swapon swapoff. Or ces commandes n'existent pas (même sur root)
Mais je suis sur Debian 4.19.16-1 du 17/01/2019 (Sparky Gameover 5.17) donc c'est très récent.
Les commandes n'existeraient plus ?
Avez-vous une idée pour me dépanner ?
Merci

  • # comment verifies-tu l'activation du swap ?

    Posté par . Évalué à 4.

    chez moi je verifies que j'ai une partition swap avec

    blkid | grep swap

    et que ma machine peut l'utiliser

    free

    qui sur ma machine, swap desactivé (pas monté par fstab ou swapoff -a), indique 0 dispo, 0 used, 0 free

    root@g1:~# free
                  total        used        free      shared  buff/cache   available
    Mem:       32837616    10649968      551608     2986504    21636040    18728644
    Swap:             0           0           0
  • # variables d'environnement

    Posté par . Évalué à 6. Dernière modification le 11/05/19 à 19:07.

    Bonjour papap

    …Or ces commandes n'existent pas (même sur root)…

    Je pense que tu as dû te connecter sous le compte root
    en lançant simplement la commande su mais sans utiliser l'option - (ou -l ou --login)
    ce qui fait que les variables d'environnement spécifiques au compte root
    (dont le PATH) n'ont pas été prises en compte.

    Depuis ton compte utilisateur, pour te connecter sous le compte root
    utilise la ligne de commande suivante (sans oublier le tiret final)

    su -
    

    =================
    Pour information,
    un extrait de la page man de la commande su

    …
           -, -l, --login
               Fournir à l'utilisateur un environnement similaire à celui qu'il
               aurait obtenu s'il s'était connecté directement.
    …
    
    • [^] # Re: variables d'environnement

      Posté par (page perso) . Évalué à 4.

      bien vu, j'ai effectivement les commandes maintenant
      Je vais essayé tout ça
      Merci

      • [^] # Re: variables d'environnement

        Posté par . Évalué à 1.

        suis curieux d’avoir la suite !
        J'ai peut être bien le même problème sur un pc fixe sous Debian 9.
        merci d'avance

        • [^] # Re: variables d'environnement

          Posté par (page perso) . Évalué à 2.

          Alors puisque c'est gentillement demandé voici la suite:J'ai utilisé ce qui a été dit ci- dessus https://wiki.debian.org/fr/Swap et
          1) su -
          pour avoir accès aux commandes manquantes
          Puisque mon swap existe déjà, quelle est sa référence ?
          blkid | grep swap
          ensuite je l'active et vérifie qu'il marche
          swapon /dev/sda2
          free -m

          pour finir je complète /etc/fstab avec l'UUID de ma partition de swap
          _# Dedicated swap partition created on DATE
          UUID=N°partition_relevee_par_blkid none swap sw 0 0
          _
          Conclusion : La partition s'active bien au démarrage, mais j'ai toujours une erreur tout au début du démarrage du noyau disant
          bklid erreur
          -t needs NAME=value pair
          et plein de lignes blkid qui s'affichent
          Merci pour tout, ça va beaucoup mieux en tout cas.

          • [^] # Re: variables d'environnement

            Posté par . Évalué à 2.

            Workaround : remplace uuid=… par /dev/sdaX dans le fstab.
            Ça n'explique pas pourquoi le block id n'est pas reconnu, mais ça devrait permettre d'avoir le swap activé.

            • [^] # Re: variables d'environnement

              Posté par (page perso) . Évalué à 2.

              De mémoire swapon vérifie qu'il y a bien une signature de swap avant d'activer une telle partition, mais ce serait un peu dommage de pointer vers une éventuelle autre partition, le jour où il y aura des changements côté stockage…

              Debian Consultant @ DEBAMAX

          • [^] # Re: variables d'environnement

            Posté par (page perso) . Évalué à 1.

            Ce serait bien de voir les lignes de log, avec un peu de contexte autour…

            Debian Consultant @ DEBAMAX

            • [^] # Re: variables d'environnement

              Posté par (page perso) . Évalué à 2. Dernière modification le 12/05/19 à 16:13.

              Je veux bien fournir les lignes de log,mais à vrai dire, je ne sais pas où les trouver. Comme c'est tout au début,il doit s'agir du log du noyau ?
              sinon, il y a marqué : (tout au début après le démarrage du noyau)
              "Error unexpected child device config size 22 (expected 27 for VBT version)"

              • [^] # Re: variables d'environnement

                Posté par . Évalué à 5.

                si tu tapes la commmande
                dmesg

                tu vas avoir tout les logs du noyau

                si tu filtre avec | grep motif_de_recherche
                il ne va prendre que les lignes contenant le motif_de_recherche

                si tu veux les lignes AVANT ce motif, il faut l'option -B X
                X etant le nombre de ligne avant le motif

                si tu veux les lignes APRES ce motif, c'est -A Y
                Y etant le nombre de ligne apres le motif

                ainsi la ligne
                dmesg | grep blkid -A3 -B4

                affichera toutes les lignes contenant blkid, suivies de 3 lignes et precedées de 4 lignes

                • [^] # Re: variables d'environnement

                  Posté par (page perso) . Évalué à 3.

                  Alors, voilà le résultat des recherches :
                  dmesg | grep blkid -A3 -B4
                  ne donne rien
                  Du coup, mon message d'erreur "[ 8.015130] [drm:intel_bios_init [i915]] ERROR Unexpected child device config size 22 (expected 27 for VBT version 106)"
                  Ne concerne pas le swap mais la carte video : c'est le driver i915 qui est utilisé mais la carte c'est une i845. Apparemment,il règle ça tout seul:
                  [ 8.011122] agpgart-intel 0000:00:00.0: Intel 845G Chipset
                  [ 8.011141] agpgart-intel 0000:00:00.0: detected gtt size: 131072K total, 131072K mappable
                  [ 8.011276] agpgart-intel 0000:00:00.0: detected 8192K stolen memory
                  [ 8.011347] [drm] Replacing VGA console driver
                  [ 8.013869] Console: switching to colour dummy device 80x25
                  [ 8.014905] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
                  [ 8.014907] [drm] Driver supports precise vblank timestamp query.
                  [ 8.015130] [drm:intel_bios_init [i915]] ERROR Unexpected child device config size 22 (expected 27 for VBT version 106)
                  [ 8.017050] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
                  [ 8.026634] [drm] RC6 disabled, disabling runtime PM support
                  [ 8.026913] [drm] Initialized overlay support.
                  [ 8.026968] [drm] PMU not supported for this GPU.

                  Mais ça ne donne pas d'explications sur l'erreur blkid. Ceci dit, ça n'a plus l'air trop grave.
                  Merci à tout le monde pour l'aide

  • # Peut-être un vieux bug…

    Posté par . Évalué à 1.

    Bonjour


    au démarrage, il fait
    bklid erreur
    -t needs NAME=value pair

    Ça ressemble au message d'erreur retourné par ce vieux bug.

    Voir le message accessible par le lien suivant :
    https://alioth-lists.debian.net/pipermail/pkg-grub-devel/2016-October/015322.html

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.