Forum Linux.debian/ubuntu samba / fichier invisible dans un partage

Posté par  (site Web personnel) .
Étiquettes : aucune
0
1
juil.
2010

Bonjour,


L'écriture depuis un poste sous NT4 fonctionne cependant lister les fichiers du partage ne renvoie rien!
Pas de soucis d'authentification ( security = share )
Une idée ?

Le partage est défini comme ceci:


[NCPROHD]
browseable = yes
comment = Ncprohd
path = /home/ncprohd
guest ok = yes
force user = ncprohd
create mask = 0600
read only = no
  • # droits ?

    Posté par  . Évalué à 1.

    c'est quoi les droits pour l'utilisateur ncprohd sur le dossier /home/ncprohd ?

    parce que s'il cree un dossier, il va avoir les droits 0600 (soit RW-------)
    donc il ne pourra pas aller dedans :(
    • [^] # Re: droits ?

      Posté par  (site Web personnel) . Évalué à 1.

      extrait du man smb.conf:
      create mask

      This parameter does not affect directory masks. See the parameter
      directory mask for details.


      ls -ld /home/ncprohd
      drwxr-xr-x 3 ncprohd ncprohd 2576 jun 3 12:00 /home/ncprohd/


      Dans le répertoire les fichiers crées sont comme ceci:


      -rw------- 1 ncprohd ncprohd 102400 jun 3 12:00 truc95


      Je précise qu'à partir un poste sous xp, seven, il n'y a aucun soucis.

      Système - Réseau - Sécurité Open Source

      • [^] # Re: droits ?

        Posté par  . Évalué à 2.

        dans ton cas, vois tu les fichiers du dossier /home/ncprohd quand tu te connectes au partage NCPROHD ? ou rien du tout ?

        comment sais tu alors que le fichier a bien été copié ?
        si tu vois bien les "anciens" fichiers quand tu te connectes sur le partage, mais pas le nouveau fichier que tu viens de copier, c'est peut-etre un probleme de rafraichissement du dossier ou un probleme de cache de ce listing (un peu comme en FTP en fait)

        de memoire, il y a quelques années il fallait claquer des options dans la base de registre en fonction des windows (98/XP/NT4/2000) pour communiquer avec le samba en face.

        A l'epoque c'etait principalement pour une histoire de mot de passe, mais y avais peut-etre d'autre clé de registre pour permettre certaines options.
        • [^] # Re: droits ?

          Posté par  (site Web personnel) . Évalué à 1.

          Je ne vois rien à partir de la machine qui pose problème. ( machine électroerosion sous NT4 le tout en japonais...)

          Mais à partir d'un xp, ou seven aucun soucis les fichiers sont visibles.

          Oui, on pouvait autoriser les mots de passe en clair via le registre ou la stratégie de sécurité.

          Système - Réseau - Sécurité Open Source

  • # NT 4 ?

    Posté par  (site Web personnel) . Évalué à 3.

    Windows NT 4 ? Je pense que même Microsoft ne t'aiderait pas, sur ce vieux truc…
    • [^] # Re: NT 4 ?

      Posté par  (site Web personnel) . Évalué à 1.

      Je vais faire faire un test à partir d'un vrai pc sous nt4.

      Système - Réseau - Sécurité Open Source

    • [^] # Re: NT 4 ?

      Posté par  . Évalué à 2.

      Rhâ Punaise, ça me rappelle l'époque de la S.S.I.I. début 2000. Quatre heures de transport par jour pour aller bosser sur NT4, IE4, parfois quelques réseaux Novell, et − quand on avait de la chance (!) − des Windows 95. J'ai cru que c'était conçu exprès pour mettre des bâtons dans les roues de l'opérateur. J'en arrivait même à préférer Windows 3.1 parfois. En plus les machines étaient lentes. Ça prenait des heuuures entières à rebooter.
  • # Charset ?

    Posté par  . Évalué à 1.

    Ta machine étant en Japonais, ton problème ne peut-il pas venir du jeux de caractère qui n'est pas compris ? (Voir : http://man.chinaunix.net/newsoft/samba/docs/man/Samba-HOWTO-(...) par ex.)
    • [^] # Re: Charset ?

      Posté par  (site Web personnel) . Évalué à 2.

      Effectivement à tester:

      testparm -v | grep charset

      dos charset = CP850
      unix charset = UTF-8
      display charset = LOCALE


      L'utf-8 pose peut-être soucis à NT4.
      A creuser...

      Système - Réseau - Sécurité Open Source

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.