Forum Linux.debian/ubuntu XFCE volume pulseaudio

Posté par . Licence CC by-sa.
Tags : aucun
0
16
juin
2015

Bonjour,

J'en ai marre. Toujours un truc qui merdouille. J'ai installé une Debien que j'essaye de configurer avec XFCE. Tout va bien excepté le volume.

Pour régler le volume j'utilise les touches matérielles du clavier. La seule touche qui marche…? volume -. Mute et vol+ ne marchent pas. En gros, une fois le son baissé je dois ouvrir les paramètres pour le monter.

https://wiki.manjaro.org/index.php?title=Volume_bloqu%C3%A9_sur_Muet_%28bureau_XFCE%29

Grâce a ce tuto, j'apprends qu'il faut virer pulseaudio qui crée un conflit. OK, je le vire et je reboot. Cool, touets les touches marchent mais…j'ai plus de son ! Tout est a fond dans les paramètres audio mais aucun son émane de mon PC!

Avez-vous une idée ? Réinstaller pulseaudio j'ai pas envie puisque mes touches vont arrêter de fonctionner.

Merci de votre aide.

  • # comptabilité materielle ?

    Posté par . Évalué à 3.

    il faudrait en savoir plus sur ton materiel,
    car parfois avec certaines cartes sons il y a des options à passer au demarrage de la machine.

    de plus si tu a virer pulseaudio, il est posible que les parametres audios ne gerent plus ta carte.
    il faut donc utiliser un autre "mixer", par exemple alsamixer, et decocher l'option MUTE (son coupé) qui l'est parfois par defaut.

    • [^] # Re: comptabilité materielle ?

      Posté par . Évalué à 1.

      Merci de ton aide. Je possède cet ordinateur là.
      http://www.ldlc.com/fiche/PB00151192.html

      Alors j'ai monté les volumes dans alsamixer ("alsamixer" dans un terminal, si c'est de ça dont tu parles) mais si n'y fait. J'ai reinstallé pulseaudio pour voir si ça allait fonctionner de nouveau avec et c'est le cas. Mais les touches sont mortes.

      Je viens mieux regarde dans alsamixer ce soir. Peut-être que j'ai raté un truc.

  • # Commentaire supprimé

    Posté par . Évalué à -1. Dernière modification le 16/06/15 à 09:51.

    Ce commentaire a été supprimé par l'équipe de modération.

  • # La solution ?

    Posté par . Évalué à 3.

    J'ai eu le même type de problème en installant la dernière version de Debian.
    Chez moi, pour régler ce bug, j'ai installé les paquets suivants :
    -gstreamer0.10-alsa,
    -gstreamer0.10-pulseaudio,
    -gstreamer1.0-alsa,
    -gstreamer1.0-pulseaudio.
    Et configurer le mixeur de Xfce xfce4-mixer pour qu'il utilise Pulseaudio à la place de Alsa.

    PS:
    - Comme tu dois tant douter Pulseaudio doit être installé.
    - Pour que les paquets fonctionnent, un redémarrage est nécessaire.

    • [^] # Re: La solution ?

      Posté par . Évalué à 1.

      Cela n'a pas marché pour moi. En revanche, j'ai fait le contraire. J'ai viré proprement tous les paquets liés à pulseaudio et j'ai installé libalsaplayer0 et c'est parfait. Tout marche très bien. Voici le tuto suivi:

      http://forums.linuxmint.com/viewtopic.php?f=197&t=60485

      • [^] # Re: La solution ?

        Posté par . Évalué à 3.

        Je ne sais pas si c'est une solution de long terme. Tôt ou tard, tu risques de passer à Pulseaudio (sauf raison spécifique).

        J'ai eu un problème similaire agaçant avec Debian/Mate. Je pouvais muter mais pas démuter. Sur le fond, c'était en gros parce qu'ALSA attend une commande en mode toggle alors que Pulseaudio a une commande pour muter et une autre pour démuter. Quelque chose comme ça. Certains préconisaient donc un script ou je ne sais quoi pour démuter, mappé sur une touche clavier. La solution était plus simple : installer le bon backend pour le mixer Mate (donc le backend Pulseaudio).

        Pourquoi le gestionnaire de paquet ne l'a pas fait correctement de lui-même, je ne sais pas. (Et j'ai pas assez compris pour ouvrir le bug qu'il faut là ou il faut.)

        La solution qui t'es proposée au-dessus pour Xfce me semble de la même trempe et c'est ce que je chercherais à creuser pour laisser le problème derrière moi plutôt que de le repousser.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.