Forum Linux.débutant Linux sur Lenovo Flex 10

Posté par . Licence CC by-sa.
0
22
avr.
2018

Bonjour,

Avant toute chose je précise que je suis debutant sur Linux.

Je viens de choper un vieux Lenovo Flex 10 , je comptais installer OpenElec dessus pour Kodi.

J'ai formater le disque dur.

Puis j'ai tenter de l'installer avec une clé usb. Hééééé. Rien a faire,c'est impossible.

L'installation se passe bien,puis quand il faut reboot,impossible. Le pc me dit qu'il ne trouve pas comment boot…

J'ai essayer en vain pendant 4h.

HELP ME PLEASE.

Merci de vos réponses..

  • # distribution ?

    Posté par . Évalué à 2.

    Hello,

    Quelle distribution installe-tu ?

    Quel est le message d'erreur exact ?

    Au delà de ces questions, tu peux essayer de voir s'il n'y a pas un groupe d'utilisateurs de linux (GUL) dans ta région, ils pourront peut-être t'aider en direct…

    • [^] # Re: distribution ?

      Posté par . Évalué à 2. Dernière modification le 23/04/18 à 09:30.

      il semble que les reponses soient dans sa question initiale

      Quelle distribution installe-tu ?

      Je viens de choper un vieux Lenovo Flex 10 , je comptais installer OpenElec dessus pour Kodi.

      Quel est le message d'erreur exact ?

      Le pc me dit qu'il ne trouve pas comment boot…

  • # Ordre d'amorçage?

    Posté par . Évalué à 2.

    Peut-être un problème lié à l'ordre d'amorçage (sur quel périphérique chercher l'OS)?

    Sinon, tu démarres en mode BIOS ou UEFI?

    • [^] # Re: Ordre d'amorçage?

      Posté par . Évalué à 1.

      Je passe par le bios pour boot et installer l'os,puis quand je dois reboot je le laisse faire tout seul mais il ne trouve pas ou boot,donc je passe dans le bios pour lui dire ou il faut qu'il boot,et c'est la ou je vois qu'il n'y a aucun endroit ou boot,aucun disque est reconnu.

  • # Atom/Celeron

    Posté par (page perso) . Évalué à 1.

    C'est un processeur de type atom non ? Il me semble que le support du kernel est pas terrible, et c'est possible que ça ne juste marche pas. Je m'étais renseigné il y a un an, et quasiment aucune tablette/touchpad ne pouvait faire fonctionner correctement linux, dans le meilleur des cas, tu avais quelque chose qui boot mais sans wifi et sans son.

  • # Vidéo d'installation openelec sur levono flex 10

    Posté par . Évalué à 1. Dernière modification le 23/04/18 à 12:27.

    Quand j'essaie de rentrer les informations que tu nous donnes dans cet outil : http://www.data-labcenter.fr/pre-diagnostic-ligne/ , j'ai l'impression que le problème ne vient pas du disque dur, mais de l'installation d'OpenElec.

    Du coup, je suis allé trouver une vidéo qui détaille l'installation d'OpenElec sur un Levono Flex 10 : https://www.youtube.com/watch?v=Le1o7AS1qjU

    Est-ce que tout se passe bien comme sur la vidéo jusqu'au reboot ? Ou sinon, à quelle étape est-ce qu'il y a une différence ?

    edit : orthographe

    • [^] # Re: Vidéo d'installation openelec sur levono flex 10

      Posté par . Évalué à 1.

      En gros.

      Quand je met ma clé bootable avec l'installation de OpenElec, l'installation se passe sans aucun soucis. Il me demande de reboot. Et a se moment la j'ai une erreur me disant qu'il n'y a aucun périphérique sur quoi boot.

      Je suis passer dans le bios rien a faire,c'est comme si il n'y avait pas de disque dur.

      J'ai rechercher un peu sur internet, j'ai entendu parler d'un problème a cause du proco il me semble? Comme quoi c'est un processeur 64bits , mais qu'il faut boot en 32bits?

      Le problème c'est que la plus part des sites sont en anglais et très technique,j'y comprend pas grand chose..

      Merci de vos réponses!

      • [^] # Re: Vidéo d'installation openelec sur levono flex 10

        Posté par . Évalué à 1.

        Apparemment, ce que je vois sur le site http://www.havetheknowhow.com/Kodi/Kodi-Installation.html : c'est qu'il faut booter à partir de la clé USB (donc ouvrir le Bios à l'allumage et demander à l'ordi de boot depuis la clé USB).

      • [^] # Re: Vidéo d'installation openelec sur levono flex 10

        Posté par . Évalué à 3.

        Malheureusement, le site de ta distribution manque cruellement de documentation (et le lien pour installer redirige vers une page qui se contente d'afficher de la pub…) donc ça va être compliqué de taper dans le mille :)

        Si ta distribution te permets, lors de l'installation, d'avoir un accès à une ligne de commande, essaies de lancer la commande efibootmgr avec l'utilisateur root.
        Si le système te réponds, comme je le soupçonne fortement: «EFI variables are not supported on this system.» ou pire, s'il ne connaît même pas la commande, c'est simple: le démarrage UEFI n'est peut-être pas supporté out-of-the-box.

        Un UEFI (successeur du BIOS) ne détecteras que les OS enregistrés correctement. S'il n'en trouve pas, il n'indiqueras aucun «disque» de démarrage.
        Du coup, je suis quasi sûr que ton UEFI démarre en mode «moderne» (le mode «legacy» permettant la compatibilité avec les anciens mécanismes d'amorçage), donc nécessite une partition de démarrage en FATxx (souvent du FAT32, mais d'autres FAT marchent aussi) préparée pour un démarrage par UEFI, que ta distribution ne fait peut-être pas correctement.

        La doc pour installer syslinux du wiki d'archilinux contiens une section qui indique ce qu'un démarrage UEFI va chercher par défaut, quand on n'a pas encore eu la possibilité de démarrer en mode UEFI:

        When booted in BIOS mode, efibootmgr will not be able to set EFI nvram entry for /EFI/syslinux/syslinux.efi. To work around, place resources at the default EFI location: esp/EFI/syslinux/* -> esp/EFI/BOOT/* and esp/EFI/syslinux/syslinux.efi -> esp/EFI/BOOT/bootx64.efi

        Donc, si je résume un peu tout en français, pour préparer un système qui sera visible par un UEFI (sans secure boot, je précise, je ne connais pas du tout ce qu'il faut pour secure boot) il te faut:

        • un disque utilisant une table de partition de type GPT (toutes les distributions ne font pas nécessairement ça par défaut!);
        • une partition formatée en FAT32;
        • mettre le drapeau «ESP» sur cette partition;
        • qu'il y ait dans cette partition un fichier à l'emplacement suivant: EFI/BOOT/ (*) nommé bootx64.efi qui contiens le programme d'amorçage de ton système.

        Normalement, à partir de là, tu devrais voir ton système dans le BIOS.
        Si, comme supposé par d'autres, c'est un problème de 64 bits vs 32 bits, tu dois probablement utiliser un fichier nommé bootx32.efi (j'en ai vus dans ma debian, même si je n'y ai jamais eu recours). Au pire, rien n'empêche d'avoir les 2 côte à côte.
        Dernier point: personnellement, j'utilise syslinux, mais il en existe d'autres qui ont moins d'inconvénients (qui requièrent moins de manipulations lors de mise à jour de noyau, en fait).
        Ceci dit, l'avantage de syslinux, c'est sa simplicité de configuration, et comme il ne fait rien automatiquement, il est pratique pour diagnostiquer.

        *: à partir du point de montage de la-dite partition, c'est à dire si elle se situe dans /dev/sdc10, il te faut par exemple faire en root: mount /dev/sdc10 /tmp; mkdir -p /tmp/EFI/BOOT et mettre un fichier bootx64.efi ici.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.