Forum Linux.général Bios UEFI, disque non reconnu

Posté par . Licence CC by-sa.
Tags : aucun
1
15
fév.
2018

Bonjour,

J'ai acheté des pièces pour monter un PC afin de remplacer l'ordinateur familial qui avait rempli plus d'une décennie de service.

Je n'arrive pas a faire reconnaître le SSD dans le bios, alors qu'il est bien accessible si je boot depuis un live usb.
Après recherches, il est fort probable que c'est a cause de UEFI/Secure boot que je n'arrive pas à bien configurer.
J'avoue que je ne comprend pas grand chose au problème, j'ai essayé plein d'options sans succès, je dois en être a la 6eme réinstallation.

Tous ce passe bien pendant l'installation, mais au redémarrage, toujours pas de disque dans le bios.

La carte mère est une asus PRIME Z270-K lien vers la documentation en anglais, en français
Le SSD est un samsung 850evo (500Go).

Une âme charitable pourrait m'indiquer quelles sont les options à modifier à partir d'un bios par défaut pour pouvoir réinstaller et booter linux sans pb ?

Merci

  • # on se fiche du BIOS/EFI tant que l'OS voit le disque

    Posté par . Évalué à 4.

    donc en gros, branches ton disque sur la machine,
    boot la machine sur ton liveUSB,
    installes l'OS sur le disque dur, en mode UEFI,

    vires ton support liveUSB, ca doit fonctionner au reboot,

    si ca ne fonctionne pas avec le liveUSB (disant que l'OS n'est pas signé) alors il faut desactiver le "secure boot"

    sur les cartes ASUS, tu as aussi generalement une option "Compatibility mode" (CSM)
    qui, lorsqu'il est activé, permet de demarrer en mode BIOS les OS qui se declarent comme tel, et en mode EFI les autres.
    tu peux le desactiver pour etre en full EFI

    • [^] # Re: on se fiche du BIOS/EFI tant que l'OS voit le disque

      Posté par . Évalué à 1.

      J'ai tout remis les params par defaut, j'ai reinstalle l'os sans pb grace au liveusb et au redemarrage… pas de disque reconnu.

      J'ai active le CSM et tout refais. toujours pas de disque…

      Je ne comprend pas.

      • [^] # Re: on se fiche du BIOS/EFI tant que l'OS voit le disque

        Posté par . Évalué à 3. Dernière modification le 16/02/18 à 01:58.

        Si après l’installation tu redémarres à nouveau sur l’USB, que tu montes ton disque dur, que tu chroot dedans et que tu lances un grub-install ?

        https://doc.ubuntu-fr.org/tutoriel/comment_restaurer_grub , la procédure « Via un CD Ubuntu (procédure par chroot) », c’est la dernière de la page.

        J’avais galéré avec un portable que j’ai installé à quelqu’un, j’avoue que c’est « tombé en marche » sans que j’ai pu comprendre ce qui n’allait pas :(

        Et sinon, tu connais la touche pour accéder au menu de boot ? Il est présent dans la liste ton disque dur ?

        Je ne suis pas très sûr mais il me semble que le fait de booter sur un live, qui ne gère pas UEFI tout à fait de la même manière que le système qui va être installé, entraîne parfois ces problèmes de boot…

        Et sinon, quelle distribution ?

        Bonne chance.

      • [^] # Re: on se fiche du BIOS/EFI tant que l'OS voit le disque

        Posté par . Évalué à 1.

        Pas de disque ou pas d'OS ?
        Est-ce que le message indique "non system disk or disk error" ou un truc comme ça ou bien, il ne t'affiches pas de message d'erreur et pas d'information ?

        Sur les EFI récent provenant de chez ACER, j'ai du aller dans le bios pardon l'EFI et dans un obscur sous menu, aller lui indiquer de démarrer sur /boot/efi/EFI/Ubuntu64.cfg

        Dans certains cas, lors de l'installation, il faut bien faire attention à créer une partition /boot et une partition /efi (qui sera montée dans /boot au démarrage, mais ça l'installeur s'en charge) distincte du reste du système (en dehors de ces partition, chez moi tout le reste tiens dans une partition)

        Julien_c'est_bien (y'a pas que Seb)

  • # GPT

    Posté par (page perso) . Évalué à 2.

    Est-ce que ton disque est partitionné en GPT? Je crois que c'est nécessaire pour l'EFI.
    Si ce n'est pas le cas, il faudra créer une table de partition GPT sur ton disque.

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: GPT

      Posté par . Évalué à 1.

      Merci de ta réponse.
      J'ai vérifié. la table de partition est bien GPT

      • [^] # Re: GPT

        Posté par . Évalué à 2.

        Et il faut une partition EFI formatée en FAT

        • [^] # Re: GPT

          Posté par . Évalué à 2.

          La partition EFI est absente de sdb donc du ssd.
          Et vu le message sur sda j'ai comme l'impression que l'installateur n'a pas fait son job correctement

          sda1: __________________________________________________________________________
          
              File system:       iso9660
              Boot sector type:  Unknown
              Boot sector info: 
              Mounting failed:   mount: /mnt/BootInfo/sda1: /dev/sda1 already mounted or mount point busy.
          
          sda2: __________________________________________________________________________
          
              File system:       vfat
              Boot sector type:  FAT16
              Boot sector info:  According to the info in the boot sector, sda2 starts 
                                 at sector 0. But according to the info from fdisk, 
                                 sda2 starts at sector 2879436. According to the info 
                                 in the boot sector, sda2 has 0 sectors.
              Mounting failed:   mount: /mnt/BootInfo/sda1: /dev/sda1 already mounted or mount point busy.
          mount: /mnt/BootInfo/sda2: /dev/sda2 already mounted or mount point busy.
          
          sdb1: __________________________________________________________________________
          
              File system:       LVM2_member
              Boot sector type:  -
              Boot sector info: 
          
          ubuntu-vg-root: ________________________________________________________________
          
              File system:       ext4
              Boot sector type:  -
              Boot sector info: 
              Operating System:  Ubuntu Bionic Beaver (development branch)
              Boot files:        /boot/grub/grub.cfg /etc/fstab 
                                 /boot/grub/i386-pc/core.img
          
          ubuntu-vg-swap_1: ______________________________________________________________
          
              File system:       swap
              Boot sector type:  -
              Boot sector info: 
          

          Plus précisément la partie :

          According to the info in the boot sector, sda2 starts
          at sector 0. But according to the info from fdisk,
          sda2 starts at sector 2879436. According to the info
          in the boot sector, sda2 has 0 sectors.

          Ca sent le truc qui a mal tourné. Puis comme dit à moins que tu démarres en mode legacy tu as besoin de cette partition sur sdb.

          • [^] # Re: GPT

            Posté par . Évalué à 1.

            Après une semaine de bidouille dans tous les sens, je me suis résigné a acheter un autre petit ssd.
            Je m'en sers pour le boot et OS. Tout a marché du 1er coup.
            Je penche donc pour une anomalie du ssd ou une incompatibilité avec la CM.

            Merci pour les réponses.

  • # pour information....

    Posté par . Évalué à 3.

    quelques notions de base que les linuxiens ont du mal à bien comprendre :

    -un système efi est différent du bios, mais avec une interface copiée
    -un système avec le LEGACY ou CSM ou COMPATIBLE activé est un bios émulé (essayez de démarrer un windows 7, qui est dans l'incapacité absolue de démarrer en full-efi sans CSM, càd sans bios émulé)
    -pour vérifier qu'un ordi est en mode bios ou full-efi :
    amorçez windows 8, si le logo est celui de windows => bios, si c'est le logo du fabricant de l'ordi => efi
    -avec efi, on a plus de mbr mais du gpt
    -avec efi, le mode d'amorcage est lié à la carte mère : si l'ordi marche, que vous déplacez le disque dur ailleurs ou que vous le ramenez, vous serez peut etre amené à le réinstaller :
    lors de l'installation en mode efi, l'ordi indique à la CM/efi sur quel fichier démarrer, car il ne le fait pas tout seul.

    exemple avec toshiba :
    csm/legacy désactivté, t'as un win8 et fedora.
    tu remplaces le disque par un autre que tu passes en csm pour booter win7 ou autre => ca marche
    tu remets ton ancien disque avec win8/fedora et tu repasses en efi => tu dois réinstaller ton grub pour déclarer ton boot à l'efi. C'est très chiant mais obligatoire et systématique

    à savoir :
    tous les appareils ne permettent pas de désactiver le legacy/CSM/compatible
    à vraiment savoir :
    un windows 7 est absolument incapable de démarrer en full efi :
    As well as disabling Secure Boot, it is also necessary to enable the UEFI BIOS Compatibility Support Module (CSM) to install Windows 7. This is for fairly technical reasons – specifically that the Windows 7 default video driver (vga.sys) doesn’t support the UEFI graphics output protocol (GOP).

    à absolument retenir :
    en 2015, seules deux grosses distributions étaient capables de ddémarrer en full-efi :
    ubuntu (version internationale) et fedora.

    la distinction à l'allumage est flagrante, notamment de par la définition d'écran de grub et la rapidité. De plus, Grub-efi communique bien avec le bios pour trouver les partitions et organiser un bootloader. Le changement de HDD d'une machine efi entraine généralement la nécessité de réinstaller grub (c''est con, mais sur plusieurs marques ca reste ainsi)

  • # BIOS/Firmware

    Posté par . Évalué à 3. Dernière modification le 17/02/18 à 11:35.

    Bonjour,

    Vérifies que le firmware de ton SSD est à jour => http://www.samsung.com/semiconductor/minisite/ssd/product/consumer/850evo/

    Vérifies aussi le BIOS de ta carte mère => https://www.asus.com/fr/Motherboards/PRIME-Z270-K/HelpDesk_BIOS/
    Il faudrait qu'il soit en version 809. La version 1002 n'apporte que la mise à jour des microcodes buggés d'Intel donc il ne faut pas l'utiliser.

    Ton SSD a été acheté neuf ?

    • [^] # Re: BIOS/Firmware

      Posté par . Évalué à 1.

      Merci pour ta réponse.

      J'avais déjà mis a jour le bios de la carte mère en 1002 en espérant que cela change quelque chose.

      Je viens d'essayer de mettre a jour le firmware du SSD mais il est déjà à la dernière version (EMT02B6Q).

      Oui, le SSD est neuf.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.