Debian Sarge : ça arrive

Posté par . Modéré par Christophe Guilloux.
Tags :
0
31
juil.
2004
Debian
Ça y est, le cycle de développement de Debian Sarge vient d'amorcer un tournant important.

En effet, la base de Debian est gelée à partir d'aujourd'hui (31 juillet) afin de permettre de finaliser l'installeur (pour une RC2). Le nombre de bogues critiques pour la publication (aka bugs RC) est suffisamment faible pour espérer une sortie officielle de Sarge courant Septembre (NdM : de cette année).

Au menu des choses habituelles sous Debian : le système de paquet rock-industrial-business-power-strength avec pour les utilisateurs moins avertis l'excellent synaptic, et la qualité habituelle de cette distribution.

Au niveau des nouveautés, l'abandon de non-us, et côté logiciels : GNOME 2.6, KDE 3.2.3, Linux 2.4 ou 2.6 au choix, une internationalisation plutôt bien gérée, et plus de 10000 paquets afin que tout le monde puisse y trouver son bonheur.

Selon les rumeurs les plus indiscrètes, une première mise à jour de la version finale pourrait rapidement suivre la sortie officielle afin de parfaire les rares problèmes qui pourraient rester. Par contre, l'architecture amd64 ne devrait pas faire partie des architectures officielles de sarge (sauf retournement de situation de dernière minute, sait-on jamais).

Aller plus loin

  • # Joli !

    Posté par . Évalué à 10.

    Mouahahahaha, j'adore la NdM, ou comment lancer un troll en deux mots... Ça aura au moins le mérite de faire taire ceux qui dise que DLFP est résoluement pro-Debian, mais à mon avis, le lancer de troll ne va quand même pas rater...
    Sur une touche moins inintéressante, j'encourage tout un chacun à tester le nouvel installateur, il est vraiment sympa, et si vous avez une architecture un peu exotique (comprendre: non-x86), je vous y encourage doublement, ça aidera à chasser et donc corriger les vilains bogues.
    Et puis tiens, une question pour finir: qu'est-ce qui est nouveau dans l'internatonalisation ? ça fait un moment que apt, debconf & cie sont traduits, donc quelle est la nouveauté ? plus de langues ?
    • [^] # Re: Joli !

      Posté par . Évalué à 3.

      J'ai eu l'occasion de tester le nouvel installeur, et il est en effet très bien : beaucoup plus clair que l'ancien et la configuration se fait plus simplement. Seul problème, le partitionnement n'a pas pu être fait sur mon PC, à cause d'une organisation particulière de mes partitions, mais après un gros nettoyage c'est passé. À part ça, aucun problème : installation par le réseau nickel.

      Sinon, une autre nouveauté importante est le passage à grub par défaut.
      • [^] # Re: Joli !

        Posté par . Évalué à -4.

        t'as nouveauté importante m'empêche d'avoir XFS en partition racine, alors je suis obligé de resté avec lilo, les boules...
        • [^] # Re: Joli !

          Posté par . Évalué à 1.

          il te donne un avertissement mais tu peux passer au dessus en bidouillant un peux... et ca fonctionne plutôt bien :)
        • [^] # Re: Joli !

          Posté par . Évalué à 3.

          Tu veux pas te faire un petit /boot de qlqs Mo en ext2/3, où tu colles tes noyaux et ton grub ? C'est une pratique assez courante, et ça permet d'être plus fantaiste sur la partoche racine.
          • [^] # Re: Joli !

            Posté par (page perso) . Évalué à 2.

            En même temps, quel intérêt d'avoir XFS pour la partition racine ?
            Selon les besoins, je préfère avoir une partition dédiée, comme pour cyrus ou samba, et là, on mets XFS pour un gain de performance.
    • [^] # Re: Joli !

      Posté par . Évalué à 2.

      Le nouvel installateur est vraiment trés pratique et rapide à configurer (rien à voir avec l'ancien installateur). Par contre, un gros défaut, je trouve, c'est le gestionnaire de paquets aptitude (à par si le probléme est ma mauvaise utilisation de cet outil?), car il m'a installé KDE et GNOME sans que je choisisse aucun paquet en lien à ces WM... ou alors, la séléction était bien cachée, mais alors où?
      • [^] # Re: Joli !

        Posté par (page perso) . Évalué à 3.

        Je ne suis pas vraiment du meme avis sur l'installeur, je l'ai utilisé hier, je m'attendais à mieux vu les commentaires.

        L'outil de partionnement(partman) n'a rien d'intuitif, il n'y a aucune doc correcte. Des symboles ascii apparaissent sans raison apparente(ni la moindre explication) dans la page principale: un éclair, un smiley, une tete de fourmi, niveau clarté, c'est génial. La traduction française est nulle(et pas que dans partman, mais j'y reviendrai plus tard pour le reste). Quand on modifies les propriétés d'une partition, il y a "Indicateur d'amorcage". C'est quoi? Aucune explication, rien. Apres renseignement pris sur la tribune, ça servirait a placer le secteur de démarrage sur la partition, pas un mot a propos des possiblité, de grub, lilo... RIEN
        Toujours a propos de partman, quand je lui dit appliquer les changements comme je lui ai dit(formater 3 partitions et monter une ext3 en tant que /home), il commence a me dire qu'il ne supporte pas le redimensionnement de partitions ext2(totalement débile vu que je ne lui ai jamais demandé de redimensionner la moindre partition), une erreur suit, il retourne a l'écran principal de partman, je lui dit de ne plus s'occuper de la partition /home et la, tout passe sans probleme.


        La sélection des packages est aussi une vraie misère, j'ai eu le même problême avec kde et gnome qui était tout les 2 sélectionnés, parce que la catégorie desktop était sélectionnée. Bon, un des 2 ok, mais les 2, ça commence à devenir lourd. Il aurait put y avoir une sous question pour demander le wm que l'on veut.
        Pour une sélection plus précise des packages, il lance aptitude(il y aurait moyen de choisir parmis tasksel et dselect, mais j'ai dut louper l'écran). Ce logiciel est vraiment une bouse monstrueuse! L'écran principal n'indique même pas le raccourci pour sélectionner ou désélectionner un package, il faut aller voir dans l'aide(qui chose rare existe et est facilement accesible par la touche ?).
        Quand on essaye de déselectionner un paquet dont d'autres dépendent, il pourrait demander ce dont on veut faire des dépendances, soit virer tout, soit laisser le paquets qu'on essaye de virer, ici, rien. Il ne fait qu'afficher en rouge les paquets dont certaines deps manquent. C'est a vous de les rechercher à la main pour les virer.
        Il y a aussi la maniere dont sont trié les packages. Quand on cherches galeon par exemple, ce n'est pas dans la catégorie web, mais dans gnome, c'est logique si on sait que galeon utilise gnome mais si on ne le sait pas, c'est pas tres simple a trouver. Il faudrait la possibilité de mettre un packages dans plusieurs catégories.

        Il y a aussi la traduction française qui m'a énervée. Ça parle de cédérom, mandataire http... C'est tellement traduit à l'extreme que ça en devient ridicule et inutilisable, qui utilise ces termes ou orthographes? Personne à part les intaigristes.

        Ma conclusion, c'est que l'installation de la sarge m'a pris 3h(mais il y a quand meme eu 1/2h de téléchargement) tellement c'est mal expliqué, mal traduit(ça aurait été plus simple de faire l'installation en anglais) alors que toutes les autres distros que j'ai utilisé(mdk, slack, suse) s'installent en 15 ou 20 min
        • [^] # Re: Joli !

          Posté par (page perso) . Évalué à 4.

          Quand on essaye de déselectionner un paquet dont d'autres dépendent, il pourrait demander ce dont on veut faire des dépendances, soit virer tout, soit laisser le paquets qu'on essaye de virer, ici, rien. Il ne fait qu'afficher en rouge les paquets dont certaines deps manquent. C'est a vous de les rechercher à la main pour les virer.

          Il suffit pourtant d'appuyer sur "Entrée" alors que le dit paquet est sélectionné.
          Apparaît alors la liste des dépendances du paquet en question...
          • [^] # Re: Joli !

            Posté par (page perso) . Évalué à 0.

            Il n'est dit nulle part dans l'aide qu'appuyer sur "Entrée" permet de rajouter ou supprimer un package. Il est juste mis "Afficher les informations à propos d'un paquet". Vraiment super clair. Il faut donc le deviner par soi meme?
        • [^] # Re: Joli !

          Posté par . Évalué à 6.

          Aptitude est l'un des meilleurs frontend à APT. Que tu ne le connaisses pas, ok, mais que tu sois de si mauvaise fois, c'est ahurissant. Ce logiciel est super bien documenté, configurable a souhait et disposant de deux interfaces, l'une en ncurses et l'autre en ligne de commande sur le modèle de celle d'apt-get. Il possède aussi des fonctions de recherche très puissantes, plus que celles d'apt-cache. Le choix par défaut de tri des paquets n'est peut-être pas le meilleur, soit, mais ce la se change.

          Pour la traduction, je vois mal un débutant voulant installer debian, avec un installer bourré d'angliscismes et jargonnage et autres débilités de ce genre. Cracher sur le travail des traducteurs comme tu le fais et vraiment nul. Ils ont fait un choix qui se tourne plus vers l'utilisateur final que vers le vieux barbu qui connait tout le jargon informatique sur le bout des doigts.
          • [^] # Re: Joli !

            Posté par (page perso) . Évalué à 3.

            Aptitude est l'un des meilleurs frontend à APT.

            Il ne doit pas y en avoit beaucoup alors.

            mais que tu sois de si mauvaise fois, c'est ahurissant.

            Je ne comprend pas, je fait une critique la plus objective possible en me basant sur toutes les installations que j'ai faites depuis des années, j'explique clairement les problemes que j'ai rencontré, je fais des comparaisons avec d'autres solutions qui fonctionnent mieux et c'est moi qui suis de mauvaises fois?

            Ce logiciel est super bien documenté

            Pas lors de l'installation, on a juste droit au fichier d'aide.

            Il possède aussi des fonctions de recherche très puissantes, plus que celles d'apt-cache.

            Ou sont elles expliqué dans LA page d'aide?

            Cracher sur le travail des traducteurs comme tu le fais et vraiment nul.

            Je ne craches que sur le travail mal fait.

            Ils ont fait un choix qui se tourne plus vers l'utilisateur final que vers le vieux barbu qui connait tout le jargon informatique sur le bout des doigts.

            C'est totalement faux, tu n'a pas dut lire correctement ce que j'ai dit. Personne ne parle de mandataire http, l'utilisateur de base ne sait pas ce que c'est, son fai lui fournit des adresses de son proxy, pas de son serveur mandataire http
            • [^] # Re: Joli !

              Posté par . Évalué à 3.

              Il ne doit pas y en avoit beaucoup alors

              apt, dselect, aptitude, synaptic, kpackage, debfoster, debwrap, gnome-apt
              Moi je trouve que ca fait déjà pas mal pour un système de gestion de dépendances.

              Je ne comprend pas, je fait une critique la plus objective possible en me basant sur toutes les installations que j'ai faites depuis des années, j'explique clairement les problemes que j'ai rencontré, je fais des comparaisons avec d'autres solutions qui fonctionnent mieux et c'est moi qui suis de mauvaises fois?

              La ce n'est plus des problèmes que tu exposes mais des jugements de valeurs.

              Pas lors de l'installation, on a juste droit au fichier d'aide.

              Faux, faux et faux, tu as un menu en haut de l'interface, il te suffit d'appuyer sur F10 et d'aller dans le menu aide et de choisir manuel de l'utilisateur.

              Ou sont elles expliqué dans LA page d'aide?

              Dans le manuel que tu n'as pas réussi à trouver.

              Je ne craches que sur le travail mal fait.

              Mouais, le travail n'est pas mal fait, il vient parfois d'une discussion sur la liste de traduction, cela a meme encore été débattu ces derniers jours. Le choix s'est porté sur « chargeur d'amorçage » il me semble.

              C'est totalement faux, tu n'a pas dut lire correctement ce que j'ai dit. Personne ne parle de mandataire http, l'utilisateur de base ne sait pas ce que c'est, son fai lui fournit des adresses de son proxy, pas de son serveur mandataire http

              Oui et ?
              Si ça ne te convient pas, tu n'a qu'à envoyer un message sur la list de traduction pour que l'on t'explique les choix qu'on fait les traducteurs.

              Au cas où, il y a une doc sur l'installation de sarge, as-tu pris le temps de la lire avant ?
              • [^] # Re: Joli !

                Posté par . Évalué à 0.

                >Oui et ?
                >Si ça ne te convient pas, tu n'a qu'à envoyer un message sur la list de traduction
                >pour que l'on t'explique les choix qu'on fait les traducteurs.

                Il dit juste qu'il voudrait pouvoir installer simplement et rapidement une distribe en comprenant ce qu'il y a écrit....son but n'est pas de rentrer en contact avec les devels debian pour boire un pot avec eux.
                Il se trouve donc que le nouvel installeur est à chier, il serait grand tant de l'admettre et d'y remédier plutôt que de dire que c'est de la faute de l'utilisateur....
                La prochaine fois l'installation se fera à l'aide de rébus longuement débatus sur la mailing-list donc se sera forcément très intuitif...c'est ça ton raisonnement???lol
          • [^] # Re: Joli !

            Posté par . Évalué à 5.

            Je vois mal un débutant voulant installer debian, avec un installer bourré d'angliscismes et jargonnage et autres débilités de ce genre.
            Celui qui installe Debian (ou une distribution Linux en général) a un minimum de connaissance en inforlatique en comprendra mieux "proxy" que "serveur mandataire". Et celui qui ne comprend pas "proxy" ne comprendra pas non plus "serveur mandataire" (serveur ? c'est celui qui sert les plats aux restaurants, qu'est ce que ça a à voir avec internet ?)
            • [^] # Re: Joli !

              Posté par (page perso) . Évalué à 1.

              Pour info, la comparaison est souvent utilisée entre serveur (informatique) et le serveur du restaurant... Il y a des clients qui demandent et des serveurs qui apportent les plats, comprennnent les commandes, etc...
        • [^] # Re: Joli !

          Posté par . Évalué à 7.

          ya pas de cabale sur linuxfr..

          Moi je crois que ce post est interressant. Pour avoir joué un peu qvec partman, je trouve ce soft aussi vriament pas terrible.
          Il sort des erreurs sur les partitions ext3, et il est surtout pas du tout efficace. diskdrake en mode texte est encore mieux..
        • [^] # Re: Joli !

          Posté par . Évalué à -1.

          Ce logiciel est vraiment une bouse monstrueuse!

          Tu ne disais pas ça il y a quelques temps : http://linuxfr.org/comments/282115.html#282115(...)
          • [^] # Ratai !

            Posté par . Évalué à 0.

            C'est pas le même Tramo :)

            M
            • [^] # Re: Ratai !

              Posté par . Évalué à 0.

              que donne le dernier recensement, au fait ?
          • [^] # Re: Joli !

            Posté par . Évalué à 8.

            Etant utilisateur non voyant j'ai eu des difficultés pour avoir le support de ma barrette braille lors du chargement de l'installateur. La seule méthode qui a fonctionné pour moi a été de démarrer sur une Knoppix, créer mes partitions à la main avec fdisk, mettre le système de fichier qui va bien avec mkreiserfs par exemple, puis d'utiliser l'outil debootstrap pour récupérer les paquets de base. J'ai ensuite édité les fichiers fstab et rcS à la main, installer un noyau et terminé l'installation avec apt-get dans un chroot sans oublier la commande lilo avant le reboot.
            En conclusion, heureusement qu'il existe une méthode alternative pour installer une Debian sans passer par les outils d'installation.
            • [^] # Re: Joli !

              Posté par . Évalué à 7.

              Bonjour,

              pour votre installation, avez-vous testé l'image faite à l'attention des non-voyants ?

              L'image de la disquette se trouve sur http://people.debian.org/~joeyh/d-i/images/daily/floppy/access(...)
              • [^] # Re: Joli !

                Posté par . Évalué à 1.

                >pour votre installation, avez-vous testé l'image faite à l'attention des non-voyants ?<

                Merci beaucoup pour l'info, j'ignorai l'existence de cette possibilité, le hic est que mon ordinateur portable ne dispose pas de lecteur de disquettes. Je vais essayer d'adapter l'image afin de la graver sur un CD.
        • [^] # Re: Joli !

          Posté par . Évalué à 10.

          Bonjour,

          j'ai lu votre message, parce que quelqu'un a posté le lien sur la liste de traduction debian-l10n-french qui est en charge de la traduction française pour Debian. La première des choses, pour quelqu'un qui se revendique de la communauté du libre, c'est déjà de faire des rapports de bugs utiles. Quelle est l'utilité de ce genre de message ? Non pas que je veuille défendre Debian, parce que je suis Développeur, mais concrètement ce post, transpire l'hypochrisie. (Si vous avez utilisé Mandrake vous auriez du vous rendre compte qu'ils utilisent également le mot de mandataire. Je ne vois pas qui ne comprend pas ce que veut dire mandataire. Il ne faut pas sortir d'une grande école pour comprendre.)

          Mais passons, là n'est pas l'essentiel. J'aimerai avant tout préciser que partman est un outil qui fonctionne sur 11 architectures matérielles différentes. Vous me direz sans doute que ça vous fait une belle jambe parce que vous utilisez une machine de type i386, mais ne l'oublions pas. Debian est aujourd'hui la seule distribution linux à offrir ce genre de service.

          Ensuite pour ce qui est de la traduction, je vous ferai remarquer qu'il y a un travail formidable qui a été effectué pour cette version de la Debian - pas uniquement pour le Français, même les langues dites de droite à gauche sont prises en compte (Bidi pour les connaisseurs). Je passe également sur la méthode d'installation pour les non-voyants. Donc que partman soit perfectible, je suis tout disposé à le croire, mais proposez-nous quelque chose. Tout le monde peut participer à Debian, sans discrimination. Commencez déjà par nous dire dans un rapport de bogue, comment vous envisagez une amélioration de cet outil.

          Donc, et j'en terminerai là, je pense que le vrai problème n'est pas tellement Debian, mais que Debian n'est pas la solution qui vous convient. Pourquoi n'utilisez-vous pas une knoppix ou la distribution de progeny ?

          Pierre Machard <pmachard@debian.org>
          • [^] # Re: Joli !

            Posté par . Évalué à 5.

            Je ne vois pas qui ne comprend pas ce que veut dire mandataire. Il ne faut pas sortir d'une grande école pour comprendre.

            Bah moi, qui n'ai fait qu'une moyenne école, mais qui suis maintenant quand même assez loin d'être un newbie de l'info, et qui sait depuis quand même pas mal d'années ce qu'est un proxy, je n'ai pas deviné en lisant le post initial ce que pouvait bien être ce fameux "mandataire". Peut-être que dans le contexte le déclic se serait fait (parcequ'il ne doit pas y avoir 36 possibilités), mais comme ça à froid, bah sincèrement, non.

            Globalement je rejoins ceux qui pensent que le meilleurs mot pour désigner une chose est celui le plus courament employé, parce que c'est celui qu'un maximum de gens comprennent (je ne parle pas en général bien sûr, mais seulement dans les cas où la langue est purement utilitaire, et non pas une fin en soit, bref dans un cas tel que l'installeur Debian). Ou bien alors, pour que tout le monde soit content, pourquoi ne pas utiliser "blablabla ... mandataire (proxy) ... blablabla". Certes c'est redondant, mais le but est d'être compris, et dans des cas comme ça je pense que ça aiderait.


            Bon après, sur le fait qu'un rapport de bug est plus constructif qu'un commentaire linuxfr, là je ne peux te pertinenter.
            • [^] # Re: Joli !

              Posté par . Évalué à 2.

              En entreprise et même dans les services informatiques, "proxy" désigne tout et n'importe quoi pour la plupart des gens : le cache mutualisé (son vrai sens si je ne m'abuse... :-), mais aussi le firewall, l'antivirus de messagerie, le dispositif d'authentification pour la connexion Internet, le filtre pour les images lestes...

              Regardez vos rues, vos magazines ou la télévision : les services marketting (marquetique ?) ne conçoivent que l'anglais pour frimer, surtout si personne ne comprend le sens précis des termes, et c'est également très vrai en informatique bien sûr... Autre manière de le dire : pour les Marchands qui nous gouvernent, il n'est que les Etats-Unis qui vaillent, français c'est ringard.

              Sur ce, "serveur mandataire", ça fait un peu notaire ; c'est très français.
          • [^] # Re: Joli !

            Posté par (page perso) . Évalué à 1.

            La première des choses, pour quelqu'un qui se revendique de la communauté du libre, c'est déjà de faire des rapports de bugs utiles. Quelle est l'utilité de ce genre de message ?

            Je l'ai installé il y a 2 jours au soir, et j'ai pas vraiment le temps pour le moment. Je voulais juste faire la remarque que l'installeur n'est pas parfait et que ceux qui le trouvent bien ne doivent avoir tester que l'ancien installeur.


            Mais passons, là n'est pas l'essentiel. J'aimerai avant tout préciser que partman est un outil qui fonctionne sur 11 architectures matérielles différentes.

            Le fait qu'une programme soit multi architecture ne le rend pas bon pour autant. Il y en avait d'autres: diskdrake , qtparted par exemple. La mandrake tourne sur x86, ia64, amd64, ppc, sparc, alpha, diskdrake doit surement aussi tourner dessus. Pourquoi est ce que debian a choisi le plus pourri?


            Donc, et j'en terminerai là, je pense que le vrai problème n'est pas tellement Debian, mais que Debian n'est pas la solution qui vous convient. Pourquoi n'utilisez-vous pas une knoppix ou la distribution de progeny ?

            Parce que je ne les aiment pas trop et aussi parce que je teste régulierement les nouvelles versions de la plupart des distributions, je ne reste pas plusieurs années en faisant des critiques sur la mandrake parce que j'e n'ai pas aimé la 6, que la woody est dépassée...
          • [^] # Re: Joli !

            Posté par . Évalué à 2.

            Il est évidemment plus utile de faire un rapport de bug complet, de contribuer au libre, et patati et patata, mais c'est sont droit le plus strict de lancer à tord et à travers sur les forums qu'il souhaite qu'il n'aime pas un outil et qu'il pense qu'obtenir un message l'informant d'un echec de redimensionnement alors qu'il n'a rien demandé est pour le moins curieux.

            Sinon, on peut à l'extrème directement aussi aller interdire tous les tests de distro, sauf si le testeur à recu l'autorisation expresse de tout le staf de la distro en question et que pour chaque point positif ou critiqué il envoit ses félicitations ou un rapport de bug.
          • [^] # Re: Joli !

            Posté par (page perso) . Évalué à 4.

            Je ne vois pas qui ne comprend pas ce que veut dire mandataire. Il ne faut pas sortir d'une grande école pour comprendre.

            Bah moi je ne comprends pas ce que veut dire mandataire, j'ai bien mis 5 minutes en lisant ce troll pour comprendre que ça voulait dire "proxy" et encore je n'en suis même pas sûr, parce que depuis que j'ai débuté en informatique (et que j'ai débuté sous Linux) j'ai toujours vu écrit "proxy" et je n'ai strictement jamais vu "mandataire".
            De telles traductions sont complètement ridicules dans le sens où elles ne vont faire qu'accentuer l'incompréhension des débutants en les noyant sous un vocabulaire francisé non-couvert par les bouquins qu'ils trouveront à droite ou à gauche. Avec une politique pareille, on va se retrouver comme sous Windows avec une VF inutilisable tellement les traductions sont incompréhensibles.
            • [^] # Re: Joli !

              Posté par . Évalué à 2.

              Pour ceux qui ont du mal avec les mots en français où qui cherche la traduction la plus correcte, je rappele l'existence du grand dictionnaire terminologique de nos amis quebecois

              http://www.granddictionnaire.com/btml/fra/r_motclef/index1024_1.asp(...)
            • [^] # Re: Joli !

              Posté par (page perso) . Évalué à 1.

              bof, je voie dans les bons prg traduits en *vrai* francais: "serveur mandataire"
              seulement y a 7 ans quand j'ai commencé linux, il n'y avait que l'anglais, donc c'est normal qu'a l'epoque on voyait que ecrit "proxy"
              • [^] # Re: Joli !

                Posté par . Évalué à 3.

                Le *vrai* français il est un peu à la traine en matière d'informatique. Cette expression de « serveur mandataire » ne veut rien dire et n'est même pas correcte en *vrai* français (où un mandataire est une personne). Peut-être que dans qlqs années, si elle s'impose dans l'usage, la langue l'intégrera... ou bien peut-être qu'elle intégrera plutôt « proxy » si c'est lui qui est plus employé.

                En quoi est-ce préférable, pour faire évoluer la langue, de donner des sens nouveaux à des mots d'origine française plutôt que d'intégrer de nouveaux mots d'origine étrangère ?

                Ensuite, pour ce qui est des « bon programmes », bah soit, peut-être, ça prouve juste que ça n'est pas Debian qui a inventé l'expression. Mais moi je constate qu'on parle de proxy dans IE, dans Mozilla, et dans les docs des fournisseurs d'accès, et que rien que ça suffit amplement pour qu'une large majorité des gens soit familière avec le termes de « proxy », et non avec celui de « serveur mandataire ». De là il me parait logique d'utiliser ce mot quand on veut être compris, et je pense que seule la défense d'une position idéologique bien tranchée sur la question précédemment posée peut faire choisir le termes plus marginal de « serveur mandataire ». Et c'est à mon avis une erreur : les traducteurs ne sont pas là pour orienter les évolutions de la langue dans le sens qu'ils préfèrent, mais juste pour l'utiliser afin de rendre les logiciels accessibles à un maximum de gens.
        • [^] # Re: Joli !

          Posté par (page perso) . Évalué à 1.

          Oui je suis d'accord avec toi, quand je vois qu'une des grandes nouveautés est l'installation de GRUB par défaut ca fait sourire.

          Il aurait aussi été bien de travailler c'est les scripts d'init, ils sont vraiment à chier, on sait pas si le processus c'est bien lancé alors oblige de faire un ps ou un netstat derrière. Par exemple tu fais un stop pour faire une bidouille, tu relances ton start suivit d'un petit netstat, tu vois ton processe sur ta socket tu te dit c'est full up mais non car ton stop avait foire, le binaire est toujours la, le start a de ce fait forcement merde...

          Puis un peu de couleur et de propre au boot ça ferait du bien car c'est quand même sacrement crado.

          Il y a toujours du xfree pourquoi ne pas avoir profité pour switcher sur xorg ?

          Bon j'arrête c'est toujours facile de critiquer quand on est au bord de sa piscine les doigts de pied en éventail :) mais j'ai l'impression que debian perd un peu de sa splendeur, la woody avait vraiment tout fracassé à sa sortie, reste a voir ce que va donner la sarge
  • # non us ?

    Posté par . Évalué à 7.

    Ils abandonnent non-us ? comment ça se fait ? La loi américaine a changé ? Debian a changé sa manière de gérer les paquets interdits aux usa ? les a abandonné ?

    par contre j'espère que la rumeur n'est qu'une rumeur, je préfère qu'ils s'en tiennent à leur ancienne politique : sortir la release quand c'est près
    • [^] # Re: non us ?

      Posté par . Évalué à 5.

      Je crois qu'ils ont trouvé des solutions pour ne pas trop être embetté par les lois US, notamment en ce qui concerne la crypto.

      sortir la release quand c'est près
      C'est toujours vrai mais on a parlé de garder certains paquets buggés dans testing/unstable pour ne pas retarder une sortie de stable.
    • [^] # Re: non us ?

      Posté par . Évalué à 10.

      > Ils abandonnent non-us ? comment ça se fait ? La loi américaine a changé ?
      > Debian a changé sa manière de gérer les paquets interdits aux usa ? les a
      > abandonné ?

      La loi US n'a pas change, mais son implementation (par l'executif) a change. Concretement, Debian n'a plus besoin de demander une autorisation pour exporter des logiciels qui utilisent la cryptographie, il suffit qu'ils l'annoncent a l'administration americaine (en leur disant ou en trouver une copie) et c'est bon. Je ne me souviens plus des details, mais je crois qu'ils ont un systeme qui envoie l'annonce automatiquement par email, plus, regulierement, ils envoient une copie papier. Dans tous les cas, plus besoin de non-US pour la cryptographie.

      Il y a encore quelques craintes car l'Administration americaine pourrait retourner sa veste en quelques minutes ("on ne sait jamais, les terroristes pourraient utiliser la cryptographie, mieux vaut etre prudent"), mais en regle generale les cryptologues n'ont pas trop trop peur que ca arrive.

      Pour les details de l'histoire, plusieurs personnes avaient poursuivi le gouvernement americain en justice a cause de l'interdition d'exporter de la cryptographie; il faut dire que la situation etait paradoxale, voire meme risible: des programmes tels que PGP, ou les codes sources distribue avec le livre "Applied Cryptography" de Bruce Schneier pouvait etre exporte sans probleme sur papier (liberte d'expression garantie par le 1er amendement a la Constitution), mais exporter le meme code sur disquette pouvait vous envoyer directement en prison sans passer par le start. En particulier, Daniel J. Bernstein (un de ces types pas doues du tout qui font un doctorat en maths et qui ecrivent un programme de mail, un serveur DNS et autres broutilles pendant leur temps libre...) s'est vu menace de poursuites s'il diffusait sa these; seulement il ne s'est pas laisse faire et a poursuivi le gouvernement pour invalider la loi. Voyant qu'il allait gagner, l'executif americain a prefere changer sa reglementation plutot que de voir la loi etre annulee -- suite a quoi le juge a rejete la demande de Bernstein car il n'y avait plus de menace concrete sur son travail. Dans tous les cas, ca permet a Debian de ne plus avoir besoin de non-US. Voila pour ceux qui aiment les details.

      Zorglub
  • # 3.1 == sarge ??

    Posté par (page perso) . Évalué à 3.

    Si la version 3.1 est bien la sarge et bien un petit apt-get dist-upgrade et déjà hier j'étais en sarge et plus en testing :-)
    Si cela ne correspond pas du tout veuillez oublier mon post :-)

    -- christophe.
    • [^] # Re: 3.1 == sarge ??

      Posté par (page perso) . Évalué à 1.

      Pareil... depuis Jeudi dernier... :p)

      Par contre, je ne comprends pas pourquoi tu t'es pris un vol de (-1)... Encore un coup de la Cabale ? Mais tu n'as rien dit de méchant...!?
      • [^] # Re: 3.1 == sarge ??

        Posté par (page perso) . Évalué à 0.

        C'est l'air du temps, ce n'est pas grave !!
        Vas savoir, pourquoi je me suis pris ces "-1" ;-)

        Bref, bonne journée à tous...

        - Christophe
      • [^] # Re: 3.1 == sarge ??

        Posté par . Évalué à 1.

        il a rien dit de méchant, mais le fait que debian-base passe en freeze implique cette modification.

        je reconnais qu'il faut le savoir... ou lire les mailing-list debian ;)
  • # SATA on 2.6

    Posté par . Évalué à 1.

    est-ce que quelqu'un a pu gérer des HDD SATA avec le noyau 2.6 de Sarge sans avoir a tripatouiller le kernel ? C'est le seul problème qui me gêne vraiment avec Sarge. Ca marche tres bien avec le 2.4.25 mais pas du tout avec le nouveau (kernel panic) si j'upgrade :-(
    • [^] # Re: SATA on 2.6

      Posté par . Évalué à 6.

      Je ne sais pas comment est configuré le 2.6 de Sarge, mais les 2.6 ont deux modules de support du SATA, un dans la rubrique IDE, et l'autre dans SCSI, et celui de la rubrique IDE est maintenant deprecated (depuis 2.6.6, 2.6.7 ?).

      Si le SATA est supporté, il devrait y avoir un module 'libata' (et d'autres spécifiques suivant le chipset, avec mon Silicon Image, le module est sii_sata, ou sata_sii, je ne suis pas sur ma machine).

      Mais évidemment, libata crée des /dev/sd??, alors que l'ancien module créait des /dev/hd??... j'ai mis du temps avant de m'en rendre compte, c'est peut-être ton problème ?
      • [^] # Re: SATA on 2.6

        Posté par . Évalué à 4.

        Je confirme : Il faut utiliser les drivers sata_* qui ce trouvent dans .../kernel/drivers/scsi/
        • [^] # Re: SATA on 2.6

          Posté par . Évalué à 1.

          je vais essayer ca lors de ma prochaine install, pour cela il faut que je puisse installer directement un 2.6 (pas upgrader depuis le 2.4) sinon je n'ai meme pas accès à une console pour toucher le menu config.
          D'apres la news le nouvel installateur de Sarge propose les 2 noyaux, je vais essayer celui là plutot que de chercher désespérément une daily build qui démarre en 2.6.
          merci pour les infos :-)
          • [^] # Re: SATA on 2.6

            Posté par (page perso) . Évalué à 5.

            Les daily built font la même que tous les -rc ou -test de l'installeur : Les 2 noyaux sont dispo.

            Par défaut l'install se fait en 2.4
            Il faut tapper linux26 au prompt lilo pour faire l'install en 2.6
            • [^] # Re: SATA on 2.6

              Posté par . Évalué à 1.

              zarma ! j'ai lu le F1 trop vite ou c'est pas dedans ca ?? Je connaissais pas l'astuce.
              Cool, j'vais me pieuter plus geek ce soir. mouarf ! mici bocou ^_^
              • [^] # Re: SATA on 2.6

                Posté par . Évalué à 3.

                Si si, c'est dedans depuis un long moment (enfin c'est relatif).

                Tu devrais même y voir des versions "expert24" et "expert26" si tu veux encore plus d'options.

                Ce nouvel installeur est une merveille, mangez en !

                M
              • [^] # Re: SATA on 2.6

                Posté par (page perso) . Évalué à 2.

                C'est bien sur dans les écrans d'aide accessible par les touches de fonction.

                La prochaine R donc le FM. :)
  • # Le nom de la prochaine?

    Posté par . Évalué à 2.

    Bon la Sid restera la Sid.

    Potato, Woody, Sarge et ensuite???

    Moi je verais bien Jessica.
    • [^] # Re: Le nom de la prochaine?

      Posté par . Évalué à 1.

      Y'as une Jessica dans Toy Story ? ...
    • [^] # Re: Le nom de la prochaine?

      Posté par . Évalué à 1.

      > Bon la Sid restera la Sid.

      Ça on l'a toujours su... on va pas revenir sur cette fausse question à chaque nouvelle version de Debian !
    • [^] # Re: Le nom de la prochaine?

      Posté par . Évalué à 10.

      Pour le moment, c'est l'une des prérogatives du Release Manager de choisir le nom de la furure version, même si certains demandent un choix plus "démocratique". C'est un débat qui va revenir bientôt à n'en point douter.

      Le fichier qui donne la liste des noms utilisés et disponibles montre "Etch" comme étant le potentiel suivant, mais ca ne veut rien dire ...

      Il reste encore sufisamment de noms disponibles pour tenir 10 ans au moins.
      D'ici là Toy Story sera considéré par les Debianneux comme un film has been de l'époque de leurs parents qui seront tellement vieux qu'ils auront connu le monopole de Microsoft (comme certains ici ont connu l'arrogance d'IBM et de ses hommes en noir).

      M
    • [^] # Re: Le nom de la prochaine?

      Posté par . Évalué à 2.

      Tramo. Pierre Tramo.
  • # Installation

    Posté par (page perso) . Évalué à 1.

    De retour de vacances, je decide d'installer une petite sarge dès fois
    qu'il m'arriverait de faire trop le con avec ma sid.

    Début de l'install, partition: impeccable, bonne francisation, nouvel utilitaire de partition très intuitif autodocumenté, bons choix de décisions par défaut. Bref, le pied. Il me propose d'installer grub, comme je l'ai déjà, je décline l'invitation,
    je reboote sur mon autre partition pour éditer tranquillement mon menu.lst.
    Je reboote (non je ne suis pas sous windows) et ça marche.

    Après, je retrouve le couple tasksel/aptitude et là je suis franchement
    déçu. Entre les 7 options de tasksel et le dédale d'aptitude, un entre-deux
    devrait être possible même pour celui qui découvre linux et ne connait pas
    tous les différents front-end à apt : ça l'était en 1997 lorsque j'ai fait ma première install de linux, une Redhat.
    Je pense que ce serait vraiment utile, car quelqu'un qu'y décide d'installer debian, même si c'est sa première install de linux, n'est pas dans l'état d'esprit
    de quelqu'un qui accepte de juste cocher la case "environnement de bureau".
    Le choix des grands classiques - emacs, latex, mozilla, gv...
    - que connait certainement déjà, au moins de nom, cet utilisateur - devrait, je crois, être proposé d'entrée de jeu.

    Du coup retour sur la doc d'Alexis de Lattre pour retrouver les manips
    d'install de X et de gnome, apt-get , etc...

    http://people.via.ecp.fr/~alexis/formation-linux/formation-linux.ht(...)
    (Qui a mon avis mériterait d'être en haut de cette page)

    Accessoirement, comme très souvent ma configuration gnome (côté utilisateur)
    ne fonctionne pas du premier coup. On dirait que le chargement du windows manager ne se termine pas tout seul. Je dois lancer à la main gnome-panel, nautilus, enregistrer la config, me reloger deux ou trois fois avant d'avoir une
    config utilisateur stable. Est-ce parceque j'ai choisi icewm-gnome et pas sawfish comme windows manager ? Pas clair.

    Niveau stabilité des applis, je n'ai rien vu à redire.
    Une bonne distro dans la tradition debian, avec quand même ce bémol sur le
    choix des paquets qui est le truc qui manque pour en faire une distro qu'on peut mettre dans les mains de "tout le monde".

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.