Journal La BPN, Linux et Firefox

Posté par  (site Web personnel) .
Étiquettes : aucune
0
9
avr.
2008
Bonjour journal !

Linux, Firefox, la BPN (Banque Populaire du Nord) est au courant, et n'hésite pas à le dire.
Comme l'extrait de la page de connexion au nouveau service de consultation des comptes par Internet :

Attention ! Votre version de navigateur est autorisée pour accéder à Cyberplus mais ne garantit pas un fonctionnement optimal
Les navigateurs sont classés en trois catégories : homologués, autorisés ou non autorisés.
Les navigateurs homologués sont les suivants :
* Windows : Internet Explorer 6.0 et 7.0, Firefox 1.5 et 2.0
* Linux : Firefox 1.5 et 2.0
* Mac OS-X : Firefox 1.5 et 2.0, Safari 1.3, Camino 1.5, Safari 3.0.4 (Leopard Mac OS X 10.5)
Pour Windows 95, le navigateur Mozilla est autorisé.
Le service de compte en ligne Cyberplus n'a pas été testé avec votre version de navigateur. Néanmoins, il n'a été reporté aucun problème de fonctionnement.


Bon, pas de bol, il connait pas Firefox 3b5... Et tester le navigateur, saimail oui, mais c'est mieux que rien :)
  • # beta

    Posté par  . Évalué à 10.

    ça t'étonne tant que cela qu'un navigateur en beta ne soit pas présenté et reconnu comme homologués ? Déjà ils te préviennent que cela semble bien passer, c'est déjà ça...

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

  • # Pas lire

    Posté par  . Évalué à 10.

    BPN, Linux, Firefox: Bienvenue chez les chtis
    • [^] # Re: Pas lire

      Posté par  . Évalué à 7.

      À force d'entendre ch''tis partout, je commence à regreter de l'être... Vivement que la mode passe.
      • [^] # Re: Pas lire

        Posté par  . Évalué à 4.

        tu n'as pas fini.Tout simplement, car ce n'est pas une mode. Depuis longtemps, j'entendais parlais de chtimis, et de chtis. Mais néanmoins, c'était peu utilisé, je préfère par exemple les termes Picards, Artésiens, Flamand, Hennuyers que chtis.
        Maintenant que les medias se sont approprié le noms, on aura le droits aux chtis à toutes les sauces . Certains journaux ont même ressorti le terme "titi Parisien"..... en attendant le retour des Poulbots.

        Mais clair que chtis, ça sous-entend plein de chose, et que malgré le film ,cela n'est pas près de changer, ou alors, en biloute.

        a+ biloute, hein
      • [^] # Re: Pas lire

        Posté par  . Évalué à 7.

        Mieux vaut être ch'tis que supporter du PSG...
  • # Pour Windows 95

    Posté par  (site Web personnel) . Évalué à 3.

    Pour Windows 95, le navigateur Mozilla est autorisé.

    Il y a encore des gens avec Windows 95? Sinon, il me semble que Firefox 2 n'est pas disponible pour Windows 98... Il n'y a donc aucun navigateur valable sur ces OS...

    Sinon, on peut signaler l'effort de compatibilité maximum avec la plupart des OS et des navigateurs...
  • # Spécification incomplète

    Posté par  (site Web personnel) . Évalué à 8.

    Il manque la ligne où ils diraient que le changement de 'user-agent' est passible des lois sur l'usurpation d'identité.

    C'est toujours aussi révoltant de voir un filtrage sur le nom du navigateur, alors qu'il y a des champs 'capabilities' prévus dans une session HTTP. Ça s'apparente au délit d'opinion.
    • [^] # Re: Spécification incomplète

      Posté par  (site Web personnel) . Évalué à 5.

      Hélas, quand les normes sont méconnues des développeurs, cela donne ce genre de pratique...
    • [^] # Re: Spécification incomplète

      Posté par  (site Web personnel) . Évalué à 10.

      Au contraire c'est très bien les tests sur les navigateurs quand c'est bien utilisé.
      Ils n'ont aucun contrôle sur ton navigateur, donc ils te disent : "voilà, on a testé avec ceux la, et ça marche. Celui que vous utilisez on ne l'a pas tester donc on ne sait pas mais personne n'a signalé de problèmes avec pour l'instant."
      Ils ne peuvent garantir que ça marche avec tous les navigateurs étant donné la jungle que c'est donc ils te disent ce pour lesquels ils savent.

      Ce qui est mal c'est de bloquer les gens qui n'utilise pas une version testée, ici ils te disent juste qu'ils ne l'on pas testée.

      Dans le cas d'une application bancaire je trouve même cela rassurant que l'on me prévienne.

      Dans le monde des bisounours, tout le monde respecterait exactement les standards sans aucun bugs et il n'y aurait pas besoin de tester sur tous les navigateurs, juste sur un. Mais on est loin d'un support parfait des normes et encore plus loin de l'absence de bugs dansles navigateurs...
      • [^] # Re: Spécification incomplète

        Posté par  (site Web personnel) . Évalué à 4.

        Je savais pas que les bisounours codaient si bien... J'imagine d'ici l'offre d'emploi :

        Cherche bisounours (humain s'abstenir) avec niveau BAC+7 en informatique et 20 ans d'expérience en milieu professionnel pour un stage non-rémunéré de 42 mois.
        • [^] # Re: Spécification incomplète

          Posté par  . Évalué à 3.

          Cherche bisounours (humain s'abstenir) avec niveau BAC+7 en informatique et 20 ans d'expérience en milieu professionnel pour un stage non-rémunéré de 42 mois.

          euh ça existe déjà ce genre d'annonce... mais sans " bisounours (humain s'abstenir)"... juste "webmaster" ou "déloppeur web" et à la fin "votre présence dans nos locaux de trifouillis-les-ois est indispensable" (et bien entendu il n'est proposé ni facilité de logement ni de déplacement)
      • [^] # Re: Spécification incomplète

        Posté par  (site Web personnel) . Évalué à 3.

        Tu dis «Dans le cas d'une application bancaire je trouve même cela rassurant que l'on me prévienne.»
        Pareil. Même que quand je me connecte à mon compte ( http://www.coopanet.coop ), on m'afiche une mise en garde générale sur l'usage du web.

        Je cite le journal, qui lui-même cite le site BPN, et le gras est de moi :
        «Les navigateurs sont classés en trois catégories : homologués, autorisés ou non autorisés.»
      • [^] # Re: Spécification incomplète

        Posté par  . Évalué à 3.

        Ouai, c'est la nouvelle mode.
        Je pense que si je devais tester mon code en C avec tous les compilos, ça deviendrait assez vite un cauchemard.
        Sauf que dans le monde du Web, c'est normal ...
        • [^] # Re: Spécification incomplète

          Posté par  (site Web personnel) . Évalué à 4.

          Euh... Désolé, mais moi je teste avec 3 compilo (GNU GCC, Microsoft et Borland car j'aime Borland), et même sur 3 OS (Car la ou GCC Linux compile sans warning, parfois GCC MacOS X ne compile pas... Si si, c'est du vécu). et sur i386 et x64 aussi, car parfois GCC râle aussi au passage 32 --> 64 bits (et pour un truc, j'ai pas encore compris pourquoi... J'y arriverai un jour!).
          J'ai même eu le plaisir de me faire envoyer balader une fois que j'ai proposé un patch à un gars compilant seulement sous GCC, pour que son code soit du vrai C, et donc compilable par Microsoft Visual C++, car Monsieurs crashe sur Microsoft, et préfère faire du code non standart que faire du code standart compatible MS.

          Si tu arrives à coder sur un compilo et sur un OS et que ça marche partout, veinard!
          Web ou compilo, même combat, le test sur plusieurs programmes ne date pas des navigateurs Web.
    • [^] # Re: Spécification incomplète

      Posté par  (site Web personnel) . Évalué à 2.

      C'est toujours aussi révoltant de voir un filtrage sur le nom du navigateur, alors qu'il y a des champs 'capabilities' prévus dans une session HTTP. Ça s'apparente au délit d'opinion.

      C'est si révoltant que ça?
      Alors pourquoi ne pas râler des sites qui filtrent sur le user-agent "IE" et dit "allez vous faire foutre" dans le cas de IE, plutôt que de laisser l'accès à la page conforme même si elle est mal lue par lesdit navigateur? N'est-ce pas un délit d'opinion aussi?

      PS : pour celui qui va se sentir tout de suite visé (c'est voulu ;-) ), zut je viens de tester le site accusé, il accepte maintenant le méchant navigateur (même si c'est pas parfaitement affiché mais ça n'est pas le problème), je ne peux plus accuser ce site de non respect des normes!
  • # Et ?

    Posté par  (site Web personnel) . Évalué à 10.

    Je trouve ça super au contraire (pour une appli bancaire hein, pas pour un site de consultation public).

    1* Ils ne te refusent pas l'accès
    2* Ils te préviennent juste qu'ils n'ont pas testé et donc ne garantissent pas tout

    Le 1 te garantit que tu as acès. Le message n'est en rien alarmiste ou de mauvaise foi, ils disent juste que ton navigateur n'a pas été testé.

    Le 2 est normal et une bonne chose pour ce genre d'appli. Ca joue avec des données souvent jugées comme importantes. Il peut y avoir des bugs, non connus. Ne pas le signaler serait irresponsable de leur part.



    A moins que ce qui te gêne c'est qu'ils ne te garantissent pas le fonctionnement sur un navigateur que tu juges respectueux des standards ?
    Mais là je crois que tu te leures complètement sur l'idée que les tests sur les navigateurs sont inutiles quand on respecte le standard. C'est encore plus vrai avec un navigateur en béta où même l'éditeur pense qu'il peut y avoir des bugs importants.
    • [^] # Re: Et ?

      Posté par  (site Web personnel) . Évalué à 2.

      La Banque Populaire Provençale et Corse qui utilise aussi Cyberplus donne aussi des informations pertinentes sur la sécurité :
      http://www.provencecorse.banquepopulaire.fr/Magazine/46Secur(...)

      et avant le switch vers la nouvelle plateforme, le site permettait un test de la sécurité et des fonctionnalités Javascript du navigateur, et cela en prenant en compte les différences de systèmes d'exploitations !

      Ça semble rien pour la plupart des internautes mais pour le respect des normes et des différences entre navigateurs c'est merveilleux !
  • # firefox sous ubuntu

    Posté par  (site Web personnel) . Évalué à -1.

    En même temps, il ne reconnaît pas non plus Firefox 2 sous Ubuntu 7.10 !

    Et ils ne sont pas non plus à jour avec Safari 3.1 sous Mac Os X Leopard !

    Mais ils sont au top, il reconnaissent Linux et Mac Os X et c'est bien !

    M5Replay (http://www.m6replay.fr) devrait en faire de même surtout que le format wmv est supporté officiellement sur Mac....
  • # BPA

    Posté par  (site Web personnel) . Évalué à 4.

    À la BPA (Banque Populaire des Alpes), on utilise également CyberPlus mais on n'a pas ce type d'informations. Par contre, on a droit aux avertissements contre l'hameçonnage.
  • # Pourri gaté, oui...

    Posté par  . Évalué à 3.

    On se plaint que son navigateur beta n'est pas reconnu, alors que aucune version d'Opera n'est dans la liste, et que toutes les versions d'Opera défoncent à plate couture chacun des misérables assemblages hétérocilites d'octets listés au dessus!!!

    Mais où va-t-on, je vous le demande?
  • # Konqueror

    Posté par  . Évalué à 3.

    CyberPlus fonctionne parfaitement avec Konqueror, il ne m'a jamais affiché ce genre de message alors que gmail me rappel à chaque fois que mon navigateur n'est pas homologué.
    • [^] # Re: Konqueror

      Posté par  . Évalué à 1.

      Il suffit que je dise ça pour que ce ne soit plus le cas...
      Mais tout marche c'est le plus important !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.