Journal Declaration impot sur le revenu en ligne interdite pour Linux

Posté par .
Tags :
6
12
mai
2010
Bonsoir,

ce soir j'ai voulu déclarer mes impôts sur www.impots.gouv.fr. Depuis que le service est disponible en ligne (au moins 2002) je réalise cette opération sans problème.

Mais ce soir, je suis particulièrement agacé de constater que le site m'interdit la déclaration avec "mon" système d'exploitation. Seuls Windows et Mac sont listés. En fait cette vérification est la nouveauté de cette année.

Voici le message qui s'affiche:
"La version de votre système d'exploitation ne vous garantit pas de pouvoir déclarer vos revenus en ligne.
Pour consulter les configurations compatibles, cliquez sur le lien ci-dessous."

Ce qui nous amène au texte suivant:

"Si votre configuration n'est pas garantie pour télédéclarer vos revenus, vous pouvez télécharger et installer gratuitement un navigateur se trouvant dans la liste ci-dessous. Vous trouverez ces navigateurs sur les sites Internet correspondants *."
et plus loin:
* La DGFiP ne peut être tenue pour responsable de l'échec ou de l'erreur liés à une téléprocédure au cas où l'utilisateur a sciemment modifié la configuration de son navigateur non supporté afin d'accéder à des services offerts.


Je me demande à quoi ça sert que je paye des impôts si c'est pour aider à détruire du service et de la liberté.

Que veut l'état exactement en faisant ça?
  • # Heink ?

    Posté par (page perso) . Évalué à 10.

    J'ai fait ma déclaration sous Linux, comme l'année dernière et celle d'avant, avec l'user agent suivant : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100402 Namoroka/3.6 (Firefox/3.6) qui ne m'a valu aucun message particulier.

    En revanche je n'ai pas pu utiliser mon certificat de l'année denière (un message me disant juste que "je ne pouvais pas télédéclarer cette année, que mon accès serait rétabli l'année prochaine") mais c'est passé tout seul avec l'autre méthode.
    • [^] # Re: Heink ?

      Posté par (page perso) . Évalué à 6.

      idem, avec Iceweasel déclaré comme étant firefox[1], je n'ai pas eu de problème non plus…

      [1] http://www.geticeweasel.org/useragent/
    • [^] # Re: Heink ?

      Posté par . Évalué à 3.

      ok, alors je vais essayer ca. Parque j'ai effectivement utilisé le certificat.
      Merci pour l'info.
    • [^] # Re: Heink ?

      Posté par (page perso) . Évalué à 4.

      Pour info voilà le message que j'ai eu : http://ssz.fr/brdl/impots-uxam.png
      Bizarre quand même, mais j'ai la même chose sous d'autres OS.
      • [^] # Re: Heink ?

        Posté par . Évalué à 4.

        Oui enfin « La DGFiP ne peut être tenue pour responsable de l'échec ou de l'erreur liés à une téléprocédure au cas où l'utilisateur a sciemment modifié la configuration de son navigateur non supporté afin d'accéder à des services offerts. » ça veut dire ce que ça veut dire.
        • [^] # Re: Heink ?

          Posté par (page perso) . Évalué à 10.

          Pour etre exhaustif j'ai envie d'ajouter que ça ne veut pas dire ce que ça ne veut pas dire.
          • [^] # Re: Heink ?

            Posté par . Évalué à -2.

            j'ai envie d'ajouter

            c'est pas ce que tu fais, justement ?
    • [^] # Re: Heink ?

      Posté par (page perso) . Évalué à 4.

      La vraie erreur dans la conception, au fond, c'est surtout de ne pas proposer un lien vers la section "déclarez sans certificat" quand les conditions techniques pour déclarer avec certificat ne sont pas remplies.
      • [^] # Re: Heink ?

        Posté par . Évalué à 2.

        Vu la sensibilité de ma déclaration d'impôts, j'aurais un peu les boules qu'on puisse la faire à ma place sans avoir besoin de mon certificat... Je ne suis pas particulièrement expert dans le domaine, mais je doute que le certificat soit là juste pour faire joli, c'est aussi surtout une grosse couche de sécurité.
        • [^] # Re: Heink ?

          Posté par . Évalué à 4.

          Sans certificat, effectuer une déclaration d'impôts en ligne nécessite tout de même les éléments suivants :
          - numéro de télédéclarant à 7 chiffres.
          - numéro fiscal à 13 chiffres
          - revenu fiscal de référence de l'année N-1
          Niveau couche de sécurité, c'est déjà pas mal !

          https://inscriptionpart.impots.gouv.fr/tdir-03/TDL/Delestage(...)
          • [^] # Re: Heink ?

            Posté par (page perso) . Évalué à 7.

            D'autant que le certificat, pour l'obtenir ... euh, il faut juste les mêmes données, donc, bon, on peut rajouter toute la crypto qu'on veut derrière, ça change pas grand chose.
        • [^] # Re: Heink ?

          Posté par . Évalué à 3.

          Vu la sensibilité de ma déclaration d'impôts, j'aurais un peu les boules qu'on puisse la faire à ma place sans avoir besoin de mon certificat...
          Et en quoi le fait d'avoir un certificat te garantit-il que quelqu'un qui connaît tes 3 numéros magiques (numéro de télédéclarant, numéro fiscal et revenu fiscal N-1) ne puisse pas faire la déclaration à ta place ?

          je doute que le certificat soit là juste pour faire joli
          Le certificat était obligatoire avant l'an dernier. Il est optionnel depuis.
          A moins que quelqu'un a déjà télédéclaré avec un certificat ne puisse pas le faire sans, j'ai l'impression que ça n'apporte plus grand chose.
          • [^] # Re: Heink ?

            Posté par . Évalué à 2.

            Ben si quand même : si tu te connectes avec un certificat, et que tu te rends compte que celui-ci n'est plus valide, tu peux te poser des questions, et agir en conséquence (faire regénérer un certificat, et vérifier ce qui a été fait en ton nom les n derniers jours).

            Sans certificat c'est plus compliqué.
            • [^] # Re: Heink ?

              Posté par . Évalué à 1.

              Ben si quand même : si tu te connectes avec un certificat, et que tu te rends compte que celui-ci n'est plus valide, tu peux te poser des questions,
              Quel rapport avec l'usurpation d'identité ?
              Que ton certificat soit valide ou pas, la télé-déclaration sans certificat est toujours possible.

              et agir en conséquence (faire regénérer un certificat,
              En quoi cela te garantit-il que quelqu'un d'autre n'a pas télé-déclaré sans certificat ?

              et vérifier ce qui a été fait en ton nom les n derniers jours).
              J'ai du mal à voir la relation entre «mon certificat n'est pas valide» et «je me suis fait usurpé mon identité». L'usurpation est a priori possible que ton certificat soit valide ou pas. Pourquoi vérifier uniquement si ton certificat a expiré ?

              Sans certificat c'est plus compliqué.
              Sans certificat, je peux aussi vérifier «ce qui a été fait dans les n derniers jours».
              • [^] # Re: Heink ?

                Posté par . Évalué à 2.

                S'il est possible de télédéclarer sans certificat (même si on a un certificat valide), effectivement, ça ne sert pas à grand chose. Je pensais naivement que si j'avais un certificat valide, il n'était pas possible d'effectuer des actions sans utiliser le certificat (sauf en regénérer un autre).
  • # Aucun problème sous Fedora 12

    Posté par . Évalué à 6.

    Aucun problème sous Fedora 12 avec Firefox 3.5, java-1.6-openjdk et tout ce qu'il y a de plus libre ...

    J'ai bien le message "La version de votre système d'exploitation ne vous garantit pas de pouvoir déclarer vos revenus en ligne. Pour consulter les configurations compatibles, cliquez sur le lien ci-dessous." mais en cliquant sur le bouton "suite" je peux poursuivre ma déclaration sans aucun problème.

    Note : j'utilise un certificat, peut-être que ça joue ...
    • [^] # Re: Aucun problème sous Fedora 12

      Posté par . Évalué à 3.

      Je confirme que cela fonctionne très bien malgré l'alerte (ce n'est qu'un avertissement contrairement au signe "stop" lorsqu'il y a un problème Java).
      • [^] # Re: Aucun problème sous Fedora 12

        Posté par . Évalué à 2.

        Chez moi, Sous debian avec Iceweasel 3.5 et openjdk, la procédure d'obtention de certificat s'est vautrée violemment. J'ai cru voir passer des exceptions Java dans le terminal

        J'ai réussi à la passer en remplaçant l'openjdk par le Java de sun.

        D'autres ont eu ce souci ?

        Accessoirement, je ne sais pas si c'est dû à mes déménagements successifs, mais malgré mes efforts, ils me disent que pour moi, cette année, pas moyen d'accéder à l'espace de déclarant, que ce sera la déclaration papier et que tout devrait être en ordre l'an prochain (j'ai eu beau changer de certificat, rien n'a fait). Par contre, chez une amie avec la même config, ça passe nickel.
  • # Incohérence ?

    Posté par . Évalué à 2.

    Je viens d'essayer avec certificat et j'ai eu le même message d'erreur ; et aïe, je constate que ma JRE pose à nouveau problème, ça sent la séance de jonglage entre les divers parfums de Java.
    Le listage uniquement des OS Windows et Mac n'est cohérent avec la fiche pratique « Quelle est la configuration recommandée pour profiter au
    mieux de notre offre ? ». Cette fiche recommande aux utilisateurs d'OS crypto communistes Linux (2.4 et suivants - 2.6 et suivants) les navigateurs
    Firefox 2.0 et suivants - 3.0 et suivants
    .
    Fiche disponible en ici : http://www.impots.gouv.fr/portal/deploiement/p1/fichedescrip(...) .
    • [^] # Re: Incohérence ?

      Posté par . Évalué à 3.

      Je bats ma coulpe ! RAS sous Debian / Iceweasel 3.5.9 avec le useragent modifié en Firefox / 3.5.9. Las ! Avec la JRE Sun, RMS would be ashamed!
  • # Iceweasel

    Posté par (page perso) . Évalué à 5.

    C'est dû à une discrimination appliquée par l'administration, non sur le système d'exploitation, mais sur le modèle du navigateur. Ils n'acceptent qu'Explorer, Firefox, Safari et je ne sais quoi d'autre. En particulier, Iceweasel ne passe pas, sauf dans les versions récentes où il se fait passer pour Firefox.

    Ces discriminations n'ont rien de normal ni d'admissibles. Un site bien fait respecte les normes et passe bien sous n'importe quel navigateur digne de ce nom. Discriminer sur l'équipement des gens, c'est mal.
    • [^] # Re: Iceweasel

      Posté par . Évalué à 9.

      Sauf que les normes sont démesurément grosses et qu'il n'existe probablement aucune procédure de test reproductible pour s'assurer de leur respect. Sans parler des navigateurs qui ne les respectent en pratique pas. (vu qu'elles sont trop grosses, toussa...)

      Dès lors, pour une telle application semi-critique, le test de la chaîne complète est obligatoire.

      Il faudrait probablement définir un sous-ensemble très stricte des technos web pour pouvoir s'appuyer sur des standards au lieu d'une white-list.
      • [^] # Re: Iceweasel

        Posté par . Évalué à 2.

        Moi ce que je trouve débile c'est de bloquer les utilisateurs. Qu'ils mettent un warning genre "Attention votre navigateur n'est pas certifié" mais qu'ils proposent quand même de pouvoir y aller.
        • [^] # Re: Iceweasel

          Posté par . Évalué à 2.

          Et si l'utilisateur pense que ça télédéclaration c'est bien faite mais que ce n'est pas le cas, qui est responsable ?
          • [^] # Re: Iceweasel

            Posté par . Évalué à 6.

            T'es fâché avec les 's' ?
            çasa télédéclaration cs'est bien faite
          • [^] # Re: Iceweasel

            Posté par . Évalué à 1.

            Nan mais arrêtez de prendre des cas de figure complètement tirés par les cheveux ! Sache que ça arrive sûrement avec la déclaration papier pour un petit nombre de personnes qui ont du mal.

            Je pense que le site peut tout à fait dire "j'essaye de signer votre déclaration", et si rien ne se passe, ou si ça dit "j'y arrive pas", l'utilisateur peut quand même comprendre que ça n'a pas marché, non ?

            En fait, tu me lourdes parce que j'ai horreur des personnes qui déresponsabilisent les gens, comme toi.
        • [^] # Re: Iceweasel

          Posté par (page perso) . Évalué à 4.

          En même temps, c'est ce qui est fait si j'ai bien compris.

          « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: Iceweasel

      Posté par (page perso) . Évalué à 5.

      Un site bien fait respecte les normes et passe bien sous n'importe quel navigateur digne de ce nom.

      Il n'y a pas de normes en ce qui concerne l'accès à la liste des certificats stockés par le navigateur et/ou le système d'exploitation.

      Il faut donc une implémentation par navigateur et/ou système d'exploitation, et il faut donc rejeter ceux pour lesquels il n'existe pas d'implémentation.

      Il est vrai que dans le cas d'Iceweasel, le détecteur pourrait être modifié pour comprendre qu'il s'agit d'un Firefox, mais c'est à peu près tout ce qui pourrait être fait en plus (tout en conservant la force juridique d'une vraie signature numérique des données émises).
    • [^] # Re: Iceweasel

      Posté par . Évalué à 10.

      La discrimination va encore plus loin, si tu déclares à partir de safari, tu as droit à un contrôle fiscal

      Vous voulez pas la jouer soft ? Je suis pas contraignant... vous voulez la jouer hard ? On va la jouer hard

    • [^] # Re: Iceweasel

      Posté par (page perso) . Évalué à 2.

      Mais de toute façon, corrigez-moi si je me trompe (je suis trop jeune pour déclarer des impôts), mais le gros de la déclaration est fait dans une applet Java. Hors, Java est portable, tourne de la même façon dans toutes les VM certifiées Sun, et tous les OS cités disposent d'une telle VM. Ce n'est pas le cas ?
      • [^] # Re: Iceweasel

        Posté par (page perso) . Évalué à 3.

        C'est vrai, mais l'applet doit accéder aux certificats du navigateur, et c'est du développement 100% spécifique (aucun standard, aucun comportement similaire selon les OS et les navigateurs).
        • [^] # Re: Iceweasel

          Posté par (page perso) . Évalué à 3.

          en même temps le slogan de Java c'est "develop once, run everywhere", la réalité c'est plutôt "test everywhere"
          • [^] # Re: Iceweasel

            Posté par (page perso) . Évalué à 3.

            En même temps c'est un des principes du développement (puis de la distribution) de logiciels. Même si tu ne fais "que" des pages HTML, les tester sur un unique navigateur est à mon sens une hérésie.
      • [^] # Re: Iceweasel

        Posté par . Évalué à 3.

        ava est portable, tourne de la même façon dans toutes les VM certifiées Sun
        Ca c'est le discours marketting. En pratique, il y a un tas d'applis qui ne tournent qu'avec une version de JVM bien précise, et qui ne passent pas avec des JVM plus récentes. Ca oblige à jongler avec les diverses versions de JVM installées, la config du navigateur, etc ....

        Je me rappelle une année avoir du jouer avec ça pour la télédéclaration : j'ai mis un moment à comprendre que la télédéclaration ne marchait pas à cause de la version de JVM (et c'était sous Windows/Firefox).
        • [^] # Re: Iceweasel

          Posté par (page perso) . Évalué à 2.

          En pratique, il y a un tas d'applis qui ne tournent qu'avec une version de JVM bien précise, et qui ne passent pas avec des JVM plus récentes.

          Tu as des exemples ? Un tas d'exemples d'ailleurs, vu que tu parles d'un tas d'applis.
          • [^] # Re: Iceweasel

            Posté par (page perso) . Évalué à 2.

            Beaucoup de ces applis sont livrées avec leur propre JVM pour être sûr que ce soit celle-là qui soit utilisé. Par exemple Matlab, j'ai aussi entendu parlé de Rational Clearcase.

            « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

          • [^] # Re: Iceweasel

            Posté par . Évalué à 2.

            Moi, j'ai un exemple précis à te donner : Chorus !
            Il ne faut surtout pas mettre à jour les postes vers Java 6 update 14 (il me semble que c'est cette update) !
            Ne me demandez pas pourquoi mais apparemment, si on en croit l'AIFE (Agence pour l'Informatique Financière de l'État), ça fout grave la merde...
            • [^] # Re: Iceweasel

              Posté par (page perso) . Évalué à 2.

              C'est possible qu'une version précise d'un soft ait un bug grave, mais en général c'est corrigé rapidement. Ça donne quoi avec Java 6 update 15, ou surtout Java 6 update 20, la plus récente ?

              Quand on parle de version de JVM ici, on parle plutôt d'évolution d'API (entre 1.2, 1.3, 1.4, 1.5, 1.6) et de logiciels qui exigent une ancienne version.
              • [^] # Re: Iceweasel

                Posté par . Évalué à 2.

                Je ne sais pas ce que donne Chorus avec d'autres versions de Java 6, car je n'ai surtout pas cherché à tester, et j'ignore sur l'AIFE a fait des tests en ce sens.
  • # la qualif coute cher...

    Posté par . Évalué à 3.

    une idée comme ça :

    Et si les développeurs s'étaient embêtés à tester le service avec toutes les combinaisons OS proprio / navigateurs et pour des raison de couts, ils n'avaient pas pris le temps de tester avec toutes les distributions de distrowatch et tous les navigateurs exotiques disponibles pour nous les libristes.

    Peut-être qu'ils en ont marre d'être face à une armée de râleurs se plaignant que "sur ma gentoo avec uzbl et gij ça passe pas, bouh, l'état me prive de mes libertés !"

    Bref c'est je pense honnête de leur part: "OK, on n'a pas testé, on vous le dit, pas taper /o\"

    Après, essaie : si ça marche, c'est une nouvelle victoire pour le libre et si ça marche pas c'est une bonne occasion d'aller au charbon et de se vanter auprès des collègues le lendemain que "oui c'était dur la déclaration sous linux mais je l'ai fait"

    Je sais pas pour vu mais moi j'aime bien l'approche du "ça ? même sous linux (modulo 10 jours de recherche acharnés sur tous les forums de la terre) je peux le faire".

    Bonne nuit.

    PS: ok sous Debian stable avec le lien symbolique à la con à créer vers je ne sais plus quelle bibliothèque pour gérer le certificat.
    • [^] # Re: la qualif coute cher...

      Posté par (page perso) . Évalué à 9.

      le plus gros problème du web, c'est l'ensemble des webdesigners aux choix techniques injustifiables.
      http://linuxfr.org/~patrick32/29678.html

      Je n'ai toujours pas compris pourquoi j'ai besoin d'une machine virtuelle java dans mon navigateur web pour gérer un certificat d'authentification et envoyer des données au serveur des impôts...

      Le problème ne vient pas du manque de tests mais de la solution technique trop complexe qui a été choisie.
      Plus c'est complexe, plus ça rapporte... au prestataire.
      • [^] # Re: la qualif coute cher...

        Posté par (page perso) . Évalué à 3.

        Tout simplement pour signer les données envoyées avec la clé privée associée au certificat. Tu es le seul détenteur de cette clé privée, il n'y a donc que toi (i.e. ton navigateur) qui puisse signer.
        • [^] # Re: la qualif coute cher...

          Posté par (page perso) . Évalué à 1.

          Quel rapport avec Java ?
          • [^] # Re: la qualif coute cher...

            Posté par (page perso) . Évalué à 8.

            Java permet de le faire, et aucune autre technique / technologie évaluée lors de la conception de l'application ne permet de le faire avec les mêmes avantages (et inconvénients).
            • [^] # Re: la qualif coute cher...

              Posté par (page perso) . Évalué à 2.

              Alors pourquoi ne pas le faire complètement en Java sans se baser sur un navigateur ?
              • [^] # Re: la qualif coute cher...

                Posté par (page perso) . Évalué à 5.

                Pour minimiser la quantité de code exécutable déployé chez les particuliers (et donc la DGFiP est responsable, niveau éventuelles failles de sécurité), pour faciliter la mise à jour de l'application, pour minimiser les coûts de développement, etc.
            • [^] # Re: la qualif coute cher...

              Posté par (page perso) . Évalué à 0.

              Pardon ? Aucune autre technique ? N'importe quel navigateur prenant en charge l'utilisation de certificats clients le fait ! C'est le principe d'SSL avec certificat client, le tuyau chiffré est mis en place par échange (Diffie-Hellmann ?) avec chiffrement et identification des deux parties.
              • [^] # Re: la qualif coute cher...

                Posté par (page perso) . Évalué à 2.

                Non, il n'y a pas d'API standardisée, en JavaScript, ou en Java, ou autre, pour utiliser l'infrastructure de chiffrement des navigateurs dans du code applicatif qui s'exécute au sein du navigateur.

                Il n'est pas question de chiffrer la communication là (les navigateurs le font en général bien), mais de vérifier la signature de flux de données, et d'en signer d'autres.
                • [^] # Re: la qualif coute cher...

                  Posté par (page perso) . Évalué à -1.

                  Quel est le but d'une signature ? Pouvoir vérifier que c'est bien Mme Michu qui affirme qu'elle a gagné tant cette année. Rien de plus. Et ça, SSL le permet, dès lors qu'on utilise un certificat client et que l'envoi du formulaire web est couvert par la connexion SSL.

                  Le code applicatif dans le navigateur ne sert à rien. Pour ce genre de déclaration, des formulaires HTML bien classiques et du SSL, ça suffit.
                  • [^] # Re: la qualif coute cher...

                    Posté par . Évalué à 8.

                    Non. Là, le but est pour le client de _signer_ (et pas tant au sens "crypto assymétrique" qu'au sens usuel du terme) sa déclaration. Que si les impôts te renvoient ta déclaration, tu puisses vérifier que c'est bien celle que tu as signée.

                    Sinon, une déclaration en clair à travers un flux chiffré - même avec authentification du client - qu'est ce qui empêche les gens de Bercy de stocker une version modifiée par leurs soins de ta déclaration?
                    • [^] # Re: la qualif coute cher...

                      Posté par . Évalué à 1.

                      Si cette garantie est aussi importante, pourquoi peut-on télédéclarer sans certificat ?
                      • [^] # Re: la qualif coute cher...

                        Posté par . Évalué à 4.

                        Aucune idée. Mais des gens plus haut se demandent ce que l'applet Java apporte par rapport à du SSL tout bête. Je répondais.
                      • [^] # Re: la qualif coute cher...

                        Posté par (page perso) . Évalué à 4.

                        La télédéclaration sans certificat est une évolution récente de l'application.

                        Probablement que les conseillers juridiques ont estimé le risque acceptable vu les circonstances actuelles.
      • [^] # Re: la qualif coute cher...

        Posté par . Évalué à 4.

        À ma connaissance, les gens qui ont décidé de l'architecture de l'application de télédéclaration étaient pour une bonne partie du côté de feu la DGI.
      • [^] # Re: la qualif coute cher...

        Posté par (page perso) . Évalué à 2.

        La plupart de ce genre d'applications "de service" ne sont pas faites par des webdesigners. Bien au contraire.
        Elles sont réalisées par des prestataires qui savent programmer mais qui souvent ne connaissent rien au web.
        C'est bien pour cela qu'on se retrouve avec des usines à gaz à l'ergonomie douteuse et à la réalisation parfois lamentable (utilsation de tableau, frame etc...).
  • # La vérification n'est pas une nouveauté

    Posté par (page perso) . Évalué à 3.

    En fait cette vérification est la nouveauté de cette année.

    Pas du tout, elle est là depuis au moins 2006, probablement avant.

    Elle est d'ailleurs indispensable (ce serait une faute de laisser les gens saisir leur déclaration pour découvrir au final que l'applet ne fonctionne pas chez eux).
  • # Chrome/Ubuntu

    Posté par . Évalué à 3.

    Aucun soucis avec Chrome/Ubuntu, sans utiliser de certificats.

    C'est plutôt efficace d'ailleurs, même si je ne comprends toujours pas la moitié des questions (mais je m'en fous, je suis trop pauvre pour être imposable \o/).
  • # Kubuntu Karmic 64bits

    Posté par . Évalué à 5.

    Réalisé sans souci sur une Karmic 64bits, sous Firefox. Effectivement, lors des vérifications la plateforme il me précise bien qu'il ne me garantit pas de pouvoir signer ma déclaration, mais au final tout s'est déroulé normalement et sans anicroche. Et avec certificat (tout neuf, en plus).

    Alors que l'an passé, dans des conditions similaires (à la version d'Ubuntu près, je suppose) j'avais été obligé d'aller signer ma déclaration depuis un autre poste.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.