Journal App Store arrive sur les distributions Linux !

Posté par .
Tags : aucun
12
28
jan.
2011
Non cela n'a rien à voir avec l'App Store d'Apple et encore moins avec le Market d'Android. Cependant, les développeurs de plusieurs distributions se sont réunis afin de réfléchir sur l'élaboration d'une interface commune pour l'installation des applications.

L'idée principale est qu'actuellement, les interfaces d'installation de logiciels fournnissent des informations trop techniques dont l'utilisateur n'en a que faire. Il s'agit donc d'avoir une interface commune à toutes les distributions, plus abordable, et centralisée. Il pourront ainsi partager des méta-données concernant chaque application telles que les applications conseillées, la note attribuée, ou encore des commentaires.

Il est bien sûre question d'unifier (et de simplifier) l'interface d'installation d'un programme mais en aucun cas d'unifier le système de packaging. Un des exemple les plus abouti de ce type d'interface serait l'Ubuntu Software Center.

Par ce geste, les distributions Linux veulent gommer l'idée selon laquelle "Linux c'est compliqué" et attirer des utilisateurs qui ne sont pas au courant de la technique.

Une vidéo (Youtube) de la rencontre est aussi disponible.


http://distributions.freedesktop.org/wiki/Meetings/AppInstal(...)
  • # moi j'ai mon appstore depuis des années

    Posté par (page perso) . Évalué à 9.

    il se nomme synaptic, et réponds à mes besoins ;-)
    • [^] # Re: moi j'ai mon appstore depuis des années

      Posté par (page perso) . Évalué à 4.

      Je ne vais pas relancer le débat sur la différence entre ce concept et celui derrière synaptic (ou autre).

      Quoi que... On est vendredi... Donc je vais pas débattre, je vais troller.

      Tu n'as pas compris en quoi un gestionnaire de paquet n'est pas un "App Store" et réciproquement.
      • [^] # Re: moi j'ai mon appstore depuis des années

        Posté par (page perso) . Évalué à 3.

        > Tu n'as pas compris en quoi un gestionnaire de
        > paquet n'est pas un "App Store" et réciproquement.

        On est vendredi ... troll's day
        Je ne faisais que rebondir sur l'info, pour le plaisir ;-)
        C'est vrai que le débat/troll sypatic/appstore a déjà été évoqué (mais pas cette année encore ;-)

        Voilà, c'était juste pour dire que, tout comme l'appstore, j'ai déjà une liste d'application disponible gratuitement, que je peux installer en 2 clics.
        Et ça existe depuis bien avant l'appstore de la pomme ;-)
        • [^] # Re: moi j'ai mon appstore depuis des années

          Posté par (page perso) . Évalué à 2.

          Non mais si on doit refaire chaque tous les débats qu'on a eu les années précédentes je sais pas si on va s'en sortir :/
          • [^] # Re: moi j'ai mon appstore depuis des années

            Posté par . Évalué à 4.

            En résumé ca a donné quoi en substance pour ceux qui étaient absent ce débat ?
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par . Évalué à 3.

              L'appstore c'est le cinéma et synaptic c'est le magnétoscope vhs des barbus linuxiens chauves vttistes amateurs d'emmental (et non de gruyère).
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par . Évalué à -3.

              ffeur
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par (page perso) . Évalué à 0.

              Déjà, c'est pas bien, ça veut dire que tu ne glandes pardon moules, pas assez sur dlfp pendant tes journées de travail. Je crois même que c'était un vendredi aussi, et c'est encore plus impardonnable.

              Ensuite, mon point de vue c'est que Gestionnaire de paquet != "installateur d'application" (oui je suis un rebelle et je pense qu'utiliser "App Store" c'est faire trop d'honneur à une petite PME californienne qui se targue d'avoir inventer le machin et le concept alors que non).

              Bien des gens ne sont pas d'accord (ils ont tord mais ne le savent pas encore), on avait par exemple, comme contre-arguments que internet c'est un "App Store" avec don't be evil comme moteur de recherche, qu'on avait pas besoin de mieux, que Synaptic/Packagekit c'est un "App Store" en mieux, que pour les commentaires et les capture d'écran, on avait les blogs et les forums et patati et patata.

              Moi je m'en fiche je pense qu'il faut arrêter de mettre les features (kikoo je choisi les lib que j'installe sur mon système) au centre des logiciels et s'intéresser aux utilisateurs. Mais pas pour les tondre (référence subtile), pour leur permettre de faire plus facilement et plus simplement ce qu'ils veulent faire.
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par . Évalué à 10.

              « En résumé ca a donné quoi en substance pour ceux qui étaient absent ce débat ? »

              Hier sur la tribune, on est tous tombé d'accord (à part les macounets extrémistes habituels évidemment) que :

              - Chaque distribution possède son AppStore sous forme de dépôt depuis plus de 10 ans, avec plus ou moins de détails techniques inutiles ;

              - Le seule système d'exploitation qui a vraiment réussi et innové un logiciel d'installation simple et complet, mais aussi amical pour l'utilisateur et sur lequel Apple a clairement copié est bien évidemment Ubuntu et son Ubuntu Software Center, ainsi que ses prédécesseurs ;

              - Mark Shuttleworth & Canonical sont à Linux ce que Steve Jobs & Apple sont au Mac ; grâce à eux, Linux et les logiciels libres avancent auprès du grand public, ces gens normaux qui décident ce qui doit rester et ce qui doit partir du mainstream selon un système démocratique établie comme le seule système permettant une évolution darwinienne optimale.

              Après tu as bien sûr les macounets habituels qui on ajoué derrière ça leur mauvaise fois habituelle du genre :

              - Le navigateur Internet n'existe vraiment que depuis Safari ;
              - Avant iTunes, écouter de la musique se résumait à insérer un CD dans un lecteur ;
              - Contrairement à MacOSX qui se suffit à lui-même, les linuiens sont obligés d'avoir un OS propriétaire tel que Windows d'installé à côté pour certaines tâches car Linux est incomplet et ne permet pas de faire tout ce que peut faire MacOSX qui n'est qu'un Unix qu'Apple a réussi à rendre humain.
              - etc etc (les railleries habituelles quoi)

              « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

        • [^] # Re: moi j'ai mon appstore depuis des années

          Posté par . Évalué à 6.

          Voilà, c'était juste pour dire que, tout comme l'appstore, j'ai déjà une liste d'application disponible gratuitement, que je peux installer en 2 clics.
          Euh.....
          Je me sens obligé de te contredire. Chez Apple, c'est mieux, car chez eux, c'est pas gratuit, c'est payant!
          • [^] # Re: moi j'ai mon appstore depuis des années

            Posté par (page perso) . Évalué à 6.

            C'est payant, et ils peuvent t'enlever tes achats de ton téléphone quand ils veulent.

            Et ça c'est la classe. Tous les autres sont des copieurs.
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par . Évalué à 0.

              Comme la MoFo qui peut te desactiver un add on dans firefox quand ils veulent?

              Depending on the time of day, the French go either way.

              • [^] # Re: moi j'ai mon appstoredepuis des années

                Posté par . Évalué à 4.

                Les addons sont libres et tu peux modifier le code source de Firefox pour changer ce comportement ? (note: je ne sais pas si tu dis vrai ou non)
                • [^] # Re: moi j'ai mon appstoredepuis des années

                  Posté par (page perso) . Évalué à 2.

                  Et surtout ils sont gratuits... Mais je ne sais pas non plus s'il dit vrai, une rapide recherche ne m'a pas apporté de réponses...
                • [^] # Re: moi j'ai mon appstoredepuis des années

                  Posté par . Évalué à 0.

                  Les addons sont libres et tu peux modifier le code source de Firefox pour changer ce comportement ?
                  Mouais le pequin de base, ça lui passe 3000m au dessus des oreilles.
                  note: je ne sais pas si tu dis vrai ou non
                  Mozilla announced yesterday that it will block the Skype Toolbar add-on for Firefox and remotely disable it for existing users. Mozilla was forced to take this extraordinary measure after discovering that severe bugs in the add-on are crippling the browser's performance and stability.
                  Graissage de moi.
                  http://arstechnica.com/open-source/news/2011/01/mozilla-bloc(...)

                  Depending on the time of day, the French go either way.

                  • [^] # Re: moi j'ai monappstoredepuis des années

                    Posté par . Évalué à 10.

                    > Mouais le pequin de base, ça lui passe 3000m au dessus des oreilles.

                    Note que je commence à en avoir marre des cons qui me parlent du péquin moyen.
                    Dans ce cas là, le péquin moyen il s'en branle aussi de la GPL, des standards
                    des fichiers de données, des brevets logiciels, etc.

                    Les débiles qui envahissent DLFP et qui n'ont qu'à l'esprit la fameuse Mme
                    Michu, allez jouer sur PCInpact ou Numerama, reproduisez vous sur MacGeneration
                    et laissez nous tranquilles.
                    • [^] # Re: moi j'ai monappstoredepuis des années

                      Posté par . Évalué à -3.

                      1/ Je ne parle pas du péquin de moyen, mais de base.
                      2/ Tu as raté ton biberon de 16h et tu es tout irrité?
                      3/ Non, rien a ajouter, et je reste si je veux, nah.

                      Depending on the time of day, the French go either way.

                    • [^] # Re: moi j'ai monappstoredepuis des années

                      Posté par . Évalué à 2.

                      Ben moi, j'en ai marre des super devs qui pensent que tout le monde peut faire ou a envie de faire du c ou du vb puis se plaignent ensuite que linux n'est pas prêt pour le bureau.

                      Et non, tout le monde n'est pas capable de modifier un soft, ni même un addons juste parce que les sources sont dispo.

                      Dans ce cas là, le péquin moyen il s'en branle aussi de la GPL, des standards des fichiers de données, des brevets logiciels, etc.

                      Ben oui, c'est le cas, ça t'étonne?

                      Les débiles qui envahissent DLFP et qui n'ont qu'à l'esprit la fameuse Mme Michu, allez jouer sur PCInpact ou Numerama, reproduisez vous sur MacGeneration et laissez nous tranquilles.

                      S'il ne reste que des super devs aussi polis que toi sur ce site, ça va être joyeux.

                      Un péquin moyen qui te dit merde.
                      • [^] # Re: moi j'ai monappstoredepuis des années

                        Posté par . Évalué à 1.

                        Et non, tout le monde n'est pas capable de modifier un soft, ni même un addons juste parce que les sources sont dispo.
                        C'est meme pas une question de competences, c'est une question d'envie de le faire.
                        Je devrais etre capable de modifier les sources de mozilla pour desactiver une feature pareille, mais tres honnetement, j'ai autre chose a foutre.
                        Modifier des applis, je le fait 50 a 60 heures par semaines, le reste du temps, je veux passer du temps avec madame, shooter des cochons dans angry birds, prendre l'air etc. Vivre quoi.

                        If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                        • [^] # Re: moi j'ai monappstoredepuis des années

                          Posté par (page perso) . Évalué à -3.

                          Il y a un monde que visiblement tu ne connais pas : celui du logiciel libre, où les gens peuvent s'échanger des patchs librement et ainsi éviter de refaire un travail qui a été déjà fait par un autre.
                          Un bon exemple c'est X-Chat sous Windows : tu peux modifier les sources toi-même pour ne plus avoir le machin qui te demande de payer, ou alors, télécharger les versions toutes faites.

                          DLFP >> PCInpact > Numerama >> LinuxFr.org

                          • [^] # Re: moi j'ai monappstoredepuis des années

                            Posté par . Évalué à 2.

                            Si c'est pour avoir des patchs a la mords moi le noeud ecrit par pankkake, sans facons, merci.
                            D'ailleurs les appops de facebook attendent ton expertise technique sur comment se passer de hadoop et tout.

                            Prendre des patchs a droite a gauche au pti bonheur la chance, les relire, les appliquer, tester et maintenir son propre build, comment dire?
                            Si c'est pour cloner le vcs des applis que j'utilise et me fader la maintenance, c'est ce que je fait au taff, j'ai autre chose a foutre, merci.

                            Si t'as pas de vie et que tout ce que t'as a foutre de tes journees c'est patcher des applis, c'est cool, pour toi...

                            If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                            • [^] # Re: moi j'ai monappstoredepuis des années

                              Posté par (page perso) . Évalué à 2.

                              Tu réponds complètement à côté (sans compter qu'il faut chercher les arguments parmi les insultes). C'est justement le point fort du logiciel libre : le travail peut être fait par n'importe qui.
                              Si tu avais regardé du côté de X-Chat, tu verrais que des versions patchées et prêtes à l'emploi sont disponibles.

                              DLFP >> PCInpact > Numerama >> LinuxFr.org

                              • [^] # Re: moi j'ai monappstoredepuis des années

                                Posté par . Évalué à -3.

                                Reflechit un chtouille a ce qu'il se passe si tu as besoin de plus d'un patch et s'il proviennent de deux sources differentes.

                                If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                              • [^] # Re: moi j'ai monappstoredepuis des années

                                Posté par . Évalué à 3.

                                "C'est justement le point fort du logiciel libre : le travail peut être fait par n'importe qui."

                                Rémi Gaillard avec nous ! \o/
                    • [^] # Re: moi j'ai monappstoredepuis des années

                      Posté par . Évalué à 1.

                      Dans ce cas là, le péquin moyen il s'en branle aussi de la GPL, des standards
                      des fichiers de données, des brevets logiciels, etc.


                      Ben c'est pas qu'il s'en branle, c'est surtout qu'il n'a pas la moindre idée de ce que c'est et en général ne cherche pas à savoir...
                • [^] # Re: moi j'ai mon appstoredepuis des années

                  Posté par (page perso) . Évalué à 3.

                  Il dit faux, il n'y a pas besoin de modifier quoi que ce soit pour réactiver l'extension :

                  http://blog.mozilla.com/addons/2011/01/20/blocking-the-skype(...)

                  The blocklist entry will be a "soft block", where the extension is disabled and the user is notified of the block and given the option to re-enable it if they choose.

                  DLFP >> PCInpact > Numerama >> LinuxFr.org

      • [^] # Re: moi j'ai mon appstore depuis des années

        Posté par (page perso) . Évalué à 1.

        > Tu n'as pas compris en quoi un gestionnaire de
        > paquet n'est pas un "App Store" et réciproquement.

        blagues à part ... je comprends très bien la différence.

        Mais, qqpart, on (dans le sens, nous, le libre) a loupé le coche.
        Sachant qu'on avait déjà toutes les grosses briques. Si on avait fait une sorte de "app-store" (un synaptic++ user-friendly) ... avec que les applis, des screenshots, des users reviews, il y a qques années ...
        et si les netbooks linux (eee701 & suivants) étaient arrivés avec ça ... peut être que la percée des machine linux/netbook aurait été plus flagrante. plus facile.

        A l'heure d'aujourd'hui, c'est effectivement le app-store d'ubuntu le plus avancé (et il reste largement perfectible) : mais on peut pas dire que c'est "dispo" en masse (dans toutes les distribs). Donc on va encore attendre un peu avant d'avoir ce genre d'appli ;-(

        On a loupé le coche ...

        Cependant, j'aime bien le concept du protocole "apt://" qui va provoquer l'installation via le système de dépot. ça permet d'avoir des frontends web adaptés et découplés, suivant les besoins ou les constructeurs/distributeurs.
        • [^] # Re: moi j'ai mon appstore depuis des années

          Posté par . Évalué à 7.

          Et pourtant ...

          Faudrait pas oublier qu'il y a quelques années , la très décriée distribution Linspire avait developpé un soft s'appuyant sur apt/dpkg qui était exactement ou presque ce qu'est l appstore aujourd hui : Click And Run.

          http://en.wikipedia.org/wiki/CNR_%28software%29
        • [^] # Re: moi j'ai mon appstore depuis des années

          Posté par . Évalué à 3.

          BeOS avait ça il y a 10 ans : http://www.bebits.com

          Une liste de logiciels triés par catégorie, avec des captures d'écran et des notes d'utilisateurs.
          Pour l'installation, il suffisait de décompresser l'archive ZIP.

          Ça n'a pas suffi à faire percer BeOS.

          BeOS le faisait il y a 15 ans !

        • [^] # Re: moi j'ai mon appstore depuis des années

          Posté par . Évalué à 2.

          Suis-je le seul à penser que les screenshots n'apportent absolument rien dans le choix d'une appli ?

          Les 3/4 des fois où je me suis fié à une capture d'écran pour choisir un soft, j'en ai été déçu. Une capture d'écran, ça n'aprend absolument rien sur l'ergonomie de l'appli, sur sa stabilité, sa vélocité etc.

          Et puis les "users reviews", bof quoi. C'est comme pour les boutiques en lignes ou les sites de suggestions de restaurants ou de cinema, au final c'est toujours les plus gueulards et les plus blasés qui s'expriment pour descendrent tout, avec 2-3 personnes qui en parlent honnêtement au milieu. Au final t'es jamais très avancé. Et dans les applis prépackagées par nos distributions, en général quand un soft est de qualité trop merdique et qu'il est trop buggé ou est défaillant d'un point de vue de sécurité, il est tout simplement ejecté.

          Du coup il reste quoi d'intéressant dans un "store" ? La description ? Ben ça on l'a déjà avec nos gestionnaires de paquets.
          • [^] # Re: moi j'ai mon appstore depuis des années

            Posté par (page perso) . Évalué à 5.

            Une capture d'écran, ça n'aprend absolument rien sur l'ergonomie de l'appli, sur sa stabilité, sa vélocité etc.

            Ca tombe bien, ce n'est pas fait pour ça, juste pour attirer le chaland.

            Et dans les applis prépackagées par nos distributions, en général quand un soft est de qualité trop merdique et qu'il est trop buggé ou est défaillant d'un point de vue de sécurité, il est tout simplement ejecté.

            Et des milliers de logiciels ne sont tout simplement pas packagés, du coup on a rpmfind et compagnie tout dépareillé et incompréhensible pour l'utilisateur non geek

            Ben ça on l'a déjà avec nos gestionnaires de paquets.

            Avec libtoto et compagnie, avec de l'argot technique etc... Un AppStore ne t'es peut-être pas destiné, tout simplement, il a pour objectif d'autres utilisateurs que toi, qui n'ont pas les mêmes besoins (en petit logiciels non dans ta distro faute de mainteneur par exemple) et compétences (et qui ne veulent pas les avoir).

            Il y a des reproches faits à la façon de fonctionner actuelle de Linux, et des gens pour essayer d'y répondre, mais non, "il n'y a pas de problèmes on a déjà tout avec nos gestionnaires de paquets méga-géniaux." en réponse, pfff...
            • [^] # Re: moi j'ai mon appstore depuis des années

              Posté par . Évalué à 3.

              Avec libtoto et compagnie, avec de l'argot technique etc...

              Euh...les gestionnaires de paquets avec gui savent depuis moultes années filtrer l'affichage des librairies. J'ai installé des linux pour quelques personnes qui me l'avaient demandés et qui n'ont aucun bagage technique, ils n'ont jamais eu de problème à installer des applis.

              Le souçis n'est pas que vous cherchiez à répondre à des reproches, c'est que vous inventez des problèmes la ou de multiples solutions existent déjà. La première, de base, c'est qu'une documentation ou un manuel, ça se lit.
              • [^] # Re: moi j'ai mon appstore depuis des années

                Posté par (page perso) . Évalué à 4.

                La première, de base, c'est qu'une documentation ou un manuel, ça se lit

                Ta base peut-être, pas la mienne ni celle de beaucoup de monde, qui est : si ça ne se fait pas simplement, qu'il faut ouvrir un manuel pour des choses simples, poubelle.
                Un grosse règle : si pour commencer tu as besoin d'un manuel, c'est que le logiciel est mauvais.

                Tu aimes peut-être être l'esclave de ta machine, d'autres choisissent la facilité (surtout quand en face on montre que c'est possible).
                • [^] # Re: moi j'ai mon appstore depuis des années

                  Posté par . Évalué à 6.

                  Ouais c'est avec des gens comme toi qui prônent l'abrutissement général de la population qu'on se retrouves dans une société où la plupart des gens ne sont même plus capables de changer une ampoule ou une roue de leur auto. À ce rythme la bientôt il faudra installer des siège sur tapis roulant sur tous les trottoirs parce que les gens seront devenus obèse par flemme de mettre un pied devant l'autre pour marcher.

                  Alors toi tu trouves peut-être cohérent de prendre la voiture puis l'ascenseur pour aller au fitness, mais le bon sens hurle à tout blinde que c'est complètement stupide, désolé si tu ne l'entends pas.

                  De toute façon si les gens sont si bêtes qu'ils sont incapables de faire une petite recherche dans leur package manager, je doute qu'ils puissent avoir conscience d'avoir besoin d'un logiciel en plus sur leur ordinateur. D'ailleurs c'est ce genre de personne qui utilisent word ou excel pour faire des dessins, s'ils ne sont pas capable de trouver les outils déjà adaptés à leur usage sur leur os, je doute qu'ils soient capables d'utiliser un "app store".

                  Et puis il y'a une solution plus simple : au lieu de leur installer un OS à moitié vide et impotent, et de se demander s'il y'aurait un moyen facile pour eux d'installer une appli, il suffit de leur installer les 31 cd ou 8 dvd de la debian. Je pense qu'avec ça ils auront de quoi faire tout ce dont ils ont besoin sans avoir à jamais installer une appli.
                  • [^] # Re: moi j'ai mon appstore depuis des années

                    Posté par (page perso) . Évalué à 0.

                    Ouais c'est avec des gens comme toi qui prônent l'abrutissement général

                    Question de point de vue.
                    Tu es au service de ta machine, moi je préfère que la machine soit à mon service.
                    Ta philosophie est pourquoi faire simple quand on peut faire compliqué, la mienne est pourquoi faire compliqué quand on peut faire simple.
                    • [^] # Re: moi j'ai mon appstore depuis des années

                      Posté par . Évalué à 3.

                      Tu es au service de ta machine, moi je préfère que la machine soit à mon service.

                      non pas vraiment. J'apprends à l'utiliser pour l'utiliser du mieux qu'elle le peut au lieu de volontairement la castrer pour l'utiliser à 10% de ses capacités par manque d'informations.

                      Ta philosophie est pourquoi faire simple quand on peut faire compliqué, la mienne est pourquoi faire compliqué quand on peut faire simple.

                      Les gestionnaires de paquet de nos distribs sont ce qui s'est fait de plus simple dans le genre. À côté les écosystèmes windows et apple sont des merdiers ou il faut naviguer de site en site pour installer des applis. D'ailleurs Apple va prochainement résoudre ce problème, mais en y ajoutant probablement des limitations inutiles et inacceptables pour un utilisateur dans le but d'assouvir leur soif de pognon.

                      Donc non, le plus simple, ça reste ce qu'on a sur nos distribs linux.
                      • [^] # Re: moi j'ai mon appstore depuis des années

                        Posté par (page perso) . Évalué à 2.

                        Les gestionnaires de paquet de nos distribs sont ce qui s'est fait de plus simple dans le genre.

                        Oui.

                        À côté les écosystèmes windows et apple sont des merdiers

                        Non. Car le "Oui" d'au dessus n'est pas ce que rencontrent des gens qui veulent un peu utiliser leur machine pour autre chose que du "standard" (bref, pas mal de monde aiment les petites applis à con).

                        Donc non, le plus simple, ça reste ce qu'on a sur nos distribs linux.

                        C'est beau les autruches.
                        Comme si un terminal, des compilations à tout va, des incompatibilités, tout ça parce que le logiciels qu'on cherche n'a pas été mis dans le dépôt, c'était simple.

                        Faudrait un minimum ouvrir les yeux. Bizarrement il n'y a pas que moi qui dit ça, d'autres se posent la même question est la seule réponse est toujours "mais non, tout va bien, il est beau mon Linux". Ben non, ça merde quelque part, mais faut pas le dire, et si d'autres le disent faut pas les écouter.
                        • [^] # Re: moi j'ai mon appstore depuis des années

                          Posté par . Évalué à 3.

                          Des petites applis distribuées hors dépôt, il y'en a plein, que ce soit sous les distribs linux, windows ou Apple.

                          On ne peut pas éviter les exceptions, et aucun autre OS n'a trouvé de meilleure solution que de compiler l'appli et fournir les librairies dépendantes avec. Si tu as un outil magique, propose le, je suis sur que Apple et Microsoft et leurs labos de recherche seront tout autant intéressé que les distributions linux.
                          • [^] # Re: moi j'ai mon appstore depuis des années

                            Posté par (page perso) . Évalué à 1.

                            <cite<Si tu as un outil magique, propose le, je suis sur que Apple et Microsoft et leurs labos de recherche seront tout autant intéressé que les distributions linux.

                            Apple et Microsoft vont bien, t'inquiette pas pour eux, ils ont mis à disposition plein d'outils pour faire des packages, et une base stable (avec un API graphique tout le temps disponible).

                            Pour Linux, c'est pas beaucoup plus compliqué : qu'ils se mettent d'accord, surtout vu la faible part de marché de chaque distro. Ah si c'est compliqué en fait, non pas techniquement mais uniquement par la volonté humaine. Il y a bien un LSB, mais ce n'est pas par défaut dans les distros par la volonté humaine. Il y a bien une compatibilité possible du 32-bit sur du 64-bit, mais pareil ça marche pas partout (il suffit de voir les gens pleurer car un package n'est que 32-bit et donc que ça marche pas. Sous Windows et Mac, ça marche).

                            Il y a des solutions, par contre ça demande que chacun y mette du sien. Et la, c'est pas gagné.
                            • [^] # Re: moi j'ai mon appstore depuis des années

                              Posté par . Évalué à 5.

                              Apple et Microsoft vont bien, t'inquiette pas pour eux, ils ont mis à disposition plein d'outils pour faire des packages, et une base stable (avec un API graphique tout le temps disponible).

                              Ouais bof quoi.

                              Pour les packages, ça semble tellement bien fait sous windows qu'on emballe ça dans un exécutable avec pleins de questions pas très michu friendly du genre ou dois-je mettre des icônes, ou poser l'appli etc...Je me rappelle aussi avoir du mettre à jour windows installer parce qu'un fichier .msi n'était compatible qu'avec la version 3.0, ce qui n'était pas forcément fourni avec le windows xp out of the box.

                              D'autre par, si la base était si stable que ça, quand t'installes un logiciel, au hasard paint.net, on ne te demanderait pas d'installer le framework .net 3.0.

                              Comme quoi ça ne semble pas marcher si bien que ça.
                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par (page perso) . Évalué à 2.

                                Ah oui, tu critiques le fonctionnement d'un nouveau soft sur un vieux OS (au moins ton Paint, tu as juste à installer le framework qui va bien, clic clic clic, et hop. Linux? Faut upgrader toute la distro sinon crève. Ben oui, le framework 3.0 est installé par défaut sous Seven, et MS permet qu'on l'utilise sous WinXP de 2001).

                                Essaye d'installer FF 4.0 sous une distro de 2001 et on rediscute de la simplicité.

                                Bref, sous windows on y arrive en souffrant un peu, sous Linux on y arrive pas, mais tu penses que Linux est mieux, va comprendre. En attendant, les gens restent sous Windows (ou vont vers Mac, pareil niveau facilité), et laissent Linux dans sa merde "parfaite". Autruche à fond.
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 4.

                                  Ah oui, tu critiques le fonctionnement d'un nouveau soft sur un vieux OS

                                  Sauf que le vieil OS de 2001, il était encore vendu avec des pc neufs il y'a moins de 2 ans.

                                  (au moins ton Paint, tu as juste à installer le framework qui va bien, clic clic clic, et hop. Linux? Faut upgrader toute la distro sinon crève.

                                  Alors la je dis n'importe quoi.

                                  D'une part parce que tu peux installer des libs récentes sur une distro ancienne, d'autre part parce que upgrader une distro, c'est pas plus de clique qu'installer ledit framework, ce qui fait que tout utilisateur d'une distrib linux n'est pas "contraint" à rester sur une release de 2001.

                                  Essaye d'installer FF 4.0 sous une distro de 2001 et on rediscute de la simplicité.

                                  ça n'aurait aucun sens car même les linuxiens les plus dinos et poilus ne se trainent pas avec un OS aussi vieux, sauf à faire dans la collection de vieilles bécanes. Ben oui quand on peut upgrader l'OS en 2-coup de cuillères, on s'emmerde pas avec des vieilleries.

                                  À chaque fois tu nous sors les mêmes arguments bidons, à chaque fois ils sont balayés aussi facilement...et à chaque fois tu nus ressors ton histoire d'autruche parce que rien ne tiens debout.

                                  Du reste si tu veux utiliser l'api windows si stable et si chérie dans tes applis, sache que la libwine est faite pour ça. C'est d'ailleurs ce que fait google pour picasa.

                                  Comme quoi l'ecosystème linux a lui, pensé à une solution pour ses developpeurs et ses utilisateurs, pendant que les fabricant des OS proprios s'évertuent à les limiter.
                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par (page perso) . Évalué à 1.

                                    Comme quoi l'ecosystème linux a lui, pensé à une solution pour ses developpeurs et ses utilisateurs,

                                    Tellement vrai que le journal parle de choses pour faire évoluer le système tellement magnifique qu'il ne faudrait pas le changer.

                                    Très rigolo.
                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                      Posté par . Évalué à 4.

                                      Sauf que si tu avais pris la peine de lire ledit journal, le sujet traité est tout autre et ne concerne pas la stabilité d'une quelconque API ou toolkit graphique, ni le packaging. Il concerne seulement la simplification des interfaces d'installation ou de mises à jours des applis et du système.
                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                        Posté par (page perso) . Évalué à 3.

                                        Et le dessus je ne suis pas d'accord avec toi, la dernière fois que j'ai mis mon vieux devant le package manager d'ubuntu (store truc), il est resté bloqué dès qu'il a vu de l'anglais dans les descriptions de package...

                                        En clair, ce qu'il manque à "Linux" c'est:
                                        - Descriptions de package traduites
                                        - Descriptions de package compréhensible: pas de GNOME, KDE, etc ... quand il s'agit d'une applications qui n'a pas besoin du bureau pour fonctionner...
                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                          Posté par . Évalué à 2.

                                          Pour la traduction des descriptions de packages, ce n'est pas un problème structurel mais un problème de main d'oeuvre et de connaissance des langues. En tout cas sur debian, certains descriptions sont traduites, d'autres pas. Et ça dépend beaucoup de la popularité du paquet.

                                          Alors maintenant vouloir utiliser l'outil informatique sans une bonne notion de l'anglais, c'est assez utopique. Encore plus s'il l'on souhaite être connecté à l'internet.

                                          Et contre ça, personne quelque soit l'OS n'a trouvé de solution adaptée autre que "on ne peut pas connaitre toutes les langues, utilisons l'anglais comme standard de fait".
                                          • [^] # Re: moi j'ai mon appstore depuis des années

                                            Posté par (page perso) . Évalué à 2.

                                            >mais un problème de main d'oeuvre et de connaissance des langues.

                                            C'est un problème de base commune entre les distribs...
                                            • [^] # Re: moi j'ai mon appstore depuis des années

                                              Posté par . Évalué à 2.

                                              Partiellement seulement.

                                              Tu as des packages qui ne sont fournis que par l'une ou l'autre et il peuvent aussi être splittés différemment. Donc avoir une base commune, ça aiderait pour que les mainteneurs renseignent les descriptions. De la à automatiser, ça devient plus compliqué.
                            • [^] # Re: moi j'ai mon appstore depuis des années

                              Posté par . Évalué à 4.


                              Il y a bien une compatibilité possible du 32-bit sur du 64-bit,
                              mais pareil ça marche pas partout (il suffit de voir les gens pleurer car un package n'est que 32-bit et donc que ça marche pas. Sous Windows et Mac, ça marche).

                              D'ailleurs voici un bel exemple.
                              Nous utilisons un logiciel 32 bits qui n'a pas été porté en 64 et que ne le sera pas (moi qui croyait que quand on crachait au bassinet pour du proprio on était les rois du monde).
                              Alors voilà ce beau logiciel et ben il a un zoli menu dans l'explorateur Windows et en 64, il ne l'a plus.

                              Alors évidemment on se retourne vers notre gentil éditeur qui nous annonce fièrement que c'est normal et que c'est la fôte aux zôtres
                              qui veulent pas mettre la win32 dans leur Seven, ces nazes (Comme si c'était dur de réécrire un menu en 64)
                              http://support.microsoft.com/kb/895561



                              1- belle démonstration de portabilité 32, 64
                              2- si les communautés ne savent pas s'entendre comment éviter pour que 2 boîtes proprio ne se refilent la patate chaude.
                              3- Tes belles démonstations de supériorité du modèle proprio, ... euh tu te les gardes merci.
                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par (page perso) . Évalué à -2.

                                Tu donnes un exemples d'appli qui s’intègre dans l'OS fortement. Oui, ça ne marche pas à 100%. Mais à 99%. Sous Linux, à 0%.
                                Je préfère 99% à 0%.

                                Tu trouveras toujours des contre-exemples, toujours... Mais au final, globalement, il y a des gens qui préfèrent rester sous Windows parce que c'est plus simple de manière générale.
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 3.

                                  Oui à 99%: ils pourront contourner avec la ligne de commande comme sous ce bon vieux Tux.
                                  Tu iras expliquer ça à nos utilisateurs.

                                  Remarque, ca devrait nous faciliter le boulot pour les convaincre de d'adopter une nouvelle solution... libre cette fois.
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 3.

                                  Et puis

                                  Tu trouveras toujours des contre-exemples, toujours...

                                  N'oublie pas de t'appliquer cette jolie remarque à toi-même


                                  Mais au final, globalement, il y a des gens qui préfèrent rester sous Windows parce que c'est plus simple de manière générale.

                                  Ou ai-je prétendu le contraire ? Bien souvent je m'associe à toi pour ce constat.

                                  Quand à savoir s'il y a un rapport de cause à effet avec le modèle proprio, ...

                                  Mais là tu tentes de noyer le poisson.
                                  Il n'en reste pas moins que ton argument massue "Avec Windows ca marche" est caduque.
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 2.

                                  99% ? Avec le nombre d'applis qui tournaient sous XP et qui ne marchent plus sous Seven pour X raison ? 64 bits, besoin de droits d'admins, etc... J'ai comme un doute sur le chiffre. Et oui il y a des modes de compatibilité, et non ça ne marche pas à tous les coups.
                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par . Évalué à 4.

                                    Un exemple très populaire :Winamp 2.x ne peut plus tourner sous Vista & Seven.
                                    Même sous XP en compte limité, il ne fonctionne pas parce qu'il tente d'écrire dans C:\Program Files.

                                    Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par . Évalué à 3.

                                Et pour préciser le contexte avant que tu ne me sortes que c'est un logiciel de niche (tu réponds pas à Nicolas d'ailleurs sur les exemples qui te defrisent avec Linux)

                                Pour le mien, je dirais qu'il est (était) mainstream dans la gestion de conf, et que son éditeur est un schtroumpf géant.
                                Si on avait les sources, on pourrait s'en occuper nous-même, mais voilà il vaut mieux qu'on continue de payer pour qu'ils peaufinent son successeur et tentent de nous l'imposer et continuent à nous éconduire poliment.
                          • [^] # Re: moi j'ai mon appstore depuis des années

                            Posté par . Évalué à 2.

                            Je pense qu'apple se demerde plutot pas mal, avec des binaires compiles en ppc (32 ou 64) qui tournent sur un x86 (32 ou 64).
                            Et c'est pas builde en statique, hein, core foundation ca fait un peu trop grossir le binaire ;-)

                            Sous linux, on en est encore a devoir chrooter manuellement les binaires x86 32 bits sur une machine 64 et avec des erreurs absconces a droite a gquche (cf journal recent).

                            Quand a windows, un binaire 95 tourne sur seven si le boulot a ete fait a peu pres correctement (16 ans de compatibilite ascendante), et un binaire seven tourne sur 2k, soit 11 ans de compatibilite descendante.

                            Bref, les labos apple et ms se portent bien, sans doute parce que quand on leur a rapporté le probleme, ils ne repondent pas "mais non, ca marche tres bien, c'est ces utilisateurs a la con qui savent pas y faire".

                            If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                            • [^] # Re: moi j'ai mon appstore depuis des années

                              Posté par . Évalué à 6.

                              Et c'est pas builde en statique, hein, core foundation ca fait un peu trop grossir le binaire ;-)

                              Oui merci capitaine obvious mais ça on sait faire sous linux, c'est même la règle. Mais bon les core foundation, c'est bien beau, mais ce n'est pas toujours suffisant.

                              Sous linux, on en est encore a devoir chrooter manuellement les binaires x86 32 bits sur une machine 64 et avec des erreurs absconces a droite a gquche (cf journal recent).

                              Quand a windows, un binaire 95 tourne sur seven si le boulot a ete fait a peu pres correctement (16 ans de compatibilite ascendante), et un binaire seven tourne sur 2k, soit 11 ans de compatibilite descendante.

                              Bref, les labos apple et ms se portent bien, sans doute parce que quand on leur a rapporté le probleme, ils ne repondent pas "mais non, ca marche tres bien, c'est ces utilisateurs a la con qui savent pas y faire".


                              Je crois surtout que ces problèmes ne concernent que les applications réalisés par des merdeux qui ne veulent pas fournir les sources sous licence libre.

                              Parce que vouloir faire tourner un binaire 32bit sur un os 64bit, c'est stupide quand on a les moyens d'utiliser le binaire compilé en 64bit. De même qui voudrait faire tourner un binaire de 11 à 16 ans d'age quand on peut avoir un binaire recompilé à partir de sources et de librairies mises à jour et aux éventuels bugs corrigés ?

                              Donc forcément, si vous essayez de rapporter des problèmes qui ne nous concernent pas parce qu'on n'a pas adopté une attitude débile au départ, c'est normal qu'on vous dise "non nous ça marche très bien".
                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par . Évalué à 0.

                                Oui merci capitaine obvious mais ça on sait faire sous linux, c'est même la règle. Mais bon les core foundation, c'est bien beau, mais ce n'est pas toujours suffisant.
                                Ben voyons, on sait faire sous linux, j'aimerais bien voir ca tiens.
                                Build une appli ppc liee dynamiquement a disons, gtk 2.2 ppc, et lance la sur un linux x86_64 avec gtk 2.8, et constate par toi meme...

                                Je crois surtout que ces problèmes ne concernent que les applications réalisés par des merdeux qui ne veulent pas fournir les sources sous licence libre.
                                Ben oui, c'est forcement de la faute des autres, evidemment. Linux est, le monde doit s'adapter a linux.

                                C'est pas parce qu'on a les sources qu'on veut necessairement se faire chier a les builder/maintenir en permanence.
                                D'autre part, suffit pas de dire "on a les sources, ya qu'a builder" pour que ca marche automagiquement tout seul.

                                Ya une foultitude de raison pour lesquels on peut vouloir faire tourner un vieux binaire.
                                Parce que, par exemple, c'est une vieille appli qui n'a pas ete touchee depuis qq temps (genre outil interne d'une boite par exemple), et qu'on a autre chose a foutre de la rebuilder.

                                Parce que, par exemple, c'est une appli maison qui a 3 jours, mais qu'entre temps on a fait un dist upgrade et qu'on est donc passe de gtk 2.8.1 a 2.8.2 et qu'on a autre chose a foutre.

                                Parce que, par exemple, c'est une appli qui se base sur une api kernel depreciee la semaine derniere, qu'il faut en reecrire les 3/4 et qu'on a autre chose a foutre.

                                If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 1.

                                  Ben voyons, on sait faire sous linux, j'aimerais bien voir ca tiens.
                                  Build une appli ppc liee dynamiquement a disons, gtk 2.2 ppc, et lance la sur un linux x86_64 avec gtk 2.8, et constate par toi meme...


                                  Je parlais de linkage dynamique. Un binaire qui foncitonne à la fois sur ppc et x86_64, ça n'a aucun intérêt.

                                  Ben oui, c'est forcement de la faute des autres, evidemment. Linux est, le monde doit s'adapter a linux.

                                  Euh non, c'est juste le problème de gens qui s'enferment dans le monde proprio et que dans le libre, on n'a pas ce genre de problème puisqu'on fournit les sources et les moyens de les compiler.

                                  Ya une foultitude de raison pour lesquels on peut vouloir faire tourner un vieux binaire.
                                  Parce que, par exemple, c'est une vieille appli qui n'a pas ete touchee depuis qq temps (genre outil interne d'une boite par exemple), et qu'on a autre chose a foutre de la rebuilder.


                                  Ouais et ça c'est que des mauvaises raisons et ce qui nous pourrit la vie dans une entreprise. Une appli, soit on l'utilise et on la maintient, soit on la jette. Vouloir garder des vieilles applis dont on ne sait si ça peut nous péter au nez dans x années...c'est une mauvaise pratique et il convient de corriger cette pratique au lieu de la soutenir.


                                  Parce que, par exemple, c'est une appli maison qui a 3 jours, mais qu'entre temps on a fait un dist upgrade et qu'on est donc passe de gtk 2.8.1 a 2.8.2 et qu'on a autre chose a foutre.


                                  Foutaise, parce qu'un dist-upgrade, ça se planifie et que ton appli de 3 jours d'age ne va pas subitement ne plus ser compiler en changeant de version mineur de gtk.

                                  Et puis je ne sais pas sur quelle planète tu vis, mais dans le monde réel, on utilise rarement des rolling releases en prod. Tes applications compilées pour telle ou telle debian stable ou rhel 4.x ou 5.x, elle ne va pas s'arrêter de fonctionner du jour au lendemain parce que tu passes des patches.
                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par . Évalué à 3.

                                    > Un binaire qui foncitonne à la fois sur ppc et x86_64, ça n'a aucun intérêt.
                                    Ben voyons!
                                    Et si il existait un truc pareil en libre, tu serais en train d'expliquer comment ca roxXxe des ours...

                                    Sinon l'interet me parait assez evident, le mec change sa machine, clone son compte sur la nouvelle et continue a utiliser la nouvelle machine comme si de rien n'etait.

                                    > Une appli, soit on l'utilise et on la maintient, soit on la jette
                                    Donc l'appli qui marche tres bien, pas de nouveaux bugs, les bugs existants sont juges suffisament peu important pour pas les corriger, et toi tu veux aller foutre tes sales pattes dedans et tout peter, juste au nom d'un beau principe a la con?

                                    > Vouloir garder des vieilles applis dont on ne sait si ça peut nous péter au nez dans x années
                                    Ouais, vaut mieux y toucher, comme ca au moins, on est sur que ca nous petera a la gueule.
                                    Bon courage pour justifier des resources en tout cas, pis ca va vachement donner envie aux decisionnaires de passer sous linux ton beau discours.

                                    > Foutaise, parce qu'un dist-upgrade, ça se planifie et que ton appli de 3 jours d'age ne va pas subitement ne plus ser compiler en changeant de version mineur de gtk.
                                    Entre 2 mineurs de gtk, peut etre, entre 2 mineurs du kernel, combien tu paries?

                                    > Tes applications compilées pour telle ou telle debian stable ou rhel 4.x ou 5.x, elle ne va pas s'arrêter de fonctionner du jour au lendemain parce que tu passes des patches
                                    Non, mais le jour ou les sysops decident de passer d'une rhel 4 a 5, je te paries mon dejeuner que 95% des binaires maisons vont te peter a la gueule.
                                    On fait quoi alors, on rebuild tout et on repasse toute la qa, et on se fait chier a tout redeployer et a prier pour que ca pete pas qq part (ce qui est une raison necessaire et suffisante pour que ca pete qq part).

                                    If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                      Posté par . Évalué à 0.

                                      > Sinon l'interet me parait assez evident, le mec change sa machine, clone son compte sur la nouvelle et continue a utiliser la nouvelle machine comme si de rien n'etait.
                                      Ben, ça le fait déjà : ton compte n’est pas censé contenir de binaires…

                                      > Et si il existait un truc pareil en libre
                                      Ça existe : c’est une fonctionnalité de Darwin, qui est libre…

                                      > entre 2 mineurs du kernel, combien tu paries?
                                      Une maj mineure du kernel qui pète une appli userland ? Tu utilises fedora en version svn ou tu as juste fait exprès pour pouvoir dire ensuite fièrement « c’est pas solide linux » ?
                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                        Posté par . Évalué à -1.

                                        Ben, ça le fait déjà : ton compte n’est pas censé contenir de binaires…
                                        Pardon pour le raccourci, les applis sont aussi migrees quand tu migres ton compte. Enfin, si tu le souhaites.

                                        Une maj mineure du kernel qui pète une appli userland ? Tu utilises fedora en version svn ou tu as juste fait exprès pour pouvoir dire ensuite fièrement « c’est pas solide linux » ?
                                        On s'en fout que l'appli soit user land ou kernel space.
                                        Si ca pete, ca pete, ca me fait une belle jambe de savoir que ca tournait en kernel space si mon driver de carte graphique refuse de faire quoi que ce soit.

                                        If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par (page perso) . Évalué à 5.

                                    >on n'a pas ce genre de problème puisqu'on fournit les sources et les
                                    >moyens de les compiler.

                                    Et beh, t'en tiens une sacré couche toi...

                                    Je te mets au défit de recompiler Gnome 1.4 sur une distrib 2011, tu vas vite comprendre pourquoi avoir les sources ca sert à rien quand l'éco système en question évolue trop vite...

                                    Alors, certe comme toi je m'en fou des softs proprios, mais tout ce que te dis le monsieur est justifié et c'est sur que pour des boites qui vendent du proprio, Linux n'est souvent pas une option... Et oui, ces boites vendent des versions n+1 de leur logiciel souvent sur du rien... Avec Linux, il faudrait faire évoluer le soft, non de non!!!
                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par (page perso) . Évalué à 0.

                                « capitaine obvious » : Non ! Capitaine Évident, ou alors, Captain Obvious.

                                DLFP >> PCInpact > Numerama >> LinuxFr.org

                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par (page perso) . Évalué à 1.

                                De même qui voudrait faire tourner un binaire de 11 à 16 ans d'age quand on peut avoir un binaire recompilé à partir de sources et de librairies mises à jour et aux éventuels bugs corrigés ?

                                Peut-être une personne qui ne sait pas compiler (99% de la population) et/ou n'a pas envie de passer des heures à debugger / trouver les dépendances / compiler les dépendances car les nouvelels versions de la distro ont changé d'API?

                                , c'est normal qu'on vous dise "non nous ça marche très bien".

                                Non, ça ne marche pas bien, le problème des applications non instables est une tare de Linux, ce n'est pas en le cachant que les gens changeront d'opinion sur Linux et sa sale réputation d'OS pour masochistes (soit qui aiment s'enfermer dans un nombre limité d'applis, soit qui aiment compiler, les deux extrêmes).
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 2.

                                  Peut-être une personne qui ne sait pas compiler (99% de la population) et/ou n'a pas envie de passer des heures à debugger / trouver les dépendances / compiler les dépendances car les nouvelels versions de la distro ont changé d'API?

                                  Ce n'est pas à l'utilisateur final de compiler, mais aux mainteneurs des distributions ou aux développeurs s'ils décident aussi d'être mainteneurs.

                                  Ton charabia sur les applications non instables ne veut rien dire.
                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par (page perso) . Évalué à 2.

                                    mais aux mainteneurs des distributions ou aux développeurs s'ils décident aussi d'être mainteneurs.

                                    Et la marmotte...
                                    Tu parles de la jolie théorie, on de parle de la vraie vie où ça ne fonctionne pas comme ça, loin de la.

                                    Reste dans ton petit monde bisounours où les mainteneurs font leur boulot théorique pour tous les logiciels sur terre avec une version à jour, en attendant les gens vivent dans la vraie vie où l'appli qu'ils voudraient n'est pas dans les dépôts (ou la version des dépots est trop ancienne).

                                    C'est la merde pour pas mal d'utilisateurs et de développeurs (même les développeurs hurlent que tel bug est déjà corrigé depuis 2 ans mais que la distro n'a pas mis à jour), il y a un tonne de dépôts parallèles pour essayer de compenser cette merde, mais chut, c'est juste pour le plaisir que les gens font ça, le monde est parfait sinon... C'est du foutage de gueule, tu m'étonnes que Linux Desktop ne décolle pas avec une telle mentalité sur les problèmes.
                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                      Posté par . Évalué à 2.

                                      Franchement cette histoire d'utilisateurs qui pleurnichent en attendant la dernière version, ce sont des foutaises. Les utilisateurs veulent quelque chose qui fonctionne, point barre. D'ailleurs la plupart des utilisateurs sous mac et windows installent leur applis quand ils reçoivent leur pc mais s'il n'y a pas de système de mise à jour intégré à l'application (problème que les distributions linux ont répondu il y'a déjà moultes années), ils ne la mettent pas à jour.

                                      C'est pas pour rien que des sociétés comme secunia ont sortis des logiciel comme PSI pour pousser les utilisateurs à mettre à jour toutes leurs applis pour ne pas se retrouver avec des milliards de zombies.

                                      Le seul domaine ou je reconnais que les utilisateurs ont un réel besoin de mise à jour facile, c'est pour les jeux avec lesquels tu ne peux pas forcément te connecter au serveur officiel si tu n'es pas synchronisé. Et pour ça il y'a des initiatives comme playdeb.
                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                        Posté par (page perso) . Évalué à 2.

                                        Juste un hic : pour pouvoir imaginer mettre à jour, encore faut-il avoir réussi à installer la première fois. Avec Linux, les MAJ c'set bien avec les dépots, juste que le logiciel souhaité n'étant pas dans les dépots, on n'installe pas (soyons positifs PsychoFox : ça élimine le besoin de MAJ, tout va bien donc)

                                        Le seul domaine ou je reconnais que les utilisateurs ont un réel besoin de mise à jour facile,

                                        Tiens, ça commence à se fissurer...

                                        Et pour ça il y'a des initiatives comme playdeb.

                                        Pour les rpm aussi? Bref, voila la merde qui arrive à grand pas...
                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                          Posté par . Évalué à 1.

                                          Passons à la pratique, tu veux bien ? Tu penses à quels logiciels au fait ?

                                          Logiciels qui bien évidemment sont : populaires (puisque tu veux augmenter les parts de marché) et plus en phase de développement intensif et tests (car c’est le modèle du libre qui te permet d’avoir accès au moins au sources dans cette phase).
                                          • [^] # Re: moi j'ai mon appstore depuis des années

                                            Posté par (page perso) . Évalué à 1.

                                            Tu penses qu'un logiciel est universel, que tout le monde doit absolument vouloir le même.
                                            Ben non : un petit jeu à la con, un petit programme à la con, que a le hype à un moment donné, un logiciel très connu dans son domaine (exemple : Ardour dans le domaine musical, le dév' en avait marre à un moment des packageurs qui packagent mal - bugs à cause d'eux - et en retard), chacun a son petit logiciel qui est important pour lui. Des personnes s'en foutent de la dernière version, pour d'autres c'est important, Windows répond au deux avec des petits problèmes, Linux ne répond qu'à un seul des cas et trouve ça parfait (mais il y a des repos dissidents pour eux, faut juste dédoubler le travail par distro... Que du simple!)

                                            Linux, sous couvert de liberté, tend à l'uniformisation (seuls les logiciels "connus de tous" peuvent avoir assez de packageurs pour être dispo partout), et les gens, ben ils veulent un trucs qui marche en dessous (l'OS) pour pouvoir ne pas être uniforme. Vaut mieux Windows uniforme + plein de logiciels que Linux non uniforme + peu de logiciels.

                                            Déjà, rien que dans la question, on voit qu'il y a un gros problème vis à vis des gens.
                                            • [^] # Re: moi j'ai mon appstore depuis des années

                                              Posté par . Évalué à 3.

                                              Et sinon ? C’est bien beau ton discours, mais donne les ces programmes ? Donne les tes exemples, donne les tes faits ! Montre là ta pratique de Linux ! Me donne pas juste un programme au marché de niche, donnes en plein si tu dis que c’est ça le problème. On va pouvoir avancer, mais si personne ne sait de quels programmes tu parles, personne va pouvoir les packager.
                                              • [^] # Re: moi j'ai mon appstore depuis des années

                                                Posté par (page perso) . Évalué à 2.

                                                Tu t'obstine à vouloir des exemples, mais tu refuses de comprendre que chaque personne est différente, et que des exemples, c'est par personnes.
                                                Si je te donnes mes exemples, tu diras "bla bla bla c'est pas bon" etc... SI je te donnes des exemples de mon voisin, pareil tu trouveras une excuse.

                                                En attendant, chacun se confronte au problème.

                                                Je t'ai donné un exemple, tu le balayes. Occupes-toi déjà de celui-la. Non, tu t'en occupes pas, tu le zappes, "juste un programme au marché de niche,", justement Windows et Mac sont remplis de programme de marché de niche et c'est ce qui fait leur force!
                                                • [^] # Re: moi j'ai mon appstore depuis des années

                                                  Posté par . Évalué à 4.

                                                  Je te demande juste d’étayer tes arguments avec des faits concrets. Tu te défiles, par deux fois. Je veux bien que ce soit la multitude de programmes au marché de niche qui bloque. Mais donne les ces programmes.

                                                  Montre que tu as raison. C’est gratifiant…

                                                  « chacun se confronte au problème »

                                                  Ben c’est là le hic. c’est que tu viens sur un site de Linuxien, que tu veux soit-disant changer les mentalités de ces même linuxiens. S’ils sont linuxiens, c’est pas par pur masochisme, c’est parce qu’ils utilisent le système qui leur convient le mieux. S’ils ne se reconnaissent pas dans tes arguments, il faut que tu apportes un peu d’eau à ton moulin. En l’occurence, je me sens pas confronté au problème : je n’ai qu’un programme (ormi les miens) que j’ai dû compilé, et c’est un projet en phase de développement (seeks) au marché de niche, et les dév. n’ont pas prévu, encore ^^, de dominer le monde avec.

                                                  « Je t'ai donné un exemple, tu le balayes. Occupes-toi déjà de celui-la. »

                                                  Le problème est qu’au bout de 2 min. de recherche je n’ai pas trouvé quels étaient les problèmes de packaging d’ardour. Et non je n’ai pas envie de passer plus de temps que ça pour vérifier des écrits balancés en moins de 10 s par des présumés trolls. Sinon je passerais ma vie sur Linuxfr à vérifier toutes les conneries qui y sont dites. N’hésite pas à me donner des pointeurs vers les discussions intéressantes à ce sujet. Ceci dit, si c’est un problème de paquet mal préparé, mon expérience de Windows n’est pas reluisante de ce côté là.
                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par (page perso) . Évalué à 2.

                                                    J'ai abandonné pour les longues explications, il y aura toujours une "bonne raison" pour bla bla bla.

                                                    Bon, allez, vite fait, pas sur un bug de package, pire, une absence : Essaye d'installer Ardour sous Debian Stable. Marche pas, pas les paquets. Une personne sous Ubuntu aura plus de chances (Universe) ainsi que ceux sous Squeeze certes.
                                                    Ardour est très apprécié dans sa niche, mais voila, sous Debian Stable (une version actuelle, tu peux pas l'installer facilement. Fail.
                                                    Ca a l'air facile Linux, mais voila, en pratique, il manque beaucoup de logiciels, qu'on ne peut pas installer faute de packageurs.
                                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                                      Posté par . Évalué à 2.

                                                      Ben qu’est-ce que tu veux que je te dise, Debian stable est Debian stable. C’est le principe de la distribution. Le packageur existe, la preuve Ardour est dispo. dans testing et le sera bientôt pour stable ; tu attends quelques semaines ? (croisons les doigts ^^)

                                                      « il manque beaucoup de logiciels »

                                                      Lesquels ?! Parce que là le seul exemple que tu as sorti, tu viens de démontrer que le paquet et le mainteneur existent (puisque dans testing). Les faits contre-disent la conclusion de ton commentaire.

                                                      Alors je le sens venir gros comme une maison, tu veux la Debian stable, pas une autre, tu veux absolument celle-là, pourqoi ? Parce que les gens c’est ce qu’il veulent, un système stable et rajouter des applications dessus comme ils veulent. Pourquoi ? Ça j’en sais fichtre rien… PARCE QUE !?¹ Peut-être parce qu’ils sont habitués à faire comme ça sous Windows. Mais concrètement quels sont les avantages ? Reste-t-ils valables dans un éco-système type Linux ?

                                                      ¹ Oui, je fais les Q&A pour gagner du temps…
                                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                                        Posté par (page perso) . Évalué à 2.

                                                        tu veux absolument celle-là, pourqoi ?

                                                        Dit-moi ce dont tu as besoin, je te dirais comment t'en passer.
                                                        Ca donne envie.

                                                        La réponse serait plutôt : pourquoi pas? Pourquoi devoir changer de distro pour un petit logiciel? pourquoi devoir bidouiller en ligne de commande comme le propose PsychoFox et donc "être dans le milieu, connaitre"? Comment on faisait avant Testing? Un logiciel la, mais pas ici, et inversement pour un autre, à se tirer des balles.

                                                        Tu prends un Windows de 2001 ça marche. Un Windows de 2010 ça marche aussi. Un Mac de 2001, aussi. Un Mac de 2010, aussi.
                                                        Ca marche ailleurs, et les gens utilisent alors cet "ailleurs" qui ne leur demande pas d'être l'esclave de la machine pour pouvoir se servir de la machine. C'est tout. Pas de combat, juste un constat : Ce n'est pas la faute des autres si Linux ne décolle pas sur le desktop, juste la faute de Linux. Je trouve ça dommage, mais ça ne m’empêche pas de dormir, je fais comme pas mal de monde : plein de logiciels libres qui répondent aux besoin sur un OS non libre.
                                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                                          Posté par . Évalué à 0.

                                                          ah bizarre, le même binaire tourne sous windows 2001 et mac 2010 ?
                                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                                          Posté par . Évalué à 2.

                                                          Non : l’esprit c’est, dis-moi ton besoin, je te dirai la distro. la plus adaptée. Quand j’ai découvert Linux, j’en ai essayé des distro., je me suis trompé d’ailleurs, d’autant qu’à l’époque c’était encore plus dur d’avoir un matériel directement reconnu. Dire que tu veux une Debian stable, et te plaindre qu’il n’y a pas tel ou tel paquet, qu’untel n’est pas à jour, c’est juste que ça paraît absurde si tu ne dis pas pourquoi tu veux une stable, si tu ne dis pas ce qui te contraint à utiliser une Debian stable.

                                                          « La réponse serait plutôt : pourquoi pas? Pourquoi devoir changer de distro pour un petit logiciel? »

                                                          Ben ouai, mais pourquoi pas… passer à testing ? Ça se fait en deux-trois mouvements de passer en testing ! Le mec qui a installé une Debian saura mettre à jour en testing, à priori, ou trouvera au moins comment faire.

                                                          « Tu prends un Windows de 2001 ça marche. Un Windows de 2010 ça marche aussi. »

                                                          Mais pourquoi utiliser un Windows de 2001 ? Pourquoi utiliser un système obsolète ? Car en 2001, si je ne me trompe pas, l’utilisation de clefs usb étaient galère, enfin… je sais que les XP non mis à jour sont très susceptibles si on tente de leur en introduire une. Pour un Windows il faut racker, mais pour un Linux alors, pourquoi prendre un Linux de 2001 ? Pourquoi utiliser un système obsolète ?

                                                          La démarche est simple : identifier tes besoins et tes contraintes, puisque tu dis que Linux ne te convient pas. Puis voir ce qui peut être fait. Ça sera un début, même si je reconnais que ça ne sera sûrement pas moi qui ira t’aider plus que ça. Mais t’auras fait au moins un convaincu (enfin, si ça ne re-dégénère pas en troll par lassitude de ma part, car pour le moment j’essaie d’être de bonne foi dans la discussion).

                                                          Sinon, que je sache testing a toujours existé, enfin depuis au moins 7-8 ans. Par contre à la base je considère que quelqu’un qui installe une Debian doit soit s’y connaître un peu, soit avoir un peu de temps pour se documenter. Pour la distrib. facile d’accès, à une époque c’était mandrake, il y a eu aussi une période pas mal knoppix, enfin ubuntu. Alors si tu commences à me parler de Debian, ne prend pas comme postulat de départ une utilisation de bureau massive ! Ça n’est certainement pas la distribution qui percera, s’il devait y’en avoir une.
                                                          • [^] # Re: moi j'ai mon appstore depuis des années

                                                            Posté par . Évalué à 2.

                                                            On notera aussi que quelqu'un qui envisage d'utiliser un logiciel comme ardour est capable de prendre les 5 minutes qu'il faut (ça ne demande pas plus) pour connaitre et intégrer le principe des releases de debian. Il aura besoin de bien plus de temps pour comprendre le fonctionnement d'une station de travail de homestudio.
                                                            • [^] # Re: moi j'ai mon appstore depuis des années

                                                              Posté par . Évalué à 1.

                                                              Le truc c'est que comprendre le fonctionnement d'un home studio, c'est son domaine (la musique).
                                                              Comprendre le fonctionnement d'une distrib, pas forcement.

                                                              Le temps est pas illimite, et generlament les gens preferent approfondir leur domaine plutot que de devoir un apprendre un radicalement different.
                                                              Surtout quand c'est propose de facon aussi agreable.

                                                              If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                                          Posté par (page perso) . Évalué à 3.

                                                          Mwai, en meme temps, Debian stable, c'est vraiment le mauvais exemple que tu donnes, c'est le principe même de pas rajouter de nouveau logiciel et de nouvelles version de logiciel... Donc c'est sur, avec Debian stable, c'est pas facile d'utiliser des soft récents :p
                                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                                          Posté par . Évalué à 2.


                                                          "être dans le milieu, connaitre"?


                                                          Toi qui est vieux de la vieille en W$, jure moi que tu n'as jamais eu à aller récupérer une dll au fin fond du net et à la recopier dans ton path pour qu'un de ces jolis petits softs fonctionne.

                                                          Jure moi que tu n'a pas pesté parce que celui-là te demandait de passer à la dernière version de dotnet et tu te retrouves en cascade à installe le dernier service pack qui te récupère les maj de IE dont tu n'as rien à carrer, que tu te retrouves à passer une heure pour tester ce truc alors que ca se fait soi-disant en un claquement de doigts.

                                                          Bizarrement ca compte pas là, faut pas être expert, hein.
                                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                                      Posté par . Évalué à 3.

                                                      Bon, allez, vite fait, pas sur un bug de package, pire, une absence : Essaye d'installer Ardour sous Debian Stable. Marche pas, pas les paquets. Une personne sous Ubuntu aura plus de chances (Universe) ainsi que ceux sous Squeeze certes.
                                                      Ardour est très apprécié dans sa niche, mais voila, sous Debian Stable (une version actuelle, tu peux pas l'installer facilement. Fail.


                                                      C'est ton argument qui est "failed".

                                                      depuis une debian stable:
                                                      aptitude install -t testing ardour

                                                      et le voila ton ardour tout beau tout propre.
                                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                                        Posté par . Évalué à 4.


                                                        depuis une debian stable:
                                                        aptitude install -t testing ardour


                                                        Mouarf... t'as vraiment essayé ?

                                                        parce que bon tirer en dépendance la libc6, gtk et la moitié de X11 de testing sur une lenny j'appelle pas ca "tout beau tout propre"
                                              • [^] # Re: moi j'ai mon appstore depuis des années

                                                Posté par . Évalué à 2.

                                                Bon, allez, mon exemple perso : un script PHP développé par un tiers, qui utilise str_getcsv. Fonction disponible depuis PHP 5.3.
                                                Va déployer ça sur une RHEL5, surtout si la politique des admins est : pas de dépôts externes.
                                                • [^] # Re: moi j'ai mon appstore depuis des années

                                                  Posté par (page perso) . Évalué à 2.

                                                  J'osais pas parler de la chose, sous peine de me faire rembarrer "c'est pour des dev, donc ils peuvent compiler" (sauf que les des PHP ne sont pas forcément fan de la compilation, mais bon chut...).

                                                  Note toutefois que de tête, PHP 5.3 est disponible dans la dernière update (RHEL5.6) en paquet optionnel (php53).
                                                  Comme quoi, ça commence doucement à être pris en compte, pour par devoir passer à RHEL6 (en cassant tout le reste) juste pour PHP 5.3 : maintenant, tu as le choix, la version initiale ou la version plus à jour, tu es libre.

                                                  Certaines complaintes commencent doucement à être prises en compte, ouf!
                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par . Évalué à 3.

                                                    Moi aussi je vais donner mon petit exemple:

                                                    Envie d'installer ImDB.py sans me prendre la tête avec un simple exe àlà Windows et là c'est le drame: il existe pas pour la 2.7 de python

                                                    Obligé d'en passer par un setup.py qui me crache à la gueule parce qu'il faut se taper l'install de lib natives.
                                                    Bilan: 1h de perdue

                                                    Je ferai pas l'offense aux linuxiens de leur demander combien ca leur prend pour faire de même sous leur distrib.

                                                    Mais tu as raison même pour les devs W$ c'est plus simple.
                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par . Évalué à 2.

                                                    Euh je veux pas dire mais tu es en pleine science-fiction. Quand on achète une redhat enterprise, on ne s'attends pas à avoir des applications bleeding edge. On paye justement pour avoir des versions éprouvées et tester. Se plaindre serait idiot.

                                                    Et c'est justement ça qui est intéressant dans le monde linux. Tu peux choisir d'utiliser une distribution favorisant plus ou moins la stabilité des versions des paquets fournies. Pourquoi s'en plaindre ?

                                                    Le problème mentionné par Moonz est organisationnel au sein de son entreprise qui choisi volontairement d'utiliser un OS ne favorisant pas le bleeding edge, tout en interdisant d'installer autre chose en voulant en même temps utiliser des outils non supportés. Il n'est pas lié à linux.
                                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                                      Posté par (page perso) . Évalué à 3.

                                                      On paye justement pour avoir des versions éprouvées et tester. Se plaindre serait idiot.

                                                      C'est pour ça que RH a mis PHP 5.3 dans RHEL 5... C'est assez surréaliste : même RH se met à faire des choses pour répondre aux clients pros, mais on est toujours dans le déni sur le besoin!

                                                      Bravo.

                                                      PS : on n'est pas obligé de payer : CentOS.
                                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                                        Posté par . Évalué à 4.

                                                        C'est pour ça que RH a mis PHP 5.3 dans RHEL 5... C'est assez surréaliste : même RH se met à faire des choses pour répondre aux clients pros, mais on est toujours dans le déni sur le besoin!

                                                        Rien à voir avec du déni, ça signifie juste qu'après 1 an et demi et de nombreuses corrections de bug, redhat a jugé php 5.3 suffisemment mature en 2011.

                                                        Ton PS est hors-sujet, on parle de redhat la, avec le support que ça sous-entend.
                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par (page perso) . Évalué à 2.

                                                    « ça commence doucement à être pris en compte »
                                                    « Certaines complaintes commencent doucement à être prises en compte, ouf! »

                                                    Red Hat a toujours fait ça, ils n'ont pas attendu tes 100 troll radoteurs journaliers sur DLFP pour proposer ce genre de choses.

                                                    Et si c'est un paquet optionnel c'est parce que certaines choses ne fonctionnent plus comme en 5.2.

                                                    DLFP >> PCInpact > Numerama >> LinuxFr.org

                                                • [^] # Re: moi j'ai mon appstore depuis des années

                                                  Posté par . Évalué à 2.

                                                  et sous windows, tu fais comment, si la politique des admins c'est "pas de logiciel externe" ?

                                                  Puis pas de dépot externe, ca n'empêche pas (tout comme poru windows) de prendre une version 5.3 et de la mettre dans un dépot interne géré par les admins.
                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                          Posté par . Évalué à 2.

                                          Et pour ça il y'a des initiatives comme playdeb.

                                          Pour les rpm aussi? Bref, voila la merde qui arrive à grand pas...


                                          Ecoutes si après tant d'années tu n'as toujours pas compris que linux c'est uniquement un noyau et que les différentes distribs sont des OS différents, je ne peux plus rien faire pour toi.
                            • [^] # Re: moi j'ai mon appstore depuis des années

                              Posté par (page perso) . Évalué à 3.

                              C'est impossible que le binaire ppc tourne sur du x86 sauf à utiliser un émulateur. https://secure.wikimedia.org/wikipedia/en/wiki/Rosetta_(soft(...) ça semble d'ailleurs assez limité.

                              Il n'y a pas besoin de chroot pour lancer des binaires 32 bit sous Linux.

                              DLFP >> PCInpact > Numerama >> LinuxFr.org

                              • [^] # Commentaire supprimé

                                Posté par . Évalué à -4.

                                Ce commentaire a été supprimé par l'équipe de modération.

                              • [^] # Re: moi j'ai mon appstore depuis des années

                                Posté par (page perso) . Évalué à 0.

                                C'est impossible que le binaire ppc tourne sur du x86 sauf à utiliser un émulateur

                                Ce qui est fait. Et quand Apple a "tout cassé" au niveau CPU, il a fait le nécessaire pour faire un transition douce (émulateur, Universal Binary" etc...), et ne pas faire fuir les développeurs. Tout le contraire de l'éco-système Linux. Et voyez qui a plus de parts de marché (sur le desktop) que Linux... Même l'iPhone seul en a plus (et plus d'applis aussi), ne parlons pas de Mac OS qui explose les parts de marché de Linux Desktop (et encore, une critique pour Mac est le manque d'applis, même en ayant bien plus d'applis que pour Linux le nain)

                                Mais ne changez rien, ça fait 10 ans que j'entend que Linux est prêt pour le desktop sans que ça arrive réellement, et c'est en ne changeant rien dans la mentalité linuxienne que ça changera (hum)!
                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 0.

                                  et encore, une critique pour Mac est le manque d'applis
                                  Ca change ca, meme si c'est toujours vrai, la percee phenomenale d'apple ces 3-4 dernieres annees aide.
                                  Et l'ecosysteme libre mac est tres actif, de tres haute qualite, on echappe notamment aux appli avec une UI a la mord moi le noeud designe par un autiste aveugle.

                                  Pour la cible d'apple (ie le gus chez lui, voire le mec qui bosse de chez lui), on en est rendu a "il manque parfois une ou deux applications pro", c'etait le cas par exemple d'autocad (jusqu'il ya peu) ou truc de ce genre.
                                  Les integrations avec les windowseries (exchange et consors) sont au poil depuis snow leopard.

                                  Et pour certaines niches, les version macos atomisent tout ce qui se fait ailleurs (genre le client mercurial machg qui est un petit bijou, handbrake qui bien que multiplateforme vient du monde mac, idem transmission etc).

                                  If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par . Évalué à 1.

                                  Je vais te dire une chose, on s'en contrecarre des parts de marché de linux. D'ailleurs on ne l'achète pas, ça facilite les choses.

                                  Maintenant, linux tourne sur nos desktop depuis 15 ans, donc il est prêt depuis belle lurette.

                                  Maintenant si tu arrêtais de confondre "utilisateur argneux et avancé qui se jette sur chaque nouvelle version de chaque appli sans vraiment savoir pourquoi" avec "utilisateur sans aucune connaissance dans l'informatique qui se contente d'avoir une appli qui répond à son problème", ça faciliterai ta compréhension de la chose.
                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                    Posté par (page perso) . Évalué à 0.

                                    Bravo tu viens de comprendre la seule argumentation de Zenitram (Madame Michu™ qui veut installer la toute dernière version de ses logiciels, cas complètement absurde) et qui veut appliquer le modèle des autres systèmes d'exploitation alors qu'il est inférieur, tout ça pour combattre les intégristes libristes qui utilisent des BIOS libres dans leur caves (qui n'existent que dans son imagination).

                                    Bref, des arguments imaginaires pour combattre des ennemis imaginaires.

                                    DLFP >> PCInpact > Numerama >> LinuxFr.org

                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                      Posté par (page perso) . Évalué à 1.

                                      Bref, des arguments imaginaires pour combattre des ennemis imaginaires.

                                      Je te dirais ça quand tu viendras pleurer que tu peux pas utiliser tel matériel faute de driver (dont le constructeur se fout complet de Linux).

                                      Et surtout, d'autres ne pensent pas que les linuxiens doivent rester autistes. C'est con, ils sont nombreux (la faute à ce méchant Canonical, allez hop), ça change au fur et à mesure (mais le chemin est long)
                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                        Posté par . Évalué à 3.

                                        Je te dirais ça quand tu viendras pleurer que tu peux pas utiliser tel matériel faute de driver (dont le constructeur se fout complet de Linux).

                                        On ne veut pas des drivers, on veut des specs.

                                        Parce qu'il n'y a pas que windows, mac et linux dans la vie. Il y'a d'autres OS qui ont tout aussi droit de cité que tes petites applications àlacon dont tu veux qu'une femme nommée Michu puisse installer.
                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                          Posté par (page perso) . Évalué à 2.

                                          On ne veut pas des drivers, on veut des specs.

                                          On veut, on veut... Ca ne marche pas comme ça.
                                        • [^] # Re: moi j'ai mon appstore depuis des années

                                          Posté par . Évalué à 0.

                                          Les specs ati, ont les a eux ya quoi, presque 3 ans maintenant?
                                          On attends toujours des pilotes libres decents...

                                          If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                          • [^] # Re: moi j'ai mon appstore depuis des années

                                            Posté par (page perso) . Évalué à 2.

                                            Ça fait deux ans au moins que je joue en 3D avec des cartes ATI (OpenArena, Unreal, et petits jeux).

                                            Et c'est bien plus stable qu'avec les drivers nVidia propriétaires, j'ai du coup tout remplacé par du ATI. Le support est très complet, je profite par exemple du support de XRandR avec multi-écran, rotation, etc.

                                            DLFP >> PCInpact > Numerama >> LinuxFr.org

                                            • [^] # Re: moi j'ai mon appstore depuis des années

                                              Posté par . Évalué à -2.

                                              Trop de la balle, tu fais tourner un jeu qui a ete ecrit ya 12 ans, qui tournait au poil sur une geforce 256 sortie en 1999 et qui doit limite pouvoir tourner avec un rendu soft sur un cpu actuel...
                                              Et tu peux meme te servir de deux moniteurs, pinaise, ca fait rever tout ca.

                                              Ouvrez les yeux les gars, vos pilotes libre que si on avait les specs on ferait un truc du feu de dieu qui dechire tout, ils se font mettre la race par un iphone....

                                              If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                              • [^] # Re: moi j'ai mon appstore depuis des années

                                                Posté par (page perso) . Évalué à 4.

                                                Tu as dit « pilotes libres decents », et oui, ils sont décents. Ce n'est d'ailleurs pas parce que ces jeux satisfont pas tes critères arbitraires que d'autres ne marchent, je n'ai juste pas testé. Ils tournent avec une carte que j'ai payé 30€ et comme je ne joue à rien d'autre…

                                                Bref, je te laisse à tes exagérations ridicules, personne n'est dupe à part toi et tes autres copains trolls frustrés.

                                                DLFP >> PCInpact > Numerama >> LinuxFr.org

                                                • [^] # Re: moi j'ai mon appstore depuis des années

                                                  Posté par (page perso) . Évalué à -2.

                                                  Tu as dit « pilotes libres decents », et oui, ils sont décents.

                                                  Attend, je regarde mon calendrier, c'est écrit... 2011. Pas 1995.
                                                  Ils auraient été décents il y a 15 ans oui, pas aujourd'hui.

                                                  C'est impressionnant vos joies sur des choses qui ont 15 ans de retard, à croire que l'informatique s'est arrêté entre 1995 et 2011, mais parait que non. Comme le dit pff, pour une fois que je suis d'accord avec lui, un smartphone de 2011 fait aussi bien, il y a un léger décalage...
                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par (page perso) . Évalué à 3.

                                                    Tu peux préciser ou c'est encore une fois pour critiquer le libre gratuitement ? En 1995 il n'y avait même pas de cartes 3D.

                                                    Comme je l'ai déjà dit deux fois : ils fonctionnent, sont stables, et assez performants pour faire de la 3D sur de vrais logiciels.

                                                    Je précise le sens de « décent » qui doit vous échapper : « acceptable: correct, suffisant, convenable, honnête » (ça vient d'un dictionnaire propriétaire, ce n'est donc pas le fruit d'horribles intégristes barbus).

                                                    DLFP >> PCInpact > Numerama >> LinuxFr.org

                                                    • [^] # Re: moi j'ai mon appstore depuis des années

                                                      Posté par . Évalué à 0.

                                                      Il a evidemment exagere un peu en citant 1995.

                                                      Ce qui est certain, c'est que quake 3 tournait a merveille sur une machine milieu de gamme de 99/2000.
                                                      Dire que ton matos vieux de deux ans tourne a la perfection sur un driver libre parce qu'il atteint les performances d'un matos qui est de dix ans son aine, comment dire?
                                                      Le simple que tu doivent preciser que le dual monitor marche bien, ca en dit long non?

                                                      If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                                        Posté par (page perso) . Évalué à 2.

                                                        Ça devient douloureux ces contorsions. Il s'agit d'une carte à 30€, et j'ai pas dit que des jeux plus gourmands ne marchent pas, je n'ai pas essayé.
                                                        Je précise le support XRandR ça parce que je ne vois pas trop ce qu'on peut demander de plus pour une utilisation « décente », et ce qui m'a séduit c'est justement que c'était mieux géré avec le driver ATI libre que le driver nVidia propriétaire.

                                                        Je rappelle une nouvelle fois le point initial : avec des specs on a eu des drivers décents, et ce en peu de temps par rapport à l'ancienneté des drivers propriétaires des concurrents.

                                                        DLFP >> PCInpact > Numerama >> LinuxFr.org

                                                • [^] # Re: moi j'ai mon appstore depuis des années

                                                  Posté par . Évalué à 0.

                                                  Non ils sont pas decents.
                                                  Ils ont 10 ans de retard.
                                                  Ca fonctionne correctement sur du matos qui a 10 ans, ca ne marche tout simplement pas sur du matos recent.

                                                  Que ca te convienne, c'est cool, mais certains se contentent d'IE6 pre SP2, ca veut pas dire que c'est un browser decent.

                                                  If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

                                                  • [^] # Re: moi j'ai mon appstore depuis des années

                                                    Posté par (page perso) . Évalué à 2.

                                                    D'après Wikipedia, ma carte date d'au plus septembre 2008. Quitte à être de mauvaise foi, autant le faire sur des données qui ne sont pas aussi facilement vérifiables.
                                                    J'en ai acheté une autre *neuve* pour le boulot il y a deux mois et ça marche très bien aussi.

                                                    Comme Zenitram, je te renvoie à la définition du mot « décent ».

                                                    DLFP >> PCInpact > Numerama >> LinuxFr.org

                                      • [^] # Re: moi j'ai mon appstore depuis des années

                                        Posté par (page perso) . Évalué à 2.

                                        Je te dirais ça quand tu viendras pleurer que tu peux pas utiliser tel matériel faute de driver (dont le constructeur se fout complet de Linux).

                                        Je ne vois pas du tout le rapport avec ton « combat ». Surtout qu'un driver qui n'est pas libre ne m'intéresse pas.
                                        Et que je suis sûr qu'un driver libre sera maintenu pour les versions suivantes, contrairement à ce qui arrive avec les OS propriétaires (je sors toujours l'exemple de ma carte son qui s'est retrouvée incompatible avec Windows XP). Bref, c'est un modèle complètement différent que visiblement tu ne veux pas comprendre.

                                        DLFP >> PCInpact > Numerama >> LinuxFr.org

                                • [^] # Re: moi j'ai mon appstore depuis des années

                                  Posté par (page perso) . Évalué à 5.

                                  >Mais ne changez rien, ça fait 10 ans que j'entend que Linux est prêt
                                  >pour le desktop

                                  Moi ca fait dix ans que je l'entend et c'est fait 3/4 ans que je vois des Ubuntu partout: étudiants (art, lettre, ...), mécano, profs, cadre, ...

                                  Bref, du Linux chez les gens, j'en vois partout, et les gens qui ont migré ne sont pas pret de faire machine arrière...
                        • [^] # Re: moi j'ai mon appstoredepuis des années

                          Posté par . Évalué à 4.

                          > Faudrait un minimum ouvrir les yeux. Bizarrement il n'y a pas que moi qui dit
                          > ça, d'autres se posent la même question [...] mais faut pas le dire, et si
                          > d'autres le disent faut pas les écouter.

                          Zenitram<, l'homme éclairé qui *ose* poser les *vraies* questions.
                    • [^] # Re: moi j'ai mon appstore depuis des années

                      Posté par . Évalué à 6.

                      Tu es au service de ta machine, moi je préfère que la machine soit à mon service.

                      Vaut-il mieux être au service de sa machine ou à sa merci ?

                      Vous avez 2 heures.
                    • [^] # Re: moi j'ai mon appstoredepuis des années

                      Posté par . Évalué à 5.

                      > Tu es au service de ta machine, moi je préfère que la machine soit à mon
                      > service.
                      >
                      > Ta philosophie est pourquoi faire simple quand on peut faire compliqué, la
                      > mienne est pourquoi faire compliqué quand on peut faire simple.

                      Niveau langue de bois tu es vraiment fort.
                    • [^] # Re: moi j'ai mon appstore depuis des années

                      Posté par . Évalué à 2.

                      Je te conseille de visionner le film Idiocraty. C'est un peu extrême, mais ça correspond à ta vision du grand public, je pense.

                      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

                      • [^] # Re: moi j'ai mon appstore depuis des années

                        Posté par (page perso) . Évalué à -2.

                        Qui est le plus idiot? Celui qui s'emmerde avec un OS qui lui demande d'éplucher 50 manpages avant de pouvoir faire un truc ou celui qui fait le nécessaire pour que ça marche facilement?

                        Le grand public n'est pas idiot, il est juste paresseux (et la paresse est ce qui nous permet de ne pas passer notre temps à aller chasser notre bouffe faute de recherche de progrès).

                        Tu as une vision bien élitiste du grand public. Le grand public n'est pas idiot, il cherche juste à ne pas s'emmerder à apprendre des trucs qu'une machine peut faire, et c'est bien plus intelligent qu'une personne qui passe du temps à lire un manuel pour faire la même chose que lui.
                        • [^] # Re: moi j'ai mon appstore depuis des années

                          Posté par . Évalué à 5.

                          Sauf que la c'est la c'est plutôt :

                          Qui est le plus idiot ? Celui qui installe une distro donnant accès en 2 clicks à des milliers d'applis compilées, testées et patchées par des équipes de maintenance formées pour ou celui qui s'emmerde à installer un OS fournissant queudalle et qui doit fouiller tout le grand ternet pour chercher une tonnes d'applis dont au moins 1 ou 2 va immanquablement transformer sa machine en pc zombie qui participera à des attaques de dénis de service pour le compte d'organisations ou d'ados plus ou moins louches tout en ralentissant son pc ?
                      • [^] # Re: moi j'ai mon appstore depuis des années

                        Posté par (page perso) . Évalué à 3.

                        En tout cas ça correspond de plus en plus à ma vision de Zenitram.

                        DLFP >> PCInpact > Numerama >> LinuxFr.org

          • [^] # Re: moi j'ai mon appstore depuis des années

            Posté par (page perso) . Évalué à 1.

            Hop, le seul je ne sais pas ...
            étant donné que pour beaucoup de programmeur, l'interface est la dernière chose a avoir son coup de polish ... Ca me permet de juger en un clin d'oeil la maturité de l'application ... sur l'Android Market, c'est manifeste....
  • # packagekit

    Posté par . Évalué à 1.

    Si le front-end évolue sans le back-end, quel est la valeur ajoutée par rapport a packagekit ?
    • [^] # Re: packagekit

      Posté par (page perso) . Évalué à 3.

      Si je comprend bien, l'idée est d'avoir une base de donnée communes aux distribution (logiciels, description traduite, capture d'écran) que les logiciels d'installation pourront consulter via une interface commune (mais du coup c'est même pas une obligation).

      Parce que le software center d'ubuntu, c'est pas mal mais trop technique et trop peu traduit.
      • [^] # Re: packagekit

        Posté par (page perso) . Évalué à 2.

        En gros, faire une appli équivalente aux sites proposant les logiciels en téléchargement (genre clubic, downloadcom, softpedia, ...) que tout utilisateur de système propriétaire consulte (entres autres) pour récupérer ses applis.
        • [^] # Re: packagekit

          Posté par . Évalué à 6.

          Ou sinon on fournit une sémantique et des outils pour que tous les sites de projets libres (ou pas, d'ailleurs) puissent pointer vers une fiche descriptive du produit (via XRDS et/ou RDF/A, par exemple). Et les gestionnaires de paquets n'ont plus qu'à suivre les champs "Homepage:" de chaque paquet pour trouver les informations utiles.
  • # Ça a un rapport avec ce schmilblick?

    Posté par . Évalué à 4.

  • # Complément d'informations

    Posté par (page perso) . Évalué à 10.

    Ce journal manque d'informations par rapport à ce meeting.

    Il a rassemblé des membres de Redhat, Canonical, Suse, Debian etc.

    Le but de tout ceci était d'unifié l'interface d'installation des paquets sur les distributions, et d'avoir un logiciel convivial où madame Michu ne trouve listées que les applications avec une interface graphique et surtout que l'engin ne liste que les applications plutôt que les paquets et dépendances qui forment ces applications.

    La conclusion de la réunion qui a duré 3 jours a été la prise de décision d'employer l'ubuntu software center comme front-end en utilisant le back-end packagekit, qui délèguera au gestionnaire de paquets natif de la distro.
    • [^] # Re: Complément d'informations

      Posté par (page perso) . Évalué à 4.

      Source que j'ai retrouvée (pour les apprentis trolls "source?"):
      [http://www.phoronix.com/scan.php?page=news_item&px=OTA1M(...)]
    • [^] # Re: Complément d'informations

      Posté par (page perso) . Évalué à 2.

      La conclusion de la réunion qui a duré 3 jours a été la prise de décision d'employer l'ubuntu software center comme front-end en utilisant le back-end packagekit, qui délèguera au gestionnaire de paquets natif de la distro.

      J'aime beaucoup ces phrases, où l'on se demande quand le dernier domino tombera...

      Prochainement, je vous proposerai peut-être un commentaire constructif.

    • [^] # Re: Complément d'informations

      Posté par (page perso) . Évalué à 3.

      L'utilisation de l'Ubuntu Software center, on ne peut pas vraiment appeler ça la "conclusion" du meeting, notamment parce que la décision ne peut pas être prise dans une telle réunion au nom des diverses distributions. On a décidé qu'on aimerait bien que le software center d'ubuntu fonctionne sur les autres distributions (ce qui implique effectivement de le faire utiliser packagekit au lieu d'apt)

      Par ailleurs le schéma "le software center interroge packagekit qui interroge le gestionnaire de paquets natif de la distribution" est un peu simple aussi vu qu'il oublie tout l'aspect métadonnées sur les applications, ce qui a été une grosse partie du sujet du meeting :
      - descriptions (et leurs traductions)
      - captures d'écran
      - tags
      - commentaires des utilisateurs
      - notes (rating)

      Selon moi, le sujet des méta-données est 1000 fois plus important que le sujet de savoir quelle application on va utiliser à la fin, sachant que l'on peut imaginer de nombreux "software centers" s'appuyant sur les mêmes données standardisées.

      J'avais essayé de résumer ça ainsi en répondant aux questions de muktware.com [1] :

      Pour chaque application nous avons :
      - Métadonnées simples (nom, résumé en une ligne et ses traductions, catégorie...) : récupérées dans les fichiers .desktop "upstream", donc partagées entre toutes les distributions
      - Captures d'écran, notes (ratings), commentaires, descriptions longues (et leurs traductions), etc. : les distributions pourront choisir si elles souhaitent avoir une base commune avec d'autres distributions, ou avoir leur propre base de données. Il existe également une voie médiane possible : que le "software center" interroge d'abord le serveur de la distribution, puis en cas de besoin (ex : capture d'écran manquante) se rabattre sur un autre serveur (celui d'une autre distribution, ou un server cross-distro)
      - Les paquetages en eux-même : restent spécifiques à chaque distribution, pas de plan pour fusionner ça pour le moment.

      [1] http://www.muktware.com/n/27/2011/712
  • # On pourrait aller plus loin

    Posté par . Évalué à 4.

    Et faire un LSB store...
  • # Ça tombe bien!

    Posté par . Évalué à -2.

    L'idée principale est qu'actuellement, les interfaces d'installation de logiciels fournnissent des informations trop techniques dont l'utilisateur n'en a que faire.

    Et ce n'est pas grave du tout: installer des logiciels n'est pas le rôle des utilisateurs. C'est celui des administrateurs.

    THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

    • [^] # Re: Ça tombe bien!

      Posté par (page perso) . Évalué à 5.

      Et ce n'est pas grave du tout: installer des logiciels n'est pas le rôle des utilisateurs. C'est celui des administrateurs.

      Et c'est bien pour ces administrateurs (de leur machine, quasi tout le monde chez soit est admin de sa machine, et heureusement, je n'aimerait ta façon e voir une machine où il faut que je demande l'autorisation) qu'il y a un problème à résoudre, et qu'une solution est proposée.
      Quoi, un problème? Quel problème? allez on dit que c'est pas grave, faut pas déconner changer quelque chose il ne faut surtout pas.

      Tu es bien parti pour HADOPI 3 : seul le gouvernement aurait le droit d'installer des applis (et des oeuvres), installer un logiciel ou une oeuvre devrait être le rôle que du gouvernement, qui aura le monopole.

      Désolé, mais non, encore heureux qu'un utilisateur de sa machine puisse installer des applis!
      • [^] # Re: Ça tombe bien!

        Posté par . Évalué à 5.

        Désolé, mais non, encore heureux qu'un utilisateur de sa machine puisse installer des applis!
        C'est un administrateur, alors. De fait. Je n'ai pas dit "qui a une formation d'administrateur" ou "qui est payé pour le faire" ou quoi que ce soit. Juste: il est utilisateur, il donne son mot de passe root, il devient administrateur ( = quelqu'un qui administre, bien ou mal ce n'est pas la question).

        Mais bon, si maintenant un mécanicien et un conducteur, un tricoteur de pull et un frileux, un gourmand et un cuisinier, c'est forcément la même chose, je veux bien, hein. Accepter cette nouvelle version du monde m'évitera des moinssages rageux (et je te sais gré d'avoir répondu pour donner ton point de vue au lieu de simplement manifester ton désaccord d'un seul clic).

        Ceci étant mis au point, peut-être qu'il serait judicieux de permettre aux utilisateurs d'installer, pour eux-mêmes, sans administrer quoi que ce soit, des logiciels.

        Sur le modèle des "applications portables" pour Windows, ou ce qui se fait sous MacOS: je prends mon application avec ses libs et tout, je l'installe dans mon profil ( ~/.bin par exemple), je suis le seul à pouvoir m'en servir, je ne risque pas de casser le système car je n'y administre rien du tout.

        Et ça, ça serait:
        - plus facilement compatible avec des distros différentes,
        - moins dépendant des contraintes de version sur les libs (obsolète, instable, compliqué, pick two of them),
        - moins dangereux, puisque l'utilisateur n'a pas à décider s'il est judicieux d'upgrader lib-sur-laquelle-tout-repose-2.0.9 en lib-sur-laquelle-tout-repose-2.1, et vu qu'apparemment le but c'est de permettre à l'utilisateur-qui-ne-veut-pas-apprendre-à-administrer comment installer des paquets.

        THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

        • [^] # Re: Ça tombe bien!

          Posté par . Évalué à 4.

          Pour ça, il y a Zero Install :
          http://zero-install.sourceforge.net/

          Il y a aussi les portable-apps ([http://portablelinuxapps.org/]), mais l'avantage de Zero Install est que si deux utilisateurs utilisent la même version du même logiciel, le logiciel ne sera pas téléchargé deux fois. Zero Install n'a pas besoin de fuse, non plus. (mais un paquet Zero Install ne se trimbale pas sur une clef USB. C'est pas le but). L'auteur de Zero Install s'est posé pas mal de questions sur la sécurité (faut lire le site, il explique tout mieux que moi, même si c'est en anglais). Après, le débat « j'ai lancé un malware qui m'a effacé mon home – T'avais qu'à utiliser les paquets de ta distrib' » revient de toute façon sur le tapis...

          Un bémol à cette solution géniale, user et packager friendly, capable de ne ramener notre femme et apporter la fortune :
          C'est pas très utilisé, pas très répandu. Il n'y a donc pas beaucoup de paquets, il faut pouvoir leur faire confiance (c'est pas comme si les paquets Zero Install se trouvaient sur le site du projet qu'on télécharge), et qu'ils soient maintenus (pas toujours le cas). Ce n'est aussi pas parfaitement intégré à notre distribution/environnement de bureau.

          Bon, je met le lien, j'adore l'idée, mais je l'utilise pas (pour des raisons pratiques). Et je suppose que c'est ce qui fait que ce genre de projets ne décolle pas vraiment : les gens comme moi, qui voient le potentiel mais ne soutiennent pas activement et se positionnent en consommateur. (là, je me démarque un peu, je viens de faire de la pub...)
        • [^] # Re: Ça tombe bien!

          Posté par . Évalué à 3.

          Absoluement.

          Linux (ou unix, ou posix, j'en sais rien) manque cruellement d'un système standard pour installer des applications en mode utilisateur. Tous les système de package que je connaisse nécessitent un passage par le mode admin.

          Actuellement, les seules solutions pour installer une application en tant qu'utilisateur, sont de, au choix :
          - récuperer un package pour sa distrib et le décompresser à la main
          - récuperer des binaires précompilés pas forcément adaptés à sa distrib
          - compiler à partir des sources

          Et dans tous les cas, il faut vérifier les dépendances à la main (et appliquer la même procédure pour chaqu'un d'entre elles).

          En pratique c'est extrêmement lourd d'utiliser une machine dont on a pas les droits admin.

          Je n'ai pas de suggestion pour résoudre le problème (sous Windows, ça marche principalement parce que bon nombre de dépendances sont liés en statique et que l'architecture est unique), mais il existe, c'est certain.
          • [^] # Re: Ça tombe bien!

            Posté par (page perso) . Évalué à 1.

            macports marche pas trop mal sans droits administrateurs. Malheureusement, il ne marche plus sous Linux/FreeBSD et même quand il marchait, il fallait avoir convaincu l'administrateur d'installer objective C avec les bibliothèques qui vont bien, et quelques outils BSD qu'on ne trouve pas tous les matins sur un linux. Après, tout ne peut pas s'installer pas en tant qu'utilisateur.
          • [^] # Re: Ça tombe bien!

            Posté par . Évalué à 2.

            tu n'as pas besoin d'être admin pour utiliser pkgsrc dans ton homedir.

            D'ailleurs sous windows non plus tu ne peux pas t'amuser à installer des programme sans être admin (j'entends par la ceux qui se mettent dans la liste des applications installées)..

            Franchement je ne vois pas vraiment où est la différence. Dans les deux cas si l'utilisateur souhaite télécharger et installer le dernier mozilla, il peux extraire le binaire dans un dossier où il a les droits.

            Qu'est-ce qu'il vous faudrait de plus ?
            • [^] # Re: Ça tombe bien!

              Posté par . Évalué à 2.

              Un truc pour rendre ça convivial. Un "App Store" qui permette en deux clics, au simple utilisateur, de dire "je veux ça", y compris si "ça" nécessite lib-trucmuche-2.8.29 et que le système tourne avec lib-truc-muche-2.8.25

              THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

              • [^] # Re: Ça tombe bien!

                Posté par . Évalué à 2.

                App-Store ne t'installes pas des dépendances. Les librairies sont fournies avec les applis.

                Qu'est-ce qui est différent avec le fait de prendre un programme compilé avec ses libs en local et d'extraire le tar.gz ? ça ne nécessite pas plus de clics.
                • [^] # Re: Ça tombe bien!

                  Posté par . Évalué à 3.

                  Ben les programmes compilés avec les libs, c'est dur à trouver sous Linux. C'est peut-être moi qui cherche mal après...
                • [^] # Re: Ça tombe bien!

                  Posté par (page perso) . Évalué à 1.

                  Qu'est-ce qui est différent avec le fait de prendre un programme compilé avec ses libs en local et d'extraire le tar.gz ? ça ne nécessite pas plus de clics.

                  Faut juste les trouver.
                  En général, le tar.gz est le source, et aucun binaire.

                  Sous windows, tu as directement sur le site un binaire, sous Linux c'est majoritairement non fait (d'une par flemme des développeurs, deux par impossibilité technique : ton fantasme de binaire en tar.gz qui marcherait sur tout Linux, c'est du fantsme pur : ça marche que sous Windows ou Mac ça, pleins de développeurs se sont cassé les dents sous Linux et ont abandonné de pouvoir fournir un binaire qui marche sous Linux. Même chez Mozilla ils ne savent pas faire, le binaire pour Firefox râle pour plein de dépendances non trouvées si tu n'a pas géré les dépendances avant)

                  Tu as l'air de trouver l'installation de logiciels sous Linux super facile, d'autres trouvent que non par expérience, et que c'est même les très gros point faible de Linux.
                  • [^] # Re: Ça tombe bien!

                    Posté par . Évalué à 2.

                    Et bien, en tous cas, Matlab et Scilab fonctionnent sans les droits administrateurs sur ma Slackware. Comme quoi ça marche.
                  • [^] # Re: Ça tombe bien!

                    Posté par . Évalué à 3.

                    Bizarre alors, comment font les mozilla, nero et autres ?

                    Il n'y a pas d'impossibilité technique, juste que les developpeurs sous windows n'ont que ce seul moyen et du coup package un binaire automatiquement. Alors qu'un developpeur sous unix ne s'embète pas et part du principe que l'utilisateur sait compiler ses logiciels ou dans le cas contraire fait confiance ou participe au packaging des distribs car c'est toujours plus avantageux d'avoir un soft intégré au système de packaging et mis à jour automatiquement plutôt que de devoir réinventer la roue et intégrer son propre système de mise à jour de l'appli comme sont obligés de le faire les devs sous windows.
                    • [^] # Re: Ça tombe bien!

                      Posté par (page perso) . Évalué à 3.

                      car c'est toujours plus avantageux d'avoir un soft intégré au système de packaging et mis à jour automatiquement plutôt que de devoir réinventer la roue et intégrer son propre système de mise à jour de l'appli comme sont obligés de le faire les devs sous windows.

                      Pour l'utilisateur, c'est plus avantageux d'avoir une appli qui ne se met pas à jour, qu'il faut cliquer quelques fois pour installer, que de ne rien avoir.
                      Car se dont tu parles (le gestionnaire de package de ta distro), c'est pour les rares élus qui y ont le droit (et ils sont rares). Tu présente la vitrine Linuxienne en faisant crorie qu'on trouve tout dessus, sauf que la triste réalité est bien triste : quelques milliers de logiciels certes, mais pas celui voulu par l'utilisateur.

                      Mais surtout faire l'autruche, ça va faire avancer les choses. En attendant, d'autres voient un problème, et essayent de le résoudre.

                      Tu parles de Mozilla, va voir le journal sur la dernière beta, et tu verras qu'elle est loin de marcher partout (problème de dépendances entre autres), et que les Linuxiens installent beaucoup moins (même en pourcentage d'utilisateurs) la beta de Firefox pour Linux que celle de Windows, mais surtout ne voir aucun problème... Tout va bien sous Linux juste la faute de ces cons d'utilisateurs qui savent pas se limiter à leur gestionnaire de package!
                      • [^] # Re: Ça tombe bien!

                        Posté par . Évalué à 2.

                        Je suis d'accord que la situation sous linux n'est pas parfaite, mais il faut comparer ce qui est comparable. Tu compares l'ensemble des distributions sous linux avec une version sous windows. Je ne suis pas sûr que windows 7 starter et windows 7 Integrale peuvent installer les mêmes logiciels. De même entre deux versions de windows il y a souvent des logiciels qui ne marchent plus (il n'y a qu'à regarder le mode Xp sous 7 professionnel).

                        Après que sous linux d'une distribution à l'autre il n'y ait pas les mêmes logiciels est embêtant. Mais il y a une norme pour tous les logiciels : le .rpm. Je pense que toutes les distributions sont capables de l'installer et une bonne pratique pour moi serait l'installation des .rpm via un simple clic (+ droit administrateur) et là, la distribution vérifie la disponibilité dans ses dépôts et laisse le choix à l'utilisateur. On peut en plus imaginer un mail envoyé aux mainteneurs pour qu'ils puissent créer le package pour leur distribution et un mail en retour pour l'utilisateur pour le prévenir de la disponibilité.

                        Néanmoins, ce système peut très rapidement devenir sale et on peut se retrouver avec un système à la windows qui devient obèse et de plus en plus instables avec le temps. Une solution, serait de mettre tout ça dans un système chrooté (dans /opt par exemple) que l'on viderait régulièrement.

                        Et pour conclure, je pense que le système de package sous linux et 10 fois mieux que sous windows. C'est tellement la galère sous windows : il faut récupérer le soft sur le site internet ou l'acheter en boutique, cliquer 15 fois sur suivant, expliquer à windows que oui on veut bien l'installer, entrer la clé d'activation, … Je ne suis vraiment pas sûr que ce soit plus facile.
                        • [^] # Re: Ça tombe bien!

                          Posté par (page perso) . Évalué à 1.

                          je pense que le système de package sous linux et 10 fois mieux que sous windows.

                          En théorie : oui, sans hésitation.
                          En pratique : non, faute de logiciels dans les dépots. Les dépots fonctionnent très bien pour les logiciels soit connus soit technique (donc un geek pour maintenir), en dehors... Crève.

                          C'est tellement la galère sous windows

                          Pour le moment, les gens préfère de manière générale la galère Windows que pas de logiciel (ou si peu par rapport à tous les logiciels sous Windows).

                          cliquer 15 fois sur suivant,

                          Quelques clics suffisent... eT toujours mieux que de dire "./cofigure et OK ça marche pas, manque un truc.

                          entrer la clé d'activation,

                          Rien à voir, il y a plein de logiciels sans clé.

                          Je ne suis vraiment pas sûr que ce soit plus facile.

                          Dans la vraie vie avec des logiciels pas dans les dépôts : oh que si...

                          Maintenant, je suis heureux de voir que d'autres que moi arrivent à la même conclusion et cherchent à faciliter la vie des développeurs. on verra ce que ça donne.
                      • [^] # Re:Çatombe bien!

                        Posté par . Évalué à 1.

                        > Car se dont tu parles (le gestionnaire de package de ta distro), c'est pour
                        > les rares élus qui y ont le droit (et ils sont rares). Tu présente la vitrine
                        > Linuxienne en faisant crorie qu'on trouve tout dessus, sauf que la triste
                        > réalité est bien triste : quelques milliers de logiciels certes, mais pas
                        > celui voulu par l'utilisateur.

                        Tu dis ça parce que le tiens n'est pas disponible sur les dépôts de la majorité
                        des distributions Linux ?
                    • [^] # Re: Ça tombe bien!

                      Posté par . Évalué à 8.


                      Il n'y a pas d'impossibilité technique, juste que les developpeurs sous windows n'ont que ce seul moyen et du coup package un binaire automatiquement.

                      Mais rien n'interdit de proposer "un binaire avec toutes ses libs" sous Linux.
                      Et, concrètement, ce serait plus facile pour l'utilisateur lambda, vraiment! (ZOMG je me retrouve à défendre les utilisateurs lambda sur LinuxFR, exorcisez moi!)

                      c'est toujours plus avantageux d'avoir un soft intégré au système de packaging et mis à jour automatiquement plutôt que de devoir réinventer la roue et intégrer son propre système de mise à jour de l'appli comme sont obligés de le faire les devs sous windows.
                      Bien vu, y'a ce point qui coince: la question des MAJ.

                      C'est pour ça qu'il serait bien d'avoir un système compatible inter-distros, avec des dépôts à jour,des versions différentes du même logiciel disponible, le tout en espace utilisateur.

                      J'installe (en tant qu'admin) ma distro préférée, que ce soit Debian stable, Debian Sid, Ubuntu, Mageia.. avec le logiciel "Linux App Store" par dessus.

                      Ensuite, n'importe quel utilisateur lance "Linux App Store" pour installer, par exemple, Firefox. Il se voit proposer deux ou trois versions de Firefox (une version stable, une version bêta et, mettons, une version entre les deux). Il l'installe en tant qu'utilisateur, rien que pour lui-même. On peut imaginer que si plusieurs utilisateurs installent le même logiciel dans la même version, il n'existe qu'une seule copie (dans /usr/local par exemple).

                      Chaque fois qu'une nouvelle version de Firefox est disponible, Firefox, ou bien le Linux App Store, proposer à l'utilisateur de le mettre à jour. Avec ses libs, compilées en statique. Et ce, même si l'administrateur a décidé de maintenir l'OS lui-même en version stable avec des vieilles libs.
                      Autrement dit, découpler totalement "les paquets, binaires, libs du système" et "les paquets, binaires, libs de l'utilisateur".

                      Parce bon: le système actuel est très bien adapté à un serveur, ou à un utilisateur qui sait administrer. Mais, franchement, avoir des logiciels orientés utilisateur final qui soient dépendants du même système de paquet, que les rouages internes de la distro, c'est dépassé. Ça ne colle pas avec les usages ni avec les besoins de madame Michu. C'est un des gros avantages de Windows: j'installe mon Windows XP, je lui mets ses services pack quand il le faut (ça c'est l'administration système), et d'un autre côté je peux mettre Firefox 4 bêta. Sur un OS qui a 9 ans. Essayez d'installer Firefox 4 sur une Debian Woody.

                      THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

                      • [^] # Re: Ça tombe bien!

                        Posté par . Évalué à 1.

                        C'est pour ça qu'il serait bien d'avoir un système compatible inter-distros, avec des dépôts à jour,des versions différentes du même logiciel disponible, le tout en espace utilisateur.

                        J'installe (en tant qu'admin) ma distro préférée, que ce soit Debian stable, Debian Sid, Ubuntu, Mageia.. avec le logiciel "Linux App Store" par dessus.


                        Ben ça existe.

                        Le truc c'est que les developpeurs comme Zenitram qui se plaignent ne les utilisent pas. Et le pas doit venir des developpeurs d'applications, pas des utilisateurs.

                        M'enfin bon, en bon français, Z préfère se plaindre que d'agir.
                        • [^] # Re: Ça tombe bien!

                          Posté par (page perso) . Évalué à 1.

                          Tu te trompes lourdement : je ne plains pas, j'ai pris un OS qui répond mieux à mon besoin, comme 99% des gens (Windows / Mac).

                          Je réagis juste quand on sort un bon gros mensonge "Linux c'est génial tu as plein de logiciel et c'est facile, tout est parfait".
                          Linux est fait pour les gens n'installant jamais rien (grand-père qui fait mail et web) et les passionnés de programmation et de ligne de commande, en dehors de ça c'est l'enfer, c'est tout.

                          L'auto congratulation "Linux c'est le must", ça me fais réagir, désolé.
                          • [^] # Re: Ça tombe bien!

                            Posté par . Évalué à 1.

                            Je dirais que linux ne convient effectivement pas à certaines personnes. Ceux qui disent : je veux photoshop, je veux l'application trucmuche.

                            Par contre les gens qui disent, je veux une application pour faire ceci, ou cela. Eux, ils trouvent leur bonheur.
                            • [^] # Re: Ça tombe bien!

                              Posté par (page perso) . Évalué à 3.

                              Oui, bien sûr, et la marmotte... La prochaine étape est de me sortir que Gimp est du même niveau technique que Photoshop c'est ça?

                              Si les applis disponibles dans les dépôts te suffisent, c'est bien pour toi, mais ça ne veut pas dire que c'est suffisant pour tout le monde (on en est bien loin, très très loin... Et non, je ne donnerai pas de nom, car chaque personne est différente et son besoin l'est tout autant).
                              • [^] # Re: Ça tombe bien!

                                Posté par . Évalué à 4.

                                Oui, bien sûr, et la marmotte... La prochaine étape est de me sortir que Gimp est du même niveau technique que Photoshop c'est ça?

                                Non rien à voir.

                                Je parle de démarche. Ceux que ça gênent, ce sont ceux qui pensent à ce qu'ils veulent télécharger avant de se poser la question de ce qu'ils ont besoin. Parce qu'il y'a des millions de gens qui utilisent photoshop uniquement pour redimenssionner des photos de vacances, tout comme il y'a des millions de gens qui ont remplacé un téléphone en très bon état pour un iphone alors qu'ils ne font que téléphoner et envoyer des sms et qu'ils n'ont jamais ajouté la moindre application ni utilisé les quelques fonctionnalités qui peuvent lui donner un intérêt. Question de prestige j'imagine. Moi j'appelle ça allumer une clope avec un lance-flamme.
                                • [^] # Re: Ça tombe bien!

                                  Posté par . Évalué à 4.

                                  je suis pas d'accord avec le lance flamme.
                                  Le lance flamme allume (très très très) bien une clope.

                                  Le iphone ne téléphone pas très très bien, même plutôt moyen pour téléphoner (ce n'est pas une critique, juste une constatation, il a d'autres points forts).
                          • [^] # Re: Ça tombe bien!

                            Posté par . Évalué à 3.

                            s/99%/9%/g

                            Pour 90% des gens, linux, windows, ou mac ils répondent tous aussi bien au besoin : il y a tous les logiciels dont ils ont besoin (office, mail, web, ...), avec toutes les fonctionnalités dont ils ont besoin (par exemple, pas besoin de connexion à une base de donnée qui intégères des tables distantes et ...).
                          • [^] # Re: Ça tombe bien!

                            Posté par (page perso) . Évalué à 2.

                            Si, tu te plains constamment, à un point à la limite de la démence.

                            « Je réagis juste quand on sort un bon gros mensonge "Linux c'est génial tu as plein de logiciel et c'est facile, tout est parfait". »
                            Qui a dit ça ?

                            Tu as vu que ton copain pBpG a dit qu'il ne manquait aucun logiciel sous Windows ?
                            « Allez, dis-moi donc ce qui manque en gratuit sous Windows et qu'il y a sous Linux, on va bien rire. »
                            https://linuxfr.org/comments/1204227.html#1204227
                            Dans les réponses qui lui sont faites le « gratuit » n'est même pas pris en compte en général, il y a des manques tout court mais il refuse complètement de le voir.

                            Ton obsession des libristes intégristes qui utilisent des BIOS libres dans leur cave te met de la merde dans les yeux. Il y a plus de trolls autocongratulateurs du propriétaire que du libre sur DLFP, c'est quand même grave.

                            « Linux est fait pour les gens n'installant jamais rien »
                            Les « gens » n'installent jamais rien sous Windows, je le constate tous les jours. Et c'est normal, parce que ça fait peur de devoir chercher sur le web des programmes. Et t'as toujours pas expliqué en quoi c'est plus compliqué sous Linux. On attend encore une Madame Michu pas contente pas pas pouvoir installer la dernière version de Firefox sur sa RHEL 4.

                            DLFP >> PCInpact > Numerama >> LinuxFr.org

  • # Mageia vs Mandriva

    Posté par (page perso) . Évalué à 2.

    3/0
    • [^] # Re: Mageia vs Mandriva

      Posté par . Évalué à 8.

      Non ! Ne divisez surtout pas par zé
      • [^] # Re: Mageia vs Mandriva

        Posté par . Évalué à 10.

        T͍̟̳͋̿̂ͧ̉̍͝r̷̓͛o̟̹̗̞͕̖̞͗͑͆̏ͦͬp̱̫͓̹ͭͧ̃̈̇ ͬ͒t̖͍̺̤͕̻̓̓͜a̛͎̻ŕ̫̬̓͊̾͆d̯̯̯̱̜̩͊̓̽͆͂͋ͥͅ!̘͉̦͉͙̤̖ͤ̉ͨ̆̂̀͐

        THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

    • [^] # Re: Mageia vs Mandriva

      Posté par (page perso) . Évalué à 2.

      Je pencherais plus pour 2/0, à relire la liste, à moins que novell ne sponsorise mageia (il suffit de relire pour comprendre de quoi je parle :)
      • [^] # Re: Mageia vs Mandriva

        Posté par (page perso) . Évalué à 2.

        D'ailleurs, Eugeni (mandriva) a dit que ça l'intéresserait bien de participer mais vivant au brésil, ça fait un peu loin. Il espère que les prochains meeting se feront via irc ou tout moyen de ce genre :)
      • [^] # Re: Mageia vs Mandriva

        Posté par (page perso) . Évalué à 3.

        Novell ne sponsorise pas Mageia mais a sponsorisé un développeur de Mageia pour venir à la conférence, comme ils l'ont fait pour Debian. Le but était juste de faire venir le plus de monde possible, pas de filer de l'argent à Mageia.

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

        • [^] # Re: Mageia vs Mandriva

          Posté par (page perso) . Évalué à 1.

          Je confirme, étant la personne "sponsorisée". Le fait que Novell propose de me rembourser l'hôtel m'a bien aidé à décider d'y aller (sans ça au final j'en aurais été de 400 euros de ma poche environ, là je n'ai pas fait les compte mais j'estime que ça ne m'a coûté que 150 à 200 euros).

          D'ailleurs l'hôtel qui était censé être pré-payé, ben non en fait... ;) Mais j'ai envoyé la facture et je devrais être remboursé a priori.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.