Forum Linux.général Problème de pool dans isc-dhcp-server (dhcpd.conf)

Posté par  . Licence CC By‑SA.
Étiquettes :
1
1
juin
2020

Bonjour à tous,
ssez jeune dans le monde de linux, je trouve plein d'utilisation géniale que je mets en place chez moi (via des VM sous Esxi), toujours sous Debian.
J'ai déjà implémenté un serveur DNS Pi-hole, une domotique Jeedom (comme backup de mon JeedomSmart pour certaines fonctions gourmandes en ressources), un motioneye et plein d'autres.
Dernièrement j'ai eu un problème avec mon serveur DHCP dont le service était assuré par mon NAS Synology. J'ai donc recherché des solutions alternatives car je voulais en profiter pour avoir un système qui puisse affecter des DNS en fonction de l'hote. J'ai trouvé mon bonheur avec isc-dhcp-server et l'interface webmin pour faciliter certaines actions. Tout fonctionne tellement bien que j'ai voulu creuser un peu et avoir 2 zones dans mon DHCP : 1 pour les hôtes connues qui sont en réservation d'IP et un autre pour les hôtes inconnues. L'idée est de pouvoir identifier rapidement les nouveaux connectés.
Ma plage IP est 192.168.0.1 à 192.168.0.253 (192.168.0.254 est la gateway).
Je voudrais que les hôtes inconnus soient entre 192.168.0.40 et 192.168.0.80

Voici mon dhcpd (sans les hosts réserves) :

# Etendue LUIGNE
subnet 192.168.0.0 netmask 255.255.255.0 {
    deny unknown-clients;
    option domain-name-servers 192.168.0.252 , 192.168.0.2;
    option subnet-mask 255.255.255.0;
    ddns-updates on;
    option routers 192.168.0.254;
    range 192.168.0.1 192.168.0.254;
    pool {
        allow unknown-clients;
        range 192.168.0.40 192.168.0.80;
        }
    }

Lorsque je relance le serveur, cela plante :

    juin 01 14:01:10 fred24-dhcp dhcpd[5777]: Dynamic and static leases present for 192.168.0.227.
    juin 01 14:01:10 fred24-dhcp dhcpd[5777]: Remove host declaration GHOME-SALON or remove 192.168.0.227
    juin 01 14:01:10 fred24-dhcp dhcpd[5777]: from the dynamic address pool for 192.168.0.0/24
    juin 01 14:01:10 fred24-dhcp dhcpd[5777]: DHCPREQUEST for 192.168.0.227 from a4:77:33:cf:83:c3 via ens192
    juin 01 14:01:10 fred24-dhcp dhcpd[5777]: DHCPACK on 192.168.0.227 to a4:77:33:cf:83:c3 via ens192
    juin 01 14:01:14 fred24-dhcp dhcpd[5777]: Dynamic and static leases present for 192.168.0.205.
    juin 01 14:
    01:14 fred24-dhcp dhcpd[5777]: Remove host declaration HARMONY-HUB or remove 192.168.0.205
    juin 01 14:01:14 fred24-dhcp dhcpd[5777]: from the dynamic address pool for 192.168.0.0/24
    juin 01 14:01:14 fred24-dhcp dhcpd[5777]: DHCPREQUEST for 192.168.0.205 from 00:04:20:f6:55:e9 via ens192
    juin 01 14:01:14 fred24-dhcp dhcpd[5777]: DHCPACK on 192.168.0.205 to 00:04:20:f6:55:e9 via ens192

J'ai fouillé sur le net et cela match bien avec l'utilisation de pool. Si j'enlève le pool, le service remonte bien. J'ai testé l'ajout via l'interface webmin qui fait la même chose et ca ne marche pas mieu.

Avez vous des pistes ?
Merci d'avance.

  • # SOLUTION

    Posté par  . Évalué à 3 (+2/-0). Dernière modification le 01/06/20 à 16:42.

    Bon, j'ai trouvé une solution sur un forum allemand qui a l'air de fonctionner.
    Il faut enlever le range dans le subnet et avoir plusieurs pools pour couvrir le range global.
    Cela donne ca :

    # Etendue LUIGNE
    subnet 192.168.0.0 netmask 255.255.255.0 {
        option domain-name-servers 192.168.0.252 , 192.168.0.2;
        option subnet-mask 255.255.255.0;
        ddns-updates on;
        option routers 192.168.0.254;
        pool {
            max-lease-time 86400;
            default-lease-time 86400;
            deny unknown-clients;
            range 192.168.0.1 192.168.0.39;
            range 192.168.0.81 192.168.0.253;
            }
        pool {
            allow unknown-clients;
            range 192.168.0.40 192.168.0.80;
            }
        }

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.