Forum Linux.général Ubuntu 9.04 Jaunty Jackalope : blocage sur Starting up... pendant une minute

Posté par (page perso) .
Tags : aucun
0
28
avr.
2009
Sur Ubuntu 9.04, installé sur une partition en ext4, je recontre le problème suivant : une fois l'entrée Ubuntu choisi dans GRUB,
le système se lance et reste bloqué pendant une minute (montre en main) sur un écran noir avec uniquement écrit "STARTING UP..."
Puis au bout de cette minute, j'ai le logo Ubuntu et la barre de progression, le système sa lance sans problème, je me connecte et tout tourne bien.

Sur cette machine, j'ai fait tourner différentes versions d'Ubuntu (depuis la première là 4.10) et la dernière était la Hardy Heron 8.04. Pour toutes ces versions, je n'ai jamais rencontré ce problème. Pour le passage en 9.04, j'ai réinstallé et reformaté la partition système.

Pour voir d'où venait le problème :
- j'ai regardé le contenu de la commande "dmesg" et je n'ai rien vu de particulier (pas d'erreur).
- j'ai ajouté les options noapic nolapic au démarrage du noyau, ça ne change rien.
- si je passe l'option "acpi=off", je n'ai plus ce temps d'attente, j'ai directement la barre de progression, mais je perd la gestion de la batterie/de l'energie, du processeur (un SEMPRON 2800+ qui peut donc tourner à deux fréquences différentes), les ventilateurs tournent à fond...
- j'ai installé Bootchart. j'ai relancé. J'ai pu voir sur le graphique généré que pendant la minute de "Starting up", j'avais bien une activité nulle pour le processeur, puis au bout d'une minute, le lancement de l'init.d et des différents services en cascade. On a donc bien le temps de pause dans ce graphique.

Ma machine : HP NX9105, AMD SEMPRON 2800+, 768Mo de RAM. Le noyau Linux est le 2.6.28-11, celui de la Ubuntu 9.04.
J'ai passé pas mal de temps sur les forums anglais et français d'Ubuntu-fr, j'ai Google pas mal et la "seule solution" et le passage de l'option acpi=off. Or, ça résoud le problème de temps de boot mais en crée un autre : je n'aime pas savoir mon ordinateur tourner à fond (le processeur n'est pas sollicité tout le temps mais n'est pas géré comme il devrait l'être, les ventilateurs tournent à fond...)

Auriez vous des conseils, des pistes? Merci à vous.
  • # Source du problème

    Posté par (page perso) . Évalué à 1.

    Le problème vient de la ligne suivante, présente dans dmesg :
    [ 63.619820] Clocksource tsc unstable (delta = 60935079939 ns)

    Je vais googler là dessus.
  • # Des pistes

    Posté par (page perso) . Évalué à 1.

    Il y a des pistes suivantes : passées l'option
    clocksource=acpi_pm ou clocksource=hpet (selon les personnes c'est l'une ou l'autre option qui marche). Si ça peut aider quelqu'un.
    • [^] # Re: Des pistes

      Posté par (page perso) . Évalué à 2.

      Maintenant que tu en parles, j'ai déjà eu le problème.
      J'avais résolu ça en désactivant HPET dans le BIOS. Puis j'avais mis une option, problablement une de celles que tu indiques.
      Va voir dans le BIOS, c'est rapide pour tester.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.