L'exchange-connector pour Evolution libéré en GPL

Posté par (page perso) . Modéré par Nÿco.
Tags :
0
12
mai
2004
Gnome
L'exchange-connector, un greffon (plugin) d'Evolution qui permet de connecter son client de messagerie à un serveur Microsoft Exchange, était un outil propriétaire et payant du temps de Ximian.

Un communiqué de presse datant du 11 mai, chez Novell, nous apprend qu'il est maintenant un logiciel libre à part entière, sous licence GPL et librement téléchargeable.

Peu de temps après la libération de Yast, voici une bonne nouvelle de la part de Novell. Espérons qu'ils continuent sur cette voie.

NdM : disponible en téléchargement à partir du 14 mai. Seules les distributions SUSE et RedHat sont supportées par Novell ou presque (Mandrake 9.1 et Sun Solaris 8 avec Sun Gnome 2), mais rien n'empêche les autres distributions d'empaqueter ce logiciel et de le supporter comme les autres logiciels libres sous licence GPL. Enfin Evolution 2.0 sortira au troisième trimestre en intégrant ce greffon.

NdM2 : merci également à klimber et tomc.

Aller plus loin

  • # Super nouvelle!

    Posté par . Évalué à 5.

    Il ne reste plus qu'à convaincre les admins Exchange d'installer le OWA (Outlook Web Access) sur leurs serveurs.
    • [^] # Re: Super nouvelle!

      Posté par . Évalué à 2.

      je ne vois pas le rapport avec le OWA.
      Juste le connecteur te permet de te connecter directement au serveur exchange avec ton Evolution. Rien à voir avec le webmail.

      Me corriger si je n'ai rien compris.
      • [^] # Re: Super nouvelle!

        Posté par . Évalué à 8.

        D'apres http://www.theregister.co.uk/2004/05/11/novell_connector/(...) , il faut que l OWA soit activé pour que le connecteur exchange puisse fonctionner , je pensais aussi que c etait du MAPI natif , apparement non.
        • [^] # Re: Super nouvelle!

          Posté par . Évalué à 4.

          je confirme, il faut OWA ....


          a part ca je suis deg, j'ai achete 2 licenses pour ma boite hier midi et ce matin je vois que ca passe GPL.... :-( j'ai demande un remboursement mais j'ai peu d'espoir...
          • [^] # Re: Super nouvelle!

            Posté par . Évalué à 10.

            Bah dis-toi que ta boite contribue au libre, et puis tu auras peut-être un support ou quelque chose de ce genre ..
            • [^] # Re: Super nouvelle!

              Posté par . Évalué à 1.

              felicitation Novel : j'ai envoye un mail hier pour demander le remboursement (sans grand espoir...) et j'ai recu ce matin meme un mail me disant que je serais rembourse !

              pour la crontribution au libre, moi je veux bien mais la carte de credit etait celle de mon boss....
              • [^] # Re: Super nouvelle!

                Posté par (page perso) . Évalué à 3.

                mais la carte de credit etait celle de mon boss....
                Et la carte de crédit de ton boss était celle de ta boite. C'est lui ou toi qui a demandé le remboursement ? Tu ne comptais pas te servir du support éventuel ?
        • [^] # Re: Super nouvelle!

          Posté par . Évalué à 6.

          il faut que l OWA soit activé pour que le connecteur exchange puisse fonctionner , je pensais aussi que c etait du MAPI natif , apparement non.

          C'est du WebDAV à travers OWA, donc il faut un accès OWA, forcément. Mais ceci dit, ça marche très bien, et au moins c'est très clair. C'est au dessus de HTTP, on peut le gérer de manière très propre au niveau d'un firewall, d'un proxy/reverse proxy ou d'une redirection de port (SSH, VPN SSL, etc.), ce qui n'est clairement pas le cas de MAPI. C'est d'ailleurs tellement bien MAPI que MS va à présent dans le sens d'un accès over HTTP pour simplifier l'accès au serveur.

          Ceci dit, le plugin est déjà téléchargeable puisque les sources sont disponibles :

          http://ftp.ximian.com/pub/source/evolution/ximian-connector-1.4.7.1(...)

          Donc les fans de la compilation peuvent se lancer. La documentation est d'ailleurs plutôt bien faite pour quiconque voudrait réimplémenter un plugin similaire. C'est le package qui est annoncé pour le 14 mai.

          Un bon point pour Novell, je vais pouvoir "brûler" ma licence Ximian Connector ;)))
          • [^] # Re: Super nouvelle!

            Posté par . Évalué à -2.

            > Un bon point pour Novell, je vais pouvoir "brûler" ma licence Ximian Connector ;)))

            Ah, tu refuses les conditions sous lesquelles est distribué le Ximian Connector et tu brûles la GPL pour le manifester ? Si tu refuses d'utiliser le Ximian Connector sous ses conditions, tu n'as pas le droit de l'utiliser, que les choses soient claires.
            • [^] # Re: Super nouvelle!

              Posté par . Évalué à 1.

              Non, je brûle la licence qui accompagnait le Ximian Connector du temps où il était propriétaire, et le fichier d'activation avec.

              C'est vrai qu'on est sur LinuxFR, j'aurions dû faire attention à employer le bon temps pour éviter les confusions...
  • # bonne très bonne nouvelle

    Posté par (page perso) . Évalué à 7.

    Cela va permettre, enfin je le souhaite de tout coeur, un passage en douceur vers des solutions libres.

    Pouvoir intégrer des stations Linux dans un environnement Windows afin de prouver sa valeur en production... voilà qui peut faire avancer grandement la cause des logiciels libres.
  • # et Lotus Notes?

    Posté par (page perso) . Évalué à 4.

    Maintenant il faudrait que des efforts se fédèrent du côté du support de Lotus Notes. Quelqu'un aurait déjà des informations à ce sujet?

    http://www.linuxforums.org/forum/viewtopic.php?p=89044(...)
    http://www.php.net/manual/en/ref.notes.php(...)

    J'ai essayé sous Wine (Debian sarge) et ca passe pas, bien que des gens aient réussi à le faire marcher.

    khorben

    • [^] # Re: et Lotus Notes?

      Posté par . Évalué à 3.

      cela ne t'etonne pas que cela ne soit pas deja fait puisque IBM se gargarise de supporter linux ?
    • [^] # Re: et Lotus Notes?

      Posté par . Évalué à 5.

      Je suis sous Debian unstable et j'utilise Lotus Notes avec wine tous les jours. Il est vrai que parfois, d'une version à l'autre de wine, ça déconne pas mal. J'ai pour ma part "freezer" la version de wine sur 0.0.20031212-1

      Pour mon install, j'ai bestialement récupéré le répertoire où était installé Notes sur un poste windows, et je complète mon "fake_windows" avec les dll qui manque. J'ai également du ajuster mon notes.ini pour avoir des chemins conformes à mon installation sous Linux
      Quel est exactement ton problème?
      • [^] # Re: et Lotus Notes?

        Posté par (page perso) . Évalué à 2.

        Pour ma part, j'ai Wine 0.0.20040408-1 (sarge), et je l'ai configuré pour utiliser ma partition et mes préférences sur ma partition NTFS Windows 2000.

        Je lance donc (Lotus Notes R5):
        $ wine nlnotes.exe
        fixme:console:SetConsoleCtrlHandler ((nil),0) - no error checking or testing yet
        fixme:console:SetConsoleCtrlHandler (0x1162770,1) - no error checking or testing yet
        Wine exited with a successful status
        $

        J'ai configuré wine avec winesetuptk, il se lance bien une fenêtre qui ressemble à celle d'un bureau wine (comme spécifié dans les exceptions "nlnotes.exe"), mais elle se ferme et wine s'arrête avec les lignes ci-dessus.

        khorben

        • [^] # Re: et Lotus Notes?

          Posté par . Évalué à 6.

          J'ai lu que c'était une mauvaise idée d'utiliser une partition Windows existante. Je te suggère de renommer ton.wine et de relancer ton winesetuptk afin qu'il te créé sous .wine un répertoire fake_windows reproduisant à peu près une arborescence windows. Il te suffit de recopier depuis ta partition Windows les dll qui manquent. Pour ma part, je n'ai eu qu'à recopier MSVCRT.dll sous fake_windows/Windows/System

          Pour ta version de wine, tu risques d'avoir des soucis avec les pièces jointes, mais néanmoins tu peux déjà commencer comme ça pour faire le nécessaire afin de démarrer Notes.
          • [^] # Re: et Lotus Notes?

            Posté par (page perso) . Évalué à 2.

            Je viens d'essayer une installation de R5 sous un Wine indépendant de Windows, et à partir de là j'arrive bien à lancer nlnotes.exe, par contre il ne veut pas se connecter au serveur Domino. Je vais vérifier mes paramètres, mais a priori ils sont bons...

            khorben

            • [^] # Re: et Lotus Notes?

              Posté par . Évalué à 2.

              Pour info, je suis en 5.0.11
              En tout cas, c'est bon signe!
      • [^] # Re: et Lotus Notes?

        Posté par . Évalué à 0.

        Wine et le client Notes, c'est pratique pour les "applis Notes", mais l'avantage d'un connecteur spécifique serait pour la synchro complète avec les PDA (agenda/courriers/carnet d'adresses).
        Sans oublier que l'interface de Notes n'est pas un modèle de "convivialité" (et la v6, quelle lourdeur...), alors un remplaçant "Outlook-Like" ravirait pas mal de monde, moi le premier ! ;-)

        A moins que tout ça ne soit déjà possible ?
  • # On se rapproche de kontact.

    Posté par (page perso) . Évalué à 0.

    Avec ce plugin libere, Evolution se hisse au niveau de Kontact (http://www.kontact.org/groupwareservers.php(...)) en terme d'acces a des serveurs de groupware.

    Pas mal.
    • [^] # Re: On se rapproche de kontact.

      Posté par (page perso) . Évalué à 3.

      Mwai, enfin le support a été enlever dans kde-3.2 car jugé trop instable ;)

      D'ailleurs: "Which means we can enjoy a groupware enabled release of KDE Kontact as soon as it is finished. "

      En clair, c'est pas fini.

      Est ce que kontact fonctionne sans le Outlook Web Access ? (debut de troll...) :)
      • [^] # Re: On se rapproche de kontact.

        Posté par (page perso) . Évalué à 5.

        Oui, c'est pas dans KDE 3.2 puisque cette version de KDE est sortie en fevrier ce qui implique un freeze a partir de la fin de l'annee 2003.

        Donc effectivement, dans la version d'il y a 6 mois, c'etait trop instable pour une release de KDE. Faut voir que Kontact est un des trucs qui bouge le plus dans KDE en ce moment. En fait, le seul probleme de Kontact, c'est qu'il est encore dans le CVS de KDE.

        Pour les fonctionnalites techniques, je ne sais pas je n'utilise ni Evolution, ni Kontact, ni Outlook Web Access. Tu peux preciser ta question ?

        Et pour repondre a la deuxieme personne, il est vrai que quand Evolution est sorti, il etait loin de kontact mais ce n'est plus le cas du tout aujourd'hui. Ce serait d'ailleurs interessant d'avoir une comparaison objective.

        Est-ce que tu as des fonctionnalites d'Evolution en tete que Kontact n'aurait pas ?
        • [^] # Re: On se rapproche de kontact.

          Posté par (page perso) . Évalué à 2.

          "Est-ce que tu as des fonctionnalites d'Evolution en tete que Kontact n'aurait pas ?"

          La météo? :)

          bon, sinon, je pense que le calendrier d'evolution est mieux pensé mais faut dire que j'ai pas beaucoup chercher a comprendre comment fonctionne korganizer.

          Sinon, y'a des gens qui connaissent un outils qui permettent de se connecter à un serveur netscape calendar? Je fais un demi hs mais j'ai besoin de ca pour le taf :( Netscape 4.7 ne sera pas considéré comme une réponse valide :)
        • [^] # Re: On se rapproche de kontact.

          Posté par (page perso) . Évalué à 1.

          Ce serait d'ailleurs interessant d'avoir une comparaison objective.
          A ce sujet, quelqu'un a déjà utilisé Aethera (thekompany.com) ?

          "La liberté est à l'homme ce que les ailes sont à l'oiseau" Jean-Pierre Rosnay

    • [^] # Re: On se rapproche de kontact.

      Posté par (page perso) . Évalué à 5.

      Je dirais que Kontact est encore loin d'Evolution: il ne faudrait pas inverser les rôles. Même si c'était propriétaire et payant, Evolution pouvait déjà le faire.
      • [^] # Re: On se rapproche de kontact.

        Posté par . Évalué à 1.

        Pour ma part , ca fait plusieurs mois (depuis l'install de la mdk 9.2) que j'utilise kmail avec un serveur exchange et j'ai pas trouvé d'erreur.

        Bon, le serveur parle en imap en entrer et smtp en sorti mais ca marche.
        • [^] # Re: On se rapproche de kontact.

          Posté par . Évalué à 3.

          oui en imap ca pose aucun souci du moment que ton client le supporte .... ca marche aussi avec mozilla et ce depuis pas mal de temps
        • [^] # Re: On se rapproche de kontact.

          Posté par . Évalué à 5.

          Bon, le serveur parle en imap en entrer et smtp en sorti mais ca marche.

          Oui, bien sûr. Du moment que l'IMAP est activé sur le Exchange, n'importe quel client peut y accéder. Mais l'intérêt du Connector, c'est de pouvoir accéder aux agendas partagés, à la gestion de réunions, etc. Les options de GroupWare.

          Si Exchange n'était qu'un serveur SMTP/IMAP, ça ferait longtemps qu'il aurait disparu du marché...
  • # questions de newbies

    Posté par . Évalué à 2.

    QQun connait un tutorial pour faire un passage tout en douceur de exchange vers qqch de plus libre? Je ne connais pas grand chose la dedans mais je sais que c'est l'une des principales réticenses des patrons. J'ai entendu parlé de Kolab mais est ce que les clients windows le "digère". Et Kontact est ce qu'il digère les servers exchange si oui comment?
    Desole de ces questions de newbie...
    Merci
  • # Pluin Connector pour Mozilla

    Posté par (page perso) . Évalué à 2.

    Vous pensez que ce serait possible de l'encapsuler pour en faire un plugin pour Thunderbord pour qu'il puisse utiliser Exchange ?

    (ou peut être y a t il déjà une extension pour mozilla qui projette son support ?)
  • # A quand le tour de Red Carpet Entreprise ? ;-)

    Posté par (page perso) . Évalué à 2.

    Bon, je sais, on peut toujours rêver, hein ;-)
  • # Y'a plus qu'à compiler

    Posté par . Évalué à 1.

    En espérant que les sources disponibles a l'heure actuelle soient compilables, je devrais pouvoir testerce plugin sous peu :)

    Je me demande bien quand même ce qui a poussé ximian à mettre son plugin sous licence GPL, beau geste de leur part
  • # Mdk

    Posté par (page perso) . Évalué à 6.

    La version 1.4 pour Mdk 10.0 est dispo sur le club (merci Frederic Crozat). Pour la version 1.5 pour Cooker, il attend des fichiers qui manquent.
  • # fonctionnement interne

    Posté par (page perso) . Évalué à 1.

    ca marche comment ce truc au fait ?
    j'ai lu plus haut qu'il fallait OWA. Ca utilise des composants COM d'OWA, ca fait des requettes HTTP, autre ?

    faut installer le connecteur sur exchange, ou en client uniquement ?
    C'est possible de faire une appli standalone utilisant ce connecteur qui se connecterait a un exchange pour en exporter les données sous un format exploitable ?
    • [^] # Re: fonctionnement interne

      Posté par . Évalué à 4.

      OWA = Outlook Web Access, en gros c'est du WebDAV, tu attaques donc le serveur en http avec les méthodes WebDAV (OPTIONS, PROPFIND,...)
      Il te faut donc cette partie sur le serveur, et le connecteur sur ton client. Cela signifie en particulier que même si tu as le connecteur, tu ne peux pas forcément te connecter sur n'importe quel serveur Exchange car OWA n'est pas installé par défaut (d'où mon premier post tout en haut de la page)
  • # Exchange 5.5

    Posté par . Évalué à 3.

    A priori, Exchange 5.5 n'est pas supporté par le connecteur. QQun a une explication technique (outre le fait que le protocole utilisé ne soit pas du MAPI) ?

    Y'a-t-il une solution pour connecter un évolution à un exchange 5.5 ?

    Ma société envisage une migration mais garde le serveur pour des raisons de coûts...
    • [^] # Re: Exchange 5.5

      Posté par . Évalué à 6.

      exchange 5.5 n'a pas OWA , le support webdav qu'utilise exchange pour faire du groupware sur http et qu'utilise le connecteur evolution.

      le connecteur novell/ximian evolution ne gere donc que exchange 2000 et 2003.

      il faut installer et activer le support OWA sur exch 2000 et 2003 (une case à cocher en gros dans l'outil d'administration)
    • [^] # Re: Exchange 5.5

      Posté par (page perso) . Évalué à 3.

      Pour répondre a ta question : Non.

      Exchange 5.5 en owa c'est de l'asp.
      C'est IIS qui fournit les fonctionalités OWA. Et IIS4 de NT4 ne fait pas WEBDAV.

      Maintenant et si tu montes un exchange 5.5 sur un serveur windows 2000 qui a un IIS5 me demanderas-tu?
      IIS5 permet Webdav mais c'est l'OWA d'exchange 5.5 qui n'a rien a voir avec celui de 2000/2003 qui va poser probleme.

      En exchange 2000, l'owa est en binaire, compilé. Ce n'est pas de l'ASP.

      Donc tu devras migrer en Echange 2000/Windows 2000 ou Exchange 2003 /Windows 2003.
      • [^] # Re: Exchange 5.5

        Posté par . Évalué à 1.

        Je vois pas le rapport entre ASP et WebDAV.

        Mais bon. Exchange 5.5 dispose de OWA, mais OWA 5.5 n'a pas de fonctionnalités WebDAV comme Exchange 2000/6.0 a. Cela rend donc impossible l'interropérabilité.

        Pour les détracteurs, sachez que MAPI c'est des RPC microsoft, et ca c'est sacrément compliqué à comprendre. D'autant plus que ca utilise des port flottants et tout le toutim.
  • # paquet debian

    Posté par . Évalué à 4.

    pour info, un paquet debian est dispo ici : (pas encore testé)
    http://www.slug.org.au/~jdub/debian/(...)
  • # Ximian Connector + OpenGroupware.org

    Posté par (page perso) . Évalué à 2.

    En tout cas, le connecteur permet au moins d'utiliser OpenGroupware.org de façon entièrement libre à défaut d'attendre le natif que développe en ce moment l'équipe de Skyrix.
  • # Mandrake 10.0

    Posté par . Évalué à 4.

    Le connecteur Ximian est dispo pour Mandrakelinux 10.0
    http://www.mandrakeclub.com/article.php?sid=2051&mode=nocomment(...)
  • # Commentaire supprimé

    Posté par . Évalué à 0.

    Ce commentaire a été supprimé par l'équipe de modération.

    • [^] # Re: Vous arrivez à le compiler ?

      Posté par . Évalué à 0.

      je n'y arrive pas non plus....


      Je pense que ca viens de la librairie gnutls!!
    • [^] # Re: Vous arrivez à le compiler ?

      Posté par . Évalué à 0.

      je n'y arrive pas non plus....


      Je pense que ca viens de la librairie gnutls!!
      • [^] # Re: Vous arrivez à le compiler ?

        Posté par . Évalué à 1.

        Moi j'y arrive (Mdk 10) mais impossible de le faire marcher :

        Erreur durant « Examen des dossiers dans « Exchange server mail» » :
        Could not connect to Evolution Exchange backend process: No such file or directory

        Je pense que le make install n'est pas adapté à la mdk 10, si k1k1 à une idée je suis preneur ...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.