Forum Astuces.divers qemu/kvm forward port

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
3
13
mai
2021

Bonjour,

Vraiment nul en réseau, je chercher à faire communiquer à l'extérieur un serveur plex qui tourne dans une vm sur dédié DC.

J'ai modifié mon xml pour ajouter le forward du port plex (32400)

<qemu:commandline>
<qemu:arg value='-net'/>
<qemu:arg value='user,hostfwd=::32400-:32400'/>
</qemu:commandline>

Depuis que j'ai fais ça, j'ai bien le port ouvert quand je fais un nmap sur le dédié. Mais le serveur plex ne communique toujours pas avec l'extérieur.
Qemu à pourtant bien géré les règles la vm à l'ip (…)

Forum Linux.général Bonding fail

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
1
18
déc.
2020

Bonjour,

Besoin d'un petit coup de main sur du bonding.

J'ai un orangepi, qui me sert de passerelle entre mon routeur fai et un autre connexion ethernet sur un répéteur wifi.

Donc j'ai deux connexions ethernet et j'ai essayé de configuré un bonding en mode 4:

auto eth0
iface eth0 inet manual
      bond-master bond0

auto eth1
iface eth1 inet manual
     bond-master bond0

auto bond0
iface bond0 inet static
address 192.168.66.66
    netmask 255.255.255.0
    gateway 192.168.66.254
    bond-mode 4
    bond-miimon 100

L'interface bond0 (…)

Forum général.général kvm bridge et performance réseau (limited 10Mb/s)

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
3
19
oct.
2020

Bonjour,

Dans un précédent post, j'évoquais mon problème de boot pxe, celui-ci est résolu.

Maintenant je rencontre un autre tout petit challenge dont je ne trouve pas de solution.
Je créer un bridge avec une commande classique:

ip link add name br0 type bridge

Je partage sur celui là connexion internet et réseau local de l'hôte.
Si je fait un ethtool sur br0 pour vérifier sa vitesse:

Speed: Unknown!

Lorsque je lance une vm sur le bridge et que je (…)

Forum Linux.général KVM, boot pxe, serveur dhcp

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
17
oct.
2020

Bonjour,

Je travail sur quelque chose qui utilise Windows Server en VM qui délivre un serveur tftp et dhcp pour du boot pxe.
Mon problème avec libvirt c'est que je n'arrive pas à faire démarrer le boot pxe sur le serveur windows.

J'ai définis une interface br0 dans la configuration du réseau, dans un xml pour libvirt.

Maintenant comment déclarer lors d'un boot pxe que le serveur ce trouve à 192.168.56.10 (adresse du du serveur Windows)

Peut-être avec dnsmasq et (…)

Forum Linux.debian/ubuntu luks debian testing, boot avec clé sur clé usb

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
1
20
fév.
2020

Bonjour,

Je me trouve dans une impasse après avoir pas mal cherché.
L'idée est de sécurisé une machine avec chiffrement des disques via luks et de mettre une clé qui autorise le déchiffrement de la partition racine automatiquement avec une clé usb inséré dans la machine.

Après avoir exploré le sujet, il s'avère si j'ai bien compris que le paramètre "keyscript" dans crypttab n'est plus pris en compte dans debian.

Il resterait donc un paramètre à passer dans grub pour (…)

Forum Astuces.divers Ssd NVME et benchmark

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
1
18
juil.
2019

Bonjour,

J'ai fais l’acquisition d'un ssd nvme M.2 (intel 760p 1to), une super affaire sur ebay.
Bref je clone mon système avec clonezilla et monte le ssd M.2 sur ma carte mère une Asus 320M-K qui a un port M.2 PCI-E 3.0 4x.

Je lance quelques benchmarks:

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=100 conv=fdatasync                                                                                       
    104857600 octets (105 MB, 100 MiB) copiés, 0,180896 s, 580 MB/s

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=1000 conv=fdatasync                                                                                      
    1048576000 octets (1,0 GB, 1000 MiB) copiés, 1,45612 s, 720
(…)

Forum Astuces.divers nginx reverse proxy wekan

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
15
juil.
2019

Bonjour,

Je tente de configurer wekan (tourne en docker, qui fonctionne bien en local) avec nginx en reverse proxy.
J'ai un début de chargement de page (titre chargé) mais l'appli ne se charge pas complètement.

La configuration en reverse:

    location /todo/ {
            proxy_pass http://192.168.1.35:8060;
            rewrite ^/todo(.*)$ $1 break; # this didnt help either
            proxy_http_version 1.1;
            proxy_set_header Upgrade $http_upgrade;
            proxy_set_header Connection "upgrade";
            proxy_set_header X-Forwarded-For $remote_addr; # preserve client IP
    }

(…)

Forum Linux.général octoprint derrière nginx

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
0
5
sept.
2018

Bonjour,

J'ai un petit serveur octoprint sur ma machine qui dispose d'un nginx accessible depuis l’extérieur, avec comme configuration:

location /octo/ {
proxy_pass http://localhost:5000/; # make sure to add trailing slash here!
proxy_set_header Host $http_host;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection "upgrade";
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Scheme $scheme;
proxy_set_header X-Script-Name /octoprint;
proxy_http_version 1.1;
client_max_body_size 0;

}

Bon voilà vous voyez. Le problème c'est quand j’accède au serveur octo sur mon adresse externe. Il ne charge pas le (…)

Forum Astuces.divers virtualisation/hyperviseur état des lieux

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
2
17
juin
2018

Bonjour,

Je vous sollicite pour vos éclairages.
Je cherche à faire tourner différent OS sur mon archlinux.

Je connais l'existence de xen en hyperviseur de type 1 qui assure normalement de bonne performance.
Je fais pour l'instant tourner un windows 10 dans un virtualbox et les performances ne sont pas toujours au rendez-vous.

Quelques questions de novice:
- Xen est la meilleur solution pour plus de performance?
- quid de lxc, virtualbox et kvm?

Si vous aviez des liens à (…)

Forum Astuces.divers resize partition backup

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
16
déc.
2017

Bonjour,

Petit problème sur une partition de sauvegarde d'un disque ssd en ext4.
Je sauvegardais toute les semaine une partition système d'une machine sous ssd (60GO)dont 21GO de libre).
Je change le ssd de ssd de cette machine pour un autre un tout petit plus petit (55GO).

Je prend donc cette image de sauvegarde et m'aide de cette documentation https://softwarebakery.com/shrinking-images-on-linux .

Tout ce passe bien j'ai bien redimensionner l'img à 55go avec les outils losetup et gparted:
Quand je mount (…)

Forum Linux.général logiciel libre et handicap moteur

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
3
29
nov.
2017

Bonjour,

Je travaille dans le médicale avec des personnes atteintes d'infirmité motrice cérébrale.
Ces personnes dispose d'ordinateur tactile (écran 360°), renforcé, sous windows. Elle sont sur fauteuil électrique et l'ordinateur est placé de façon adapté.

Le logiciel principale est Mind Express (http://www.cimis.fr/logiciels/aide-a-la-communication-1/pictogrammmes/mind-express-4-482.html).

Le principe est de faire du tts sur un symbole. On édite le symbole, on le nome et on écrit la phrase qui sera prononcée. Selon les capacités motrice, la personne clique sur le pictogramme avec (…)

Forum Astuces.divers choix carte mini pcie

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
15
sept.
2017

Bonjour,

Je vous sollicite pour le choix d'une carte mini pcie wifi/bluetooth.
La norme n pour le wifi suffit et le bluetooth 4.0 ira bien.

J'ai fait plusieurs test avec différentes cartes:

  • broadcom 4313, avec le drivers broadcom-wl, le wifi et le bluetooth marche bien ensemble, mais problème de continuité dans la connexion. Avec un vpn je finis toujours avec un time out (cf log NetworkManager). Et le drivers qui plante de temps en temps obligé de reconnecter manuellement dans (…)

Forum général.général résolution dns google mystère

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
13
août
2017

Bonjour,

Je me permet de poster un message car je rencontre un problème peut-être mystérieux.

J'utilise un vieux laptop comme routeur wifi/ethernet, serveur web et d'autre service.
Celui-ci se connecter en wifi (sur connexion vpn) sur mon routeur branché au net.

Mon problème se situe lorsque je demande une résolution dns vers google lors d'une adresse distribué par mon dnsmasq.
Elle reste non résolue alors que j'ai accès à tout le reste.
Je précise que sur le laptop en question (…)

Forum Linux.général Gandi livebox ip dynamique

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes :
0
9
avr.
2017

Bonjour,

Je me tourne vers vous, car je déménage et je vais me retrouver avec un livebox3 à ip dynamique.
Je possède un petit nom de domaine en auto hébergement et je réfléchi à une solution pour mettre à jour automatiquement l'entrée dns.

La machine qui héberge le site est aussi connecté en vpn et la connection est géré par NetworkManager. J'ai bien vu des script avec l'api Gandi et si je cherche mon ip avec un curl ifconfig.pro je (…)