Forum Linux.débutant libre office calc, point comme séparateur décimale

Posté par . Licence CC by-sa.
Tags :
0
4
nov.
2018

Hello. J'utilise Fedora 27 avec une localisation française, du coup pour libre office calc, le séparateur décimale est une virgule.

J'aimerais changer cela par un point (plus facile avec le pavé numérique du clavier) sans devoir mettre tout mon libre office en anglais.

Google ne m'a pas aidé, je suis bien tombé ici mais je n'ai pas envie de mettre mon système en français suisse (séparateur des milliers = apostrophe …)

Merci pour votre aide.

  • # Options linguistiques

    Posté par (page perso) . Évalué à 6 (+5/-0). Dernière modification le 04/11/18 à 18:07.

    Dans LibreOffice, va dans le menu Outils > Options, onglet Paramètres Linguistiques > Langues, et décoche "Touche du séparateur de décimales: identique au paramètre de la locale"

    Autre solutions:
    https://forum.ubuntu-fr.org/viewtopic.php?id=1389581

    Et ça devrait être bon!

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # Désolé ...

    Posté par . Évalué à 2 (+1/-0). Dernière modification le 04/11/18 à 20:51.

    Je me suis avoué vaincu par cet "mouche dans le lait" …
    Je navigue entre différentes plateformes à la maison et au boulot : Windows, Linux et macOS (sympa, Apple, la touche du pavé numérique marqué virgule et qui produit, quelle que soit l'appli, une virgule ! Logique, je dis pas, logique, mais d'un chiant …).
    Dans le genre vicieux, il y a aussi la config de langue de l'OS (je préfère mes OS en anglais) qui influe sur l'interprétation du point ou de la virgule comme étant un séparateur décimal ou des milliers. Un LibreOffice configuré pour du français est capable je pense de te faire une virgule au pavé numérique, même si ton OS est en anglais. Ou l'inverse. C'est tellement du cas par cas que je ne sais plus trop.
    Si on ajoute à ça la réinstallation qui devient obligatoire de temps en temps (un OS, ça s'use. Même un Linux, à force de faire des trucs bizarres …).
    Et du coup, j'ai fais la reconfiguration de LibreOffice pour obtenir le bon comportement. Un bon nombre de fois. Mais j'ai abandonné il y a longtemps, j'ai préféré m'adapter à chaque fois maintenant …

    Je vous ai dis que depuis quelques temps, j'utilise le clavier de mon portable pour avoir un écran de plus en dessous des trois autres ? Un clavier de portable, c'est bien aussi pour devenir dingue … Avec ses touches mal placées …
    Et je vous ai parlé de la fois où j'ai bossé en Belgique ? Ils ont des claviers "différents" eux-aussi ! ;-)

    Par contre, je n'ai jamais essayé LibreOffice sur un portable belge ! Qu'il soit configuré en anglais ou en belge …

  • # LC_NUMERIC

    Posté par . Évalué à 2 (+0/-0). Dernière modification le 04/11/18 à 22:32.

    Ou plus simple :

    dnf install libreoffice autocorr-fr mythes-fr hyphen-fr unspell-fr libreoffice-langpack-fr -y

    oocalc -> options -> paramètres linguistiques -> langues -> touche séparatrice de décimale : décochez la case kivabien.

    ps : fedora 27 pourrait être mise à jour vers 28

    [EDIT] : arf, désolé du doublon, Ted

    • [^] # Re: LC_NUMERIC

      Posté par . Évalué à 2 (+1/-0).

      Hello, non cela ne fonctionne pas !
      Grâce au poste un peu plus haut j'ai pu trouvé une astuce dans les options de l'agencement clavier…::

      option clavier

      Pour "Comportement de la touche suppr du pavé numérique" il faut mettre "touche à 4 niveaux avec séparateur décimale abstrait".

      Et du coup, avec la cache que tu montres coché. Libre office interprète le point de mon clavier numérique comme une virgule, c'est un progrès mais:

      1) Je ne peux pas utiliser de point comme séparateur décimale si je modifie pas la "langue" de mon système.
      2) maintenant libre office Writer interprète le point de mon pavée numérique comme une virgule…

      C'est quand même fou que cela ne soit pas plus simple que ça…

      • [^] # Re: LC_NUMERIC

        Posté par . Évalué à 2 (+0/-0). Dernière modification le 09/11/18 à 16:12.

        et avec la locale ?

        faire un export LC_CTYPE="en_US.UTF-8"
        oocalc

        ou un
        LC_CTYPE="en_US.UTF-8" oocalc

        La locale peut être surchargée de façon sélective, lancer la commande locale pour avoir la liste ;)

        Il ne faut pas décorner les boeufs avant d'avoir semé le vent

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.