Forum Linux.général impossible de trouver le port du server X

Posté par . Licence CC by-sa.
Tags : aucun
0
18
juin
2019

Bonjour,

D'apres ce que j'ai compris, tous les programmes qui souhaitent afficher graphiquement des interfaces doivent se connecter en TCP sur le port 6000 en localhost pour communiquer avec le server X.

J'ai donc testé les ports utilisés en localhost via la commande :

nmap 127.0.0.1 -p-

et le programme me retourne

PORT STATE SERVICE
22/tcp open ssh
139/tcp open netbios-ssn
445/tcp open microsoft-ds
631/tcp open ipp
3306/tcp open mysql
50200/tcp open unknown
50201/tcp open unknown
50202/tcp open unknown

Or je ne vois aucun port 6000 utilisé

avez vous une idée du probleme.

Merci d'avance

  • # socket

    Posté par . Évalué à 7 (+5/-0).

    Pour une utilisation locale, ça n'a pas de sens de passer par une connexion réseau, donc on communique avec le serveur via un fichier spécial: un socket
    Pour comprendre comment cela fonctionne, les mots clés sont IPC (InterProcess Communication) et unix sockets

    • [^] # Re: socket

      Posté par (page perso) . Évalué à 4 (+2/-0).

      Exact, et la communication par réseau est désactivée par défaut par les distributions car elle n'est pas sécurisée (tout circule en clair).

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # Avec ss

    Posté par . Évalué à 4 (+2/-0).

    Pour obtenir des informations sur un socket utilisé par un programme, tu peux utiliser "ss" (successeur de "netstat"), ici en demandant les socket en écoute, avec les informations du processus (comme son nom) :

      $ sudo ss -lp|grep Xorg
      nl     UNCONN     0      0      uevent:Xorg/1861              *                     
      nl     UNCONN     0      0      uevent:Xorg/1861              *                     
      u_str  LISTEN     0      128    /tmp/.X11-unix/X0 27775                 * 0                     users:(("Xorg",pid=1861,fd=7))
      u_str  LISTEN     0      128    @/tmp/.X11-unix/X0 27774                 * 0                     users:(("Xorg",pid=1861,fd=6))
      tcp    LISTEN     0      128    :::x11                  :::*                     users:(("Xorg",pid=1861,fd=5))
    

    Ici, on voit deux sockets Netlink, deux sockets Unix orientés flux (stream) dont un « caché », et un socket TCP qui écoute sur le port standard x11 (6000). Chez toi tu ne dois pas avoir ce dernier, qui est effectivement souvent désactivé par défaut aujourd'hui. Celui plus couramment utilisé est le socket Unix ; j'avoue ne pas savoir pourquoi il y en a deux.

    Pour activer l'écoute en TCP, tu peux changer l'option (sous Debian) dans /etc/X11/xinit/xserverrc :

      exec /usr/bin/X -listen tcp "$@"
    

    ("listen" à la place de "nolisten")

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.