GCompris 7.0.1 dans les bacs

Posté par (page perso) . Modéré par Mouns.
Tags :
0
17
sept.
2005
Communauté
L'équipe de développement de GCompris vient de sortir la version 7.0.1 de ce Logiciel Libre éducatif primé aux Trophées du Libre 2003.

Cette version est particulièrement dédiée au monde des écoles car elle intègre des fonctionnalités qui faciliteront l'utilisation de GCompris dans celles-ci. En effet, le développement s'est focalisé sur la gestion, notamment pour les utilisations en classe. L'outil gcompris_edit a été remplacé par une nouvelle implémentation est accessible avec l’icône ’configuration de GCompris’ du bureau (comme avant), ou par la commande ’gcompris -a’.

GCompris inclut maintenant plus de 70 activités et cette nouvelle version ajoute un sudoku, des mangeurs de nombres et une version contre l'ordinateur du memory. Difficile de conserver la concentration des enfants avec autant de choix !

Avec le nouveau module d’administration, les professeurs peuvent créer des profils par groupes d’utilisateurs. Les professeurs peuvent facilement enregistrer plusieurs profils, dans lesquels les activités proposées ne sont pas les mêmes. Mieux, l'enseignant peut maintenant finement adapter les activités. Par exemple, un professeur français peut configurer l’activité ’clique sur la lettre’ pour avoir les consignes en anglais (ou une autre langue), comme d'ailleurs dans les autres tableaux de lectures.

D'un point de vue technique, la base de données des profils est sauvegardée dans une base de données relationnelle grâce à sqlite. La base de données peut-être partagée entre plusieurs ordinateurs en utilisant NFS par exemple, afin que tous les ordinateurs d'une salle utilisent la même configuration.

Il nous manque encore des fonctionnalités importantes comme les rapports d'utilisation par élève mais c'est bien la suite logique de nos développements.

NdM : rappelons que GCompris est disponible pour les Unix (Linux, MacOS X, etc.) et pour Windows, et est distribué sous licence GPL, mais avec une petite originalité : la version binaire complète pour Windows n'est pas proposée au libre téléchargement, mais seulement à l'achat. Au delà de GCompris, nous aimerions partager avec vous quelques nouvelles sur la progression de GNU/Linux dans le monde de l'éducation :

- Du coté de Edubuntu, nous avons appris par JaneW qu'au 'Edubuntu Summit' en juillet en Australie, des éducateurs de tous les continents se sont rassemblés. Le rapport indique qu'Edubuntu sera bientôt installé dans des centaines d'écoles à travers l'Europe de la Suède à l'Espagne -- dans la région d'Andalousie, le gouvernement a choisi Ubuntu Linux pour ses écoles, bibliothèques et toutes les infrastructures publiques. Au Brésil, Elkner a dit que plus d'un million d'élèves utiliseront Edubuntu.

- Du coté de GCompris, nous avons certains contacts aussi qui nous montrent clairement que GNU/Linux progresse partout dans le monde. Là où il y a quelques années je m'enthousiasmais d'apprendre que GNU/Linux et GCompris était utilisé dans l'école du village, il est maintenant courant d'entendre des régions ou des pays basculer vers le Logiciel Libre.

Par contre, je suis déçu de ne pas voir de projet d'envergure émerger en France dans le monde de l'éducation. Que se passe-t-il, pourquoi ce qui est possible au Brésil ou en Espagne ne se fait pas en France ? Ce ne sont pourtant pas les contributeurs français qui manquent, que ce soit des développeurs indépendants ou des sociétés commerciales à même de fournir des solutions.

Aller plus loin

  • # Faut croire...

    Posté par (page perso) . Évalué à 10.

    Qu'ils ont bien retenu la leçon de la dernière news qui utilisait l'expression "dans les bacs" (sic)... Ça fait 896...
    http://linuxfr.org/comments/622334.html#622334(...)
    • [^] # Re: Faut croire...

      Posté par . Évalué à 3.

      oui mais là dans le cas de Gcompris, visiblement l'auteur fait référence... aux bacs à sables, lieux de jeux habituels des enfants ;)

      Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

  • # Et les screenshots ?

    Posté par . Évalué à 4.

  • # Logiciels éducatifs en France

    Posté par (page perso) . Évalué à 10.

    Dire qu'il n'y a pas grand chose de fait en France est aller un peu vite en besogne.

    En dehors des grands classiques comme abuledu, et Freeduc, on peut noter cette année les sorties de freeduc-école primaire, l'investissement dans skolelinux des lug de Lorraine en particulier du lug Forbachois Schlosslug, , le fork librement téléchargeable de abuledu, majilux fait essentiellement par un parent d'élève, Jean-Louis Louër, la poursuite de artouste par paulla (lug palois), freeduc-sup, pingoo, et j'en oublie.

    http://www.abuledu.org/(...)
    http://www.majilux.org/(...)
    http://www.scideralle.org/(...)
    http://eole.orion.education.fr/(...)
    http://www.pingoo.org/(...)
    http://www.skolelinux.org/fr/(...)
    http://schlossgul.org/wakka.php?wiki=PagePrincipale(...)

    Majilux est un serveur scolaire sur base kaella.
    Il peut devenir un serveur domestique ou un serveur de bureautique assez facilement. Skolelinux est sur une base Debian.

    Freeduc dans ses versions collège-lycée , école primaire, ou même jeux est sur une base knoppix.
    http://www.ofset.org/fr/freeduc-cd(...)
    http://logiciellibre.free.fr/freeduc/(...)

    Tout ces projet sont français d'origine, même si dans le cas de freeduc on trouve des contribution et des plagiats (souhaités) au Brésil et en Inde.

    On peut rencontrer les équipes de ces projets aux RMLL, ou parfois à solution linux.


    Mon impression est qu'au contraire, la France est un pays très productif dans ce domaine.

    Beaucoup de ces projets sont initiés par des enseignants ou des parents d'élèves, peu par les services concernés de l'éducation nationnale ou de l'enseignement privé.
    J'attribue cela au manque de culture technologique des décideurs.
    • [^] # Re: Logiciels éducatifs en France

      Posté par . Évalué à 6.

      Dire qu'il n'y a pas grand chose de fait en France est aller un peu vite en besogne.
      Non, c'est vrai. Ce que veut dire Bruno, c'est qu'on apprend régulièrement qu'un pays, ou toute une region, installe du linux (avec gcompris) dans ses écoles. L'Andalousie, par exemple, mais aussi plus d'un millions d'élèves au Brésil d'après edubuntu, et on a reçu des informations du même ordre pour d'autres régions (par les traducteurs souvent).

      En France il y a un tas de développement qui se fait, mais aucun projet d'envergure pour l'installer dans des centaines d'établissements scolaires[1]. Imagine un peu qu'un département annonce le déploiement de edubuntu sur les postes de tous les collèges de son département. Ou même; plus modestement, qu'une mairie fasse cela pour ses écoles. Ce ne serait pourtant pas impossible, niveau primaire-collège (B2i 1 et 2), une edubuntu contient tout ce dont on a besoin. Une majilux ou une abuledu aussi d'aileurs. Et pourtant cela semble impossible en France.

      [1] je ne parle pas des serveurs de fichiers ou des serveurs d'accès filtrants au net. Je parle bien des postes clients.
    • [^] # Re: Logiciels éducatifs en France

      Posté par (page perso) . Évalué à 3.

      Ben oui on est d'accord, malgrès tous ca, combien de ville, département, région en France ont choisis GNU/Linux pour leurs écoles ?

      C'est schématique mais on peut penser que ailleurs, ils codent moins mais ils deploient déjà !
      • [^] # Re: Logiciels éducatifs en France

        Posté par . Évalué à 3.

        En France, les villes (communes) n'ont rien à dire concernant l'informatique pédagogique. Leur seul droit est de *payer* ce que les enseignants leur "proposent" (proposer veut ici dire : prétendre que le maire est un ignoble avare s'il ne veut pas entièrement équiper l'école en PCs tous neufs sous Windows + Microsoft Office, seuls logiciels que maîtrisent les formateurs de ces enseignants.

        Au sommet de la hiérarchie des prescripteurs de produits pédagogiques informatisés de l'éducation nationale et du réseau de formateurs et de correspondants figurent les CTICE : correspondants académiques TICE, discrétionnairement choisis par les secrétaires généraux d'académie.

        Alors, en tant que maire, il faudrait vraiment être con pour tendre le bâton pour se faire battre, hein....
        • [^] # Re: Logiciels éducatifs en France

          Posté par . Évalué à 4.

          Windows + Microsoft Office, seuls logiciels que maîtrisent les formateurs de ces enseignants.

          Généralisation hâtive et méprisante ?
          http://www.google.fr/search?q=IUFM+openoffice(...)
          http://www.google.fr/search?q=IUFM+linux(...)

          Leur seul droit est de *payer* ce que les enseignants leur "proposent"
          Pas du tout. Ils ont également la maintenance à financer, ce qui leur donne un évident droit de regard sur le système choisi.
          http://www.aful.org/wws/arc/educ/2005-09/msg00006.html(...)

          Au sommet de la hiérarchie des prescripteurs de produits pédagogiques informatisés de l'éducation nationale... se trouve l'enseignant qui dispose de la liberté pédagogique du choix de ses outils, quelque soient les prescriptions. Ce qui pose évidemment le problème de la formation... et des pressions des inspecteurs qui pourraient être tenté de faire pression pour tel ou tel outil, de même qu'il peut leur arriver de critiquer les choix des livres.

          Cette histoire est intéressante, parce qu'elle montre les dégats dans les esprits que peuvent une solution mal gérée:
          http://www.aful.org/wws/arc/educ/2004-07/msg00015.html(...)
        • [^] # Re: Logiciels éducatifs en France

          Posté par (page perso) . Évalué à 3.

          Pour être un peu dans le métier, je dirais plutot que le maire a envie que l'argent qu'il va mettre dans une école soit utilisé par le plus grand monde.

          Ainsi, beaucoup de mairie pretent la salle de l'école pour les "clubs informatiques" communaux.
          Et les clubs informatiques, sans windows, ils sont perdus. (sauf GUL bien sur ;) )
          Donc, il est TRES difficile de faire acheter à la mairie des ordinateurs sans windows.

          Por agrémenter le débat, je trouve qu'en France il y a beaucoup TROP de solutions. A moins d'être vraiment indépendant dans une petite commaune et ayant qq'un sous la main "qui sache faire", la politique actuelle n'es tpas du tout celle d'installer des postes clients sous Linux, bien au contraire.
          Par contre, ce qui se développe et devient des priorité des académies, c'est mettre un serveur pare-feu, passerelle, serveur de fichier sous Linux dans les écoles. Ca oui. Par contre en client... c'est pas encore gagné (A mon avis, faute de com et SURTOUT de compétences)
          • [^] # Re: Logiciels éducatifs en France

            Posté par . Évalué à 4.

            Ayant le malheur d'être l'un des interlocuteurs de l'éducation nationale lorsqu'il s'agit de faire payer leurs lubies informatiques aux communes, je me suis toujours étonné de voir que l'idée même de se présenter aux associations départementales, régionales ou nationale de maires n'effleure pas une seule seconde les "ingénieurs en technologies éducatives". Il faut dire à leur décharge qu'eux ne semblent pas avoir la possibilité de se faire assister de professionnels un tant soit peu compétents pour monter leurs dossiers, et ont parfois du mal à imaginer que leurs interlocuteurs puissent être professionnels en exercice du secteur dans lequel ils prétendent ici faire preuve d'expertise.
    • [^] # Re: Logiciels éducatifs en France

      Posté par . Évalué à 1.

      Dire qu'il n'y a pas grand chose de fait en France est aller un peu vite en besogne.

      Oui c'est vrai et j'ajouterai à ta liste le site http://www.education.free.fr/,(...) maintenu par le président du Graoulug, http://www.graoulug.org(...) , qui résume tout ce qui se fait en matière de logiciels éducatifs.
  • # remarques

    Posté par . Évalué à 4.

    Salut, ca semble pas mal, ma fille de 4 ans 1/2 aimearis bien essayer...
    bon, je suis allé sur le site,

    déjà j'aimerais bien avoir une liste des differents programmes/activité proposés classés par age (ouais parceque 3 à 10 ans c'est large) j'espere que dns gcompris il y a un moyen de connaitre l'age moyen des activité.. autrement que de les essayer...

    justement, tiens je telecharge pour essayer...

    les package pour ma mdk 10.0 ? ha ouais, ok tout est expliqué, bien.. il faut telecharger quelques packages "assetml", ya une url, c'est bien foutu...
    bien je m'execute, mais au moment d'installer gcompris, ben..
    "Certains paquetages demandés ne peuvent pas être installés :
    gcompris-7.0.1-1.i586 (car libpython2.4.so.1.0 est non satisfait)"

    c'est pas écrit dans sur le site cette depedance là.. et quel package dois-je prendre hein ? bon rmpsearch, ok, installé..
    ouf on recommence.. merde "libsqlite3" maintenant !
    bon... y'en a beaucoups des dépendances encore ?
    une ptite liste avec les liens depusi votre site ca serait pas mal.
    voilà, juste ces deux remarque, sinon ca a l'aire super bien. joli...
    merci d'avance.
    • [^] # Re: remarques

      Posté par . Évalué à 1.

      La liste des dépendances et des paquets à installer se trouve dans le fichier INSTALL dans les sources...
      Par contre, sur une mdk 10.0 je ne pense pas que cela fonctionne, ni même sur la 10.1 mais sur la 10.2 mini car je crois qu'il faut une version plus récente de gtk+ (2.6) et python (2.4)
      Tu peux malgré tout installer la version précédente pour ta fille qui contient déjà un bon nombre d'activités.
      • [^] # Re: remarques

        Posté par . Évalué à 3.

        merci.

        je suis en effet bien bloqué, (apres avoir installé "brutallement" libsqlite3 a coup de --nodeps pour cause de ldconfig pas a niveau) et bien de toute maniere il me manque le package pysqlite2 que je ne trouve pas sur le net alors... bon. j'abandone.

        sympa la liste de dependance, dans les sources, sur le site web ca serait pas mal aussi non ?

        domage qu'il faille toujours la derniere version...
        • [^] # Re: remarques

          Posté par . Évalué à 2.

          domage qu'il faille toujours la derniere version...
          gtk 2.4 suffit. Les seules nouveautés de cette version sont les dépendances sur libsqlite3 et pysqlite2.

          Tu dois pouvoir fonctionner juste avec libsqlite3, mais le module administration ne marchera pas. Par contre toutes les activités marcheront, elles.
          • [^] # Re: remarques

            Posté par . Évalué à 2.

            Pourtant quand j'essaye de le compiler à partir des sources depuis ma mdk 10.1, j'ai le message d'erreur suivant :
            ../../src/gcompris/.libs/libgcompris-1.so: undefined reference to `gtk_combo_box_get_active_text'
            collect2: ld returned 1 exit status
            make[4]: *** [gcompris] Erreur 1

            alors que les précédentes versions passaient sans pb... et il semble que cette fonction ne soit disponible qu'en 2.6.
            Donc si tu as une piste, car le .rpm ne s'installe pas non plus à cause de python...
            • [^] # Re: remarques

              Posté par . Évalué à 1.

              gtk_combo_box_get_active_text ()

              Since 2.6

              Merde, tu as raison, j'avais pas vu ça. Il faut le 2.6. Je vais corriger ça.
            • [^] # Re: remarques

              Posté par . Évalué à 1.

              passe sur irc://freenode #gcompris si tu veux tester la correction.
        • [^] # Re: remarques

          Posté par . Évalué à 5.

          domage qu'il faille toujours la derniere version...
          Il est normal qu'un programme actif se tourne vers des librairies récentes lors de son évolution. On ne va pas utiliser un vieux pysqlite, ni un vieux sqlite, alors que les versions maintenues sont les dernières.

          Il te reste le choix d'installer une vieille version de gcompris, ou mettre ton système à jour. L'avantage des distributions linux, en théorie, c'est que les mises à jour sont possibles gratuitement.
          • [^] # Re: remarques

            Posté par . Évalué à 4.

            vielle version : c'est ce que j'ai fait.
            maintenant a propos des denieres versions, je comprends que QUAND on ajoute des fonctionalité (tel sqlite d'apres ce que j'ai compris) et bien on a forcement besoin de la lib en question.
            mais en ce qui concerne gtk... je n'ai pas vu entre la 6.5.3 et le screenshot de la 7.0.1 une difference eclatante au niveau UI.
            Ensuite je peu me tromper, je n'ai pas participé mais j'ai dans l'idée que pas grand chose justifie le passage à gtk 2.6, sauf que les devs avait la 2.6 d'installé.

            C'est une generalité (donc rien contre gcompris) mais regardez, j'ai une 10.0 qui n'a qu'un an, et ben ya plein de softs qui ne s'installent pas. non pas parcequ'il ont des fonctionalité nuoevlles dans qt ou gtk, mais simplement de le (les) dev l'on prevu aevc leur derniere version.

            Derniere experiance avec un soft dev par qqun d'ici, mais compatible qu'avec un kde derniere vesion, pour un simple "analyseur"(afficheur avec filtre quoi) de log... ca avait l'air bien mais bon...

            1 an c'est pas enorme, pour info : quand je boot sous windows 2000, (qui a donc 5 ans en gros hein) j'ai pas tant de probleme que ca.
            moi j'aime bien linux pour sa stabilité, j'aime pas réinstaller mes OS tous les ans. Je comprends que pour beacoups linux est tellement fun que se faire des install tous les 6 mois faut le coups pour avoir la derniere techno qui tue. (moi la dern. techno j'en veux pas j'ai un P3 700).
            tous ca pour dire qu'une distro (a jour au niveau patch) vieille d'un an ne dois pas être consideré comme has been...
            • [^] # Re: remarques

              Posté par (page perso) . Évalué à 2.

              moi j'aime bien linux pour sa stabilité, j'aime pas réinstaller mes OS tous les ans
              Et?
              Les mises à jours fonctionnent franchement bien
              j'ai une ubuntu qui a fait 04.10 vers 05.jesaiplusquoi (hoary quoi)
              une mandrake (en serveur) qui a fait 9.2 -> 10.0 -> 10.1 -> 10.2 (dans ces eaux la quoi)
              Après faut avoir une bonne connexion quand on fait ces mises à jours
              • [^] # Re: remarques

                Posté par . Évalué à 2.

                ouais, j'ai pas toujours eut autant de chance, ma derniere tentative m'avait laissé un systeme assez instable et un gout amer.
                maintenant, je ne fait que les mise a jour "securité" en gardant la release de base.

                Je crois d'ailleur que c'était une 9.2 vers 10.0 ... ou p'têtre une 9.1 vers 10.0 bref, j'evite.
                bon j'ai vu dans une review que la mise a jour de la RC1 vers RC2 de la 2006 c'etait supaiiiir bien passé \o/ :)
                est-ce que je vais la tenter depuis ma 10.0 rien de moins sur...

                en fait mon reve secret, c'est qu'a un moment donnée qt et gtk soient tellement genial et bien terminé qu'enfin ils arrete de pondre des nouvelles versions... (du moins aussi souvent)
                je vois que la 2006 sera dépassé dés sa sortie au niveau qt...
            • [^] # Re: remarques

              Posté par . Évalué à 2.

              mais en ce qui concerne gtk... je n'ai pas vu entre la 6.5.3 et le screenshot de la 7.0.1 une difference eclatante au niveau UI.
              Exact. Le besoin de la 2.6 signalé dans un autre commentaire concerne une fonction (choisie par erreur, j'aurais du en prendre une autre) utilisée dans la partie administration. C'est au niveau du combobox pour choisir les langues pour les activités de lecture, par exemple.
              • [^] # Re: remarques

                Posté par . Évalué à 5.

                Ce qu'il faudrait en fait, ça serait des #ifndef un peu partout dans les headers de GTK qui permettrait de masquer les nouvelles fonctions de chaque version, histoire de pouvoir sur un système avec Gtk 2.6 vérifier qu'on a bien codé en compatible 2.4 par exemple.
                • [^] # Re: remarques

                  Posté par (page perso) . Évalué à 1.

                  Super idée, bonjour la lisibilité du code !
                  • [^] # Re: remarques

                    Posté par . Évalué à 2.

                    Bah je propose pas de le faire sur tout l'historique de GTK2 non plus, mais disons que juste sur ce qui est nouveau dans la 2.x par rapport à la 2.x-1, ça n'aurait rien d'immonde. Je viens de faire un diff entre les headers 2.6.10 et 2.8.3, et si tu ignores les changements cosmétiques style en-têtes ou nouvelles macros pour remplacer des vieux copier-coller, il te reste en moyenne en gros un, parfois deux, chunks par fichier où tu as les vraies nouveautés de l'API. Mettre ces chunks là dans des "#ifndef PRETEND_TO_BE_GTK26", je pense pas que ça tuerait la lisibilité...
                • [^] # Re: remarques

                  Posté par . Évalué à 1.

                  Non, la bonne technique c'est d'avoir des tests de regressions pour la 2.4 que tu fais tourner sur la 2.6
                  • [^] # Re: remarques

                    Posté par . Évalué à 2.

                    Hmm, j'suis pas sûr de comprendre là... Hésites pas à me la refaire si tu n'en es pas sûr non plus :)

                    Faire tourner des machins datant de la 2.4 sur la 2.6, c'est jamais un soucis ça, la compatibilité ascendante pour GTK elle est déjà très bonne.

                    Là ce dont je parlais, c'est plutôt l'inverse : comment s'assurer, quand on développe avec GTK 2.6 d'installé, qu'on ne tape pas dans les quelques nouvelles additions à l'API, mais seulement dans ce qui existait déjà du temps de la version précédente ?
                    • [^] # Re: remarques

                      Posté par . Évalué à 2.

                      comment s'assurer, quand on développe avec GTK 2.6 d'installé, qu'on ne tape pas dans les quelques nouvelles additions à l'API,

                      jetez-moi si je dis une connerie, mais simplement avec la doc.

                      moi je dev un peu en php, bon c'est moins classe que du gtk c'est vrai, ca fais moins pro, mais bon, j'utilise les fonctions de l'API du php, et ben toujours jete un coups d'oeuil a la doc (php.net) pour voir ou je me situe, par exemple si je vois 5.0.5 je me dis, "tiens c'est du tout nouveau, je vais voir si ya pas du 4.x qui fait pareil". c'est en tout cas une étape a priori et non a posteriori (faire des tests de non-regression, quel horreur)

                      bon ensuite, je ne sais pas, c'est sans doute beaucoups moins facile avec l'API gtk que je ne connais pas....
                    • [^] # Re: remarques

                      Posté par (page perso) . Évalué à 2.

                      Tu fais, puis t'attends que les utilisateurs râlent :-)
            • [^] # Re: remarques

              Posté par . Évalué à 1.

              Ensuite je peu me tromper, je n'ai pas participé mais j'ai dans l'idée que pas grand chose justifie le passage à gtk 2.6, sauf que les devs avait la 2.6 d'installé.

              C'est pire que ça: on a décidé de dépendre de la 2.4, et donc quand on a ajouté des fonctions on a boycotté celles estampillées "Since: 2.6". Dans ces cas là il suffit de se planter pour une pour que tout foire.

              Ce n'est pas très grave pour nous sur ce coup-là, parce que la dépendance sur pysqlite2 oblige de toutes façons à mettre à jour les distributions, et que lui on ne pouvait pas s'en passer.

              j'ai une 10.0 qui n'a qu'un an et pourquoi tu upgrades pas ? Si tu en a peur parce que les upgrade de Mandrake ont une mauvaise réputation largement obsolète, mets-toi une ubuntu. J'ai mis le CD de edubuntu breezy dans un hoary, il m'a ouvert automatiquement une fenêtre pour me proposer d'upgrader et ça c'est très bien passé. Pourtant c'était même avant la preview. Depuis j'ai une icône qui me préviens qu'il y a des mises à jours...

              1 an c'est pas enorme, pour info : quand je boot sous windows 2000, (qui a donc 5 ans en gros hein) j'ai pas tant de probleme que ca.
              Pas de problème, tu peux installer gtk2.8 gcompris 7.0 sur un noyau linux d'il y a 5 ans.
              Tu peux aussi virer ton linux et ne garder que windows, il y a même un vieux gcompris qui tourne dessus.

              Le logiciel libre évolue plus vite que le propriétaire, tout en restant extraordinairement stable. Les mises à jour sont gratuites. Où est le problème? Dans ta flemme de cliquer sur le bouton "mises à jour"?

              On t'oblige pas à utiliser linux, j'espère? Si tu préfère windows reste sous windows.
              • [^] # Re: remarques

                Posté par . Évalué à 2.

                On t'oblige pas à utiliser linux, j'espère? Si tu préfère windows reste sous windows.
                ce n'était pas mon propos,
                j'espere ne pas avoir donnée l'impression d'être agressif.

                heuresement il existe des projets (et des gros) qui ont a coeur de ne pas forcement dependre des dernieres techno. (ni des avant dernieres d'ailleur).

                Ensuite en tant que dev vous avez bien le droit de gerer gcompris comme vous le sentez, je voulais juste vous sensibiliser un peu a ce phenomene d'obsolescence acceléré dans le monde linux (et se mettre à la place du prof qui va essayer de mettre gcompris 7 sur son linux pas obligatoirement tout frais).

                bravo pour votre travail en tout cas.

                Ps : ouais, je double boot et c'est mon choix.
              • [^] # Re: remarques

                Posté par . Évalué à 2.

                ne le prends pas mal, c'est juste une ptite question hein :

                on a décidé de dépendre de la 2.4

                Et qu'est-ce qui a motivé ce choix, en fait ?
                la 6.5.3 devais je pense dependre de la 2.2 (puisque ca marche sur ma mdk10.0 qui est normalement gtk2.2)
                j'ai pas vu (en dehors des screenshots) tourner gcompris 7. mais y a t'il une telle difference avec la 6.5.3 que j'ai installé ?
                c'est une vaie question, ca se trouve il y a effectivement des widgets tout neuf qui n'existait pas pas dans la 2.2 et qui revolutionnent gcompris...

                mais si ce n'est pas le cas, pourquoi choisir une 2.4 ? (qui n'est pas la derniere version certe, hein) pourquoi pas rester en 2.2 ? ya t'il un choix etchnologique ou c'est simplement parceque vous vous êtes dis "ha ben de toute maniere les distro sortent en 2.4 de nos jours donc, c'est marche ou creve"

                voilà c'est ca ma question ?
                • [^] # Re: remarques

                  Posté par (page perso) . Évalué à 2.

                  Sur GCompris, on décide de faire au mieux avec nos maigres moyens. La "GCompris gold team" c'est 2 développeurs actifs, un graphiste des traducteurs et des utilisateurs qui testent sur leur distrib. Voila nos resources.

                  Avec ca, faire en sorte de faire des tests de régressions pour les librairies utilisées, ce n'est tout simplement pas envisageable. Je n'ai personnellement pas envie de perdre du temps à réinstaller une vieille distro pour tester. Tu parles de GTK, mais le problème est le même pour SDL, SQLITE, et les autres librairies dont nous dépendons.

                  Si tu veux, un un sens, oui c'est marche ou crêve, et le problème que tu remontes est réel. Cependant, cela devrait être corrigé au niveau de la plate-forme globale de développement, pas au niveau de chaque projet car c'est trop complexe.

                  Si tu veux faire marcher et maintenir GCompris sur ta 10.0, remonte nous les patches on les intégrera.
                  • [^] # Re: remarques

                    Posté par . Évalué à 2.

                    De toute façon le problème est le même pour une 10.2 (LE 2005)
                    Je n'arrive pa snon plus a installer GCompris a cause de la dépendance a pysqlite2.
                    Ce n'est donc pas une question de vielle distrib car la 10.2 est la dernière dispo de Mandriva.

                    A noter : j'avais installé l'ancienne version de GCompris il y a qq temps et c'est vraiment trés bien. Mon fils 4 ans a bien aimé. Beau travail à part ce petit soucis de dépendance. Merci
                • [^] # Re: remarques

                  Posté par . Évalué à 1.

                  c'est une vaie question, ca se trouve il y a effectivement des widgets tout neuf qui n'existait pas pas dans la 2.2 et qui revolutionnent gcompris...
                  Y'en a pas mal. Des treeviews, des combobox, des ghashtables, des machins comme ça.
                  Comme le gtkcombo est deprecated depuis le 2.4 c'était normal de prendre le gtkcombobox du 2.4.

                  Cela concerne surtout la partie administration, si tu ne t'en sers pas tu ne verras pas la différence.
                  http://fynl.free.fr/dotclear/images/select.png(...)
                  • [^] # Re: remarques

                    Posté par . Évalué à 2.

                    Y'en a pas mal. Des treeviews, des combobox, des ghashtables, des machins comme ça.

                    ok, merci pour l'info, c'était une vrai question de curiosité de ma part, c'était pas pour troller ou pour vous faire chier, et je comprends que vous ayez pu être excedé par mes questions.
              • [^] # Re: remarques

                Posté par . Évalué à 3.

                On ne va pas s'enflammer pour si peu tout de même...
                Les deux points de vue sont défendables. D'un côté, tu as des utilisateurs à qui on annonce une nouvelle version d'un soft censé tourner sur leur distrib (indiqué mdk 10.1 dans le fichier INSTALL), qui galèrent un peu avec les dépendances et qui au final s'aperçoivent que leurs efforts sont vains et en ressentent une certaine frustration.
                De l'autre, tu as des développeurs qui nous offrent le résultat de leur travail sans imposer de contrepartie, et qui peuvent malgré tout leurs efforts et leur bonne volonté passer au travers de quelques erreurs. Le logiciel libre évolue comme ça depuis pas mal de temps maintenant et ne cesse de s'améliorer car ces erreurs sont rapidement corrigées.
                C'est vrai que les maj de mdk ont historiquement plus conduit à des réinstall que des upgrade. Sur ce genre de distrib, il faut accepter de ne pas avoir les dernières versions de tous les softs à jour, mais privilégier la stabilité et la facilité d'utilisation. Sinon des distribs comme gentoo permettent de choisir finement les versions des logiciels sans avoir à tout réinstaller...
                Personellement, mes enfants attendront la mise à jour de mon poste en 2006 pour profiter de la dernière version et vue le nombre d'activités déjà présent dans la précédente version, ils ne m'en tiendront ceratinement pas rigueur pour peu que je leur laisse l'accés à l'ordi :-)
                Bon dimanche à tous et merci encore pour ce super logiciel qui honore le logiciel libre.
                • [^] # Re: remarques

                  Posté par . Évalué à 1.

                  un soft censé tourner sur leur distrib (indiqué mdk 10.1 dans le fichier INSTALL)
                  ça c'est une vraie bêtise. On va corriger le cvs de suite.
                • [^] # Re: remarques

                  Posté par . Évalué à 1.

                  Personellement, mes enfants attendront la mise à jour de mon poste en 2006 pour profiter de la dernière version
                  Tu ne peux décemment pas priver tes enfants du sudoku !
                  http://fynl.free.fr/dotclear/images/sudoku.png(...)

                  Non, crois-moi. Ubuntu c'est bien.
                  • [^] # Re: remarques

                    Posté par . Évalué à 2.

                    C'est justement pour ça que je n'installe pas cette version! Ils ne comprendaient pas pourquoi Papa joue aussi à Gcompris :-)
                    • [^] # Re: remarques

                      Posté par . Évalué à 2.

                      Bah, de toute façon, j'ai pas essayé dans GCompris, mais pour avoir joué un peu avec GNUdoku, je trouve quand même que l'écran ça vaut pas une version crayon/gomme/papier. T'as nulle part pour gribouiller tes réductions de domaine...
              • [^] # Re: remarques

                Posté par . Évalué à 0.

                le jour où une distribution Linux se mettra à jour sans problème en cliquant sur le bouton "mises à jour", vous me réveillerez.
        • [^] # Re: remarques

          Posté par . Évalué à 2.

          dans ce cas tu edite la page de download avec quanta, tu ajoute les liens sur la page et tu l'envoie au devellopeur par mail.

          si tu es fainant tu peut alors juste envoyer un mail avec une mise en page sommaire de tout les liens vers les paquets que tu as trouvé. et une petite explication.

          1)tu participe a Gcompris sans savoir programmer
          2)le devellopeur est un devellopeur et cela lui fait plaisir de presque rien faire pour mettre a jour le site
          3)le temps que tu as cherché les liens, les dependances, essayé sur mandrake 9.1 et que cela ne marche pas aideras surement d'autres utilisateurs.
          4)ton figureras en lettre de feu sur le site et dans contrib des sources.

          je te remercie, note au passage que j'ai deja envoyé des pages html mis a jour/corrigé a des devellopeurs sans que cela soit utilisé, mais je ne leur en veut pas.
          • [^] # Re: remarques

            Posté par . Évalué à 2.

            C'est une super idée, mais c'était valable pour les 1er paquets que j'ai trouvé et qui pouvais se *rajouter* facilement... j'ai arreté quand il fallais mettre a jour ldconfig qui lui même avec des dépedances trop profondement ancré dans le systeme (en gros il fallait tout mettre a jour)
            et que comme les comentaires suivant le suggerent, j'en avait pas fini : il y a gtk a monter en v 2.4 .. j'avais abandonné avant.
            docn je ne connais pas la liste de tous les paquets, je ne peux donc pas aider.
            • [^] # Re: remarques

              Posté par . Évalué à 4.

              excuse moi d'insister mais: tu ne connais pas la liste de tous les paquets certe mais tu en connais un peu, tu peux commencer d'autre termineront. Bon c'est vrai cela prend du temps toussa,

              mon but est que tu vois/comprenne (c'est valable pour ceux qui nous lisent) ce qu'est la collaboration et comment participer meme un petit peu a un projet sans connaissance particuliere en informatique, rien d'obligatoire.

              parce que des excuses pour ne rien faire j'en ai moi même un sac complet :)
          • [^] # Re: remarques

            Posté par . Évalué à 2.

            dans ce cas tu edite la page de download avec quanta, tu ajoute les liens sur la page et tu l'envoie au devellopeur par mail.
            Plus simple tu envoies un mail pour demander un compte. Le site c'est SPIP, pas besoin de Quanta.
    • [^] # Re: remarques

      Posté par . Évalué à 2.

      déjà j'aimerais bien avoir une liste des differents programmes/activité proposés classés par age

      C'est difficile, des fois on a des surprises. Sur la page des copies d'écran tu as des étoiles qui représentent les difficultés (de 1 à 6). On va dire que pour 4 ans 1/2, il te faut viser les niveaux 1-2, à peu près. Oublie pas d'installer tuxpaint, à cet âge là c'est indispensable, et il y a un lanceur dans gcompris.

      Dans la partie administration il y a un filtre (absolument génial, je dis pas ça parce que c'est moi qui l'ai écrit, hein...) pour sélectionner les activités par niveau dans la partie administration.

      Quand aux dépendances difficiles, si je voulais troller je te dirais de changer de distro ou d'upgrader. Je crois que la dernière mdk (LE ou un truc comme ça) a tout ce qu'il faut. debian sarge aussi...

      bon... y'en a beaucoups des dépendances encore ?
      Notre but secret est que gcompris dépende de tous les paquets de debian ;-) en gros on dépend de libgnomecanvas (et donc gtk+, glib, libart, gettext...), libsdl-mixer, libxml2, python, pygtk, gnome-python, pyxml, et maintenant lisqlite3 et pysqlite2.
      • [^] # Re: remarques

        Posté par (page perso) . Évalué à 3.

        Ce qui serait vraiment super, c'est d'avoir une page d'accueil au lancement du logiciel qui demande à l'enfant de choisir son niveau (de façon graphique, bien sur).

        Parce que je suis bien d'accord, l'accès par niveau est indispensable pour que l'enfant puisse être autonome.
        • [^] # Re: remarques

          Posté par . Évalué à 1.

          Ce qui serait vraiment super, c'est d'avoir une page d'accueil au lancement du logiciel qui demande à l'enfant de choisir son niveau (de façon graphique, bien sur).
          Tu peux choisir les niveaux utilisés dans l'administration, comme ça ton gamin quand il le lance il n'y a que ces niveaux là.

          Mais choisir au démarrage, je suis pas sûr. En particulier en dessous de 6 ans ça risque de créer trop de problèmes.
    • [^] # Re: remarques

      Posté par (page perso) . Évalué à 3.

      "déjà j'aimerais bien avoir une liste des differents programmes/activité proposés classés par age (ouais parceque 3 à 10 ans c'est large) j'espere que dns gcompris il y a un moyen de connaitre l'age moyen des activité.. autrement que de les essayer..."


      Pour chaque activité, on a un système de diffficulté matérialisé pas des étoiles. C'est pas simple d'être précis entre autre cause de la nature internationale de GCompris.
      1, 2 or 3 étoiles simple - 2 à 6 ans
      1, 2 or 3 étoiles complexe - A partir 7 de 7 ans

      Pour ton installation, il est préférable de te contenter d'un version plus ancienne de GCompris est de l'installer via URPMI de ta Mandrake.
  • # Création d'un thème ÉDUCATION sur LinuxFr ?

    Posté par (page perso) . Évalué à 5.

    Si vous êtes pour, votez #295 dans le système de suivi http://linuxfr.org/tracker/(...)

    Commentaires sur le sujet : http://linuxfr.org/tracker/295.html(...)
  • # Déménagement d'icônes

    Posté par . Évalué à 1.

    Bonjour,

    Les enfants adorent gcompris. Par contre c'est moi qui peste à chaque fermeture du jeu : les icônes du bureau sont tous déplacés en haut à gauche de l'écran...

    Ca n'arrive qu'à moi ?

    (Mandriva + gcompris 7 + résolution 1024*768)

    Merci pour toute piste.

    M

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.