Suivi - Administration système Ruby Sass est déprécié

#1865 Posté par (page perso) . État de l'entrée : ouverte. Licence CC by-sa.
Tags : aucun
0
13
fév.
2019

Hello,

Je suis en train de monter à nouveau une machine de développement pour linuxfr.

Je viens de terminer l'installation des gem avec bundle et j'ai eu le message post-installation de Ruby Sass qui m'avertit qu'il est déprécié et qu'il faut changer de gem.

Il y a un lien vers un article pour plus d'informations qui explique qu'il faut passer à Dart Sass.

Comme j'ai vu que le support se termine au 26 mars 2019, je me suis dit qu'il fallait ouvrir une entrée dans le suivi :)

Il faut s'y attarder ou ce n'est pas nécessaire à court terme ?

  • # Il faudra s'en occuper un jour

    Posté par (page perso) . Évalué à 3 (+0/-0).

    C'est effectivement un problème connu depuis un bout de temps. Pour le moment, la communauté Rails n'a pas l'air très décidée sur le chemin à prendre :

    • certains proposent effectivement d'utiliser Dart Sass en l'embarquant dans une gem Ruby, mais personne n'a l'air d'avancer dans ce sens (ie écrire du code et être prêt à le maintenir)
    • d'autres suggèrent de passer à sassc-rails, mais ce n'est pas très clair si le mainteneur de sassc-rails va encore maintenir cette gem très longtemps, et là encore, il n'y a pas de contributeurs
    • enfin, Rails est en train de migrer progressivement de son assets pipeline vers webpack, et possiblement, la manière conseillée d'utiliser sass avec Rails 6.0 sera de passer via webpack.

    Bref, pour le moment, le mieux est sûrement de continuer à attendre https://github.com/rails/rails/issues/32896, sachant qu'il n'y a pas d'urgence. Même si la version Ruby de Sass n'est plus prise en charge officiellement, elle ne va pas s'arrêter de marcher du jour au lendemain.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.