Linux 2.4.21 est sorti

Posté par  . Modéré par Pascal Terjan.
Étiquettes :
0
13
juin
2003
Noyau
La huitième Release Candidate du noyau est devenue 2.4.21 aujourd'hui même, sans modifications :)

Quelques exemples d'améliorations : le système de fichiers ReiserFS, l'USB (prise en charge de nouveaux périphériques comme le palm 100 ou le Clie NZ790V, divers bugfixs de usb-storage ...), les Frame Buffers et pleins d'autres encore.

Pendant ce temps la branche de développement continue à avancer, elle est aujourd'hui en version 2.5.70.

NdM: Merci à Damien POBEL qui a aussi proposé cette news.

Aller plus loin

  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à -10.

    C'est une exellente nouvelle.
    [aïe]
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 8.

    question : cette version est-elle compilable avec gcc 3.3 contrairement à la version 2.4.20 ?

    (avec la 2.4.20, il faut modifier les sources du kernel, j'ai pas trop osé, du coup j'attends toujours mon ACPI, moi...)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 9.

      J'ai compilé le rc7 sans problème il y'a quelques jours.
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 6.

      dans le changelog, y'a pas de fix sur la compatibilté avec gcc 3.3 et normalement il ne devrait pas y avoir de problème...

      https://damien.pobel.fr

      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 3.

        ... haheum, j'ai eu des problemes il y a qques tps avec gcc 3.3 sur certains modules, a la compilation "unresolved symbols" ou qqch dans le genre et apres, bien sur, impossible de charger le module.
        Pour ma pomme je continue d'utiliser des versions un peu plus anciennes, il faut dire que je n'ai pas remarqué de grandes differences au niveau des perfs (pour ne pas dire aucune).
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 3.

          Normal, qu'il n'y ai pas d'augmentation des perfs ce ne sont que des BugFixes. Moi mon firewall avait qq pb d'IDE et j'espère bien qu'ils sont réglés.
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  (site Web personnel) . Évalué à 2.

            Passé presque sans aucun problème sur ma gateway, sauf au niveau de l'IDE...
            J'ai un controlleur HPT366 sur une carte mère Abit BE6. Sur le 2.4.20, les durs branchés sur l'UDMA passaient en /dev/hde, hdf, etc etc
            Maintenant, ils passent en hda, hdb, etc

            A vérifier donc ;)
            • [^] # Re: Linux 2.4.21 est sorti

              Posté par  . Évalué à 1.

              tu n'avais pas mis l'option "Boot off-board chipsets first support" dans le kernel par hasard?
              • [^] # Re: Linux 2.4.21 est sorti

                Posté par  (site Web personnel) . Évalué à 1.

                Nan nan, mon controleur est un controleur intégré à la carte mère, il est parfaitement reconnu sans ça.
                • [^] # Re: Linux 2.4.21 est sorti

                  Posté par  . Évalué à 1.

                  Il est normal que les disques soient /dev/hda ... Dans le noyau de la mandrake, l'option "Boot off-board chipsets first support" est activé. Si tu veux le même comportement il faut activer l'option.
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 8.

      compile hier soir avec gcc-3.3 dernier update de la debian unstable aucun pb
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 1.

        Moi j'ai alsa qui compile plus avec la debian sid + kernel-2.4.21.
        Chez toi ça marche aussi ?
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          J'ai compilé la 0.9.4 sans problème (carte : als4000).
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  (site Web personnel) . Évalué à 1.

          jai le meme probleme

          le configure se plante en cherchant la version de gcc utilisé pour compiler le noyau et celle reellement dispo

          il me sort un truc genre decoded kernel compile type=version version=gcc
          et le compiler dispo il me sort type=gcc version=3.2.2

          fait chier ça marchait avec la rc8
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  . Évalué à 4.

            > fait chier ça marchait avec la rc8

            Le problème doit être ailleurs.
            La différence entre rc8 et final est le minimum du minimum :
            http://www.fr.kernel.org/pub/linux/kernel/v2.4/testing/incr/patch-2(...)
            diff -urN linux-2.4.21-rc8/Makefile linux-2.4.21/Makefile
            --- linux-2.4.21-rc8/Makefile 2003-06-13 07:54:36.000000000 -0700
            +++ linux-2.4.21/Makefile 2003-06-13 07:54:41.000000000 -0700
            @@ -1,7 +1,7 @@
            VERSION = 2
            PATCHLEVEL = 4
            SUBLEVEL = 21
            -EXTRAVERSION = -rc8
            +EXTRAVERSION =

            KERNELRELEASE=$(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
            • [^] # Re: Linux 2.4.21 est sorti

              Posté par  (site Web personnel) . Évalué à 1.

              je sais c pour ça que c hOrrible

              c peut etre dropline qui fout sa merde j'ai l'impression
              n'empeche je vois pas pourquoi ça compile sur la rc8 et pas sur la 2.4.21
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 1.

    Si j' ai bien vu le changelog il y a un support agpgart/Nforce , \o/, ça va m' éviter quelques ennuis, en plus usb storage doit mieux fonctionner \o/ que demande le peuple.
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 3.

      C'est quoi le pb d'usb-storage ???
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  (site Web personnel) . Évalué à 2.

        perso j'ai des problèmes avec usb storage mais je sais pas si ça vient de ma carte mère ou du noyau. Il ne supporte qu'une seule connection avant de déconnecter l'appareil. Hors pour monter un appareil photo par exemple, il faut minimum 2 connections. Je m'en sort en faisant une image disque de la carte mémoire. Mais si il y'a mieux ;)
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 2.

          c'était mon pb avec 2.4.19 et un Dimage 7i ( minolta ).

          J'ai ajouté une ligne dans un fichier du kernel avec les bon flags et ca a roulé nickel !
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 2.

          C'est bizarre j'ai jamais le pb sur mon Coolpix 4300.
          tant mieux :)
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 5.

        Le protocole "usb mass storage", ca permet aux peripheriques qui l'implementent d'etre vus comme des disques scsi et montes sans avoir besoin de pilotes specifiques.

        PDA, Appareils photo numeriques, lecteurs de cartes CF/SD/MemoryStick...
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 3.

        Pour l' usb storage, le hotplug qui fonctionne mal, ou quelquechose dans le genre.

        J' ai un lecteur de carte mémoire compactflash, et une mémoire usb, par moment la reconnaissance ne fonctionne plus, le kernel ne les trouvent plus. résultat: reboot.

        Et ceci quelque soit le chipset, intel 440bx, via kt133, via kt 333 (les trois ou j' ai testé avec des distrib différentes). Alors soit je ne suis pas doué, soit il y a un pb.

        Donc je suis content de voir qu' il y a un suivi .
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          Si c'est parce que tu n'es pas doué, alors tu n'es pas le seul.

          Moi aussi j'ai de gros problèmes avec les clés USB. En gros, une fois que j'ai monté une certaine clé USB, je ne peux plus que monter/démonter celle-ci jusqu'au prochain reboot.

          Ca le fait sur mes deux PC et j'ai vu ce probème chez bien d'autres...
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  . Évalué à 2.

            J'ai une clef USB et j'avais un Archos recorder 20 (attention ce genre d'appareil a tendance à dispaitre de votre sac sans prévenir, en plus il est très discret puisque personne n'a rien vu sur la dizaine de personne qui travail autours de votre bureau) et je suis sûr d'avoir monté et démonté la clef alors que le Archos était branché et inversement (kernel 2.4.20). J'ai une carte mère à base de KT266A et une carte USB 2.0 aditionnelle avec un chip NEC.
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  (site Web personnel) . Évalué à 2.

            Oui, la première A est montée sur sda et la deuxième B sur sdb. Si on les branche d'abord B puis A, B est sur sda et A sur sdb et ce jusqu'au prochain boot.
            Si on a mis les entrées dans /etc/fstab, elles ne sont plus apariées avec les périphériques.
            La solution serait de mémoriser les types de périphériques sur la machine pour pouvoir les remonter à l'identique.
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          perso, sur ma mdk 9.1 (et sur la 9.0 aussi avant), je dois monnter 2 fois une compactflash pour que ça marche... mais ça marche a tous les coup la deuxième fois.
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 0.

      > \o/ que demande le peuple

      Du sang, de la sueur et des orgies (et la retraite à 50 ans)
  • # Et l'acpi ?

    Posté par  . Évalué à 8.

    Est-ce que le support de l'acpi est maintenant correct d'origine ou faut-il toujours patcher son noyau ?

    Pour ceux qui voudraient patcher, une très bonne doc :
    http://xtrinsic.com/geek/articles/acpi.phtml(...)
    • [^] # Re: Et l'acpi ?

      Posté par  . Évalué à 7.

      Sauf indication dans le changelog, il faut appliquer un patch qui backporte les modifs de l'acpi de la branche 2.5 (et priori ils considerent que ce n'est pas assez "stable" pour être backporté ou plutot ca n'est pas prévu d'avoir un acpi potable pour la 2.4 et il faudra attendre la 2.6).
      • [^] # Re: Et l'acpi ?

        Posté par  . Évalué à 8.

        Cela faisait partie des discussions sur la mailing list lors du cycle des RC.

        Bilan ACPI et AIC7xxx ne sont pas inclus (du moins pas les dernieres versions), mais le cycle de devel du 2.4.22 devrait etre plus rapide que pour ce noyau pour inclure ces 2 modifs rapidement. On parle d'un cycle de 2 mois.

        Voila.
  • # Re: Linux 2.4.21 est sorti

    Posté par  (site Web personnel) . Évalué à 3.

    tiens supporte le palm, bon faut que je lache le cable série alors
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 10.

    Pour ce noyau 2.4.21, le jeu de patch CK (Con Kolivas), qui améliore les temps de réponse pour un PC en tant que station de travail, se trouvent déjà à l'adresse suivante :

    -> http://members.optusnet.com.au/ckolivas/kernel/index2.html(...)

    Il s'agit du patch réalisé à l'origine pour la rc8, mais vu qu'il n'y a pas eu de modification, il est aussi utilisable avec la version finale.

    « Je vous présente les moines Shaolin : ils recherchent la Tranquillité de l'Esprit et la Paix de l'Âme à travers le Meurtre à Main Nue »

  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 10.

    Et pour tous ceux qui sont paranos :

    http://www.grsecurity.net(...)

    Le patch pour le 2.4.21 est déjà présent.
    Ce patch renforce la sécurité du noyau.
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 9.

    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 1.

      c plus rapide et plus sur que de le telecharger sur un mirroir officiel de kernel.org?
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 2.

        > c plus rapide

        C'est rapide, même très rapide en période de forte demande. Lors de la sortie de mandrake 9.1 c'était le moyen le plus rapide et fiable (inutile de tester une dizaine de mirroir pour en trouver un rapide).

        > plus sur

        Sauf utiliser les signatures GPG comme quand tu utilises un mirroir ou kernel.org. Bittorrent vérifie ton download avec md5sum.

        En plus, ça soulage les mirrors. Il n'y a aucun problème dans l'utilisation de bittorrent et c'est dans l'esprit du libre. Tu downloades et ce que tu as downloadé est uploadé par les autres. Tu participes à la diffusion du noyau. Laissez tourner bittorrent quelque minutes après le download :-)
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 2.

    Je suis sur le c*l ...
    Je viens de donner un coup de main à un gars pour installer Linux (une MCC avec kernel 1.0.4) sur un portable de type 386 avec 2 mo de ram.
    Le rapport avec cette news ? Eh bien j'ai reçu un mail hier soir : il me demande de l'aide maintenant pour installer un gestionnaire de RPMs (!) et cela afin d'y installer les packages gcc etc. (attendez, c'est pas fini) et dans le but final d'y recompiler le noyau 2.4.21 !!!
    Je ne sais pas trop comment réagir ... J'oscille entre effarement et hilarité. Un nouveau Jayce ? ;-)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 0.

      Laisse-le se brûler, c'est presque un service à lui rendre :-)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 2.

      Apprends lui a faire de la cross-compilation et arme toi de patience ;-)
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 7.

        C'est bien un cousin de Jayce:-)
        Ce matin, je lui ai répondu par mail que si c'est pour le fun, autant recompiler le noyau d'époque de la dustribution MCC que je l'ai aidé à installer. Et que la gestion de l'USB, de l'AGP et toutes ces merveilleuses nouveautés il devrait de toute façon les supprimer, et qu'au contraire il avait de grandes chances de ne pas arriver à reconnaître une partie de son matériel.
        Mais il insiste le bougre :
        "Sur le lien que vous m'avez donné, y a que quelques packages, mais pour
        pouvoir compiler le noyau, j'ai besoin de tout cela :
        a.. glibc-devel
        b.. ncurses-devel
        c.. tcl, tclx, tix, tk
        d.. perl
        e.. pgcc
        f.. make
        g.. binutils, textutils & sh-utils
        Et bien sûr ils n'y sont pas tous, donc j'en conclue que je suis foutu, non
        ???"


        /o\ comme on dit sur la Tribune :-)

        Et le summum (je rappelle qu'il s'agit d'un portable de type 386 avec 2 Mo de ram) :
        "Je voulais donc me servir de la MCC comme base, afin d'installer ma
        propre distrib !!!!
        Tant pis.....snif"

        Bon, si ça continue, je fais un journal avec ses aventures quotidiennes :-)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 1.

      ca me rappel le bon vieux temp ou le cross-compil n'existait pas encore et qu'il fallait une bonne semaine pour compiler un kernel sur un 386 avec 4 megs de ram... :) faut avoir envie....
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 2.

    Est ce que le PIV Mobile est supporté par cette version du noyau ?
    Dans la 2.4.20, il est reconnu comme un PIII M
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à -6.

    Hmm, c'est une exellente nouvelle qui va permettre de faire connaître le libre dans les entreprises et administrations. J'aurrai préféré qu'ils choisissent une mandrake, mais bon.

    ps: merci à huhuhu pour sa suggestion ;)
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 6.

    Pour moi, ce qui est trèes important ici, ce sont les fix de sécurité.. en effet, le 2.4.20 de base était quand même assez troué:
    - ptrace
    - le problème de hash mettant à genoux le noyau (x2)
    (et j'en oublie sans doute)

    Il y a aussi les problèmes de ext3, voir http://www.zip.com.au/~akpm/linux/ext3/.(...)

    Bref, le 2.4.21 est, pour moi, une bonne nouvelle car il intègre tous ces fixes directement :)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 2.

      Je préfère quand même attendre pour voir si cette version ne comporte pas d'autres problèmes.

      Merci au passage aux testeurs du 2.4.11 ;)

      Comme pour tout logiciel, inutile de se précipiter à moins de vouloir essuyer les plâtres. Les utilisateurs de PHP comprennent de quoi je parle :)

      no troll involved, juste le constat qu'il faut toujours laisser mûrir avant de déguster... oui, comme le vin !
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  (site Web personnel) . Évalué à 3.

        mouai :)
        Heureusement que tout le monde ne raisonne pas comme toi, sinon, on aurait jamais de noyaux stables
        faut bien l'utiliser pour le tester et pour trouver les autres problemes non ? :)
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à -1.

          Oui mais j'ai pas envie de risquer mes données, ça peut se comprendre.

          A quand les tests unitaires pour le noyau ? ;)
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  (site Web personnel) . Évalué à 2.

        > Je préfère quand même attendre pour voir si cette version ne comporte pas d'autres problèmes.

        Ben si, ya des nouveaux problèmes :(((
        J'ai un disque externe firewire et avant le modules sbp2 le reconnaissait automatiquement au démarrage et le montait en meme temps que mes autres systèmes de fichiers avec fsck et tout et tout.
        Dans le 2.4.21, ya plus le hotplug dans le modules sbp2 car considéré comme instable. résultat pour faire reconnaitre un disque firewire externe, on est obligé d'exécuter à la main le script rescan-scsi-bus.sh et de monter les partions manuellement :(((

        Il est temps que je passe définitivement au 2.5 moi, le 2.4, c'était mieux avant ;o)
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          moi c'est mon UPS qui n'est plus reconnu, le timeout de 5s n'a pas l'air de suffir pour le MGE Ellipse 800... et dire qu'ils disaient que le pb était règlé... je suis décu, terriblement décu :o) lol

          Ou alors c'est le kernel membrake qui merde... ;o)
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  (site Web personnel) . Évalué à 1.

        Pour reprendre ton analogie avec le vin, lorsqu'on te sert un vin déjà bien vieux au restaurant, tu peux en théorie le consommer sans te détruire le palet.

        Il s'agit ici de la branche stable du noyau, d'une version définitive. Donc il s'agit de quelque chose de testé, ce n'est pas du tout expérimental.

        Et ce noyau règle des problèmes connus (ptrace etc...).
  • # Re: Linux 2.4.21 est sorti

    Posté par  . Évalué à 2.

    Attention, il y a des problèmes avec le support de l'ultra-dma sur les cartes mères à base de chipset via (à ce qu'il semblerait).

    Je n'ai pas encore trouvé de solution, mais je cherche... (super-google, à l'aide!)
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 1.

      Bingo ! j'ai un chipset VIA !

      Bon, d'ici qu'il y ai un paquet Debian, je serai fixé.

      Je répète : ceci n'est pas un troll, c'est juste du bon sens en informatique, pour l'automobile, ... le dernier n'est pas forcément le meilleur.

      Qui utilise encore la branche 2.2 ? par choix ?
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 1.

        J'ai un chipset VIA et tout est ok ici (kernel membrake 2.4.21-0.18mdk recompilé maison) :)

        Il pourrait être plus clair notre ami... c'est quoi ton pb avec le chipset via ?
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 2.

          Voici :

          > debian# hdparm -d1 /dev/hdc
          > /dev/hdc:
          > setting using_dma to 1 (on)
          > HDIO_SET_DMA failed: Operation not permitted
          > using_dma = 0 (off)

          Après avoir cherché sur google, j'ai effectivement vu ce problème reporté à plusieurs reprises, mais, à ce qu'il semblerait, pas pour 2.4.21 (ou bien 2.4.21-rc8, c'est pareil). (une recherche sur "HDIO_SET_DMA failed: Operation not permitted" éclaire un peu)
          Le problème ne vient pas de mon matériel, car je n'avais pas de problème avec la 2.4.20.

          Alors de deux choses l'une : soit je suis incompétent, soit je suis tombé sur un bug non référencé (je penche plutot pour la première solution).
          Dans tous les cas, désolé pour le troll si il y a eu.

          Ci-dessous : les résultats de diverses commandes, si ça peut aider...


          > debian# lspci
          > 00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] > (rev 03)
          > 00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 > > AGP]
          > 00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
          > 00:07.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
          > 00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
          > 00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
          > 00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
          > 00:08.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
          > 00:0b.0 Multimedia audio controller: Avance Logic Inc. ALS4000 Audio Chipset
          > 01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  (site Web personnel) . Évalué à 1.

            Tu as forcement oublié d'activer une option dans ton kernel, le KT133 est un chipset très courant et le DMA marche sans problème. Va faire un tour du coté de 'make menuconfig' et vérifie que tu as bien activé 'Generic PCI bus-master DMA support' et 'VIA82CXXX chipset support' dans 'IDE, ATA and ATAPI Block devices'.
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          J'aurais une petite question pour toi? le kernel 2.4.21-0.18mdk est-ce que c'est le 2.4.21 officiel?? ou c'est seulement quelques patch de sécurité? J'ai compilé le 2.4.21 downloadé sur www.kernel.org avec le patch pour supermount sur mandrake 9.1 et ca fonctionnes bien sur mon ordi (J'ai un chipset VIA aussi) mais je me posais la question pour celui qui avait dans les updates de mandrake :)
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  . Évalué à 5.

            > le kernel 2.4.21-0.18mdk est-ce que c'est le 2.4.21 officiel?

            Oui, Mandrake a récupéré le 2.4.21 officiel il y a 3 mois avec ipot ( http://kadreg.free.fr/ipot/(...) ) .

            - pardon ?
            - DEHORS ----> []
            • [^] # Re: Linux 2.4.21 est sorti

              Posté par  . Évalué à 1.

              Je parles sérieusement...
              • [^] # Re: Linux 2.4.21 est sorti

                Posté par  . Évalué à 2.

                Tu t'es trompé de site :-)

                Le 2.4.21-0.18mdk est sorti le 4 juin et le 2.4.21 officiel le 13. Donc « sérieusement », à part ipot pour faire ça, je vois pas.

                $ rpm2cpio kernel-2.4.21.0.18mdk-1-1mdk.src.rpm | cpio -t
                linux-2.4.20.tar.bz2
                patch-2.4.21-pre4.bz2

                C'est un 2.4.21-pre4 qui est sorti vers janvier février 2003.
                • [^] # Re: Linux 2.4.21 est sorti

                  Posté par  . Évalué à 1.

                  En tout cas le 2.4.21 fonctionnes à merveilles ici sous Mandrake 9.1 avec le patch pour supermount ;)
                  • [^] # Re: Linux 2.4.21 est sorti

                    Posté par  . Évalué à 2.

                    Ben le membrake fonctionne très bien aussi... où est le problème ? le 0.18 est sorti de jour de la final release du 2.4.21... je ne sais pas ce que membrake rajoute dans son kernel à part le GRsecurity et les 3rd party... un expert membrake dans le coin ?

                    Arf, c'est un rc6 corrigé... pfffff...

                    Changelog :
                    * mer jun 04 2003 Juan Quintela <quintela@demo.mitica> 2.4.21-0.18mdk
                    - bugfixes of 2.4.21-rc6.

                    Quelle b*rne... tellement habitué avec les noyaux Debian...
                    • [^] # Re: Linux 2.4.21 est sorti

                      Posté par  . Évalué à 1.

                      Je sais pas si j'hallucines mais avec le dernier j'ai un peu plus de rapidité sur le chargement des programmes! J'ai pas essayé le dernier de Mandrake mais je compte bien rester sur le 2.4.21 officiel!
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  . Évalué à 5.

      Attention, il y a des problèmes avec le support de l'ultra-dma sur les cartes mères à base de chipset sis (récent). SiS a changé l'architecture de ses chipsets récents (SiS745 , 645, 635 entre autres), et distingue à présent le northbridge du southbridge (où réside le controlleur IDE). Conséquence, le driver linux, qui se basait sur l'ID du northbridge pour trouver le type de controleur IDE, a quelques problèmes. Le driver inclus dans le 2.4.21 (sis5513.c), a été partiellement patché, mais Alan n'a pas livré à Marcelo la dernière version (pour une raison inconnue), et donc quelques sérieux problèmes pouvant occasionner de grosses pertes de données subsistent (d'ailleurs, regardez le fichier en question, ya encore un gros FIXME dedans...). Bref, prenez au moins le driver en question dans le noyau -ac... http://marc.theaimsgroup.com/?l=linux-kernel&m=105292163431153&w=2 http://marc.theaimsgroup.com/?l=linux-kernel&m=105300087109403&w=2 http://marc.theaimsgroup.com/?l=linux-kernel&m=105308854825215&w=2 http://www.nikosoft.net/howtos/a7s333.php#ide
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 2.

        Alan bosse depuis un bon moment sur la IDE pour la refaire presque complètement. Les versions -ac sont plus avancées sur l'IDE. Le développement est fait en premier sur 2.4 puis est porté sur 2.5. > mais Alan n'a pas livré à Marcelo la dernière version (pour une raison inconnue) Peut-être parce qu'on ne peut pas demander un noyau stable et les derniers développements dedans.
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          rien à voir examine le fichier dont je t'ai parlé (dans la version officielle et -ac), et tu verras qu'il n'y a que de la correction de bug, comme c'est d'ailleurs expliqué dans les mails que je pointe. Sur le 2.4.21, il y a eu une grosse fusion de la branche -ac, et notamment de la couche IDE, mais certaines corrections de bug ultérieures n'ont pas été fusionnées (en tous cas pour le sis5513), d'où mon interrogation. ceci dit, pour le reste, il est vrai que la branche -ac profite d'un nettoyage complet de la couche IDE depuis qu'Alan a pris le taureau par les cornes, mais justement, le 2.4.21 marque la fusion de ces efforts dans le noyau officiel.
          • [^] # Re: Linux 2.4.21 est sorti

            Posté par  . Évalué à 1.

            Je parlais de façon général et c'était pour dire qu'Alan bosse sur IDE et donc ceux qui ont des problèmes doivent regarder et tester la branche -ac et il y a un patch-2.4.21-rc8-ac1 (marche sur un 2.4.21). La version marcelo est "logiquement" en retard sur la version Alan. Je ne trouve pas ça vraiment anormal.

            Enfin, les corrections et ajout de driver que tu annonces sont d'un mois environ. Soit en pleine phase rc.

            Pour info, les patchs Alan sont là :
            http://www.fr.kernel.org/pub/linux/kernel/people/alan/(...)

            C'est toujours comme ça, un noyau n'est jamais parfait et la com entre les devs non plus. C'est la vie... mais globalement ça roule.
            • [^] # Re: Linux 2.4.21 est sorti

              Posté par  . Évalué à 3.

              > Enfin, les corrections et ajout de driver que tu annonces sont d'un mois environ. Soit en pleine phase rc.

              Les liens que je pointe sont en effet pendant la phase RC, mais justement, la phase RC ça sert à fusionner les correctifs de bug, d'autant que, pour le sis5513, le gros changement a été fusionné au -pre2 (mais ce changement contenait des bugs, qui sont l'objet des mails que je pointais). Les bugs, c'est normal, ça arrive, j'ai jamais dit non plus le contraire !

              Bon, après, pour la com entre les devs, c clair que ce doit être là qu'il y a eu un problème, mais justement, je "répare" en faisant de la com ici pour avertir directement les utilisateurs ;-)

              Ceci dit, je trouve que changer la couche IDE était une excellente initiative, d'autant qu'Andre Hedrick, son mainteneur historique, tirait un peu la langue tellement c'était devenu lourd à maintenir (il faut dire aussi que les chipsets et contrôleurs IDE sont de plus en plus complexes, le temps où ça marchait presque tout seul est bien loin).
              Au passage, si j'ai bien suivi, dans le pilote pour le sis5513 dont je parle, certains changements proviennent de SiS directement, ce qui est une excellente nouvelle, car un fabriquant de matériel qui supporte Linux en OpenSource, ça devient hélas de plus en plus rare.
    • [^] # Re: Linux 2.4.21 est sorti

      Posté par  (site Web personnel) . Évalué à 1.

      idem... j'ai un KT333, et si j'active DMA dans noyau, j'ai de gros bug (genre fichier de 3To) ... si je vire le support dans le noyau du chipset via, je peux activer a la main avec hdparm le DMA et ca roule
      • [^] # Re: Linux 2.4.21 est sorti

        Posté par  . Évalué à 1.

        chez moi j'ai aucun probleme : KT333 + VIA vt8235 (rev 00) IDE UDMA133 Jun 14 13:06:51 localhost kernel: hda: attached ide-disk driver. Jun 14 13:06:51 localhost kernel: hda: host protected area => 1 Jun 14 13:06:51 localhost kernel: hda: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=9729/255/63, UDMA(100) Jun 14 13:06:51 localhost kernel: hdc: attached ide-disk driver. Jun 14 13:06:51 localhost kernel: hdc: host protected area => 1 Jun 14 13:06:51 localhost kernel: hdc: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=155061/16/63, UDMA(100) Jun 14 13:06:51 localhost kernel: hdd: attached ide-disk driver. Jun 14 13:06:51 localhost kernel: hdd: host protected area => 1 Jun 14 13:06:51 localhost kernel: hdd: 80418240 sectors (41174 MB) w/1863KiB Cache, CHS=79780/16/63, UDMA(100)
        • [^] # Re: Linux 2.4.21 est sorti

          Posté par  . Évalué à 1.

          Bonjour
          J'ai le même problème
          Avez vous trouvé une solution
          Car j'aimerais bien l'avoir
          Merci
  • # Linux 2.5.71 est sorti

    Posté par  . Évalué à 2.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.