Sortie de Mozilla Firefox 1.5

Posté par . Modéré par Florent Zara.
Tags :
0
29
nov.
2005
Mozilla
Un peu plus d'un an après la sortie de la version 1.0 de son navigateur phare, la Fondation Mozilla nous livre aujourd'hui celui-ci en version 1.5 avec son lot conséquent d'améliorations.

C'est ainsi qu'après plusieurs retards (comme dans tout projet informatique conséquent), une version 1.1 intermédiaire annulée, 2 versions alpha (seule une partie des fonctionnalités est implémentée), 2 versions bêta (toutes les fonctionnalités sont prêtes mais ce n'est pas encore stable) et 3 releases candidates (seules les corrections de bug sont apportées à l'application), Mozilla nous livre Firefox 1.5. Les dizaines de langues habituelles sont au rendez-vous et devraient apparaître rapidement sur les serveurs (Une vingtaine de langues dont le français étaient déjà présentes sur les serveurs FTP au moment de la rédaction de ces lignes).

Celui-ci apporte un grand nombre d'améliorations, tant au niveau du support des standards du web qu'au niveau de la sécurité ou de l'accessibilité. Le développement n'est pas en reste puisque les développeurs web pourront profiter des dernière technologies et ceux qui écrivent des extensions ont désormais à leur disposition une API (Application Programming Interface) plus complète permettant de nouvelles possibilités.

NdM : merci à oen et grdscarabe pour avoir également proposé une dépêche à ce sujet. Liste non-exhaustive des améliorations

Support des standards amélioré
  • Support complet de la recommandation CSS 2 (W3C)
  • Support partiel du brouillon (working draft) CSS 3 (W3C)
  • Support des graphiques et événements SVG 1.1 (W3C)
  • Support de l'élément canvas (WhatWG)
  • Support des formulaires XML XForms (W3C)
  • Support d'ECMAScript/Javascript 1.6 (ECMA-262)
  • Support d'E4X (ECMAScript for XML, ECMA-357)

Amélioration de l'accessibilité
  • Amélioration de l'accessibilité DHTML grâce à un don de code de la part d'IBM
  • Support de Window-Eyes 5.5 bêta screen reader for Microsoft Windows destiné aux non-voyants.

Sécurité renforcée
  • Blocage des popups amélioré (celui de Freenews ne passe plus ;-)
  • La fonction "Clear Private Data" permet de vider le cache, effacer l'historique, vider les formulaires mémorisés et autres données personnelles en un seul clic (une boîte de confirmation permet de choisir quelles actions doivent réellement être exécutées pour un nettoyage rapide mais sélectif).
  • Lorsqu'on nous propose de sauvegarder un mot de passe, l'option par défaut est "Pas maintenant" au lieu de "Oui" (de plus, les intitulés ont été clarifiés).
  • IDN (International Domain Name), qui permet d'accéder aux sites avec des caractères non-ascii (lettres accentuées) a été réintroduit mais avec une liste blanches des TLD (Top Level Domain) qui ont une politique stricte quant à l'attribution des noms de domaines comme c'est le cas pour .jp (Japon) et .de (Allemagne) par exemple, les autres domaines seront affichés en punycode (rfc 3492) afin d'éviter les homographes mal-intentionnés.

Utilisabilité améliorée
  • Possibilité de déplacer les onglets à la souris pour les réorganiser
  • Ctrl+K ouvre une boîte de dialogue si la barre de recherche web est désactivée.
  • Affichage plus rapide des pages de manière générale.
  • Affichage des pages beaucoup plus rapide lors de l'utilisation des boutons "Précédent" et "Suivant".
  • Des pages d'erreurs claires lors des erreurs http remplacent les boîtes de dialogue. De plus, l'url n'est plus perdue si le chargement de la page échoue.
  • Possibilité de faire glisser une url sur les boutons "nouvelle page" et "nouvel onglet" de la barre d'outil.
  • Meilleur support de Mac OS X (10.2 et plus) et possibilité d'importer les préférences de Safari.
  • Les feuilles de style utilisateur (userContent.css) permettent de modifier le rendu d'un site automatiquement.
  • Réorganisation du panneau d'options qui évite d'avoir à faire défiler pour voir toutes les options.
  • Le gestionnaire d'extensions et le gestionnaire de téléchargements ont eux aussi été améliorés.
  • Compatibilité avec les site codés pour Internet Explorer améliorée.
  • La mise à jour incrémentale permet maintenant de ne pas avoir à télécharger la totalité des 5 à 9 Mo d'une nouvelle version mais seulement le nécessaire, ce qui est particulièrement intéressant pour ceux qui n'ont pas encore accès au haut-débit.
  • Fenêtre translucide pour Linux et Windows (pas forcément utile mais c'est joli :-p).

Améliorations pour les développeurs Web
  • Le DOM inspector (option lors de l'installation de Firefox) est maintenant une extension, tout comme l'outil de rapport de sites qui ne passent pas avec Firefox.
  • Le support des technologies exposées au début est aussi un avantage pour les développeur de sites qui peuvent tirer parti de celles-ci pour apporter une nouvelle expérience au visiteur.

Amélioration pour les développeurs d'extensions
  • Fonctions supplémentaires pour l'interaction avec Firefox
  • Possibilité d'utiliser E4X dans les extensions.

Aller plus loin

  • # Fenêtre translucide pour Linux et Windows

    Posté par (page perso) . Évalué à 3.

    Cool ! :)

    mais j'ai beau chercher, hormis plein de site qui t'explique que c'est possible aucun ne dit comment faire !
    Faut le recompiler ? une option dans about:config ? une extension ?
    bref si quelqu'un à une nympho ! :p

    Bon bah maintenant on attends Fx 2.0 alors ... :)
  • # note pour la version 1.5RC3

    Posté par (page perso) . Évalué à 8.

    Comme je l'ai dit dans un des journaux, si vous avez installé la version 1.5RC3 (au moins la version en-US), vous n'aurez pas de mise à jour, puisqu'il n'y a pas eu de modifications depuis, même au niveau du numéro de version. Donc ne vous attendez pas à ce que le système de mise à jour auto se déclenche :-)

    En clair Firefox 1.5RC3 = Firefox 1.5.

    (explication ici http://www.squarefree.com/burningedge/2005/11/29/rc3-is-fire(...) )

    De plus, pour les développeurs d'extensions et developpeurs web, il y a des détails supplémentaires sur les nouveautés ici : http://xulfr.org/wiki/NouveautesDeFirefox1.5
    • [^] # Re: note pour la version 1.5RC3

      Posté par . Évalué à 4.

      En utilisant le build officiel de Firefox 1.5 RC3 sous Minislack, j'ai eu de gros freezes lors du déplacement des onglets. Ca veut donc dire que le bug est toujours présent dans la version finale ? Je n'ai pas enquété plus que ça, malheureusement.

      Par ailleurs, le blocage du popup de Freenews ne marchait toujours pas chez moi...
      • [^] # Re: note pour la version 1.5RC3

        Posté par . Évalué à 3.

        Pour Freenews, j'utilise adblock et je bloque tout ce qui vient de "netavenir.com" (de mémoire) et pas de popup là-bas ...
        • [^] # Re: note pour la version 1.5RC3

          Posté par . Évalué à 2.

          C'est ce que je fais aussi. Je signalais en fait que l'affirmation de la news Blocage des popups amélioré (celui de Freenews ne passe plus ;-) n'est toujours pas vraie, malheureusement.
    • [^] # Re: note pour la version 1.5RC3

      Posté par . Évalué à 3.

      Chez moi le popup est bloqué et j'ai pas d'addblock ...
      Et j'ai jamais eu de freeze en déplaçant des onglets ...

      Fx 1.5 RC3 Windows XP
  • # sftp

    Posté par . Évalué à 2.

    Un truc bete: sftp://addresse_ip
    ne marche pas. Est-ce normal ou ai-je oublié qq chose ?
    • [^] # Re: sftp

      Posté par (page perso) . Évalué à 2.

      http://www.chezmoicamarche.org/

      XP SP2, Firefox 1.5, un lien de type "sftp://xx.xx.xx.xx" lance WinSCP vers xx.xx.xx.xx
      • [^] # Re: sftp

        Posté par . Évalué à 3.

        heu... tu veux dire que ça lance une appli externe !!!
        Enfin sous Linux ca marche pas (sftp est dispo en shell)
        La chose est transparante avec konqueror comme si la directorie
        était locale.
        • [^] # Re: sftp

          Posté par . Évalué à 8.

          Ben, le protocole sftp n'est pas géré par Firefox, c'est tout. Rien de bien exceptionnel.
          Konqueror a toujours voulu en faire plus ;-) (mais pas forcément mieux !)

          Si tu veux faire gérer sftp:// par des applis externes dans firefox, c'est juste une clé à ajouter dans le "about:config"
          Une booléenne : "network.protocol-handler.external.sftp", à mettre à "true"
          et une chaîne "network.protocol-handler.app.sftp", où indiquer le chemin/nom de l'appli.
  • # Merci Mozilla, mais...

    Posté par (page perso) . Évalué à 10.

    On peut lire sur le blog de T. Nitot:

    - Support natif de SVG 1.1 (dialecte XML permettant l'affichage de graphiques vectoriels et leur manipulation via JavaScript et le DOM) ;


    C'est la killer-feature que j'attendais si je puis dire et... je dois dire que je suis déçu par le peu d'évolution en la matière depuis mon dernier essai de build "SVG-enabled" (en avril dernier donc).

    Je ne dis pas, les fonctionnalités de base sont là - paths, surfaces, gradients - mais quid de l'animation et des filtres par exemple ? Des dizaines d'exemples de la Testsuite du W3C ( http://www.w3.org/Graphics/SVG/Test/ ) n'ont pas le rendu escompté.

    OK c'est peut être faire le difficile pour une technologie qui a du mal à décoller - d'autant que le reste du produit est comme toujours à la hauteur. Mais au risque de passer pour un épilateur de chenilles, on n'annonce pas le "support natif de SVG 1.1" si on ne supporte pas la norme en entier ;) je préfère le "Support des graphiques et événements SVG 1.1" de l'article ^^
    • [^] # Re: Merci Mozilla, mais...

      Posté par (page perso) . Évalué à 6.

      Oui le support n'est pas complet.

      Voir ce qui est pris en charge dans FF 1.5 : http://developer.mozilla.org/en/docs/SVG_in_Firefox_1.5

      Et sinon, sur le tronc, c'est ici :

      http://www.mozilla.org/projects/svg/status.html
    • [^] # Re: Merci Mozilla, mais...

      Posté par (page perso) . Évalué à 10.

      C'est la première fois qu'un produit Mozilla intègre SVG en version finale. Alors non, le support n'est pas complet à 100%, et je n'ai d'ailleurs absolument pas dit qu'il l'était ! Pourtant c'est *à ma connaissance* le meilleur support natif de SVG tous navigateurs confondus. Opera a aussi fait des efforts dans ce sens, mais d'après ce que j'ai compris, ils se focalisent sur un sous-ensemble appelé "SVG Tiny".

      Maintenant, il faut savoir qu'il est rarissime qu'un standard soit 100% implémenté. Entre la théorie (les specs) et la réalité (les implémentations), il y a toujours une différence.

      Prenons l'exemple de CSS2, qui est quand même un truc très utilisé sur le Web, aucun navigateur n'implémente toute la spec. C'est pour cela qu'est prévu CSS2.1 qui va *retirer* de la spec ce qu'on n'a jamais pu implémenter (et que visiblement, après toutes ces années, on n'implémentera jamais).

      Pour prendre une métaphore, le support de SVG par Gecko / Firefox, c'est un verre à moitié plein, qu'on peut aussi voir à moitié vide. D'un autre coté, c'est la premiere fois qu'on voit un verre aussi plein. :-D
      • [^] # Re: Merci Mozilla, mais...

        Posté par (page perso) . Évalué à 4.

        Au contraire de ce qui est dit, à ce que j'ai testé, le CSS2 n'a pas l'air complètement implémenté :

        http://www.w3.org/TR/CSS2/text.html#text-shadow-props

        n'a pas l'air de fonctionner. Je n'ai vu pour l'instant que Safari l'implémenter... il paraît qu'il y a un ticket d'ouvert pour Firefox là-dessus... y'a un système de dons qqpart pour motiver les features ? ;)
      • [^] # Re: Merci Mozilla, mais...

        Posté par . Évalué à 2.

        > Opera a aussi fait des efforts dans ce sens, mais d'après ce que j'ai compris, ils se focalisent sur un sous-ensemble appelé "SVG Tiny".

        Pour info, il semble que la version 9 d' Opéra supportera plus que la version tiny. On peut lire "SVG support increased to partial SVG 1.1 basic" sur la page de la version 9 beta (et après quelques tests, le support SVG m'a l'air du niveau de Firefox).
        • [^] # Re: Merci Mozilla, mais...

          Posté par (page perso) . Évalué à 5.

          D'ailleurs, Qt4 propose un moteur SVG 1.2 tres performant(faible conso cpu et mémoire) et supportant les animations. Il semble d'ailleurs que le SVG sera utiliser partout ou il y aura des animations dans kde 4.0.

          Il s'agit d'un moteur SVG basique mais Ksvg sera la pour offrir toutes les possibilités dont à besoin konqueror. On peut donc esperer un tres bon support de SVG pour kde 4.0.
  • # Mise à jour auto ?

    Posté par (page perso) . Évalué à 1.

    Et pour nos amis les windowsiens, quand la mise à jour sera-t-elle proposée ? Mme Michu me confirme qu'elle a pas encore la petite icone rouge en haut à droite....

    Des idées ?
    • [^] # Re: Mise à jour auto ?

      Posté par (page perso) . Évalué à 3.

      Je dois etre un neuneu moi aussi, j'ai jamais eu de mise a jour automatique sous windows. Pourtant, mon patronyme n'est pas Michu ! Ma version est la 1.5 beta 2.

      Sous GNU/Linux, je mets a jour via mon systeme de package.
      • [^] # Re: Mise à jour auto ?

        Posté par . Évalué à 5.

        j'ai vu aussi que sous la version 1.0.7 windows, apparemment la mise à jour vers la 1.5 n'est pas proposée

        Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

        • [^] # Re: Mise à jour auto ?

          Posté par . Évalué à 2.

          Je suppose que la mise à jour automatique commencera à partir de la 1.5 finale.
          Quant à la mise à jour de 1.0.7 vers 1.5, je ne pense pas qu'elle sera proposée, puisque c'est une nouvelle version, avec de nouvelles fonctionnalités, et non un simple patch de sécurité ou autre.
  • # Génial

    Posté par . Évalué à 2.

    Mais bon comme Internet Explorer ne supporte pas ces supers technologie ...
    - soit on fait "2 sites" un pour les IEiens ;)
    - soit on marque : "Navigateur non pris en charge : download FF 1.5"

    Est-ce vraiment réaliste ...
    • [^] # Re: Génial

      Posté par (page perso) . Évalué à 5.

      oui, ils le font bien dans l'autre sens. Et puis ça dépend du public auquel tu t'adresses...
    • [^] # Re: Génial

      Posté par . Évalué à 4.

      Tu peux faire des démos aussi...

      il n'y a pas de plugin pour SVG sous IE?
    • [^] # Re: Génial

      Posté par . Évalué à 3.

      Suffit de faire en sorte que ça soit pas indispensable de gérer... Dans le sens contraire, firefox ne gère pas les balises ruby http://www.w3.org/TR/ruby/ et je ne me gêne pas pour autant pour en mettre pour ceux qui utilisent IE... (Quelqu'un saurait me donner un lien "contribuer le support d'une balise à Gecko en 10 leçons" ?)
      • [^] # Re: Génial

        Posté par (page perso) . Évalué à 5.

        Pour une implémentation dans gecko même : oubli tes 10 leçons. Il faut plusieurs mois afin de bien connaître le coeur (c'est tres complexe).

        Mais heureusement, maintenant tu as la technologie XTF de gecko, qui te permet d'ajouter la prise en charge d'un langage XML via une extension. (donc pourquoi pas des balises ruby). L'implémentation de XForms utilise XTF.

        Malheureusement, la doc sur XTF est quasi inexistante. J'ai toutefois commencé à en faire une :

        http://xulfr.org/wiki/XTF
        • [^] # Re: Génial

          Posté par . Évalué à 5.

          Puisqu'on parle du ruby et de "plusieurs mois pour qu'un patch integre Gecko", au niveau du support Ruby on en est deja a plus de 5 ans. Bug ouvert en mars 2000, plusieurs patchs proposes, tous refuses parce qu'implementes avec des inline-table.

          Apparament personne de la MoFo ne bosse dessus, et les contributeurs se sont tous decourages. Resultat, il reste une extension qui implemente le patch par des feuilles de style.

          Du temps de Netscape il y avait au moins Momoi-san qui etait interesse par le probleme.
          • [^] # Re: Génial

            Posté par . Évalué à 3.

            Ok, merci à Laurent et à toi pour les infos respectives.

            Hmm, c'est vrai que XTF a l'air sympa mais je ne sais pas si ça peut convenir pour ça (les balises du module ruby partagent le même espace de nom que le xhtml 1.1).

            Je m'en doutais bien que ça ne pouvait pas être simple, mais après tout je n'avais jamais demandé ;-).
    • [^] # Re: Génial

      Posté par (page perso) . Évalué à 8.

      Est-ce vraiment réaliste ...


      Oui, parce que :

      1) ce sont des technos standards
      2) pour le SVG, adobe fourni un plugin
      3) Pour xforms : il doit certainement exister un plugin quelque part
      4) pour les styles CSS3 : tu fais comme d'hab avec CSS2 que IE ne prend pas en charge non plus : tu t'en fous, c'est pas grave si pour l'utilisateur de IE n'a pas le petit coin arrondi ou le multi colonne : ton site reste quand meme lisible.

      Et puis si il faut attendre IE 10.0 (IE 7 ne prendra pas en charge tout ça), pour utiliser les technologies qui améliorent l'experience utilisateur, qui facilite la vie des développeurs, on n'a pas fini d'attendre.

      L'utilisateur n'a qu'à basculer vers FF ou autre navigateur supportant ces technos.

      Si il ne peut pas basculer, l'information reste tout de même accessible.
      Et si il lui faut absolument accéder au site parce que c'est important pour son boulot, qu'il ne peut pas basculer tout seul, cas typique en entreprise, il aura tout de même son firefox si son service informatique est un bon service informatique..

      Faut bien avancer dans la vie. Faut bien avancer sur le web.

      Il ne faut pas avoir de scrupules à utiliser toutes ces technos *standards*. Surtout si tu sais que ta cible est plus ou moins restreinte (un intranet par ex).
    • [^] # Re: Génial

      Posté par (page perso) . Évalué à 4.

      Sans aller jusque là on peut faire un site qui soit plus beau avec les navigateurs respectueux des standarts que sous ie tout en restant lisible sous ce dernier.
    • [^] # Re: Génial

      Posté par . Évalué à 2.

      Dans le cadre d'Intranets où tu peut avoir besoin de ces technologies, tu peut imposer le navigateur. Dans ce cadre, l'ajout de ces technologies est plus que réaliste.
      • [^] # Re: Génial

        Posté par (page perso) . Évalué à 2.

        sauf quand des boulets sélectionnent des produits d'une techno jetable comme asp, de surcroît blindés d'activeX
  • # mozilla versus firefox

    Posté par (page perso) . Évalué à 1.

    Personnellement je reste sous mozilla + multizilla que je trouve plus toujours plus rapide que firefox + tabbrowserextension je ne m'explique d'ailleurs pas le pourquoi de cette lenteur surtout au demarrage

    firefox est a la limite du freeze pour une disaine de tab ce qui n'est pas le cas de mozilla 1.7.1x..
    • [^] # Re: mozilla versus firefox

      Posté par . Évalué à 1.

      Le vrai problème c'est TBE. Le jour ou j'ai viré cette extension j'ai halluciné sur la différence de vitessE.

      Il faut vaux mieux utiliser TabBrowser Preferences et d'autres extensions si tu manques certaines fonctionnalités de TBE.
    • [^] # Re: mozilla versus firefox

      Posté par . Évalué à 1.

      C'est pas terrible çà comme troll ! Bofff....

      Peut-être que xulrunner résoudra les problèmes de lenteur...
      C'est vrai que sous Windows Firefox est assez long à lancer...
      (Bon après, c'est sur que sous Gentoo c'est super rapide, better troll inside)
  • # Et aussi pour vos PDA/Smartphones

    Posté par . Évalué à 2.

    Un bonheur n'arrivant jamais seul, la version de test .001 de MiniMo est sortie le 23 du mois courant [1], et tous les utilisateurs/testeurs/rapporteurs sont les bienvenus. Merci la fondation Mozilla [2] :-)

    ( Pour celui du fond qui ne le saurait pas, MiniMo est le projet de navigateur web de la fondation Mozilla pour les systèmes mobiles ).

    1: http://www.vtr-hardware.com/news/n7213-mozilla-dans-vos-pda-(...)
    2: http://www.mozilla.org/projects/minimo/downloads.html
  • # Dépêche

    Posté par . Évalué à 2.

    Au fait merci à l'auteur de la dépêche qui a en même temps été le premier à dégainer (avant l'annonce de la sortie d'ailleurs) et avec une dépêche de très bonne qualité .
    • [^] # Re: Dépêche

      Posté par (page perso) . Évalué à 1.

      je nuance un peu des cites comme clubic ou matbe ont annoncés la sortie avant . mais bon c'est pas tout d'etre les premiers il faut surtout etre les meilleurs ;) (ce qui n'est vraiment pas la meme chose)
  • # Contexte

    Posté par (page perso) . Évalué à 6.

    Rappelons le contexte rapidement :
    La seconde guerre des navigateurs semble se mettre en marche avec beaucoup plus d’acteurs cette fois-ci.

    Microsoft avec IE7 beta1 (non disponible pour le grand public) doit rattraper son retard pris en arrêtant le développement il y a 4 ans, et en reprenant avec une toute nouvelle équipe de développement indienne. On n'est même pas sûr que ce IE7 sera dispo pour autre chose que la prochaine version de Windows et Windows XP SP2, ce qui exclu tous les utilisateurs de Windows XP, 2000 et autres.

    Safari d’Apple est le premier navigateur a avoir passé le test Acid2.

    Konqueror 3.5, tout fraîchement publié, passe le test Acid2 grâce au boulot d'intégration de patches de Safari.

    Opera avec sa future version 9, désormais gratuite, passe également le test Acid2, implémente un canvas et SVG Tiny, un sous-ensemble de SVG.

    George Staikos, un développeur de KDE, a réunit quelques uns des développeurs de Opera, Firefox et Internet Explorer pour discuter de la sécurité des navigateurs, notamment le phishing et l’abandon de SSLv2.

    Rappelons également que côté Mozilla, XULRunner avance à grand pas et que beaucoup d’applications se préparent autour de cette plateforme pour interfaces riches : Sunbird/Lightning, Flock, Piggy Bank, Songbird, WengoPhone, SXXX (une boîte connue va sortir une appli XUL qui va faire parler d'elle).

    Et puis AJAX et Web 2.0 font toujours le buzz, et puis WhatWG secoue un peu le W3C.
    • [^] # Re: Contexte

      Posté par (page perso) . Évalué à 3.

      > Sunbird/Lightning, Flock, Piggy Bank, Songbird, WengoPhone, SXXX (une boîte connue va sortir une appli XUL qui va faire parler d'elle).

      Je n'ai entendu parler que de Flock et Sunbird, mais on peut dire que tu sais mettre l'eau à la bouche des lecteurs toi! Je vais regarder ce que sont ces autres applis, mais en attendant, cette boite connue on peut savoir qui c'est? ;)

      ps: je suis étonné que personne n'ait mentionné le coût prohibitif pour les non-étatsuniens des accessoires en vente sur la boutique: près de cent sacs pour un malheureux polo, je n'ose pas imaginer le prix du panda. :-(
      https://store.mozilla.org/international_examples.asp
      • [^] # Re: Contexte

        Posté par (page perso) . Évalué à 2.

        Marrant, par "hasard" je suis tombé sur Piggy-Bank ce matin (si c'est bien le même), avant de lire cet article, j'ai classé le lien pour regarder à tête reposée ce qu'ils proposent. Cela parle de web-sémantique et d'aggrégation... Tout un programme :)

        Le lien : [http://simile.mit.edu/piggy-bank/]
    • [^] # Re: Contexte

      Posté par . Évalué à 6.

      ajoutons quand même que le Safari d'Apple ne passe l'acid test que dans la version pour Tiger, et qu'il n'est pas possible d'avoir une version récente du navigateur pour Panther.

      Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: Contexte

      Posté par . Évalué à 2.

      Rappelons également que côté Mozilla, XULRunner avance à grand pas et que beaucoup d’applications se préparent autour de cette plateforme pour interfaces riches : Sunbird/Lightning, Flock, Piggy Bank, Songbird, WengoPhone, SXXX (une boîte connue va sortir une appli XUL qui va faire parler d'elle).

      Juste une précision, Flock n'est pas basé sur XULRunner. C'est basé sur Firefox, avec un accès facilité aux sites de "web social" (blogs, partage de photos, de bookmarks...) Ça reste une version alpha, il reste du chemin. Mais c'est pile dans le buzz Web 2.0 ;-)

      http://www.flock.com

      Il devrait y avoir une milestone avant la fin de l'année, avant ça je conseille les hourly builds plutot que la 0.4.10 parce que le développement est très actif.
      • [^] # Re: Contexte

        Posté par . Évalué à 2.

        Ah, je viens de voir que la prochaine version stable de Flock sera plutot vers la mi-janvier...
    • [^] # Re: Contexte

      Posté par . Évalué à 1.

      et en reprenant avec une toute nouvelle équipe de développement indienne

      Ah bon ? J'ai un pote qui va pas etre content d'apprendre qu'on lui a pris son passeport francais pour l'echanger contre un passeport indien :+)
  • # Plugins Java et Flash

    Posté par . Évalué à 2.

    Je lis que Firefox implémente désormais tout un tas de technologies avant-gardistes mais je viens de l'installer et je n'arrive pas à installer les plugins de base Flash et Java alors que ça marchait sur mon précédent Firefox. J'ai pourtant suivi à la lettre les instructions http://plugindoc.mozdev.org/fr-FR/linux.html , je les vois bien quand je fais about:plugins mais ça ne veut pas fonctionner.

    Vous y arrivez vous ?
  • # C'est la fete !

    Posté par . Évalué à 3.

  • # aperçu avant impression

    Posté par (page perso) . Évalué à 2.

    J'espérais beaucoup de la 1.5 mais y'a toujours ce satané bug !
    Quand je vais dans "apercu avant impression" je vois que ça va m'imprimer 10 pages (par exemple) alors (comme je veux économiser un peu de papier) je change l'échelle et j'indique 50% (par exemple)...et bien le nombre de page à imprimer ne se rafraichit pas ! ça m'indique toujours "page 1 sur 10" !
    Il faut fermer l'aperçu puis re-rentrer dedans pour voir le nouveau nombre de pages.
    Très très chiant !
    • [^] # Re: aperçu avant impression

      Posté par . Évalué à 1.

      Ca ne répond peut-être pas à ta question si tu as vraiment 10 pages bourrées de texte à imprimer, mais si tu veux imprimer un texte de 5 pages qui contient tout plein de fioritudes inutiles (style bandeau de pub, menu de navigation...) qui prennent 5 pages de plus, et bien, je te conseille l'extension Nuke anything enhanced. Tu peux ainsi supprimer les éléments inutiles de la page pour n'imprimer que l'utile. Vachement pratique :)
    • [^] # Re: aperçu avant impression

      Posté par (page perso) . Évalué à 3.

      Ben perso, je n'ai pas moyen de changer l'echelle dans l'apercu avant impression donc comme ca, pas de probleme!

      C'est que sous windows ou quoi?
      • [^] # Re: aperçu avant impression

        Posté par (page perso) . Évalué à 2.

        oui je suis sous Win2k au boulot.
        Mais ça me semblerait bizarre que la possibilité de changer l'échelle dans l'apercu ne soit que sous Win non ? t'est sur que tu peux pas dans le Firefox de ta distro ?
        • [^] # Re: aperçu avant impression

          Posté par . Évalué à 1.

          Pareil ici, apparemment ce n'est que pour Windows...
          • [^] # Re: aperçu avant impression

            Posté par . Évalué à 3.

            Pour contourner ton problème, il te suffit de cliquer sur la petite flèche qui t'amènes sur la dernière page de l'aperçu, de cette manière, tu verras par exemple "Page 8 sur 10", et tu saura que ton document fait 8 pages à cette echelle (c'est un peu plus simple que de fermer l'aperçu :))
            • [^] # Re: aperçu avant impression

              Posté par (page perso) . Évalué à 1.

              merci !
              c'est certain ce n'est qu'un contournement de bug mais ça marche !
              sinon il faudrait faire un bug-report mais moi je sais pas écrire en anglais alors bon....
  • # Greasemonkey

    Posté par (page perso) . Évalué à 2.

    Pour ceux qui utilisent Greasemonkey, il semble qu'il faut passer à la version 0.6.3 (une version de devel de la nouvelle version 0.6, pas de version officiellement publiée, il faut chercher un peu) pour que cela fonctionne avec FF 1.5

    Vala, avec cette version, cela semble fonctionner correctement avec le script que j'ai fait pour LinuxFr, mais apparement il y a des modifications dans FF qui font que pas mal de scripts seront à revoir. Le problème le plus commun semble être que pour les ajouts de fonctions pour capturer les évènements (onClick, onKeyPress, onBiduleMachin, etc...) il faut passer dorénavant par addEventListener(), plus d'infos : [http://dunck.us/collab/GreaseMonkeyUserScripts#head-4ac4d1e8(...)]
    • [^] # Re: Greasemonkey

      Posté par . Évalué à 2.

      Perso je me suis mis à faire un script greasemonkey depuis cette version 0.6 donc pas de problème ...
      Mais je suis abonné à la mailing-list et, oui, apparemment beaucoup de scripts sont cassés ...
      Ensuite pour la version 0.6.3 il suffit d'aller dans les archives de la mailing-list, une p'tite recherche et c'est trouvable ...
      Au pire je peux retrouver l'adresse exacte si ça intéresse quelqu'un ...
      Pour addEventListener, je ne sais pas si c'est dans ton lien, mais en fait le mieux est de le wrapper dans son propre gestionnaire d'évènement, car les évènements ajoutés de cette manière ne sont pas libérés, et donc s'empile au fur et à mesure des pages ... Ce qui peut conduire firefox à être très très gourmand, j'ai eu ce problème pour mon script, je ne connaissais pas ce bug, et au bout de 2h d'utilisation (c'est pour un forum, sur lequel je suis assez actif, et j'ajoutais pas mal d'évènements), fx me prenait 300 Mo de mémoire 8)
      Donc 2 solutions :
      1. Le nombre d'évènement ajouté est fixe et les objets sont pleinement connus, il suffit de faire un removeEventListener de tous ces objets dans une fonction appelé en unLoad et c'est bon.
      2. Le nombre n'est pas fixe (ce qui est mon cas), et dans ce cas là, le mieux est de faire une fonction "myAddEventListener" qui va stocker ces évènements et d'ajouter une fonction en unLoad qui se servira de ce stockage pour les enlever.
      Le code peut être trouvé sur la mailing-list également, sinon je peux en fournir un morceau ...

      Ce bug a apparemment été corrigé récemment (le mois dernier), mais au moment où cela a été découvert on ne sait/savait pas si ce serait intégré à fx 1.5, et je pense que ce n'est pas le cas, donc ce mécanisme est encore nécessaire ...
  • # Faisons le chieur

    Posté par (page perso) . Évalué à 4.

    1)
    Le téléchargement ne fonctionne pas : je vais sur les pages, je clique sur le lien download firefox, et le .dmg s'ouvre dans mon navigateur. Bon, qu'à cela ne tienne, récupérons le lien. Arghh, c'est une redirection. Bon, qu'à cela ne tienne, gorettisons et attrappons l'url de l'installeur qui s'affiche dans ma barre d'adresse quand des suites de signe caballistiques s'affichent dans mon navigateur.

    2)
    Le premier lancement est bizarre : l'icône apparaît dans le dock, puis disparaît, puis réapparaît, puis redisparaît, puis réapparaît et enfin, une fenêtre s'affiche. Whouah, trop bien, il sait afficher une page web...

    3)
    Le support de css2 est peut-être complet, mais il n'est pas bon : les display: inline-table sont toujours incompris par le meilleur navigateur du monde.

    4)
    La désinstallation se passe très bien.

    [je précise que ce test a été sous macosx pour ceux qui ne comprennent pas certains termes]
    • [^] # Re: Faisons le chieur

      Posté par . Évalué à 2.

      Le premier lancement est bizarre : l'icône apparaît dans le dock, puis disparaît, puis réapparaît, puis redisparaît, puis réapparaît et enfin, une fenêtre s'affiche.


      Ca c'est juste le vérificateur des thèmes et extensions installé qui fait son boulôt, si j'ai bien compris. Ca ne le fait qu'à chaque fois qu'une nouvelle version (de Firefox, pas du reste) est installée.

      Par contre, pour ton problème de téléchargement, je suis assez étonné. Tout s'est bien passé de mon côté, depuis www.mozilla.com, et téléchargé avec Firefox (il est vrai que je n'ai pas essayé avec Safari).
      • [^] # Re: Faisons le chieur

        Posté par . Évalué à 2.

        j'ai essaye avec safari pour voir si ca valait le coup de le remplacer (le clic milieu ne marchant pas jusqu'a maintenant), absolument aucun probleme.

        Par contre, je prefere toujours safari, les gouts et les couleurs (et tant pis pour la dlfp bar).
      • [^] # Re: Faisons le chieur

        Posté par (page perso) . Évalué à 2.

        j'ai tente le telechargement avec safari, mais de la version en_Us (celle que me proposait www.mozilla.com), la version française quant à elle se télécharge comme il faut.
    • [^] # Re: Faisons le chieur

      Posté par . Évalué à 1.

      > 3) Le support de css2 est peut-être complet, mais il n'est pas
      > bon : les display: inline-table sont toujours incompris

      "display: inline-block" qui est un volet assez important du standard, manque toujours à l'appel aussi.

      L'uniligne ci-dessous devrait etre rendu avec une bordure rouge limitée au mot "Test" et non pas étendue à toute la ligne:

      data:text/html,<div style='display:inline-block;border:solid red 1px'>Test


    • [^] # Re: Faisons le chieur

      Posté par . Évalué à 1.

      Moi aussi je veux faire le chieur :)

      1. En installant par dessus mon FF 1.0 (Windows) il ne se lançait tout simplement plus. C'est peut-être (surement) écrit quelque part de désinstaller avant mais je sens que ça va faire chier pas mal de monde

      2. Les gifs animés sont toujours mal gérés au niveau de la vitesse et de la fluidité, notamment quand il y en a plusieurs sur une page. Exemple : http://www.webhamster.com/

      3. J'ai voulu tester SVG depuis le temps que j'en entends parler, je ne suis tombé que sur des erreur xml. J'ai alors essayé avec le plugin Adobe sous IE et ben c'est une techno qui à l'air sympa, mais pas sous FF.

      4. Il y a des tonnes de changement mais ils sont plutot invisibles et finalement pas mal de monde a l'air de se dire "tout ça pour ça". Je pense que IE7 va faire mal à FF, notamment auprès de ceux qui installeront Vista. On va me dire, IE ne fait pas le quart de FF avec ses extensions, oui mais je croise souvent des gens qui n'utilisent pas les extensions ou qui ne connaissent pas les meilleurs et plus pratiques. Je ne parle même pas de la valeur par défaut de browser.cache.check_doc_frequency qui cause des problèmes d'actualisation de l'information.

      Mais la route est encore longue et droite même si la pente est forte et the yes needs the no to win against the no.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.